Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 304885 - kde-base/cantor-4.4.0: tries to link w/ libgfortran while libR.so was build using dev-lang/ifc
Summary: kde-base/cantor-4.4.0: tries to link w/ libgfortran while libR.so was build u...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: All All
: High normal (vote)
Assignee: Gentoo Science Related Packages
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 339465 313999
  Show dependency tree
 
Reported: 2010-02-13 15:46 UTC by Alexey Antipovsky
Modified: 2011-09-22 20:16 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,21.24 KB, text/plain)
2010-02-13 15:47 UTC, Alexey Antipovsky
Details
emerge --info (EINFO,4.90 KB, text/plain)
2010-02-13 15:48 UTC, Alexey Antipovsky
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexey Antipovsky 2010-02-13 15:46:46 UTC
I have libR.so, libRlapack.so and libblas.so.0 build using Intel Fortran Compiler (dev-lang/ifc-11.1.056), but kde-base/cantor-4.4.0 tries to link against libgfortran while linking cantor_rbackend.so and cantor_rserver.so

Reproducible: Always

Steps to Reproduce:
1. emerge kde-base/cantor (you must have libblas build using ifc and gcc[-fortran])

Actual Results:  
/usr/lib/gcc/x86_64-pc-linux-gnu/4.3.3/../../../../x86_64-pc-linux-gnu/bin/ld: cannot find -lgfortran
collect2: ld returned 1 exit status
make[2]: *** [lib/cantor_rbackend.so] Error 1
make[1]: *** [cantor/src/backends/R/CMakeFiles/cantor_rbackend.dir/all] Error 2


It builds very well w/o -lgfortran (libR.so depends on all needed libraries itself)
Comment 1 Alexey Antipovsky 2010-02-13 15:47:59 UTC
Created attachment 219435 [details]
build.log
Comment 2 Alexey Antipovsky 2010-02-13 15:48:39 UTC
Created attachment 219437 [details]
emerge --info
Comment 3 Samuli Suominen (RETIRED) gentoo-dev 2010-02-13 15:51:01 UTC
Not a supported
Comment 4 Samuli Suominen (RETIRED) gentoo-dev 2010-02-13 15:51:55 UTC
Oops, ignore that last comment. Reassigned to sci@ for dev-lang/ifc.
Comment 5 Sébastien Fabbro (RETIRED) gentoo-dev 2010-02-17 04:50:35 UTC
Hi,

You could check the results of "eselect show blas" and "eselect show lapack". Did you compile lapack with ifort?
Comment 6 Alexey Antipovsky 2010-02-17 05:25:13 UTC
(In reply to comment #5)

$ eselect blas show
lib64: reference
$ eselect lapack show
$

$ ldd /usr/lib64/libblas.so.0
        linux-vdso.so.1 =>  (0x00007fff4f1ff000)
        libifport.so.5 => /opt/intel/Compiler/11.1/056/lib/intel64/libifport.so.5 (0x00007f400d4e5000)
        libifcore.so.5 => /opt/intel/Compiler/11.1/056/lib/intel64/libifcore.so.5 (0x00007f400d26e000)
        libimf.so => /opt/intel/Compiler/11.1/056/lib/intel64/libimf.so (0x00007f400cedc000)
        libsvml.so => /opt/intel/Compiler/11.1/056/lib/intel64/libsvml.so (0x00007f400ccc5000)
        libm.so.6 => /lib/libm.so.6 (0x00007f400ca41000)
        libintlc.so.5 => /opt/intel/Compiler/11.1/056/lib/intel64/libintlc.so.5 (0x00007f400c904000)
        libpthread.so.0 => /lib/libpthread.so.0 (0x00007f400c6e7000)
        libc.so.6 => /lib/libc.so.6 (0x00007f400c388000)
        libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x00007f400c171000)
        libdl.so.2 => /lib/libdl.so.2 (0x00007f400bf6d000)
        /lib64/ld-linux-x86-64.so.2 (0x00007f400d920000)
Comment 7 Andreas K. Hüttel archtester gentoo-dev 2010-06-11 17:32:43 UTC
How about 4.4.4?
Comment 8 Sébastien Fabbro (RETIRED) gentoo-dev 2010-06-16 18:52:01 UTC
It might be that cantor hard code the gfortran. You can try to build cantor with ifort, setting FC=ifort F77=ifort before installing.
Comment 9 Sergio D. Rodríguez Inclan 2011-05-17 14:01:28 UTC
I had the same problem, but in my case I was updating KDE from 4.4.5 to 4.6.2 and I didn't have gcc compiled with the fortran flag. I recompiled gcc with USE="frotran" and it worked. Maybe would be useful to add a fortran use flag verification to the ebuild.
Comment 10 Andreas K. Hüttel archtester gentoo-dev 2011-06-19 08:32:13 UTC
Making cmake and fortran-2.eclass work together nicely will be interesting...
Comment 11 Andreas K. Hüttel archtester gentoo-dev 2011-09-22 20:16:12 UTC
Checked in 4.7.1 and the problem is fixed.