Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 300947 - app-pda/libopensync-plugin-synce-0.22-r1 does not build against app-pda/synce-librra-0.14 (fixed "upstream")
Summary: app-pda/libopensync-plugin-synce-0.22-r1 does not build against app-pda/synce...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Piotr Jaroszyński (RETIRED)
Depends on:
Blocks: 354423
  Show dependency tree
Reported: 2010-01-14 09:10 UTC by Luca Santarelli
Modified: 2011-02-15 05:19 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---

Proposed new ebuild (may require QA-checking) (libopensync-plugin-synce-0.22.1.ebuild,839 bytes, text/plain)
2010-01-14 19:20 UTC, Luca Santarelli
Required patch in files dir (libopensync-plugin-synce-0.22.1-warning.patch,628 bytes, patch)
2010-01-14 19:21 UTC, Luca Santarelli
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Luca Santarelli 2010-01-14 09:10:01 UTC
The only ebuild for app-pda/libopensyc-plugin-synce works against app-pda/synce-librra-0.13, but fails to compile against app-pda/synce-librra-0.14 due to a change in the API.

(Add your witty/sad remark about synce/opensync/world incompatibility here)

This has been fixed "upstream", meaning that the SynCE team has released an updated version of libopensync-plugin-synce (0.22.1 [1]) at the time of their release of 0.14

I still haven't tried to build it on my system, but I hope that it's just a matter of changing the SRC uri in the ebuild.


Reproducible: Always

Steps to Reproduce:
1. keyword app-pda/synce packages
2. mask app-pda/opensync packages >= 0.30 (upstream "unstable")
3. emerge app-pda/libopensync-plugin-synce
Comment 1 Luca Santarelli 2010-01-14 09:13:21 UTC
Excuse me, I forgot to add what I suggest to do:

1. Modify the ebuild for app-pda/libopensync-plugin-synce-0.22-r1 to strictly depend on <app-pda/synce-librra-0.14, to avoid a compilation failure.

2. Make a new ebuild app-pda/libopensync-plugin-synce-0.22.1 where SRC_URI points to the SynCE source package, to support synce-0.14 packages.
Comment 2 Luca Santarelli 2010-01-14 19:20:33 UTC
Created attachment 216536 [details]
Proposed new ebuild (may require QA-checking)
Comment 3 Luca Santarelli 2010-01-14 19:21:47 UTC
Created attachment 216537 [details, diff]
Required patch in files dir

The current warning patch does not work with the new source from the synce team. This is a fixed version.
Comment 4 Luca Santarelli 2010-01-14 19:24:25 UTC
I wrote an ebuild as per point 2. of comment #1; I tested it on my system (x86, mostly stable except for synce and opensync, as expected) and it compiles fine.

msynctool recognizes the plugin and adds it to a group w/ success. (actual sync-ing still doesn't work, but it may be a misconfiguration on my part).

It may require some QA check, I'm not your local ebuild expert.
Comment 5 Samuli Suominen (RETIRED) gentoo-dev 2010-12-19 00:24:09 UTC
Removed from tree (bug 340007 for future restoration).