Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 300697 - Stable =media-libs/libkate-0.3.7 (was: 0.2.5 fails with glibc 2.10)
Summary: Stable =media-libs/libkate-0.3.7 (was: 0.2.5 fails with glibc 2.10)
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords: STABLEREQ
Depends on:
Blocks: glibc-2.10-stable
  Show dependency tree
 
Reported: 2010-01-12 11:14 UTC by Arttu Valo
Modified: 2010-01-21 22:46 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Short-ish build.log with the failure at the end (build.log,23.01 KB, text/plain)
2010-01-12 11:15 UTC, Arttu Valo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Arttu Valo 2010-01-12 11:14:57 UTC
media-libs/libkate-0.2.5 doesn't seem to be compatible with more recent glibc versions:

kate_parser.y:1005: error: conflicting types for ‘getline’

Red Fedora folks seem to have fixed something similar nearly a year ago:

https://bugzilla.redhat.com/show_bug.cgi?id=458714

But still, I solved this by enabling a later libkate (0.3.7). So maybe the old version could be flushed out, and a new one stabilized in its place?
Comment 1 Arttu Valo 2010-01-12 11:15:52 UTC
Created attachment 216206 [details]
Short-ish build.log with the failure at the end
Comment 2 Tobias Klausmann gentoo-dev 2010-01-16 13:28:15 UTC
Before we can stabilize libkate on alpha, we need to test&stable some version of liboggz. Any preferences there?
Comment 3 Samuli Suominen gentoo-dev 2010-01-16 13:58:10 UTC
(In reply to comment #2)
> Before we can stabilize libkate on alpha, we need to test&stable some version
> of liboggz. Any preferences there?
> 

Latest possible (1.1.0)
Comment 4 Tobias Klausmann gentoo-dev 2010-01-16 14:35:12 UTC
Stabled libkate-0.3.7 and liboggz-1.1.0 on alpha.
Comment 5 Kacper Kowalik (Xarthisius) (RETIRED) gentoo-dev 2010-01-16 17:06:09 UTC
Tested =media-libs/liboggz-1.1.0 on x86 chroot:
 * required ~x86 deps: none
 * flag combinations: -*, *
 * test suite: all passed

Tested =media-libs/libkate-0.3.7 on x86 chroot:
 * required ~x86 deps: liboggz-1.1.0
 * flag combination: -*, *
 * test suite: all passed
 * add. info: compiled media-video/vlc-1.0.4[kate], media-libs/tiger-0.3.3
Comment 6 Christian Faulhammer (RETIRED) gentoo-dev 2010-01-16 20:09:32 UTC
x86 stable, thanks Kacper
Comment 7 nixnut (RETIRED) gentoo-dev 2010-01-19 18:36:20 UTC
ppc stable
Comment 8 Raúl Porcel (RETIRED) gentoo-dev 2010-01-21 19:55:19 UTC
sparc stable
Comment 9 Brent Baude (RETIRED) gentoo-dev 2010-01-21 22:46:21 UTC
ppc64 done; closing as last arch