Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 300592 - kde-base/kmail-4.3.5 fails to open attachments in associated programs if konqueror is not installed
Summary: kde-base/kmail-4.3.5 fails to open attachments in associated programs if konq...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 313999
  Show dependency tree
 
Reported: 2010-01-11 14:19 UTC by radim
Modified: 2011-10-28 22:18 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description radim 2010-01-11 14:19:40 UTC
Whnen I try to open an attachment from kmail it gives me the dialogue window to open with. But when I choose program to do the action nothing happens. Does not mater if it is from the "known application" or if I give the full path to the program.

emerge --info
Portage 2.1.6.13 (default/linux/x86/10.0/desktop, gcc-4.3.4, glibc-2.10.1-r1, 2.6.32-gentoo-r1 i686)
=================================================================
System uname: Linux-2.6.32-gentoo-r1-i686-Intel-R-_Pentium-R-_M_processor_1.73GHz-with-gentoo-1.12.13
Timestamp of tree: Mon, 11 Jan 2010 11:00:01 +0000
app-shells/bash:     4.0_p35
dev-java/java-config: 2.1.9-r2
dev-lang/python:     2.6.4
dev-util/cmake:      2.6.4-r3
sys-apps/baselayout: 1.12.13
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6b
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=pentium-m -O2 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=pentium-m -O2 -pipe"
DISTDIR="/mnt/nfs_portage/distfiles"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="rsync://192.168.1.1/gentoo-portage/distfiles rsync://192.168.1.1/gentoo-portage/ rsync://ftp6.linux.cz/pub/linux/gentoo/ rsync://ftp.fi.muni.cz/pub/linux/gentoo/ ftp://ftp.wh2.tu-dresden.de/pub/mirrors/gentoo ftp://ftp.tu-clausthal.de/pub/linux/gentoo"
LANG="cs_CZ.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="cs us"
PKGDIR="/mnt/nfs_portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/mnt/nfs_portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="7zip X a52 aac acl acpi alsa berkdb bluetooth branding bzip2 cairo cdr cli consolekit cracklib crypt cups cxx dbus dri dts dvd dvdr dvdread eds emboss encode evo faad fam firefox flac fortran gdbm gif gpm gstreamer gtk hal iconv ipv6 jack java java6 jpeg kde laptop ldap libnotify mad mikmod mmx mng modules mp3 mp4 mpeg mudflap ncurses nls nptl nptlonly nsplugin ogg opengl openmp pam pcre pdf perl png ppds pppd python qt qt3support qt4 quicktime readline reflection sdl session slang spell spl sse sse2 ssl startup-notification svg sysfs tcpd thunar tiff truetype unicode usb vorbis win32codecs x264 x86 xinerama xml xorg xulrunner xv xvid zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev keyboard mouse synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="cs us" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="intel i810"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, MAKEOPTS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 radim 2010-01-15 09:26:27 UTC
I found it. It is necessary to install konqueror. Otherwise kmail is not able to start the programs required to open the attachment.
It would be interesting for me if other openbox users solved the problem differently.
Comment 2 Carsten Lohrke (RETIRED) gentoo-dev 2010-01-18 13:33:27 UTC
This is still a valid bug. Either Konqueror should be listed as runtime dependency or KMail should throw a message informing the user about the (list of) possible apllication(s) handling the required file type.
Comment 3 Andreas K. Hüttel archtester gentoo-dev 2010-04-29 22:28:11 UTC
Which kde version was that? 
Do you know if the problem still exists in 4.3.5 or 4.4.2?

(As far as I can see, konqueror is not in kdebase-runtime-meta in either case.)
Comment 4 radim 2010-04-30 05:59:18 UTC
In my case it is 4.3.5 
Comment 5 Andreas K. Hüttel archtester gentoo-dev 2010-05-16 13:29:10 UTC
Do you still remember - When you emerged konqueror, did that pull in any other additional packages?

Just trying to reproduce this here...
Comment 6 Maciej Mrozowski gentoo-dev 2010-06-05 21:55:19 UTC
I think it's more about kde-base/kfmclient than kde-base/konqueror.
Comment 7 Andreas K. Hüttel archtester gentoo-dev 2010-06-09 19:46:23 UTC
So how about placing

$(add_kdebase_dep kfmclient)

in RDEPEND? Should fix this nice and easily.
Comment 8 Andreas K. Hüttel archtester gentoo-dev 2010-06-10 16:17:07 UTC
Fixed in the overlay for 4.4.4 and later. Please test.
Comment 9 Maciej Mrozowski gentoo-dev 2010-06-11 03:17:38 UTC
No, it seems kfmclient is not the way to go. Also I'm unable to reproduce and I've removed konqueror, kfmclient, dolphin and half of relevant (like kmimetypefinder, kfile, kioclient) kdebase-runtime already.

I would like to ask you to investigate a bit, like run kmail in strace or sth.
Comment 10 Vicente Olivert Riera (RETIRED) gentoo-dev 2010-06-11 09:50:49 UTC
(In reply to comment #8)
> Fixed in the overlay for 4.4.4 and later. Please test.
> 

Works for me.
Comment 11 Maciej Mrozowski gentoo-dev 2010-09-12 04:04:01 UTC
I'm closing this one with NEEDINFO.

If issue still appears for you, please run:

strace -o kmail.strace kmail --nofork

try to open attachement file, close kmail and attach kmail.strace to this bug.
Comment 12 Carsten Lohrke (RETIRED) gentoo-dev 2010-09-12 20:12:21 UTC
The bug is still somewhat valid - and not limited to KMail, but rather a bug related to the runtime dependency handling of the kdelibs ebuild and likely other stuff up the software stack.

As you can see, when looking at the code, KMail - as other KDE applications do - calls KToolInvocation::invokeBrowser, from kdelibs, which calls kfmclient respective xdg-open, when not in a full KDE session, or kfmclient not available.

Seemingly everything fine - even though the runtime dependency would be better || ( kfmclient xdg-utils)- but there is yet another fallback to "kde-open", part of the workspace runtime or more exactly kde-base/kioclient. So it is a runtime dependency of kdelibs.

Even if this doesn't convice you, because xdg-open should catch everything - a quick grep through kdelibs shows that KWidgetJobTracker calls kde-open, Currency::convert calls kioclient.

And isn't it a bit problematic to factor out kfmclient into its own ebuild, giving that half the functionality requires an installed Konquerer and silently doesn't work, if it isn't installed?! Also kfmclient itself does a runtime call to kioclient, too.
Comment 13 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2010-12-31 01:15:32 UTC
According to carlo's comment, either we add || ( kfmclient xdg-utils) in kdelibs rdepend (which is a better but not perfect solution for this bug) or we leave it as it is and resolve it without doing anything more. Opinions please or I'll close it soon.
Comment 14 Andreas K. Hüttel archtester gentoo-dev 2010-12-31 07:40:43 UTC
Lets add the deps otherwise it comes up again and again...
Comment 15 Andreas K. Hüttel archtester gentoo-dev 2011-03-05 17:57:17 UTC
Fixed starting with 4.6.1 (added dependencies).
Comment 16 Martin Walch 2011-03-06 14:19:23 UTC
Sorry for bothering. Adding kfmclient as a dependency of kdelibs leads to a circular dependency in fresh kde installs.
Comment 17 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2011-03-06 14:30:06 UTC
already fixed (depedency moved from RDEPEND to PDEPEND), sync again later