Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 290861 - app-office/openoffice-3.1.1[kde] "Save as..." dialog broken
Summary: app-office/openoffice-3.1.1[kde] "Save as..." dialog broken
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal with 1 vote (vote)
Assignee: Gentoo Office Team
URL:
Whiteboard:
Keywords:
: 339569 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-10-28 11:24 UTC by Marc Schiffbauer
Modified: 2011-04-19 20:49 UTC (History)
8 users (show)

See Also:
Package list:
Runtime testing required: ---
tampakrap: Bugday+


Attachments
Screenshot of Save As Dialog (ooo_saveas.png,65.22 KB, image/png)
2009-10-28 11:26 UTC, Marc Schiffbauer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marc Schiffbauer gentoo-dev 2009-10-28 11:24:56 UTC
Using ooo with kde USE flag now uses KDE file dialogs. Great!

But in the "Save as..." dialog there are some captions missing. For example for the Document-Password option. Please see screenshot.

This is on ~AMD64. I did not test x86.
Comment 1 Marc Schiffbauer gentoo-dev 2009-10-28 11:25:36 UTC
Portage 2.2_rc46 (default/linux/amd64/10.0/desktop, gcc-4.4.2, glibc-2.10.1-r0, 2.6.31-gentoo-r4 x86_64)
=================================================================                                       
System uname: Linux-2.6.31-gentoo-r4-x86_64-Intel-R-_Core-TM-2_Duo_CPU_T7300_@_2.00GHz-with-gentoo-2.0.1
Timestamp of tree: Tue, 27 Oct 2009 17:45:01 +0000
distcc 3.1 x86_64-pc-linux-gnu [enabled]
ccache version 2.4 [enabled]
app-shells/bash:     4.0_p35
dev-java/java-config: 2.1.9-r1
dev-lang/python:     2.6.3, 3.1.1-r1
dev-util/ccache:     2.4-r8
dev-util/cmake:      2.6.4-r3
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.5.2-r1
sys-apps/sandbox:    2.2
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2, 1.11
sys-devel/binutils:  2.20
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.30-r1
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -O2 -pipe -Wl,--as-needed"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/lib64/tomoyo/conf /usr/share/X11/xkb /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/eselect/postgresql /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=core2 -O2 -pipe -Wl,--as-needed"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--keep-going --load-average=3.0"
FEATURES="assume-digests ccache distcc distlocks fixpackages news parallel-fetch preserve-libs protect-owned sandbox sfperms splitdebug strict unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="http://de-mirror.org/distro/gentoo/ http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror/ http://ftp.uni-erlangen.de/pub/mirrors/gentoo"
LANG="C"
LDFLAGS="-Wl,-O1"
LINGUAS="de"
MAKEOPTS="-j12"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/vmware /usr/local/portage/layman/zugaina /usr/local/portage/layman/sunrise /usr/local/portage/layman/devnull /usr/local/portage/layman/kde-testing"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X a52 aac aalib acl acpi adns akonadi alsa amd64 ao audiofile bacula-clientonly bacula-console bash-completion berkdb bluetooth branding bzip2 cairo caps captury cdda cddb cdr cli consolekit cracklib crypt css cups curl dbus device-mapper dhclient disk-partition dri dts dvd dvdr eds emboss encode exif fam ffmpeg firefox flac gdbm geolocation gif gimp google-gadgets gpm gstreamer gtk hal ibmacpi iconv id3tag ieee1394 ipod isdnlog jpeg kde kipi l7filter lame laptop lcms ldap libnotify lm_sensors logrotate loop-aes lzo mad mikmod mjpeg mmap mmx mmxext mng modules mp3 mp4 mpeg mudflap multilib musicbrainz mysql ncurses networkmanager nls nptl nptlonly nsplugin ntp ogg openexr opengl openmp pam pcmcia pcre pdf perl phonon png policykit postgres ppds pppd python qt3support qt4 quicktime readline reflection rss samba sdl semantic-desktop session smapi smp sndfile spell spl sse sse2 ssl ssse3 startup-notification svg sysfs tcpd threads thumbnail thunar tiff truetype unicode usb utempter vcd vim-syntax vnc vorbis webkit x264 xattr xcomposite xine xinerama xml xorg xscreensaver xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse synaptics evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

Comment 2 Marc Schiffbauer gentoo-dev 2009-10-28 11:26:35 UTC
Created attachment 208498 [details]
Screenshot of Save As Dialog
Comment 3 Andreas Proschofsky (RETIRED) gentoo-dev 2009-11-25 10:10:14 UTC
Could you please check which ooo-build-release this is with? (You'll find the information in the about-dialog). There have been some recent KDE-file-selector fixes in ooo-build-3.1.1.4, so if your patchset version is older, you might try a rebuild
Comment 4 Andreas Proschofsky (RETIRED) gentoo-dev 2009-11-28 20:56:18 UTC
Just bumped the ooo-build-patchset to 3.1.1.5, which brings another set of improvements to the KDE4 file selector.

Please rebuild and report back, if you still get problems
Comment 6 Andreas Proschofsky (RETIRED) gentoo-dev 2009-12-03 17:19:43 UTC
Adding kde herd, this needs to be fixed in kdelibs obviously, thanks @Hanno for tracking it down
Comment 7 Hanno Zysik (geki) 2009-12-03 17:54:21 UTC
The debian open/save dialog bugreport I forgot before:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=544691#73

And on a side-note, OOo 3.2 oowriter statusbar has a similar issue where the kde4 plugin does not draw or redraw the elements, although I applied the patches to kdelibs/kstyles 4.3.3.
https://forums.gentoo.org/viewtopic-p-6079218.html#6079218
Comment 8 Hanno Zysik (geki) 2009-12-08 16:45:48 UTC
Qt 4.6 and KDE 4.4 (4.3.80) fix the statusbar issue.
I see Qt 4.6 in portage. KDE 4.4 release[0] is planned for february. It would be great to get the patches in that should fix these drawing issues.

[0] http://techbase.kde.org/Schedules/KDE4/4.4_Release_Schedule
Comment 9 Marc Schiffbauer gentoo-dev 2009-12-14 19:37:15 UTC
Update: I can confirm, that with Qt4.6 and KDE 4.3.80 the drawing bug has gone.

The Dialog is still not usable though:

There is a horrible lag of several seconds after every action in the dialog, so if you want to navigate through some directories / create a directory / change the filter etc you have to wait ages every time...

It seems that everytime an update is made to the file listing the hang occurs.

Additionally the filter does not seem to work properly: Sometimes it does not even list a single file in a directory with screenshots (png files) although it should (with filter set to *.png).
Comment 11 Hanno Zysik (geki) 2010-01-03 00:33:52 UTC
JFYI, status bar drawing issue is back, slightly different though. With ...

[ebuild   R   ] x11-libs/qt-core-4.6.0-r1
[ebuild   R   ] kde-base/kdelibs-4.3.85
Comment 12 Franz Trischberger 2010-06-29 06:11:06 UTC
(> There is a horrible lag of several seconds after every action in the dialog, so
> if you want to navigate through some directories / create a directory / change
> the filter etc you have to wait ages every time...
> 
> It seems that everytime an update is made to the file listing the hang occurs.

I don't know if it is related to the file listing. But the problem is definitely related to copy/paste from OOo. Close all OOo-windows, and everything using the kdefileview. Open a Document (e.g. in writer). Now if you check the filedialogs respond as they should. Now select and copy from OOo. To make all kde-file-views (not only OOo, e.g. even dolphin, btw!) slow as hell, just paste the content copied from OOo somewhere (e.g. kwrite). As long as OOo is running, you will have those slow dialogs.
Comment 13 Jens Gruentjes 2010-06-29 12:19:53 UTC
> I don't know if it is related to the file listing. But the problem is
> definitely related to copy/paste from OOo. Close all OOo-windows, and
> everything using the kdefileview. Open a Document (e.g. in writer). Now if you
> check the filedialogs respond as they should. Now select and copy from OOo. To
> make all kde-file-views (not only OOo, e.g. even dolphin, btw!) slow as hell,
> just paste the content copied from OOo somewhere (e.g. kwrite). As long as OOo
> is running, you will have those slow dialogs.

I can confirm that here on an amd64.

[ebuild   R   ] app-office/openoffice-3.2.0
[ebuild   R   ] x11-libs/qt-core-4.6.2-r1
[ebuild   R   ] kde-base/kdelibs-4.4.4

This is my emerge --info:
Portage 2.1.8.3 (default/linux/amd64/10.0/desktop, gcc-4.4.3, glibc-2.11.2-r0, 2.6.33-gentoo-r2 x86_64)
=================================================================
System uname: Linux-2.6.33-gentoo-r2-x86_64-Intel-R-_Core-TM-2_Duo_CPU_E6850_@_3.00GHz-with-gentoo-1.12.13
Timestamp of tree: Mon, 28 Jun 2010 06:45:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     4.0_p37
dev-java/java-config: 2.1.11
dev-lang/python:     2.6.5-r2, 3.1.2-r3
dev-util/ccache:     2.4-r7
dev-util/cmake:      2.6.4-r3
sys-apps/baselayout: 1.12.13
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.65
sys-devel/automake:  1.7.9-r1, 1.8.5-r3, 1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       3.4.6-r2, 4.3.4, 4.4.3-r2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6b
virtual/os-headers:  2.6.30-r1
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA dlj-1.1 AdobeFlash-10.1"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=nocona -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=nocona -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests ccache distlocks fixpackages news parallel-fetch protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror/ http://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/ http://mirror.switch.ch/ftp/mirror/gentoo/ http://mirror.muntinternet.net/pub/gentoo/ http://gentoo.tiscali.nl/"
LANG="de_DE.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="de"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/overlay"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 bash-completion berkdb branding bzip2 cairo cdr cli consolekit cracklib crypt cups cxx dbus dri dts dvd dvdr emboss encode exif fam firefox flac fortran gdbm gif gpm hal iconv ipv6 java jpeg kde lcms libnotify mad mikmod mmx mng modules mp3 mp4 mpeg mudflap multilib ncurses nls nptl nptlonly nsplugin nvidia ogg opengl openmp pam pango pcre pdf perl png ppds pppd python qt3support qt4 readline reflection samba sdl session spell spl sse sse2 ssl ssse3 startup-notification svg sysfs tcpd tetex threads tiff truetype unicode usb vorbis x264 xcb xcomposite xinerama xml xorg xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 14 Ronny Multrus 2010-08-20 08:34:51 UTC
(In reply to comment #12)
> (> There is a horrible lag of several seconds after every action in the dialog,
> so
> > if you want to navigate through some directories / create a directory / change
> > the filter etc you have to wait ages every time...
> > 
> > It seems that everytime an update is made to the file listing the hang occurs.
> 
> I don't know if it is related to the file listing. But the problem is
> definitely related to copy/paste from OOo. Close all OOo-windows, and
> everything using the kdefileview. Open a Document (e.g. in writer). Now if you
> check the filedialogs respond as they should. Now select and copy from OOo. To
> make all kde-file-views (not only OOo, e.g. even dolphin, btw!) slow as hell,
> just paste the content copied from OOo somewhere (e.g. kwrite). As long as OOo
> is running, you will have those slow dialogs.

I can confirm this on my box, but just copying something in OOo is enough to trigger the freezing KDE file dialog. Thanks for finding that out! But those dialogs only hang in OOo for me, not KDE-wide.

app-office/openoffice-3.2.1
kde-base/kdelibs-4.4.5
x11-libs/qt-core-4.6.2-r1
Comment 15 Ronny Multrus 2010-08-20 08:48:07 UTC
Doesn't seem to be Gentoo-only, as SuSE users are affected, too: https://bugzilla.novell.com/show_bug.cgi?id=579795
Comment 16 Ronny Multrus 2010-08-20 09:27:22 UTC
As someone on #openoffice.org just found out, clearing Klipper's history makes OOo go back to normal behavior. No solution yet, but a useful workaround ;-).
Comment 17 Jens Gruentjes 2010-08-20 09:38:34 UTC
(In reply to comment #16)
> No solution yet, but a useful workaround ;-).
I wouldn't call that useful but extremely annoying.

I do not have Klipper running at all but I also have the problem wih the "Save as..."-dialog. If I start Klipper and delete the history, OOo works as you described.

Shouldn't this bug be reported upstream?
Comment 18 Franz Trischberger 2010-10-12 12:31:17 UTC
There is a DUP post, that links a patch probably solving this issue:
http://bugs.gentoo.org/show_bug.cgi?id=339569
I can't try it, so i can't say if it is working.
Comment 19 Andreas Proschofsky (RETIRED) gentoo-dev 2010-11-11 19:49:49 UTC
*** Bug 339569 has been marked as a duplicate of this bug. ***
Comment 20 Bjoern Olausson 2010-11-22 15:11:44 UTC
Same problem for OpenOffice-3.2.1

I can't reproduce it for sure, but it smells like Copy&Past is involved.

Cheers
Bjoern
Comment 21 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2010-12-30 02:10:09 UTC
so, did anyone report it upstream? :)
Comment 22 Andreas K. Hüttel gentoo-dev 2011-03-31 19:44:59 UTC
(In reply to comment #21)
> so, did anyone report it upstream? :)

Well it seems to work fine in libreoffice :)
Comment 23 Tomáš Chvátal (RETIRED) gentoo-dev 2011-04-19 20:49:03 UTC
Works fine with libreoffice, so just move to them...
Closing as fixed by latest version