Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 288097 - [Gentoo Ten Live DVD] xorg-server KDE causes screen flicker
Summary: [Gentoo Ten Live DVD] xorg-server KDE causes screen flicker
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Release Media
Classification: Unclassified
Component: LiveCD/DVD (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Team Anniversary
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 286589
  Show dependency tree
 
Reported: 2009-10-07 18:47 UTC by Jens Gruentjes
Modified: 2010-12-30 01:11 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---
tampakrap: Bugday+


Attachments
Logfile with kernel "gentoo nox nosound" (Xorg.0.log,9.22 KB, text/plain)
2009-10-18 12:21 UTC, Jens Gruentjes
Details
Logfile with kernel "gentoo-nofb nox nosound" (Xorg.0.log.nofb,20.06 KB, text/plain)
2009-10-18 12:23 UTC, Jens Gruentjes
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jens Gruentjes 2009-10-07 18:47:26 UTC
When I boot from the LiveDVD on my Dell Inspiron 6000, starting X always fails. The message in /var/log/Xorg.0.log is

(WW) Warning, couldn't open module i810
(II) UnloadModule: "i810"
....
Fatal server error:
Cannot run in framebuffer mode. Please specify busIDs for all framebuffer devices

The module i810 can be loaded via modprobe i810 and no errors are shown.

Reproducible: Always

Steps to Reproduce:
1. Boot from LiveDVD
2. choose kernel gentoo
3. watch console log

Actual Results:  
I see the errors mentioned above

Expected Results:  
X should start normally
Comment 1 Fernando (likewhoa) 2009-10-07 18:57:04 UTC
please try one of the new revised images at http://mirrors.sfo1.gni.com/Gentoo/ten/

thanks
Comment 2 Jens Gruentjes 2009-10-09 09:42:14 UTC
I have tried the most recent image from 2009-10-07 but the problem remains the same.

The output of lspci (which I forgot in my bug report and which might be interesting) is
00:02.0 VGA compatible controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 03)
Comment 3 David Abbott gentoo-dev 2009-10-09 13:50:23 UTC
(In reply to comment #2)
> I have tried the most recent image from 2009-10-07 but the problem remains the
> same.
> 
> The output of lspci (which I forgot in my bug report and which might be
> interesting) is
> 00:02.0 VGA compatible controller: Intel Corporation Mobile 915GM/GMS/910GML
> Express Graphics Controller (rev 03)
>
Thanks for the report, is this the iso, and also try to boot with gentoo-nofb;
http://mirrors.us.kernel.org/gentoo//releases/x86/10.0/livedvd-x86-amd64-32ul-10.0.iso
Check out the FAQ below and if you could paste the output of /var/log/Xorg.0.log as discribed in the FAQ. 
http://www.gentoo.org/proj/en/pr/releases/10.0/faq.xml#xorg-server
Comment 4 David Abbott gentoo-dev 2009-10-09 13:53:35 UTC
OK I missed it, is this the iso?
http://mirrors.sfo1.gni.com/Gentoo/ten/livedvd-x86-amd64-32ul-10.0.iso
You want the x86 iso and try to boot with gentoo-nofb
Comment 5 David Abbott gentoo-dev 2009-10-10 01:44:18 UTC
Please try 10.1 and report your findings.
http://mirrors.sfo1.gni.com/Gentoo/ten/
Comment 6 Jens Gruentjes 2009-10-11 15:45:30 UTC
I've tried the 10.0 with gentoo-nofb but the results were the same.
I can test the 10.1 version only next weekend but I will report the results as soon as I can. Thanks for your help.
Comment 7 Jens Gruentjes 2009-10-18 12:20:12 UTC
I have tried the 10.1 and found that with kernel "gentoo nox nosound" the error is more or less the same, but it works with "gentoo-nofb nox nosound". I have started X manually by typing "/etc/init.d/xdm start". I have attached both Xorg.0.log files hoping you can gather the required information from that.

I noticed that strange things happen when I try to start KDE. I can log in into KDE and I can see the startup-screen. I can see the first four icons appear but when the KDE icon appears the screens get black and I can only see the mouse cursor. When I move to the corners of the screen I sometimes see the KDE desktop but it's flickering like crazy. I don't know if this is another bug ot if it's related to this one.
Comment 8 Jens Gruentjes 2009-10-18 12:21:43 UTC
Created attachment 207470 [details]
Logfile with kernel "gentoo nox nosound"

This is the logfile when I start with kernel "gentoo nox nosound" and then start X manually. X doesn't start as you can see in the file
Comment 9 Jens Gruentjes 2009-10-18 12:23:09 UTC
Created attachment 207472 [details]
Logfile with kernel "gentoo-nofb nox nosound"

This is the logfile when I start with kernel "gentoo-nofb nox nosound" and then
start X manually. X starts as you can see in the file
Comment 10 David Abbott gentoo-dev 2009-10-18 14:04:52 UTC
Jens,
Start as before gentoo-nofb nox nosound
Change from kdm to gdm
edit /etc/conf.d/xdm
and change "kdm" to "gdm"
Once you are in gdm change the session to gnome and let me know if it is any better. Thanks for testing this out:)
Comment 11 Jens Gruentjes 2009-10-18 15:11:42 UTC
David,
I forgot to mention that any session apart from KDE worked (without changing kdm to gdm). So Gnome, fluxbox, xfce worked, only KDE made the screen flicker like crazy. Do you want to test your proposal anyway?
Comment 12 David Abbott gentoo-dev 2009-10-18 15:33:03 UTC
(In reply to comment #11)
> David,
> I forgot to mention that any session apart from KDE worked (without changing
> kdm to gdm). So Gnome, fluxbox, xfce worked, only KDE made the screen flicker
> like crazy. Do you want to test your proposal anyway?
> 

No, not needed. thanks
Comment 13 Maciej Mrozowski gentoo-dev 2009-10-20 13:43:21 UTC
From bug description "When I move to the corners of the screen I sometimes see the KDE desktop but it's flickering like crazy. I don't know if this is another bug ot if it's related to this one." - it seems like Intel driver issue.
Apparently driver claims compositing support, but it either doesn't work or is misconfigured in xorg.conf somehow.
Btw, screen corners activate some kwin compositing effects, like Cube, Desktop Grid, Present Windows and such.
Comment 14 Alex Alexander (RETIRED) gentoo-dev 2009-10-20 13:57:44 UTC
Is compositing enabled? If yes, can you try disabling it to see if the issues are fixed? You can also try switching the compositing type to XRender (System Settings -> Desktop Effects -> Advanced)
Comment 15 Team Anniversary gentoo-dev 2009-10-20 14:25:52 UTC
I believe composite is not enabled by default on the livedvd. 
Comment 16 Jens Gruentjes 2009-10-20 14:35:00 UTC
After chosing KDE as session type I only see a black screen and the mouse
pointer. I can't see anything on the desktop. When I move the mouse I sometimes
see the desktop for a second and in this second the screen is flickering. When
I stop moving the mouse the screen is again completely black.
The only chance to finish the KDE session is "/etc/init.d/xdm restart" on the
console.

@Maciej: There was no xorg.conf after I started X via "/etc/init.d/xdm start".
I think it uses a default configuration. Do you need more information on that
from me?

@Alex: I don't know if compositing is enabled on the LiveDVD, the Release Team
probably does. I am not able to check that myself because I can't see the
desktop long enough.
Comment 17 Andreas K. Hüttel gentoo-dev 2010-11-12 22:33:33 UTC
Is this bug still in any way valid or relevant?

(No messages for over a year now...)
Comment 18 Fernando (likewhoa) 2010-11-12 22:49:06 UTC
(In reply to comment #17)
> Is this bug still in any way valid or relevant?
> 
> (No messages for over a year now...)
> 

i would close it since nobody has reported anything with the current iso which is a difference revision from bug reporter.
Comment 19 Jens Gruentjes 2010-11-13 18:30:14 UTC
As I use Kubuntu now, it is no longer relevant for me.
You can close it if you like to.
Comment 20 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2010-12-30 01:11:41 UTC
resolving per last comments