Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 286589 - [TRACKER] Gentoo 10 Live DVD Testing
Summary: [TRACKER] Gentoo 10 Live DVD Testing
Status: RESOLVED INVALID
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Team Anniversary
URL:
Whiteboard:
Keywords: Tracker
Depends on: 281827 288097 292437 377301
Blocks: 287182 287873
  Show dependency tree
 
Reported: 2009-09-27 00:38 UTC by David Abbott
Modified: 2017-01-19 18:47 UTC (History)
7 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
zero byte xorg.conf, xorg.conf.in not working (xorg.conf.tgz,3.12 KB, text/plain)
2009-09-29 18:31 UTC, Wilbert van Bakel
Details
Xorg.log - X hangs with geforce 6200 and ACPI enabled (Xorg-hang-nvidia-6200-with-acpi.0.log,16.95 KB, text/plain)
2009-09-30 14:31 UTC, Alex Busenius
Details
/var/log/messages - X hangs with geforce 6200 and ACPI enabled (messages,52.70 KB, text/plain)
2009-09-30 14:33 UTC, Alex Busenius
Details
xorg.conf (xorg.conf,713 bytes, text/plain)
2009-09-30 14:59 UTC, David Abbott
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David Abbott gentoo-dev 2009-09-27 00:38:10 UTC
The Gentoo Ten LiveDVD Team wants to thank you for Testing. There will be two
arches supported, x86 and amd64. We would have liked to support all arches,
but we did not have the time for this release. 

If you feel the bug you are reporting is unrelated to the DVD, you can report
the bug in the normal fashion, please add this bug as a blocker when you are
reporting it so we can track packages that may need to be removed. We want the
release to be the best that we can put out so we may remove packages that are
not working.


Reproducible: Always
Comment 1 Nikos Chantziaras 2009-09-28 06:31:04 UTC
First thing I noticed with this, is that Gtk apps look like crap :P

Please, if possible, have something like x11-themes/gtk-engines-qtcurve on the DVD.
Comment 2 Roman v. Gemmeren 2009-09-28 10:33:42 UTC
hi,

new livedvd good idea!
Here are the things i noticed on first test:
1. nfsmount wouldn't start as rpcd.statd could not start -> probably remove nfsmount from bootup?
2. nepomuk/strigi could be removed from the kde-startup in /usr/share/autostart/, as an indexing on the livedvd is not really needed, and it probably slows down the kde-startup.
3. Kdevelop would crash instantly (but probably not a direct problem of the dvd)
4. The "Internet" Menu in KDE directly filled my whole screen... this could probably be split up in "Filesharing" "Browser" etc...
Comment 3 Fernando (likewhoa) 2009-09-28 10:57:00 UTC
(In reply to comment #2)
> hi,
> 
> new livedvd good idea!
> Here are the things i noticed on first test:
> 1. nfsmount wouldn't start as rpcd.statd could not start -> probably remove
> nfsmount from bootup?
> 2. nepomuk/strigi could be removed from the kde-startup in
> /usr/share/autostart/, as an indexing on the livedvd is not really needed, and
> it probably slows down the kde-startup.
> 3. Kdevelop would crash instantly (but probably not a direct problem of the
> dvd)
> 4. The "Internet" Menu in KDE directly filled my whole screen... this could
> probably be split up in "Filesharing" "Browser" etc...
> 

Thanks for your suggestions, I will look into your request for next iso which should be coming later today.


(In reply to comment #1)
> First thing I noticed with this, is that Gtk apps look like crap :P
> 
> Please, if possible, have something like x11-themes/gtk-engines-qtcurve on the
> DVD.
> 

is this compatible with kde4?
Comment 4 Nikos Chantziaras 2009-09-28 11:23:08 UTC
(In reply to comment #3)
> (In reply to comment #1)
> > First thing I noticed with this, is that Gtk apps look like crap :P
> > 
> > Please, if possible, have something like x11-themes/gtk-engines-qtcurve on the
> > DVD.
> > 
> 
> is this compatible with kde4?

I'm not sure I understand what you mean with "compatible." gtk-engines-qtcurve is a Gtk style, used by Gtk apps (like Firefox, Gimp, etc.)  In its default settings, it looks somewhat similar to KDE's Oxygen style, which is the reason I recommend it for running Gtk apps in a KDE 4 desktop.

Anyway, *any* style is better than the gruesome default (which results in Gtk apps looking like Windows 3.11...)

Examples:

Firefox without any Gtk style engine:

   http://i34.tinypic.com/aowev9.png

Firefox after installing gtk-engines-qtcurve:

   http://i38.tinypic.com/s2qool.png

I think the improvement is obvious.  Non-default Gtk styles are used in every live CD/DVD I know of.

Two things are needed to be installed:

  a) x11-themes/gtk-engines-qt
  b) x11-themes/gtk-engines-qtcurve

a) will allow you to select styles for Gtk from withing KDE 4's SystemSettings:

  http://www.eternal-sun.net/wp-content/uploads/2009/01/settings.jpg

b) is simply the Gtk style that most closely resembles Oxygen.  After it is installed, it can be selected in SystemSettings in the new setting provided by a).

Hope this helps.
Comment 5 Fernando (likewhoa) 2009-09-28 11:58:11 UTC
(In reply to comment #4)
> (In reply to comment #3)
> > (In reply to comment #1)
> > > First thing I noticed with this, is that Gtk apps look like crap :P
> > > 
> > > Please, if possible, have something like x11-themes/gtk-engines-qtcurve on the
> > > DVD.
> > > 
> > 
> > is this compatible with kde4?
> 
> I'm not sure I understand what you mean with "compatible." gtk-engines-qtcurve
> is a Gtk style, used by Gtk apps (like Firefox, Gimp, etc.)  In its default
> settings, it looks somewhat similar to KDE's Oxygen style, which is the reason
> I recommend it for running Gtk apps in a KDE 4 desktop.
> 
> Anyway, *any* style is better than the gruesome default (which results in Gtk
> apps looking like Windows 3.11...)
> 
> Examples:
> 
> Firefox without any Gtk style engine:
> 
>    http://i34.tinypic.com/aowev9.png
> 
> Firefox after installing gtk-engines-qtcurve:
> 
>    http://i38.tinypic.com/s2qool.png
> 
> I think the improvement is obvious.  Non-default Gtk styles are used in every
> live CD/DVD I know of.
> 
> Two things are needed to be installed:
> 
>   a) x11-themes/gtk-engines-qt
>   b) x11-themes/gtk-engines-qtcurve
> 
> a) will allow you to select styles for Gtk from withing KDE 4's SystemSettings:
> 
>   http://www.eternal-sun.net/wp-content/uploads/2009/01/settings.jpg
> 
> b) is simply the Gtk style that most closely resembles Oxygen.  After it is
> installed, it can be selected in SystemSettings in the new setting provided by
> a).
> 
> Hope this helps.
> 
from gtk-engines-qt

RDEPEND="${COMMONDEPEND}
        || ( kde-base/kdebase-data:3.5 kde-base/kdebase:3.5 )"
need-kde 3.5

Thanks for the explaining on how to set it up.



Looks like it will try to pull in kde-3.5. I will talk to the kde herd about getting this updated for kde4.

Comment 6 Alex Busenius 2009-09-28 12:44:10 UTC
I couldn't get the LiveDVD to work at all (x86-x86_64-10.0-20090926-1952), I tried both gentoo and gentoo64 kernels. There are two problems: my keyboard does not work and the X server hangs during start.

The keyboard does not work neither during the layout selection, nor afterwards. And since the X server seem to hang (black screen until reboot) I can not even see whether there are some error messages on another VT.

My machine is: AMD Athlon64 3500+, VIA K8T800, nVidia GeForce 6200, MS Natural Ergonomic Keyboard 4000 USB


Should I better report a new bug for this? The problem is definitely related to the DVD, but I don't feel comfortable posting all sorts of hardware specs and logs into the tracker bug...
Comment 7 Alex Busenius 2009-09-28 14:49:01 UTC
Update

After some experiments I found out that the keyboard starts working after unplugging it and plugging it back again, so I was able to save the logs.
The X server starts fine with "noacpi" (and AFAIK, previous gentoo live CD/DVD worked fine also with ACPI).

However, I couldn't switch vt even with working keyboard while X hangs. The rest of the system seems to continue working normally, since I can e.g. shutdown it properly using power button.

Anybody have an idea how to mount the hard disk and save the X log in this situation?
Comment 8 Nikos Chantziaras 2009-09-28 16:21:29 UTC
(In reply to comment #5)
> from gtk-engines-qt
> 
> RDEPEND="${COMMONDEPEND}
>         || ( kde-base/kdebase-data:3.5 kde-base/kdebase:3.5 )"
> need-kde 3.5
> 
> Thanks for the explaining on how to set it up.
> 
> Looks like it will try to pull in kde-3.5. I will talk to the kde herd about
> getting this updated for kde4.

It is already updated to KDE4 and I've been using it for a long time:

x11-themes/gtk-engines-qt-1.1-r2

Only older versions are KDE3 (0.8x).  Or, in other words, slot 2 of that package is KDE3, slot 1 is KDE4.  So for KDE4, you need gtk-engines-qt:1.
Comment 9 Peter Robb 2009-09-28 21:38:47 UTC
I also got the X freeze when booting into a mac mini.. 

In a cli boot (gentoo softlevel=boot) there was no "installer".

In cli, startx failed with libglx.so not found, and module i810 not found.

Regards,
Peter
Comment 10 Fernando (likewhoa) 2009-09-28 22:32:48 UTC
(In reply to comment #8)
> (In reply to comment #5)
> > from gtk-engines-qt
> > 
> > RDEPEND="${COMMONDEPEND}
> >         || ( kde-base/kdebase-data:3.5 kde-base/kdebase:3.5 )"
> > need-kde 3.5
> > 
> > Thanks for the explaining on how to set it up.
> > 
> > Looks like it will try to pull in kde-3.5. I will talk to the kde herd about
> > getting this updated for kde4.
> 
> It is already updated to KDE4 and I've been using it for a long time:
> 
> x11-themes/gtk-engines-qt-1.1-r2
> 
> Only older versions are KDE3 (0.8x).  Or, in other words, slot 2 of that
> package is KDE3, slot 1 is KDE4.  So for KDE4, you need gtk-engines-qt:1.
> 

ok keep an eye out for it on next iso.
Comment 11 David Abbott gentoo-dev 2009-09-28 22:33:58 UTC
Hi Peter,
    Are you sure you are using livedvd-amd64-10.0-20090926-1952.iso or
    livedvd-x86-x86_64-10.0-20090926-1952.iso.

    You should not see i810 with the latest testing iso

Comment 12 Fernando (likewhoa) 2009-09-28 22:36:51 UTC
(In reply to comment #7)
> Update
> 
> After some experiments I found out that the keyboard starts working after
> unplugging it and plugging it back again, so I was able to save the logs.
> The X server starts fine with "noacpi" (and AFAIK, previous gentoo live CD/DVD
> worked fine also with ACPI).
> 
> However, I couldn't switch vt even with working keyboard while X hangs. The
> rest of the system seems to continue working normally, since I can e.g.
> shutdown it properly using power button.
> 
> Anybody have an idea how to mount the hard disk and save the X log in this
> situation?
> 

the livedvd has been testing with several nvidia cards and I don't see why X is not working with your specific card. Can you test it from a usb stick or hard drive?

Comment 13 Wilbert van Bakel 2009-09-29 18:31:17 UTC
Created attachment 205609 [details]
zero byte xorg.conf, xorg.conf.in not working

NVidia MCP73 mobo / GeForce 7050 video.

The xorg.conf generated by the livecd is 0 bytes and Xorg starts with a blank screen.
The xorf.conf.in is not working either, I generated a new xorg.conf with Xorg -configure and replaced the driver with 'vesa' to get Xorg started properly.

Attached the generated confs from the livecd.
Comment 14 Wilbert van Bakel 2009-09-29 18:33:28 UTC
I tried to connect to my WPA enabled wireless network and the network manager shows "This network requires encryption to be enabled".

Couldn't figure out what to do next, wpa_supplicant seems available.
Comment 15 Fernando (likewhoa) 2009-09-29 22:26:12 UTC
(In reply to comment #14)
> I tried to connect to my WPA enabled wireless network and the network manager
> shows "This network requires encryption to be enabled".
> 
> Couldn't figure out what to do next, wpa_supplicant seems available.
> 

You might to ask at forums.gentoo.org about connectivity support, this bug is for issues with livedvd applications. 
Comment 16 Vytautas 2009-09-30 07:11:44 UTC
My little testing results:
Bugs:
*terminal (root) asks for root password and root/root do not work.
*sudo dolphin in ntfs was bad idea and ended in crash (I know upstream bug, but still...)

Feature request:
*hdd auto-mount and place folder on desktop.
Comment 17 Fernando (likewhoa) 2009-09-30 07:48:17 UTC
(In reply to comment #16)
> My little testing results:
> Bugs:
> *terminal (root) asks for root password and root/root do not work.
> *sudo dolphin in ntfs was bad idea and ended in crash (I know upstream bug, but
> still...)
> 
> Feature request:
> *hdd auto-mount and place folder on desktop.
> 

to gain root access you need to run "sudo su" as root's password is scrambled on boot.
Not sure about sudo dolphin, to bad it crashed on you. can you post link to upstream bug?
Comment 18 christian heß 2009-09-30 09:06:55 UTC
Hello of people, 
the Live DVD bootet up to the start of the diagram maps and then is nothing more, the monitor remains black. 

The DVD was tried 2x burned 2x to download and on 2 systems, sees:

http://paste.ubuntuusers.de/396405/ 
http://paste.ubuntuusers.de/396406/

Thanks for your attention, with kind regards
xrolly
Comment 19 Fernando (likewhoa) 2009-09-30 11:40:29 UTC
(In reply to comment #18)
> Hello of people, 
> the Live DVD bootet up to the start of the diagram maps and then is nothing
> more, the monitor remains black. 
> 
> The DVD was tried 2x burned 2x to download and on 2 systems, sees:
> 
> http://paste.ubuntuusers.de/396405/ 
> http://paste.ubuntuusers.de/396406/
> 
> Thanks for your attention, with kind regards
> xrolly
> 

There another user with a 6 series nvidia card having issues too, but you are the first I see with a radeon 9 series card. We had both nvidia and ati cards booted just find and it could just be your specific series but I will have to get more results from others with similar cards. If you can manage to get the xorg.conf working on your own attach it to this bug for reference. thanks.
Comment 20 Alex Busenius 2009-09-30 14:31:49 UTC
Created attachment 205677 [details]
Xorg.log - X hangs with geforce 6200 and ACPI enabled

I was able to save the logs during X hang. I have skipped xdm start using interactive boot and started it later.
It seems that KDM kills X server because it is not responding, but I don't see anything suspicious in the X log.

End of /var/log/messages:
<cut>
Sep 30 13:57:36 livecd dhclient: bound to 192.168.1.64 -- renewal in 39252 seconds.
Sep 30 13:57:36 livecd dhclient: Can't create /var/run/dhcp/dhclient.pid: No such file or directory
Sep 30 14:03:34 livecd acpid: client connected from 7151[0:0]
Sep 30 14:03:34 livecd acpid: 1 client rule loaded
Sep 30 14:03:43 livecd atkbd.c: Unknown key pressed (translated set 2, code 0xbb on isa0060/serio0).
Sep 30 14:03:43 livecd atkbd.c: Use 'setkeycodes e03b <keycode>' to make it known.
Sep 30 14:03:43 livecd atkbd.c: Unknown key released (translated set 2, code 0xbb on isa0060/serio0).
Sep 30 14:03:43 livecd atkbd.c: Use 'setkeycodes e03b <keycode>' to make it known.
Sep 30 14:03:47 livecd kdm[7147]: X server startup timeout, terminating
Sep 30 14:04:02 livecd kdm[7147]: X server termination timeout, killing
Sep 30 14:04:02 livecd kdm[7147]: X server for display :0 cannot be started, session disabled
Sep 30 14:04:47 livecd acpid: client 7151[0:0] has disconnected
Sep 30 14:04:47 livecd init: Switching to runlevel: 0


(In reply to comment #12)
> the livedvd has been testing with several nvidia cards and I don't see why X is
> not working with your specific card. Can you test it from a usb stick or hard
> drive?
> 
I'll test it from an USB stick.
Comment 21 Alex Busenius 2009-09-30 14:33:46 UTC
Created attachment 205679 [details]
/var/log/messages - X hangs with geforce 6200 and ACPI enabled
Comment 22 David Abbott gentoo-dev 2009-09-30 14:59:06 UTC
Created attachment 205684 [details]
xorg.conf

(In reply to comment #21)
> Created an attachment (id=205679) [edit]
> /var/log/messages - X hangs with geforce 6200 and ACPI enabled
> 
Could you try with the xorg.conf I have attached. Here are the steps I have used that worked but not on your card so I am just curious.
boot with gentoo nox
add the xorg.conf to /etc/X11/
/etc/init.d/xdm start
Comment 23 John D Maunder 2009-09-30 21:27:29 UTC
Black screen of death at startx. When starting kdm or startx get the infamous black screen lock with flashing cursor in top left. Machine is unresponsive other than to reboot. This is due to radeon 4850 video card (I believe). Can boot using "gentoo nox" and command line works as expected but get freeze at startx.

Have also tested this on laptop with nvidia Geforce 6600 video card and startx works as expected.

Impressed (but where is the installer?)
Comment 24 M. Edward Borasky 2009-09-30 22:18:20 UTC
Boots fine on HP Pavilion dv4 laptop but neither the wired nor wireless network came up out of the box. "lspci" says:

00:00.0 Host bridge: Advanced Micro Devices [AMD] RS780 Host Bridge
00:01.0 PCI bridge: Hewlett-Packard Company Device 9602
00:04.0 PCI bridge: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (PCIE port 0)
00:05.0 PCI bridge: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (PCIE port 1)
00:06.0 PCI bridge: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (PCIE port 2)
00:07.0 PCI bridge: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (PCIE port 3)
00:11.0 SATA controller: ATI Technologies Inc SB700/SB800 SATA Controller [AHCI mode]
00:12.0 USB Controller: ATI Technologies Inc SB700/SB800 USB OHCI0 Controller
00:12.1 USB Controller: ATI Technologies Inc SB700 USB OHCI1 Controller
00:12.2 USB Controller: ATI Technologies Inc SB700/SB800 USB EHCI Controller
00:13.0 USB Controller: ATI Technologies Inc SB700/SB800 USB OHCI0 Controller
00:13.1 USB Controller: ATI Technologies Inc SB700 USB OHCI1 Controller
00:13.2 USB Controller: ATI Technologies Inc SB700/SB800 USB EHCI Controller
00:14.0 SMBus: ATI Technologies Inc SBx00 SMBus Controller (rev 3a)
00:14.1 IDE interface: ATI Technologies Inc SB700/SB800 IDE Controller
00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA)
00:14.3 ISA bridge: ATI Technologies Inc SB700/SB800 LPC host controller
00:14.4 PCI bridge: ATI Technologies Inc SBx00 PCI to PCI Bridge
00:18.0 Host bridge: Advanced Micro Devices [AMD] Mobile K10 [Turion X2, Athlon X2, Sempron] HyperTransport Configuration (rev 40)
00:18.1 Host bridge: Advanced Micro Devices [AMD] Family 11h [Turion X2, Athlon X2, Sempron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] Mobile K10 [Turion X2, Athlon X2, Sempron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] Mobile K10 [Turion X2, Athlon X2, Sempron] Miscellaneous Control
00:18.4 Host bridge: Advanced Micro Devices [AMD] Mobile K10 [Turion X2, Athlon X2, Sempron] Link Control
01:05.0 VGA compatible controller: ATI Technologies Inc RS780M/RS780MN [Radeon HD 3200 Graphics]
01:05.1 Audio device: ATI Technologies Inc RS780 Azalia controller
08:00.0 System peripheral: JMicron Technology Corp. SD/MMC Host Controller
08:00.2 SD Host controller: JMicron Technology Corp. Standard SD Host Controller
08:00.3 System peripheral: JMicron Technology Corp. MS Host Controller
08:00.4 System peripheral: JMicron Technology Corp. xD Host Controller
09:00.0 Network controller: Broadcom Corporation BCM4322 802.11a/b/g/n Wireless LAN Controller (rev 01)
0a:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 02)


I think the wifi driver is proprietary - I had to get it using the wired network on openSUSE 11.1. But the wired driver is there after an openSUSE install. 

Comment 25 Fernando (likewhoa) 2009-10-01 03:25:44 UTC
(In reply to comment #23)
> Black screen of death at startx. When starting kdm or startx get the infamous
> black screen lock with flashing cursor in top left. Machine is unresponsive
> other than to reboot. This is due to radeon 4850 video card (I believe). Can
> boot using "gentoo nox" and command line works as expected but get freeze at
> startx.
> 
> Have also tested this on laptop with nvidia Geforce 6600 video card and startx
> works as expected.
> 
> Impressed (but where is the installer?)
> 

Thanks for testing on nvidia 6 series as some users are reporting issues with it. 

P.S there no installer anymore, use the handbook ;)

Comment 26 Fernando (likewhoa) 2009-10-01 03:27:02 UTC
(In reply to comment #24)
> Boots fine on HP Pavilion dv4 laptop but neither the wired nor wireless network
> 

If your wired network didn't work out the box, you'll need to run 'net-setup eth0' to configure it.
Comment 27 M. Edward Borasky 2009-10-01 03:31:19 UTC
(In reply to comment #26)
> (In reply to comment #24)
> > Boots fine on HP Pavilion dv4 laptop but neither the wired nor wireless network
> > 
> 
> If your wired network didn't work out the box, you'll need to run 'net-setup
> eth0' to configure it.
> 

Ah ... I've been away from Gentoo nearly a year. I tried it on my 512 MB Compaq Presario and it was totally non-functional for lack of RAM. I may just install Gentoo from the installer on that machine - that way I can get a lightweight desktop. I'm doing some audio stuff on that machine and openSUSE is also struggling with the low RAM.
Comment 28 Fernando (likewhoa) 2009-10-01 03:32:47 UTC
(In reply to comment #27)
> (In reply to comment #26)
> > (In reply to comment #24)
> > > Boots fine on HP Pavilion dv4 laptop but neither the wired nor wireless network
> > > 
> > 
> > If your wired network didn't work out the box, you'll need to run 'net-setup
> > eth0' to configure it.
> > 
> 
> Ah ... I've been away from Gentoo nearly a year. I tried it on my 512 MB Compaq
> Presario and it was totally non-functional for lack of RAM. I may just install
> Gentoo from the installer on that machine - that way I can get a lightweight
> desktop. I'm doing some audio stuff on that machine and openSUSE is also
> struggling with the low RAM.
> 

Try the minimal install cd instead with a low ram machine.
Comment 29 Ondrej Filip 2009-10-01 15:34:55 UTC
What about handbook on the dvd? I think it would be nice.
Comment 30 Göktürk Yüksek gentoo-dev 2009-10-04 20:59:22 UTC
Before init script starts, copyright notice states years as between 1999 - 2007 instead of 1999- 2009. Since there is no 8th year liveDVD, can you fix it :)
Comment 31 Fernando (likewhoa) 2009-10-05 01:38:39 UTC
(In reply to comment #30)
> Before init script starts, copyright notice states years as between 1999 - 2007
> instead of 1999- 2009. Since there is no 8th year liveDVD, can you fix it :)
> 

that copyright notice is for isolinux and it has nothing to do with the livedvd.
Comment 32 Göktürk Yüksek gentoo-dev 2009-10-05 02:24:56 UTC
Hi,

I'm using Late 2008 Aluminum Macbook, first I booted the dvd without providing any boot options and i got an empty screen where i'm supposed to see kde startup screen. 

To diagnose it, i provided "nox" option, boot completed successfully but it didn't recognize my keyboard so i was unable to type anything.

Then i tried to use "doload=applesmc,usbhid" but it didn't help either. 

I had this problem with minimal installation images before when i boot with "nodetect" option.
Comment 33 David Abbott gentoo-dev 2009-10-05 13:39:16 UTC
x-setup not needed

I believe x-setup was included at some point when they were using proprietary graphics drivers. We are only using  xorg-x11 opengl
To test I booted with nox
then checked opengl
eselect opengl list
xorg-x11 was set
then ran /etc/init.d/xdm start
X started fine
Comment 34 David Abbott gentoo-dev 2009-10-06 00:21:07 UTC
On the released amd64 iso livedvd-amd64-multilib-10.0.iso there is no sound because none of the snd-* modules can be loaded "invalid module format"
Comment 35 Lars 2009-10-06 08:05:43 UTC
Can't load module for nforce Ethernet.

modprobe forcedeth brings FATAL:Error inserting forcedeth: Invalid module format
Comment 36 David Abbott gentoo-dev 2009-10-06 08:30:24 UTC
(In reply to comment #35)
> Can't load module for nforce Ethernet.
> 
> modprobe forcedeth brings FATAL:Error inserting forcedeth: Invalid module
> format
> 
Which iso: 
livedvd-amd64-multilib-10.0.iso or \
livedvd-x86-amd64-32ul-10.0.iso  or \
both?
Comment 37 Fernando (likewhoa) 2009-10-06 11:02:34 UTC
(In reply to comment #34)
> On the released amd64 iso livedvd-amd64-multilib-10.0.iso there is no sound
> because none of the snd-* modules can be loaded "invalid module format"
> 

I am working on a new iso that supports a few things like wacom tables and more kernel drivers plus it's compressed with lzma, lets see if we can push this, because I didn't have enough time to QA final release.
Comment 38 Alex Busenius 2009-10-06 20:02:53 UTC
(In reply to comment #20)
> (In reply to comment #12)
> > the livedvd has been testing with several nvidia cards and I don't see why X is
> > not working with your specific card. Can you test it from a usb stick or hard
> > drive?
> > 
> I'll test it from an USB stick.
> 
It didn't help.


Btw., the new livedvd-x86-amd64-32ul-10.0 is even worse, X server still hangs but additionally it does not recognize my USB devices at all.
Comment 39 David Abbott gentoo-dev 2009-10-06 20:47:25 UTC
(In reply to comment #38)
> (In reply to comment #20)
> > (In reply to comment #12)
> > > the livedvd has been testing with several nvidia cards and I don't see why X is
> > > not working with your specific card. Can you test it from a usb stick or hard
> > > drive?
> > > 
> > I'll test it from an USB stick.
> > 
> It didn't help.
> 
> 
> Btw., the new livedvd-x86-amd64-32ul-10.0 is even worse, X server still hangs
> but additionally it does not recognize my USB devices at all.
> 
I have a 64 bit system with a nvidia card I boot with livedvd-x86-amd64-32ul-10.0 with gentoo64-nofb and it worked fine here.
Comment 40 Lars 2009-10-06 22:08:50 UTC
(In reply to comment #36)
> (In reply to comment #35)
> > Can't load module for nforce Ethernet.
> > 
> > modprobe forcedeth brings FATAL:Error inserting forcedeth: Invalid module
> > format
> > 
> Which iso: 
> livedvd-amd64-multilib-10.0.iso or \
> livedvd-x86-amd64-32ul-10.0.iso  or \
> both?
> 

Oh, sorry: livedvd-amd64-multilib-10.0.iso
Comment 41 David Abbott gentoo-dev 2009-10-06 23:52:51 UTC
(In reply to comment #40)
> (In reply to comment #36)
> > (In reply to comment #35)
> > > Can't load module for nforce Ethernet.
> > > 
> > > modprobe forcedeth brings FATAL:Error inserting forcedeth: Invalid module
> > > format
> > > 
> > Which iso: 
> > livedvd-amd64-multilib-10.0.iso or \
> > livedvd-x86-amd64-32ul-10.0.iso  or \
> > both?
> > 
> 
> Oh, sorry: livedvd-amd64-multilib-10.0.iso
> 

There is a problem with that iso and it will be updated, can you try livedvd-x86-amd64-32ul-10.0.iso and boot with gentoo64-nofb and let me know if it is any better.
Comment 42 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-10-07 15:07:38 UTC
on toshiba qosmio f50-108 neither wired nor wireless work. I use net-wireless/iwl5000-ucode:0 (not :1) firmware in my already installed gentoo for the wireless card.lspci output:

00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub (rev 07)
00:01.0 PCI bridge: Intel Corporation Mobile 4 Series Chipset PCI Express Graphics Port (rev 07)
00:1a.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 03)  
00:1a.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 03)  
00:1a.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 03)
00:1c.2 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 3 (rev 03)
00:1c.3 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 4 (rev 03)
00:1c.5 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 6 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 93)
00:1f.0 ISA bridge: Intel Corporation ICH9M LPC Interface Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation ICH9M/M-E SATA AHCI Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 03)
01:00.0 VGA compatible controller: nVidia Corporation G94 [GeForce 9700M GTS] (rev a1)
0e:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 02)
14:00.0 Network controller: Intel Corporation Wireless WiFi Link 5100
20:00.0 FireWire (IEEE 1394): JMicron Technology Corp. IEEE 1394 Host Controller
20:00.1 System peripheral: JMicron Technology Corp. SD/MMC Host Controller
20:00.2 SD Host controller: JMicron Technology Corp. Standard SD Host Controller
20:00.3 System peripheral: JMicron Technology Corp. MS Host Controller
20:00.4 System peripheral: JMicron Technology Corp. xD Host Controller

thanks
Comment 43 Alistair 2009-10-07 16:16:12 UTC
Confirm +1 on the module_layout version issue on livedvd-amd-64-multilib-10.0.iso 
  
  Lenovo T400 4Gbram/2Core2duo/intel(internal video) - grabbing 64-32ul iso to try that one.  
   
  Question -- I can see precisely where the issue lies - if I can rebuild the initrd correctly do you want the resulting iso somewhere you can grab it?

  I might have time to beat on it tonight between work change controls and WoW time.
   
Comment 44 Fernando (likewhoa) 2009-10-07 16:50:35 UTC
(In reply to comment #43)
> Confirm +1 on the module_layout version issue on
> livedvd-amd-64-multilib-10.0.iso 
> 
>   Lenovo T400 4Gbram/2Core2duo/intel(internal video) - grabbing 64-32ul iso to
> try that one.  
> 
>   Question -- I can see precisely where the issue lies - if I can rebuild the
> initrd correctly do you want the resulting iso somewhere you can grab it?
> 
>   I might have time to beat on it tonight between work change controls and WoW
> time.
> 
> 

The problem should be fixed on the revision coming up later.
Comment 45 David Abbott gentoo-dev 2009-10-07 20:05:36 UTC
Please Test;
http://mirrors.sfo1.gni.com/Gentoo/ten/
Comment 46 Team Anniversary gentoo-dev 2009-10-08 13:41:55 UTC
(In reply to comment #1)
> First thing I noticed with this, is that Gtk apps look like crap :P
> 
> Please, if possible, have something like x11-themes/gtk-engines-qtcurve on the
> DVD.
> 

Already implemented.
Comment 47 KOPRajs 2009-10-10 23:27:52 UTC
Hi,
on the new iso when USB flash disk is inserted HAL cannot mount it automatically because of missing /media directory... after manually creating empty /media directory flash disk can be mounted as expected.
Also I'm missing firmware for my Intel 5100 Wifi adapter... missing file can be downloaded here: http://www.intellinuxwireless.org/iwlwifi/downloads/iwlwifi-5000-ucode-8.24.2.12.tgz
after copying to /lib/firmware my Wifi on SONY VAIO FW41E/H works.
Comment 48 David Abbott gentoo-dev 2009-10-10 23:31:15 UTC
Everyone try the latest 10.1 with many bug fixes and please report you finding, thanks for helping out.
    
http://bouncer.gentoo.org/fetch/gentoo-10.1-livedvd/x86/    [x86]
http://bouncer.gentoo.org/fetch/gentoo-10.1-livedvd/amd64/  [amd64]
Comment 49 Gary 2009-10-18 06:43:16 UTC
I downloaded and burned 10.1 today. Like with the minimal CD, my Apple A1242 keyboard doesn't work. But I can unplug/replug it to get it going, except none of the function keys work.

It also fails to startX. The XOrg log error is "ignoring unsupported device 0x10de0861" which is my mac mini's nVidia GeForce 9400.
Comment 50 Gary 2009-10-18 06:45:35 UTC
Forgot to mention -- amd64 build.
Comment 51 Morris 2009-11-10 12:09:49 UTC
I have a similar problem, my Microsoft Wireless Multimedia Keyboard (and mouse) 1.1 does not work, I have to unplug the usb receptor and then plug it again, so it does work. That's the only problem I've run into with amd64 build.
Comment 52 David Abbott gentoo-dev 2010-08-27 23:26:47 UTC
No longer testing this version