Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 287161 - koffice-2.0.2 and 2.2.0: image shape file dialog works only if file is double-clicked
Summary: koffice-2.0.2 and 2.2.0: image shape file dialog works only if file is double...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High minor (vote)
Assignee: Andreas K. Hüttel
URL: http://forums.gentoo.org/viewtopic-p-...
Whiteboard:
Keywords:
Depends on:
Blocks: 340070
  Show dependency tree
 
Reported: 2009-09-30 21:02 UTC by Eduard Huguet
Modified: 2010-11-01 09:18 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---
tampakrap: Bugday+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eduard Huguet 2009-09-30 21:02:46 UTC
This happens in any of the koffice-2.0.2 applications (Karbon, Krita, KPresenter, etc...): while using ther "Image shape" tool in any of them, I've observed the following weird behaviour: if I double click a file in the file selection popup box it works, but simply selecting it then pressing OK results in a "gray" rectangle displayed on the page, like if the image hasn't been loaded.



Reproducible: Always

Steps to Reproduce:
1. Open any koffice 2.0.2 application: karbon, krita, kpresenter, etc...
2. Choose "Image shape" tool
3. Click on the page. The file selection popup box appears
4. Now:
· if I DOUBLE CLICK a file, the program loads it and displays it in a window. Closing the window makes the bitmap appear on the page, as expected.

· but if I simply select a file and press "OK" button, then the image is not loaded. Instead, a gray rectangle is displayed on the page.
 

Actual Results:  
The image is correctly loaded only in case you double click the file, but not if you select it then press OK.


Expected Results:  
The image should be displayed and loaded, no matter which whay you choose to select the file (doble-click or select + "ok" button).


My emerge --info:
Portage 2.1.6.13 (default/linux/x86/2008.0/desktop, gcc-4.4.1, glibc-2.10.1-r0, 2.6.31-gentoo-r1 i686)
=================================================================                                     
System uname: Linux-2.6.31-gentoo-r1-i686-Intel-R-_Pentium-R-_4_CPU_3.20GHz-with-gentoo-2.0.1         
Timestamp of tree: Mon, 28 Sep 2009 12:15:02 +0000                                                    
app-shells/bash:     4.0_p33                                                                          
dev-java/java-config: 2.1.9-r1                                                                        
dev-lang/python:     2.6.2-r2, 3.1.1-r1                                                               
dev-util/cmake:      2.6.4-r2                                                                         
sys-apps/baselayout: 2.0.1                                                                            
sys-apps/openrc:     0.4.3-r3                                                                         
sys-apps/sandbox:    2.1                                                                              
sys-devel/autoconf:  2.13, 2.63-r1                                                                    
sys-devel/automake:  1.8.5-r3, 1.9.6-r2, 1.10.2, 1.11                                                 
sys-devel/binutils:  2.19.1-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.30-r1
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=prescott -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/share/config/kdm/ /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -march=prescott -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://ftp.udc.es/gentoo/ "
LANG="es_ES.utf8"
LC_ALL="es_ES.utf8"
LDFLAGS="-Wl,-O1"
LINGUAS="es ca es_ES ca_ES"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/sunrise /home/root/portage/custom"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="7zip X a52 aac aalib acl acpi aiglx alsa asf avahi berkdb bluetooth branding bzip2 cairo cdda cddb cdparanoia cdr cleartype cli cracklib crypt cups dbus dirac djvu dri dts dv dvb dvd dvdr dvdread eds effects emboss encode esd evo exif faac faad fam fat fbcondecor ffmpeg fftw firefox flac flash foomaticdb fortran freetype gdbm gif gimp glitz gpm gstreamer hal hddtemp htmlhandbook iconv ieee1394 imagemagick imlib ipv6 isdnlog jfs jpeg jpeg2k kde kde4 kdehiddenvisibility kipi lame lcms libnotify lm_sensors lzo mad mdnsresponder-compat mikmod mjpeg mmx mng modules mp3 mp4 mpeg mplayer mudflap musicbrainz mysql mythtv ncurses network nls nptl nptlonly nptonly nsplugin ntfs nuv nvidia ogg openexr opengl openmp pam pcre pdf plugin png ppds pppd pulseaudio python qt3 qt3support qt4 quicktime radio readline reflection samba schroedinger sdl session spell spl srt sse sse2 ssht ssl startup-notification subversion svg sysfs tcpd theora threads thumbnail thunar tiff truetype udev unicode usb v4l v4l2 vcd visualization vorbis wifi win32codecs wmf x264 x86 xcb xcomposite xfs xine xinerama xml xorg xscreensaver xulrunner xv xvid xvmc zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev keyboard mouse wacom" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="es ca es_ES ca_ES" SANE_BACKENDS="epson2" USERLAND="GNU" VIDEO_CARDS="nvidia nv vesa"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Andreas K. Hüttel gentoo-dev 2010-07-07 18:52:49 UTC
How about koffice-2.1.x (in tree) or koffice-2.2 (in kde-overlay)?
Comment 2 Eduard Huguet 2010-07-08 12:28:56 UTC
Hi, 
I'm not using Gentoo anymore on this machine, but I've just tested current version in Kubuntu backports (2.2.0) and the bug is still there.

Maybe should I report it upstream instead of in Gentoo bugzilla?

Kind regards
Comment 3 Andreas K. Hüttel gentoo-dev 2010-09-26 12:30:43 UTC
> I'm not using Gentoo anymore on this machine, but I've just tested current
> version in Kubuntu backports (2.2.0) and the bug is still there.
> 
> Maybe should I report it upstream instead of in Gentoo bugzilla?

Good idea- and please add a link here to kde bugzilla!
Comment 4 Andreas K. Hüttel gentoo-dev 2010-11-01 09:18:24 UTC
Can't reproduce this with 2.2.2, so I assume this is fixed. 

Please reopen otherwise...