Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 277619 - News item 2009-07-12-xorg-74-alpha shows up on other archs
Summary: News item 2009-07-12-xorg-74-alpha shows up on other archs
Status: RESOLVED FIXED
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Core (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords: InVCS
: 301140 (view as bug list)
Depends on:
Blocks: 210077 288499
  Show dependency tree
 
Reported: 2009-07-13 08:13 UTC by Allen Brooker (AllenJB)
Modified: 2010-01-23 14:32 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
completely untested patch (news.py,9.67 KB, patch)
2009-07-17 05:16 UTC, Alec Warner
Details | Diff
somehow I think the patch will be more useful than my marked up news.py ;) (patch,2.44 KB, patch)
2009-07-17 05:17 UTC, Alec Warner
Details | Diff
old patch without messed up tabbing (patch,2.40 KB, patch)
2009-07-17 05:26 UTC, Alec Warner
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Allen Brooker (AllenJB) 2009-07-13 08:13:23 UTC
News item headers:
Title: xorg-x11-7.4 and xorg-server-1.5 kernel support
Author: Tobias Klausmann <klausman@gentoo.org>
Content-Type: text/plain
Posted:
Revision: 1
News-Item-Format: 1.0
Display-If-Installed: x11-base/xorg-server
Display-If-Profile: default-linux/alpha
Display-If-Profile: default/linux/alpha

This news item is showing up on non-alpha architectures (I'm on amd64).

Installed version of eselect-news: 20080320

emerge --info:
Portage 2.2_rc33 (default/linux/amd64/2008.0/desktop, gcc-4.3.2, glibc-2.9_p20081201-r2, 2.6.18-xen-r12 x86_64)
=================================================================
System uname: Linux-2.6.18-xen-r12-x86_64-AMD_Athlon-tm-_64_Processor_3000+-with-glibc2.2.5
Timestamp of tree: Mon, 13 Jul 2009 07:20:01 +0000
app-shells/bash:     3.2_p39
dev-java/java-config: 2.1.8-r1
dev-lang/python:     2.5.4-r3
dev-util/cmake:      2.6.4
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=native -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/init.d /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d /usr/share/X11/xkb"
CXXFLAGS="-O2 -march=native -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--ask --alphabetical --verbose --tree"
FEATURES="buildpkg collision-protect distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch userpriv usersandbox"
GENTOO_MIRRORS="        http://www.mirrorservice.org/sites/www.ibiblio.org/gentoo       http://mirror.switch.ch/mirror/gentoo/          http://pandemonium.tiscali.de/pub/gentoo/  "
LANG="en_GB.UTF-8"
LC_ALL="en_GB.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="en_GB en"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_EXTRA_OPTS="--exclude-from=/etc/portage/rsync_excludes"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage /usr/portage/local/layman/armagetron /usr/portage/local/layman/allenjb /usr/portage/local/layman/sunrise"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X aac acl acpi alsa amd64 amr aoss apache2 apm asf bash-completion branding bzip2 cairo caps cdr cli cracklib crypt cups curl dbus dedicated dga dri dts dvd dvdr dvdread emboss enca encode evo exif expat fastcgi fbcon ffmpeg firefox flac ftp gif gnutls hal iconv idn ipod ipv6 isdnlog ithreads java javascript jpeg jpeg2k junit kde lcms libnotify lirc lzo mad matroska midi mikmod mjpeg mmx mmxext mng mozsvg mp3 mp4 mpeg msn mudflap multilib musepack mysql mysqli ncurses nls nocd nptl nptlonly nvidia ogg oggvorbis opengl openmp pam pcre pdf perl php png ppds pppd python qt3 qt3support qt4 quicktime rdesktop readline reflection rrdtool rss samba sdl session speex spl sqlite sqlite3 sse sse2 ssl startup-notification subversion svg sysfs tcpd theora threads tidy tiff truetype unicode usb vcd vhosts videos vorbis webdav wmf x264 xcomposite xine xinerama xml xorg xpm xulrunner xv xvid yv12 zlib" ALSA_CARDS="emu10k1" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm      authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner    authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires   ext_filter file_cache filter headers ident include info log_config logio mem_cache mime    mime_magic negotiation rewrite setenvif so speling status unique_id userdir usertrack   vhost_alias" CAMERAS="canon" ELIBC="glibc" INPUT_DEVICES="evdev keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en_GB en" LIRC_DEVICES="livedrive_midi" USERLAND="GNU" VIDEO_CARDS="vesa nv"
Unset:  CPPFLAGS, CTARGET, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS
Comment 1 Tobias Klausmann (RETIRED) gentoo-dev 2009-07-13 15:00:50 UTC
I asked about the logical operators between Display-If-X and I understood that the various lines with constant X are ORed and those sets of OR'ed lines are then AND'ed. The docs say so and -dev@ consensus was that it should work that way.

So in my case this should have been:
(
 profile=default-linux/alpha||
 profile=default/linux/alpha
)&&
 installed=x11-base/xorg-server

But apparently, it isn't so either the code has a bug or the docs are wrong.
Comment 2 Ulrich Müller gentoo-dev 2009-07-16 07:45:48 UTC
Reassigning to portage, since filtering of items is the package manager's task.
Comment 3 Alec Warner archtester gentoo-dev Security 2009-07-17 04:58:33 UTC
(In reply to comment #1)
> I asked about the logical operators between Display-If-X and I understood that
> the various lines with constant X are ORed and those sets of OR'ed lines are
> then AND'ed. The docs say so and -dev@ consensus was that it should work that
> way.
> 
> So in my case this should have been:
> (
>  profile=default-linux/alpha||
>  profile=default/linux/alpha
> )&&
>  installed=x11-base/xorg-server
> 
> But apparently, it isn't so either the code has a bug or the docs are wrong.
> 

In portage, all the restrictions are OR'd.

<code from="news.py">
for restriction in self.restrictions:
  if restriction.checkRestriction(**kwargs):
    return True
</code>
Comment 4 Alec Warner archtester gentoo-dev Security 2009-07-17 05:16:18 UTC
Created attachment 198248 [details, diff]
completely untested patch

I hate tabs; a lot.
Comment 5 Alec Warner archtester gentoo-dev Security 2009-07-17 05:17:03 UTC
Created attachment 198250 [details, diff]
somehow I think the patch will be more useful than my marked up news.py ;)

I still hate tabs.
Comment 6 Alec Warner archtester gentoo-dev Security 2009-07-17 05:26:07 UTC
Created attachment 198251 [details, diff]
old patch without messed up tabbing

i still hate tabs; but figured I'd fix em.
Comment 7 Zac Medico gentoo-dev 2009-08-17 23:45:11 UTC
(In reply to comment #6)
> Created an attachment (id=198251) [edit]

Thanks, this is in svn r14081.
Comment 8 Zac Medico gentoo-dev 2009-08-21 23:16:40 UTC
This is fixed in 2.2_rc39.
Comment 9 Zac Medico gentoo-dev 2009-10-11 00:57:00 UTC
This is fixed in 2.1.7.
Comment 10 Tobias Klausmann (RETIRED) gentoo-dev 2010-01-23 14:32:07 UTC
*** Bug 301140 has been marked as a duplicate of this bug. ***