Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 276330 - fltk-1.1.9 will not compile with glibc 2.10.1
Summary: fltk-1.1.9 will not compile with glibc 2.10.1
Status: RESOLVED DUPLICATE of bug 270487
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-07-03 01:19 UTC by Audiodef
Modified: 2009-07-04 08:45 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Audiodef 2009-07-03 01:19:50 UTC
fltk-1.1.9 will not compile with any combination of use flags. 

Reproducible: Always

Steps to Reproduce:
1.emerge =fltk-1.1.9

Actual Results:  
Compile fails:

filename_list.cxx: In function 'int fl_filename_list(const char*, dirent***, int (*)(dirent**, dirent**))':
filename_list.cxx:70: error: invalid conversion from 'int (*)(const void*, const void*)' to 'int (*)(const dirent**, const dirent**)'
filename_list.cxx:70: error:   initializing argument 4 of 'int scandir(const char*, dirent***, int (*)(const dirent*), int (*)(const dirent**, const dirent**))'
make[1]: *** [filename_list.o] Error 1
make: *** [all] Error 1
 * 
 * ERROR: x11-libs/fltk-1.1.9 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 2948:  Called die
 * The specific snippet of code:
 *       emake || die "emake failed";
 *  The die message:
 *   emake failed
 * 
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/x11-libs/fltk-1.1.9/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/x11-libs/fltk-1.1.9/temp/environment'.
 * 

>>> Failed to emerge x11-libs/fltk-1.1.9, Log file:

>>>  '/var/tmp/portage/x11-libs/fltk-1.1.9/temp/build.log'


Expected Results:  
Successful emerge.
Comment 1 Lars Wendler (Polynomial-C) gentoo-dev 2009-07-04 08:45:30 UTC

*** This bug has been marked as a duplicate of bug 270487 ***