Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 270487 - x11-libs/fltk fails to build w/ glibc-2.10
Summary: x11-libs/fltk fails to build w/ glibc-2.10
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GCC Porting (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Desktop Misc. Team
URL: http://cvs.fedoraproject.org/viewvc/d...
Whiteboard:
Keywords:
: 270511 271455 275802 276330 (view as bug list)
Depends on:
Blocks: glibc-2.10
  Show dependency tree
 
Reported: 2009-05-19 20:07 UTC by Chris Smith
Modified: 2009-11-22 08:20 UTC (History)
10 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
fltk-2.0_pre6786 fix for glibc-2.10 (fltk2-gcc44.patch,664 bytes, patch)
2009-06-01 22:05 UTC, David Davidson
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Smith 2009-05-19 20:07:19 UTC
x11-libs/fltk-1.1.9 and x11-libs/fltk-2.0_pre6786 fail to build using gcc-4.4.0 - may not be due to gcc-4.4.0 but it's what I'm using currently.

Reproducible: Always

Actual Results:  
Fl_x.cxx: In function ‘int can_boxcheat(uchar)’:
Fl_x.cxx:1372: warning: suggest parentheses around ‘&&’ within ‘||’
Compiling filename_isdir.cxx...
Compiling filename_list.cxx...
Compiling filename_match.cxx...
filename_list.cxx: In function ‘int fl_filename_list(const char*, dirent***, int (*)(dirent**, dirent**))’:
filename_list.cxx:70: error: invalid conversion from ‘int (*)(const void*, const void*)’ to ‘int (*)(const dirent**, const dirent**)’
filename_list.cxx:70: error:   initializing argument 4 of ‘int scandir(const char*, dirent***, int (*)(const dirent*), int (*)(const dirent**, const dirent**))’
make[1]: *** [filename_list.o] Error 1
make[1]: *** Waiting for unfinished jobs....
make: *** [all] Error 1


Expected Results:  
should compile and install normally

emerge --info
Portage 2.1.6.13 (default/linux/amd64/2008.0, gcc-4.4.0, glibc-2.10.1-r0, 2.6.29-gentoo-r4 x86_64)
=================================================================
System uname: Linux-2.6.29-gentoo-r4-x86_64-Intel-R-_Core-TM-2_CPU_6600_@_2.40GHz-with-gentoo-2.0.0
Timestamp of tree: Tue, 19 May 2009 18:15:01 +0000
app-shells/bash:     4.0_p24
dev-java/java-config: 2.1.7
dev-lang/python:     2.6.2
dev-util/cmake:      2.6.4
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.4.3-r2
sys-apps/sandbox:    1.9
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.19.51.0.4
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.29
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -fomit-frame-pointer -pipe -floop-interchange -floop-strip-mine -floop-block"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/eselect/postgresql /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=native -O2 -fomit-frame-pointer -pipe -floop-interchange -floop-strip-mine -floop-block"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--with-bdeps y"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://gentoo.mirrors.tds.net/gentoo http://gentoo.cites.uiuc.edu/pub/gentoo/ ftp://gentoo.chem.wisc.edu/gentoo/ http://gentoo.chem.wisc.edu/gentoo/"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,--as-needed"
LINGUAS="en_US en"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/gnome /usr/local/portage/layman/graaff /usr/local/portage"
SYNC="rsync://davinci.realcomputerguy.soho/gentoo-portage"
USE="X a52 aac aalib acl acpi addressbook alsa amd64 amr apache2 audiofile avahi avi bash-completion berkdb bzip2 cairo caps cdaudio cdparanoia cdr chm cli consolekit cracklib crypt cups curl dbus designer-plugin djvu dri dts dv dvb dvd dvdr dvdread ebook encode exif fam ffmpeg flac fortran gdbm gif glitz gmp gnome gphoto2 gpm gps graphite gstreamer gtk gtk2 hal htmlhandbook iconv ieee1394 imagemagick imap imlib ipv6 isdnlog jack java jpeg jpeg2k kpathsea lame lcd lcms ldap libnotify mad marble midi mmap mmx mozcalendar mozilla mp3 mudflap multilib musicbrainz ncurses nepomuk nls nodrm nptl nptlonly nsplugin nvidia ofx ogg oggvorbis openexr opengl openmp pam pcre pdf perl png pppd pulseaudio python qt3 qt4 quicktime readline reflection samba sasl scanner sdl semantic-desktop session slp smp sndfile spell spl sse sse2 ssl subversion svg sysfs tcltk theora threads tiff tk transparency truetype unicode usb utf8 v4l v4l2 vcd vim-syntax vorbis wav wavpack wmf x264 xattr xcomposite xine xml xorg xscreensaver xv xvid xvmc zlib" ALSA_CARDS="hda-intel hdsp" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="*" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en_US en" USERLAND="GNU" VIDEO_CARDS="nvidia nv vesa fbdev vmware v4l"
Unset:  CPPFLAGS, CTARGET, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Peter Alfredsen (RETIRED) gentoo-dev 2009-05-19 20:18:10 UTC
Patch in URL
Comment 2 Chris Smith 2009-05-19 20:24:58 UTC
(In reply to comment #1)
> Patch in URL

Works here. Thanks! 

Comment 3 Peter Alfredsen (RETIRED) gentoo-dev 2009-05-19 21:19:18 UTC
Glibc-2.10 bug
See http://udrepper.livejournal.com/20948.html
Comment 4 Peter Alfredsen (RETIRED) gentoo-dev 2009-05-21 14:03:11 UTC
*** Bug 270511 has been marked as a duplicate of this bug. ***
Comment 5 Ben de Groot (RETIRED) gentoo-dev 2009-05-28 23:05:24 UTC
*** Bug 271455 has been marked as a duplicate of this bug. ***
Comment 6 David Davidson 2009-06-01 22:01:55 UTC
With the fltk-1.1.9 xft use flag enabled this patch is also needed:

http://cvs.fedoraproject.org/viewvc/devel/fltk/fltk-1.1.9-consts.patch?revision=1.1


I'll also attach a patch for fltk-2.0_pre6786 that I'm using.
Comment 7 David Davidson 2009-06-01 22:05:08 UTC
Created attachment 193192 [details, diff]
fltk-2.0_pre6786 fix for glibc-2.10
Comment 8 Bernd Butscheidt 2009-06-08 12:01:34 UTC
I had success using the patch of the previous post with fltk 2.0_pre6786.

emerge --info:

Portage 2.2_rc33 (default/linux/amd64/2008.0/desktop, gcc-4.3.3, glibc-2.10.1-r0, 2.6.29-gentoo-r2 x86_64)
=================================================================
System uname: Linux-2.6.29-gentoo-r2-x86_64-AMD_Athlon-tm-_64_X2_Dual_Core_Processor_3600+-with-gentoo-2.0.1
Timestamp of tree: Sun, 07 Jun 2009 17:15:02 +0000
ccache version 2.4 [enabled]
app-shells/bash:     4.0_p24
dev-java/java-config: 1.3.7-r1, 2.1.8
dev-lang/python:     2.5.4-r2, 2.6.2-r1
dev-python/pycrypto: 2.0.1-r8
dev-util/ccache:     2.4-r8
dev-util/cmake:      2.6.4
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.4.3-r2
sys-apps/sandbox:    2.0
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2, 1.11
sys-devel/binutils:  2.19.1-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.29
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=athlon64 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=athlon64 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distlocks fixpackages parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://ftp.tu-clausthal.de/pub/linux/gentoo/ ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gentoo ftp://linux.rz.ruhr-uni-bochum.de/gentoo-mirror/ ftp://ftp.uni-erlangen.de/pub/mirrors/gentoo ftp://ftp.join.uni-muenster.de/pub/linux/distributions/gentoo ftp://ftp.wh2.tu-dresden.de/pub/mirrors/gentoo ftp://ftp.join.uni-muenster.de/pub/linux/distributions/gentoo http://mirrors.sec.informatik.tu-darmstadt.de/gentoo/ ftp://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/ ftp://pandemonium.tiscali.de/pub/gentoo/ ftp://de-mirror.org/distro/gentoo/ "
LANG="en_GB.UTF-8"
LC_ALL="en_GB.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="en en_GB de"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/own /usr/local/portage/layman/berkano /usr/local/portage/layman/portato /usr/local/portage/layman/oss-overlay /usr/local/portage/layman/sunrise /usr/local/portage/layman/java-overlay /usr/local/portage/layman/vmware"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="3dnow X acl acpi alsa amd64 berkdb bluetooth branding bzip2 cairo caps cdr cli cracklib crypt cups dbus dga dri dvd dvdr dvdread eds emboss encode esd evo fam firefox fortran gdbm gif gpm gstreamer hal iconv ipv6 isdnlog jpeg kde ldap libnotify mad midi mikmod mmx mp3 mpeg mudflap multilib ncurses nls nptl nptlonly ogg opengl openmp pam pcre pdf perl png ppds pppd python qt3 qt3support qt4 quicktime readline reflection sdl session spell spl sse sse2 ssl startup-notification svg sysfs tcpd threads tiff truetype unicode usb vorbis xml xorg xulrunner xv zlib" ALSA_CARDS="HDA NVidia" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="mouse keyboard" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_GB de" USERLAND="GNU" VIDEO_CARDS="mga nv nvidia nvidia%"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 9 Xavier Miller gentoo-dev 2009-06-23 18:06:25 UTC
(In reply to comment #7)
> Created an attachment (id=193192) [edit]
> fltk-2.0_pre6786 fix for glibc-2.10
> 

Patch worked fine for me !

emerge --info
Portage 2.2_rc33 (default/linux/x86/2008.0, gcc-4.3.3, glibc-2.10.1-r0, 2.6.29-tuxonice-r3 i686)
=================================================================
System uname: Linux-2.6.29-tuxonice-r3-i686-Intel-R-_Atom-TM-_CPU_N270_@_1.60GHz-with-gentoo-2.0.1
Timestamp of tree: Tue, 23 Jun 2009 06:30:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     4.0_p24
dev-lang/python:     2.5.4-r2, 2.6.2-r1
dev-util/ccache:     2.4-r8
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.4.3-r3
sys-apps/sandbox:    2.0
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.9.6-r2, 1.10.2, 1.11
sys-devel/binutils:  2.19.1-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.29
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-linux-gnu"
CFLAGS="-O2 -pipe -fomit-frame-pointer -march=native -mtune=native"
CHOST="i686-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -pipe -fomit-frame-pointer -march=native -mtune=native"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--with-bdeps y"
FEATURES="candy ccache distlocks fixpackages parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://ftp.belnet.be/mirror/rsync.gentoo.org/gentoo/"
LANG="fr_BE.UTF-8"
LC_ALL="fr_BE.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="fr fr_BE fr_BE.UTF-8"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/overlays /usr/portage/local/layman/pro-audio"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X acl acpi alsa apache apache2 branding bzip2 cairo cleartype cli consolekit cracklib crypt cups dri dssi exif ffmpeg gd gif glitz gpm gui hal iconv id3tag isdnlog jack jpeg libnotify midi mmx mp3 mp3rtp mpeg mudflap ncurses nls nptl nptlonly ogg opengl openmp osc osc_opcodes pam pcre pdf php pkcs11 png ppds pppd qt3 readline reflection rle samba session slang spl sqlite sqlite3 sse sse2 sse3 ssl subversion svg sysfs tcpd tiff truetype unicode vorbis vst win32codecs wmf x264 x86 xfce xml xorg xscreensaver zlib" ALSA_CARDS="hda-intel usb-audio virmidi" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse synaptics evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="fr fr_BE fr_BE.UTF-8" USERLAND="GNU" VIDEO_CARDS="intel"
Unset:  CPPFLAGS, CTARGET, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

Comment 10 Lars Wendler (Polynomial-C) gentoo-dev 2009-07-04 08:45:30 UTC
*** Bug 276330 has been marked as a duplicate of this bug. ***
Comment 11 Ben de Groot (RETIRED) gentoo-dev 2009-07-04 16:52:58 UTC
*** Bug 275802 has been marked as a duplicate of this bug. ***
Comment 12 Ben de Groot (RETIRED) gentoo-dev 2009-07-04 18:39:28 UTC
Patch added. Thanks for your contributions.
Comment 13 Ben de Groot (RETIRED) gentoo-dev 2009-07-04 18:40:45 UTC
Sorry, I only fixed fltk:2. Reopening for 1.1.
Comment 14 Ben de Groot (RETIRED) gentoo-dev 2009-07-05 08:38:42 UTC
Proposed patches added to 1.1.9 ebuild as well. Thanks again!
Comment 15 Audiodef 2009-07-06 15:50:15 UTC
Did I miss something? I synced and emerged again, but I'm still getting this compile error. 
Comment 16 Samuli Suominen gentoo-dev 2009-07-06 16:04:22 UTC
(In reply to comment #15)
> Did I miss something? I synced and emerged again, but I'm still getting this
> compile error. 
> 

You could check ChangeLog in /usr/portage/x11-libs/fltk. It should say,

  05 Jul 2009; Ben de Groot <yngwin@gentoo.org> fltk-1.1.9.ebuild,
  +files/fltk-1.1.9-consts.patch, +files/fltk-1.1.9-glibc2.10-scandir.patch:
  Add patches to make 1.1.9 build with glibc-2.10/gcc-4.4. Fixes bug 270487.
  Patches originate from Fedora CVS.
Comment 17 Audiodef 2009-07-06 18:56:15 UTC
After syncing, this is what I get:

  09 Jan 2009; S<C3><A9>bastien Fabbro <bicatali@gentoo.org>
  +files/fltk-1.1.9-as-needed.patch, +files/fltk-1.1.9-conf-tests.patch,
  +files/fltk-1.1.9-desktop.patch, metadata.xml, +fltk-1.1.9.ebuild:
  Version bump for 1.1, with ebuild modernization and added games. Dropping
  ppc64 and hppa until htmldoc is keyworded.

  09 Jan 2009; R<C3><A9>mi Cardona <remi@gentoo.org> fltk-1.1.7.ebuild,
  fltk-1.1.7-r2.ebuild, fltk-1.1.7-r3.ebuild, fltk-2.0_pre6525.ebuild:
  Change virtual/xft dependency to x11-libs/libXft, bug 253771.

  07 Jan 2009; Brent Baude <ranger@gentoo.org> fltk-2.0_pre6525.ebuild:
  Marking fltk-2.0_pre6525 ppc64 for bug 253082

  05 Jan 2009; Markus Meier <maekke@gentoo.org> metadata.xml:
  drop local xft USE-flag description, as it's global now

  30 Dec 2008; Ben de Groot <yngwin@gentoo.org> -fltk-2.0_pre6403.ebuild,
  -fltk-2.0_pre6483.ebuild, fltk-2.0_pre6525.ebuild:
  Removing old snapshots. Minor ebuild improvements wrt die messages. Add
  ~ppc keyword, bug 242774#c13.


I don't see anything about a consts patch.
Comment 18 Samuli Suominen gentoo-dev 2009-07-06 21:15:23 UTC
Yep, your rsync mirror is broken, please change it..
Comment 19 Johannes Rauh 2009-07-07 13:19:40 UTC
It seems that with the patches I have exactly the reverse error: If I want to compile fltk-1.1.9 with glibc-2.9_p20081201-r2 under sys-devel/gcc-4.3.3, I get the following output (sorry for the German localization...):

Compiling filename_list.cxx...                                                                                                                               
filename_list.cxx: In function »int fl_filename_list(const char*, dirent***, int (*)(dirent**, dirent**))«:                                                  
filename_list.cxx:70: Fehler: ungültige Umwandlung von »int (*)(const dirent**, const dirent**)« in »int (*)(const void*, const void*)«                      
filename_list.cxx:70: Fehler:   Argument 4 von »int scandir(const char*, dirent***, int (*)(const dirent*), int (*)(const void*, const void*))« wird initialisiert                                                                                                                                                        
make[1]: *** [filename_list.o] Fehler 1                                                                                                                      
make[1]: *** Warte auf noch nicht beendete Prozesse...                                                                                                       
Fl_x.cxx: In function »int can_boxcheat(uchar)«:                                                                                                             
Fl_x.cxx:1372: Warnung: Klammern um && innerhalb von || empfohlen                                                                                            
make: *** [all] Fehler 1
Comment 20 Johannes Rauh 2009-07-07 15:33:58 UTC
and I just checked: If I remove the two patches +files/fltk-1.1.9-consts.patch, +files/fltk-1.1.9-glibc2.10-scandir.patch from the ebuild, then the emerge works without problem.
Comment 21 Ben de Groot (RETIRED) gentoo-dev 2009-07-07 21:46:42 UTC
(In reply to comment #19)
> It seems that with the patches I have exactly the reverse error: If I want to
> compile fltk-1.1.9 with glibc-2.9_p20081201-r2 under sys-devel/gcc-4.3.3, 

Yes, that's bug 276695
Comment 22 Ben de Groot (RETIRED) gentoo-dev 2009-07-08 11:53:21 UTC
Due to that failure I have reverted the glibc-2.10 patches from 1.1.9 and 2.0_pre6786, so those versions compile with glibc-2.9 and can be marked stable. I have added -r1 ebuilds with the patches, so ~amd64 and ~x86 users can use those.
Comment 23 emerald 2009-11-22 08:20:42 UTC
Please keyword the -r1 versions for all arches, where glibc >= 2.10.1 is keyworded and marked for testing (in my case it's ppc).