Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 274583 - media-plugins/vdr-graphtft-0.2.2-r1 fails to build with gcc-4.4
Summary: media-plugins/vdr-graphtft-0.2.2-r1 fails to build with gcc-4.4
Status: RESOLVED DUPLICATE of bug 273840
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo VDR Project
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gcc-4.4
  Show dependency tree
 
Reported: 2009-06-18 06:45 UTC by Joost Ruis
Modified: 2009-07-01 15:45 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Joost Ruis 2009-06-18 06:45:43 UTC
...

 * DeepBlue-horchi-0.0.11.tar.bz2 RMD160 SHA1 SHA256 size ;-) ...                                                                         [ ok ]
 * checking ebuild checksums ;-) ...                                                                                                      [ ok ]
 * checking auxfile checksums ;-) ...                                                                                                     [ ok ]
 * checking miscfile checksums ;-) ...                                                                                                    [ ok ]
 * Compiling against
 *      vdr-1.6.0-2 [API version 1.6.0]
>>> Unpacking source...
>>> Unpacking vdr-graphtft-0.2.2.tar.bz2 to /var/tmp/portage/media-plugins/vdr-graphtft-0.2.2-r1/work
>>> Unpacking DeepBlue-horchi-0.0.11.tar.bz2 to /var/tmp/portage/media-plugins/vdr-graphtft-0.2.2-r1/work
>>> Source unpacked in /var/tmp/portage/media-plugins/vdr-graphtft-0.2.2-r1/work
>>> Preparing source in /var/tmp/portage/media-plugins/vdr-graphtft-0.2.2-r1/work/graphtft-0.2.2 ...
 * Applying vdr-graphtft-0.2.2_gentoo.diff ...                                                                                             [ ok ]
 * Patching Makefile
 *   Setting paths ...                                                                                                                     [ ok ]
 * VDR has gettext support
 * Plugin has gettext support, fine
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/media-plugins/vdr-graphtft-0.2.2-r1/work/graphtft-0.2.2 ...
>>> Source configured.
>>> Compiling source in /var/tmp/portage/media-plugins/vdr-graphtft-0.2.2-r1/work/graphtft-0.2.2 ...
make -j2 -s all LOCALEDIR=/var/tmp/portage/media-plugins/vdr-graphtft-0.2.2-r1/work/tmp-locale LIBDIR=/var/tmp/portage/media-plugins/vdr-graphtft-0.2.2-r1/work/graphtft-0.2.2 TMPDIR=/var/tmp/portage/media-plugins/vdr-graphtft-0.2.2-r1/temp
In file included from graphtft.c:16:
./theme.h: In constructor 'Scan::Scan(const char*)':
./theme.h:43: warning: format not a string literal and no format arguments
In file included from ./sysinfo.h:13,
                 from dspitems.c:16:
./common.h:118: error: 'uint64_t' does not name a type
In file included from dspitems.c:17:
./theme.h: In constructor 'Scan::Scan(const char*)':
./theme.h:43: warning: format not a string literal and no format arguments
make: *** [dspitems.o] Error 1
make: *** Waiting for unfinished jobs....
 *
 * ERROR: media-plugins/vdr-graphtft-0.2.2-r1 failed.


Reproducible: Always
Comment 1 Joost Ruis 2009-06-18 06:57:55 UTC
Right after submitting this report i started to doubt the relation with glibc, any way in addition here is some more info:

 sabayon server # emerge --info
Portage 2.2_rc33 (default/linux/x86/2008.0/desktop, gcc-4.4.0, glibc-2.10.1-r0, 2.6.25-sabayon i686)
=================================================================
System uname: Linux-2.6.25-sabayon-i686-Intel-R-_Xeon-R-_CPU_X3220_@_2.40GHz-with-gentoo-2.0.1
Timestamp of tree: Fri, 12 Jun 2009 12:00:05 +0000
distcc 3.1 i686-pc-linux-gnu [disabled]
ccache version 2.4 [disabled]
app-shells/bash:     4.0_p24
dev-java/java-config: 1.3.7-r1, 2.1.8
dev-lang/python:     2.4.6, 2.5.4-r3, 2.6.2-r1
dev-python/pycrypto: 2.0.1-r8
dev-util/ccache:     2.4-r8
dev-util/cmake:      2.6.3
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.4.3-r5
sys-apps/sandbox:    2.0
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2, 1.11
sys-devel/binutils:  2.19.1-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.29
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=i686 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /etc/entropy /opt/glftpd/etc /opt/glftpd/ftp-data /opt/openfire/resources/security/ /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/share/config/kdm/ /usr/kde/3.5/shutdown /usr/kde/4.2/env /usr/kde/4.2/share/config /usr/kde/4.2/shutdown /usr/lib/fax /usr/share/config /usr/share/xbmc/userdata /var/bind /var/lib/hsqldb /var/spool/fax/etc /var/spool/torque"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/skel /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -march=i686 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="collision-protect distlocks fixpackages parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://mirror.leaseweb.com/gentoo/ ftp://mirror.leaseweb.com/gentoo/ ftp://mirror.muntinternet.net/pub/gentoo/ ftp://91.121.124.139/gentoo-distfiles/ http://mirror.switch.ch/ftp/mirror/gentoo/"
LANG="en_US"
LC_ALL="en_US"
LDFLAGS="-Wl,-O1"
LINGUAS="en en_US af ar az bg bn br bs ca cs cy da de el en_GB eo es et eu fa fi fr fy ga gl he hi hr hu is it ja kk km ko lt lv mk mn ms nb nds nl nn pa pl pt pt_BR ro ru rw se sk sl sr sr@Latn ss sv ta tg tr uk uz vi zh_CN zh_TW es_AR es_ES fy_NL ga_IE gu gu_IN nb_NO nn_NO pt_PT sv_SE zh"
MAKEOPTS="-j2 -s "
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/enlightenment /usr/local/portage/layman/sabayon"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="7Zip X a52 aac aalib accessibility acl acpi aiglx aim alsa artswrappersuid audiofile avahi bash-completion berkdb bidi bluetooth bzip2 cairo cdda cddb cdr chm cjk cli config_wizard cpudetection cracklib crypt css cups dbox2 dbus dga dri dts dv dvb dvd dvdr dvdread dxr3 emboss encode extramodules fam fame fat ffmpeg fftw firefox flac flash foomatic-db fortran freetype gcj gdbm gif gimpprint gmp gnutls gphoto2 gpm gs gsm gstreamer gtk hal hfs iconv icq ieee1394 imap inotify ipod ipv6 irc irda isdnlog jabber jack jfs jingle joystick jpeg kde kdeenablefinal kdehiddenvisibility kerberos kipi lame lcd ldap libnotify live lj lm_sensors logitech-mouse lzo mad mail midi mikmod mjpeg mmx mng mozdevelop mp3 mp3rtp mpeg msn mudflap musepack musicbrainz ncurses network new-login nls nptl nptlonly nsplugin ntfs ogg openal openexr opengl openmp pam pcmcia pcre pda pdf perl png policykit povray ppds pppd pulseaudio python qt3support qt4 quicktime quotas rar rdesktop readline reflection reiserfs rss scanner sdl session slp sms speex spell spl ssl startup-notification stream svg sysfs tcpd theora tiff tracker truetype udev unicode usb v4l v4l2 visualization voice vorbis weather wifi win32codecs wmf x264 x86 xcb xfs xine xinerama xml xorg xpm xprint xulrunner xv xvid xvmc yahoo zeroconf zlib" ALSA_CARDS="emu10k1x darla20 darla24 emu10k1 gina20 gina24 hdsp hdspm ice1712 indigo indigoio layla20 layla24 mia mixart mona pcxhr rme32 rme96 sb16 sbawe sscape usbusx2y vx222 usb-usx2y" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" APACHE2_MPMS="prefork" CAMERAS="agfa_cl20 casio_qv dimagev dimera3500 kodak_dc120 kodak_dc210 kodak_dc240 kodak_dc3200 kodak_ez200 konica_qm150 panasonic_coolshot panasonic_dc1000 panasonic_dc1580 panasonic_l859 polaroid_pdc320 polaroid_pdc640 polaroid_pdc700 ricoh_g3 sipix_blink sipix_blink2 sipix_web2 sony_dscf1 sony_dscf55 toshiba_pdrm11 adc65 aox barbie canon clicksmart310 digigr8 digita directory enigma13 fuji gsmart300 hp215 iclick jamcam jd11 konica largan lg_gsm mars mustek pccam300 pccam600 ptp2 ricoh samsung sierra smal sonix soundvision spca50x sq905 stv0674 stv0680 sx330z template" ELIBC="glibc" INPUT_DEVICES="evdev keyboard mouse void" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_US af ar az bg bn br bs ca cs cy da de el en_GB eo es et eu fa fi fr fy ga gl he hi hr hu is it ja kk km ko lt lv mk mn ms nb nds nl nn pa pl pt pt_BR ro ru rw se sk sl sr sr@Latn ss sv ta tg tr uk uz vi zh_CN zh_TW es_AR es_ES fy_NL ga_IE gu gu_IN nb_NO nn_NO pt_PT sv_SE zh" LIRC_DEVICES="audio audio_alsa" USERLAND="GNU" VIDEO_CARDS="fbdev vesa"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 2 Mike Auty gentoo-dev 2009-06-21 21:53:08 UTC
This is more likely a gcc-4.4 bug...
Comment 3 Víctor Ostorga (RETIRED) gentoo-dev 2009-07-01 15:45:27 UTC

*** This bug has been marked as a duplicate of bug 273840 ***