Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 273347 - media-sound/phonon-4.3.80-r1 doesn't compile with USE="-xcb"
Summary: media-sound/phonon-4.3.80-r1 doesn't compile with USE="-xcb"
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
: 291268 307149 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-06-09 12:23 UTC by Dmitry Bigunyak
Modified: 2010-09-05 19:38 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---
tampakrap: Bugday+


Attachments
build log (build.log,15.27 KB, text/plain)
2009-06-09 12:24 UTC, Dmitry Bigunyak
Details
fix for the issue (phonon-no-xcb-fix.patch,1.73 KB, patch)
2009-09-05 15:51 UTC, Andrzej Rybczak
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dmitry Bigunyak 2009-06-09 12:23:44 UTC
Package media-sound/phonon-4.3.1 isn't compile without "xcb" use flag.
Comment 1 Dmitry Bigunyak 2009-06-09 12:24:46 UTC
Created attachment 193988 [details]
build log
Comment 2 Premek Vohnout 2009-06-22 16:12:28 UTC
It works for me. I think it will need more info. gcc version, xorg version... 
Comment 3 Andrzej Rybczak 2009-09-05 15:48:24 UTC
(In reply to comment #2)
> It works for me. I think it will need more info. gcc version, xorg version... 
> 

Same here with media-sound/phonon-4.4_pre20090520 (with 4.3.1 it didn't work either)

unknown@electronics ~ $ emerge phonon -pv

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] media-sound/phonon-4.4_pre20090520  USE="xine -debug -gstreamer -xcb" 0 kB

Note that I don't have xcb installed. Maybe the reason it works for you is that you have and that covers the actual bug.

Steps to reproduce:

1. emerge libxcb -C
2. USE="-* xine" emerge phonon
Comment 4 Andrzej Rybczak 2009-09-05 15:51:11 UTC
Created attachment 203201 [details, diff]
fix for the issue

it works with both 4.3.1 and 4.4_pre20090520.
Comment 5 Samuli Suominen gentoo-dev 2010-02-28 10:29:38 UTC
*** Bug 307149 has been marked as a duplicate of this bug. ***
Comment 6 Samuli Suominen gentoo-dev 2010-02-28 10:37:13 UTC
*** Bug 291268 has been marked as a duplicate of this bug. ***
Comment 7 D W 2010-02-28 15:00:17 UTC
By the way, it doesn't compile with [xine,-xcb]
The build error is in the xine code.
It does compile with [-xine,gstreamer,-xcb]
Comment 8 Andreas K. Hüttel gentoo-dev 2010-07-07 18:44:31 UTC
What's happening with phonon-4.4.1-r1?
Comment 9 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2010-09-05 19:38:42 UTC
Couldn't reproduce with phonon-4.4.2, so I guess the relevant xine code has been fixed. Please reopen if the problem persists for you. Thanks