Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 273173 - app-emulation/vmware-modules-1.0.0.15-r2 fails to build with sys-kernel/gentoo-sources-{2.6.29-{r2,r5},2.6.30-r5}
Summary: app-emulation/vmware-modules-1.0.0.15-r2 fails to build with sys-kernel/gento...
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal with 2 votes (vote)
Assignee: Gentoo VMWare Bug Squashers [disabled]
URL:
Whiteboard:
Keywords:
: 264098 273193 288300 288735 (view as bug list)
Depends on:
Blocks: 264722
  Show dependency tree
 
Reported: 2009-06-08 10:22 UTC by velladecin
Modified: 2011-03-17 13:20 UTC (History)
15 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
vmmon module patch for kernels 2.6.29 and 2.6.30 (050_all_kernel-2.6.29.patch,32.26 KB, patch)
2009-07-08 22:01 UTC, Jani-Matti Hätinen
Details | Diff
vmnet module patch for kernels 2.6.29 and 2.6.30 (040_all_kernel-2.6.29.patch,55.34 KB, text/plain)
2009-07-08 22:02 UTC, Jani-Matti Hätinen
Details
patch to export init_mm symbol in kernels 2.6.29 and 2.6.30 (2.6.29-export-init_mm.patch,530 bytes, patch)
2009-07-08 22:06 UTC, Jani-Matti Hätinen
Details | Diff
corrected version of vmnet patch above (040_all_kernel-2.6.29.patch,12.80 KB, patch)
2009-07-27 13:23 UTC, Mathias Weigt
Details | Diff
Output of patch step (050_all_kernel-2.6.29.patch-9061.out,44.04 KB, text/plain)
2010-01-17 18:06 UTC, Sebastiano Cavicchio
Details

Note You need to log in before you can comment on or make changes to this bug.
Description velladecin 2009-06-08 10:22:16 UTC
with kernel 2.6.29-gentoo-r5 (also 2.6.29-gentoo-r2) emerge vmware-server fails, moduels needed never build (=app-emulation/vmware-server-1.0.8.126538, =app-emulation/vmware-modules-1.0.0.15-r2) 

Reproducible: Always

Steps to Reproduce:
1. emerge -avt vmware-server
2. Would you like to merge these packages? [Yes/No] y


Actual Results:  
>>> Source unpacked in /var/tmp/portage/app-emulation/vmware-modules-1.0.0.15-r2/work
>>> Compiling source in /var/tmp/portage/app-emulation/vmware-modules-1.0.0.15-r2/work ...
 * Preparing vmmon module
make -j5 HOSTCC=i686-pc-linux-gnu-gcc CROSS_COMPILE=i686-pc-linux-gnu- LDFLAGS= auto-build VMWARE_VER=VME_S1B1 KERNEL_DIR=/usr/src/linux KBUILD_OUTPUT=/lib/modules/2.6.29-gentoo-r5/build 
Using 2.6.x kernel build system.
make -C /usr/src/linux/include/.. M=$PWD SRCROOT=$PWD/. modules
make[1]: Entering directory `/usr/src/linux-2.6.29-gentoo-r5'
make[1]: warning: jobserver unavailable: using -j1.  Add `+' to parent make rule.
  CC [M]  /var/tmp/portage/app-emulation/vmware-modules-1.0.0.15-r2/work/vmmon-only/linux/driver.o
In file included from /var/tmp/portage/app-emulation/vmware-modules-1.0.0.15-r2/work/vmmon-only/./include/x86.h:21,
                 from /var/tmp/portage/app-emulation/vmware-modules-1.0.0.15-r2/work/vmmon-only/linux/driver.h:15,
                 from /var/tmp/portage/app-emulation/vmware-modules-1.0.0.15-r2/work/vmmon-only/linux/driver.c:53:
/var/tmp/portage/app-emulation/vmware-modules-1.0.0.15-r2/work/vmmon-only/./include/x86apic.h:80:1: warning: "APIC_BASE_MSR" redefined
In file included from /usr/src/linux-2.6.29-gentoo-r5/arch/x86/include/asm/fixmap_32.h:29,
                 from /usr/src/linux-2.6.29-gentoo-r5/arch/x86/include/asm/fixmap.h:5,
                 from /usr/src/linux-2.6.29-gentoo-r5/arch/x86/include/asm/apic.h:8,
                 from /usr/src/linux-2.6.29-gentoo-r5/arch/x86/include/asm/smp.h:13,
                 from include/linux/smp.h:36,
                 from include/linux/topology.h:33,
                 from include/linux/mmzone.h:767,
                 from include/linux/gfp.h:4,
                 from include/linux/kmod.h:22,
                 from include/linux/module.h:13,
                 from /var/tmp/portage/app-emulation/vmware-modules-1.0.0.15-r2/work/vmmon-only/linux/driver.c:16:
/usr/src/linux-2.6.29-gentoo-r5/arch/x86/include/asm/apicdef.h:132:1: warning: this is the location of the previous definition
In file included from /var/tmp/portage/app-emulation/vmware-modules-1.0.0.15-r2/work/vmmon-only/./include/vmci_kernel_defs.h:26,
                 from /var/tmp/portage/app-emulation/vmware-modules-1.0.0.15-r2/work/vmmon-only/./common/vmciContext.h:19,
                 from /var/tmp/portage/app-emulation/vmware-modules-1.0.0.15-r2/work/vmmon-only/linux/driver.h:21,
                 from /var/tmp/portage/app-emulation/vmware-modules-1.0.0.15-r2/work/vmmon-only/linux/driver.c:53:
/var/tmp/portage/app-emulation/vmware-modules-1.0.0.15-r2/work/vmmon-only/./include/compat_wait.h:60: error: conflicting types for 'poll_initwait'
include/linux/poll.h:67: error: previous declaration of 'poll_initwait' was here
/var/tmp/portage/app-emulation/vmware-modules-1.0.0.15-r2/work/vmmon-only/linux/driver.c: In function 'LinuxDriver_Open':
/var/tmp/portage/app-emulation/vmware-modules-1.0.0.15-r2/work/vmmon-only/linux/driver.c:579: error: 'struct task_struct' has no member named 'euid'
/var/tmp/portage/app-emulation/vmware-modules-1.0.0.15-r2/work/vmmon-only/linux/driver.c: In function '__LinuxDriver_Ioctl':
/var/tmp/portage/app-emulation/vmware-modules-1.0.0.15-r2/work/vmmon-only/linux/driver.c:1530: error: 'struct task_struct' has no member named 'suid'
/var/tmp/portage/app-emulation/vmware-modules-1.0.0.15-r2/work/vmmon-only/linux/driver.c:1531: error: 'struct task_struct' has no member named 'cap_permitted'
/var/tmp/portage/app-emulation/vmware-modules-1.0.0.15-r2/work/vmmon-only/linux/driver.c:1796: error: 'struct task_struct' has no member named 'euid'
/var/tmp/portage/app-emulation/vmware-modules-1.0.0.15-r2/work/vmmon-only/linux/driver.c:1796: error: 'struct task_struct' has no member named 'uid'
/var/tmp/portage/app-emulation/vmware-modules-1.0.0.15-r2/work/vmmon-only/linux/driver.c:1797: error: 'struct task_struct' has no member named 'fsuid'
/var/tmp/portage/app-emulation/vmware-modules-1.0.0.15-r2/work/vmmon-only/linux/driver.c:1797: error: 'struct task_struct' has no member named 'uid'
/var/tmp/portage/app-emulation/vmware-modules-1.0.0.15-r2/work/vmmon-only/linux/driver.c:1798: error: 'struct task_struct' has no member named 'egid'
/var/tmp/portage/app-emulation/vmware-modules-1.0.0.15-r2/work/vmmon-only/linux/driver.c:1798: error: 'struct task_struct' has no member named 'gid'
/var/tmp/portage/app-emulation/vmware-modules-1.0.0.15-r2/work/vmmon-only/linux/driver.c:1799: error: 'struct task_struct' has no member named 'fsgid'
/var/tmp/portage/app-emulation/vmware-modules-1.0.0.15-r2/work/vmmon-only/linux/driver.c:1799: error: 'struct task_struct' has no member named 'gid'
make[3]: *** [/var/tmp/portage/app-emulation/vmware-modules-1.0.0.15-r2/work/vmmon-only/linux/driver.o] Error 1
make[2]: *** [_module_/var/tmp/portage/app-emulation/vmware-modules-1.0.0.15-r2/work/vmmon-only] Error 2
make[1]: *** [sub-make] Error 2
make[1]: Leaving directory `/usr/src/linux-2.6.29-gentoo-r5'
make: *** [vmmon.ko] Error 2
 * 
 * ERROR: app-emulation/vmware-modules-1.0.0.15-r2 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 3654:  Called linux-mod_src_compile
 *             environment, line 2772:  Called die
 * The specific snippet of code:
 *               eval "emake HOSTCC=\"$(tc-getBUILD_CC)\" 						CROSS_COMPILE=${CHOST}- 						LDFLAGS=\"$(get_abi_LDFLAGS)\" ${BUILD_FIXES} 						${BUILD_PARAMS} 						${BUILD_TARGETS} " || die "Unable to emake HOSTCC="$(tc-getBUILD_CC)" CROSS_COMPILE=${CHOST}- LDFLAGS="$(get_abi_LDFLAGS)" ${BUILD_FIXES} ${BUILD_PARAMS} ${BUILD_TARGETS}";
 *  The die message:
 *   Unable to emake HOSTCC=i686-pc-linux-gnu-gcc CROSS_COMPILE=i686-pc-linux-gnu- LDFLAGS=   auto-build VMWARE_VER=VME_S1B1 KERNEL_DIR=/usr/src/linux KBUILD_OUTPUT=/lib/modules/2.6.29-gentoo-r5/build
 * 
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/app-emulation/vmware-modules-1.0.0.15-r2/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/app-emulation/vmware-modules-1.0.0.15-r2/temp/environment'.
 * 

>>> Failed to emerge app-emulation/vmware-modules-1.0.0.15-r2, Log file:

>>>  '/var/tmp/portage/app-emulation/vmware-modules-1.0.0.15-r2/temp/build.log'

 * Messages for package app-emulation/vmware-modules-1.0.0.15-r2:

 * 
 * ERROR: app-emulation/vmware-modules-1.0.0.15-r2 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 3654:  Called linux-mod_src_compile
 *             environment, line 2772:  Called die
 * The specific snippet of code:
 *               eval "emake HOSTCC=\"$(tc-getBUILD_CC)\" 						CROSS_COMPILE=${CHOST}- 						LDFLAGS=\"$(get_abi_LDFLAGS)\" ${BUILD_FIXES} 						${BUILD_PARAMS} 						${BUILD_TARGETS} " || die "Unable to emake HOSTCC="$(tc-getBUILD_CC)" CROSS_COMPILE=${CHOST}- LDFLAGS="$(get_abi_LDFLAGS)" ${BUILD_FIXES} ${BUILD_PARAMS} ${BUILD_TARGETS}";
 *  The die message:
 *   Unable to emake HOSTCC=i686-pc-linux-gnu-gcc CROSS_COMPILE=i686-pc-linux-gnu- LDFLAGS=   auto-build VMWARE_VER=VME_S1B1 KERNEL_DIR=/usr/src/linux KBUILD_OUTPUT=/lib/modules/2.6.29-gentoo-r5/build
 * 
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/app-emulation/vmware-modules-1.0.0.15-r2/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/app-emulation/vmware-modules-1.0.0.15-r2/temp/environment'.
 * 



decin vella # emerge --info
Portage 2.1.6.13 (default/linux/x86/2008.0, gcc-4.3.2, glibc-2.8_p20080602-r1, 2.6.29-gentoo-r5 i686)
=================================================================
System uname: Linux-2.6.29-gentoo-r5-i686-Intel-R-_Core-TM-2_Quad_CPU_Q6600_@_2.40GHz-with-glibc2.0
Timestamp of tree: Mon, 08 Jun 2009 01:45:02 +0000
app-shells/bash:     3.2_p39
dev-java/java-config: 2.1.7
dev-lang/python:     2.5.4-r2
dev-python/pycrypto: 2.0.1-r8
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=prescott -pipe -fomit-frame-pointer -ggdb"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/nanorc /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d /etc/wget"
CXXFLAGS="-O2 -march=prescott -pipe -fomit-frame-pointer -ggdb"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://mirror.pacific.net.au/linux/Gentoo ftp://mirror.pacific.net.au/linux/Gentoo http://ftp.swin.edu.au/gentoo ftp://ftp.swin.edu.au/gentoo http://ftp.jaist.ac.jp/pub/Linux/Gentoo/ ftp://ftp.jaist.ac.jp/pub/Linux/Gentoo/ http://ftp.twaren.net/Linux/Gentoo/ ftp://ftp.twaren.net/Linux/Gentoo/ http://ftp.ncnu.edu.tw/Linux/Gentoo/ ftp://ftp.ncnu.edu.tw/Linux/Gentoo/ "
LDFLAGS="-Wl,-O1"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/flash /usr/local/portage/flash"
SYNC="rsync://rsync.au.gentoo.org/gentoo-portage"
USE="X acl acp acpi alsa berkdb branding bzip2 cairo caps cdr cli cracklib crypt css cups dbus dri dvd dvdr dvdread firefox fortran ftp gdbm gif gpm gtk hal iconv icq ieee1394 ipv6 isdnlog java jpeg latex midi mp3 mpeg mplayer msn mudflap ncurses nls nptl nptlonly nvidia ogg opengl openmp pam pcre pdf perl png pppd python quicktime readline reflection samba session snmp soap spl ssl startup-notification sysfs tcpd trutype unicode usb win32codecs x86 xml xorg xscreensaver xv xvmc zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Rafał Mużyło 2009-06-08 14:53:53 UTC
*** Bug 273193 has been marked as a duplicate of this bug. ***
Comment 2 Lars Wendler (Polynomial-C) gentoo-dev 2009-06-09 14:11:08 UTC
Unfortunately this bug probably will stay unsolved for a while as our vmware herd currently has no maintainer.
Comment 3 Konstantin Agouros 2009-06-10 18:06:50 UTC
(In reply to comment #2)
> Unfortunately this bug probably will stay unsolved for a while as our vmware
> herd currently has no maintainer.
> 
I found a patch or new version of the modules at http://www.it-psycho.de/2009/03/29/vmware-server-108-und-kernel-2629
The site is in German but there are two downloads at the beginning. Althou the url talks about server-108 I am not sure if the dowloadable file do not belong to VMWare Server 2.X

Konstantin
Comment 4 Konstantin Agouros 2009-06-12 13:59:42 UTC
OK for those that really need it:

I can confirm, that if one patches the kernel to export the init_mm symbol and then builds
vmmon and vmnet from the site mentioned above this will result in a working vmware-server
with gentoo-sources-2.6.29-r5

Cheers,

Konstantin
Comment 5 Sebastian Dörner 2009-07-04 09:53:26 UTC
This seems to be the same problem as in
http://bugs.gentoo.org/show_bug.cgi?id=264098
Comment 6 Jani-Matti Hätinen 2009-07-08 22:01:41 UTC
Created attachment 197271 [details, diff]
vmmon module patch for kernels 2.6.29 and 2.6.30

This patch fixes vmmon module for kernels 2.6.29 and 2.6.30. Although, in both cases the kernel must also be patched to export the init_mm symbol.

To use this patch, make a copy of the vmware-modules package in your local overlay and copy this file to app-emulation/vmware-modules/files/patches/vmmon and regenerate the digest for the ebuild as usual.

I didn't make this patch, just converted it to work with the vmware-modules-1.0.0.15-r2 ebuild, so don't ask me if it fails. Original source is:
http://www.insecure.ws/2009/04/21/vmware-specific-specific-55x-and-kernel-2629
Comment 7 Jani-Matti Hätinen 2009-07-08 22:02:54 UTC
Created attachment 197273 [details]
vmnet module patch for kernels 2.6.29 and 2.6.30

This patch fixes vmnet module for kernels 2.6.29 and 2.6.30. Although, in both cases the kernel must also be patched to export the init_mm symbol.

To use this patch, make a copy of the vmware-modules package in your local overlay and copy this file to app-emulation/vmware-modules/files/patches/vmnet and regenerate the digest for the ebuild as usual.

I didn't make this patch, just converted it to work with the vmware-modules-1.0.0.15-r2 ebuild, so don't ask me if it fails. Original source is:
http://www.insecure.ws/2009/04/21/vmware-specific-specific-55x-and-kernel-2629
Comment 8 Jani-Matti Hätinen 2009-07-08 22:06:25 UTC
Created attachment 197274 [details, diff]
patch to export init_mm symbol in kernels 2.6.29 and 2.6.30

This kernel patch is required to make vmware-modules-1.0.0.15-r2 work on kernels > 2.6.28.

Apply with patch -p1 inside the kernel source root and rebuild the kernel with make clean && make && make modules_install.

Original source:
http://www.insecure.ws/2009/04/21/vmware-specific-specific-55x-and-kernel-2629
Comment 9 Mathias Weigt 2009-07-27 13:23:07 UTC
Created attachment 199335 [details, diff]
corrected version of vmnet patch above

In the original patch bridge.c.orig was patched too (which is an artifact on the original authors file structure) therefore the patch failed and I corrected it (by throwing away the unnecessary patch)
Comment 10 Pierre-Olivier Bouchard 2009-08-21 23:16:39 UTC
I can confirm the patches are working fine here.

Thanks
Comment 11 Vadim Kuznetsov (RETIRED) gentoo-dev 2009-08-28 14:31:22 UTC
Two patches are in the tree:
  +files/patches/vmmon/050_all_kernel-2.6.29.patch,
  +files/patches/vmnet/040_all_kernel-2.6.29.patch
Comment 12 Vadim Kuznetsov (RETIRED) gentoo-dev 2009-08-28 14:32:32 UTC
*** Bug 264098 has been marked as a duplicate of this bug. ***
Comment 13 Vadim Kuznetsov (RETIRED) gentoo-dev 2009-08-28 14:44:53 UTC
*** Bug 282743 has been marked as a duplicate of this bug. ***
Comment 14 Steven Parkes 2009-09-01 22:58:38 UTC
The 2.6.29 patches (at least the vmmon one) break module installation on 2.6.28.
Comment 15 Steven Parkes 2009-09-01 23:04:57 UTC
2.6.28 compilation failure:

  CC [M]  /var/tmp/portage/app-emulation/vmware-modules-1.0.0.15-r2/work/vmmon-only/linux/driver.o
/var/tmp/portage/app-emulation/vmware-modules-1.0.0.15-r2/work/vmmon-only/linux/driver.c: In function 'LinuxDriver_Open':
/var/tmp/portage/app-emulation/vmware-modules-1.0.0.15-r2/work/vmmon-only/linux/driver.c:575: error: 'struct task_struct' has no member named 'cred'
/var/tmp/portage/app-emulation/vmware-modules-1.0.0.15-r2/work/vmmon-only/linux/driver.c: In function '__LinuxDriver_Ioctl':
/var/tmp/portage/app-emulation/vmware-modules-1.0.0.15-r2/work/vmmon-only/linux/driver.c:1496: error: implicit declaration of function 'prepare_creds'
/var/tmp/portage/app-emulation/vmware-modules-1.0.0.15-r2/work/vmmon-only/linux/driver.c:1496: warning: assignment makes pointer from integer without a cast
/var/tmp/portage/app-emulation/vmware-modules-1.0.0.15-r2/work/vmmon-only/linux/driver.c:1501: error: dereferencing pointer to incomplete type
/var/tmp/portage/app-emulation/vmware-modules-1.0.0.15-r2/work/vmmon-only/linux/driver.c:1502: error: dereferencing pointer to incomplete type
/var/tmp/portage/app-emulation/vmware-modules-1.0.0.15-r2/work/vmmon-only/linux/driver.c:1503: error: implicit declaration of function 'commit_creds'
/var/tmp/portage/app-emulation/vmware-modules-1.0.0.15-r2/work/vmmon-only/linux/driver.c:1768: error: dereferencing pointer to incomplete type
/var/tmp/portage/app-emulation/vmware-modules-1.0.0.15-r2/work/vmmon-only/linux/driver.c:1769: error: dereferencing pointer to incomplete type
/var/tmp/portage/app-emulation/vmware-modules-1.0.0.15-r2/work/vmmon-only/linux/driver.c:1770: error: dereferencing pointer to incomplete type
/var/tmp/portage/app-emulation/vmware-modules-1.0.0.15-r2/work/vmmon-only/linux/driver.c:1770: error: dereferencing pointer to incomplete type
/var/tmp/portage/app-emulation/vmware-modules-1.0.0.15-r2/work/vmmon-only/linux/driver.c:1771: error: dereferencing pointer to incomplete type
/var/tmp/portage/app-emulation/vmware-modules-1.0.0.15-r2/work/vmmon-only/linux/driver.c:1771: error: dereferencing pointer to incomplete type
Comment 16 Vadim Kuznetsov (RETIRED) gentoo-dev 2009-09-02 02:16:34 UTC
(In reply to comment #15)
> 2.6.28 compilation failure:
> 
Thanks you for the report. I reverted to the previous state.

  02 Sep 2009; Vadim Kuznetsov vadimk@gentoo.org
  -files/patches/vmmon/050_all_kernel-2.6.29.patch,
  -files/patches/vmnet/040_all_kernel-2.6.29.patch:
  revert previous commit. Bug 273173

Comment 17 Sebastian Luther (few) 2009-10-09 12:56:13 UTC
*** Bug 288300 has been marked as a duplicate of this bug. ***
Comment 18 Sebastian Luther (few) 2009-10-12 17:06:23 UTC
*** Bug 288735 has been marked as a duplicate of this bug. ***
Comment 19 Sebastiano Cavicchio 2010-01-17 18:05:15 UTC
(In reply to comment #16)
> (In reply to comment #15)
> > 2.6.28 compilation failure:
> > 
> Thanks you for the report. I reverted to the previous state.
> 
>   02 Sep 2009; Vadim Kuznetsov vadimk@gentoo.org
>   -files/patches/vmmon/050_all_kernel-2.6.29.patch,
>   -files/patches/vmnet/040_all_kernel-2.6.29.patch:
>   revert previous commit. Bug 273173
> 

Hi. I am trying to install vmware-server 1.0.9 with a 2.6.30-tuxonice-r6 kernel, and 

emerge =vmware-modules-1.0.0.15-r2 

fails with the "poll_initwait" error. Following the directions in this bugzilla bug, I tried to apply the vmmon/vmnet patches for kernel 2.6.29 with no success: the emerge process fails when trying to apply any of the two patches. I'm attaching the output of the patch step as suggested by emerge: 050_all_kernel-2.6.29.patch-9061.out

I am quite a new to patching, bugzilla and ebuilds in general, so I do not understand much about this log. I only understand that some files seem to be missing from the work directory where portage it trying to build vmware-modules.

Any suggestion? 
Comment 20 Sebastiano Cavicchio 2010-01-17 18:06:19 UTC
Created attachment 216747 [details]
Output of patch step

Output of patch step of overlay ebuild for vmware-modules-1.0.0.15-r2 with 2.6.30-tuxonice-r6 kernel
Comment 21 Vadim Kuznetsov (RETIRED) gentoo-dev 2011-03-17 13:20:40 UTC
vmware-server 1.0.x and vmware-modules-1.0.0.1x are not in the portage anymore.
Bug 354383.