Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 270276 - kde-base/kdelibs-4* fails to build with sys-libs/glibc-2.10.1
Summary: kde-base/kdelibs-4* fails to build with sys-libs/glibc-2.10.1
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords: InVCS
: 270948 (view as bug list)
Depends on:
Blocks: glibc-2.10
  Show dependency tree
 
Reported: 2009-05-18 11:21 UTC by Martin Jansa
Modified: 2009-05-27 18:54 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,32.51 KB, text/plain)
2009-05-18 11:23 UTC, Martin Jansa
Details
kdelibs-4.2.85-glibc-2.9.patch (kdelibs-4.2.85-glibc-2.9.patch,5.64 KB, patch)
2009-05-18 11:56 UTC, Martin Jansa
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Jansa 2009-05-18 11:21:39 UTC
glibc-2.10.1 defines function
const char* strcasestr(const char*, const char*)
in /usr/include/string.h
second definition is in kdelibs source kdecore/compression/kfilterbase.cpp

tested with kdelibs 4.2.3 and 4.2.85

Reproducible: Always
Comment 1 Martin Jansa 2009-05-18 11:23:17 UTC
Created attachment 191644 [details]
build.log
Comment 2 Martin Jansa 2009-05-18 11:24:55 UTC
just in case emerge --info

Portage 2.2_rc33 (default/linux/amd64/2008.0/desktop, gcc-4.4.0, glibc-2.10.1-r0, 2.6.30-rc6-JaMa-00145-g08e9469 x86_64)
=================================================================
System uname: Linux-2.6.30-rc6-JaMa-00145-g08e9469-x86_64-AMD_Phenom-tm-_9600_Quad-Core_Processor-with-gentoo-2.0.0
Timestamp of tree: Mon, 18 May 2009 07:00:01 +0000
ccache version 2.4 [disabled]
app-shells/bash:     4.0_p24
dev-java/java-config: 2.1.7
dev-lang/python:     2.6.2
dev-python/pycrypto: 2.0.1-r8
dev-util/ccache:     2.4-r8
dev-util/cmake:      2.6.4
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.4.3-r2
sys-apps/sandbox:    1.9
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.5, 1.7.9-r1, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.19.51.0.4
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.29
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=barcelona -pipe -ftree-vectorize"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/4.2/env /usr/kde/4.2/share/config /usr/kde/4.2/shutdown /usr/kde/4.3/env /usr/kde/4.3/share/config /usr/kde/4.3/shutdown /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -march=barcelona -pipe -ftree-vectorize -fvisibility-inlines-hidden -fvisibility=hidden"
DISTDIR="/tmp/distfiles"
FEATURES="distlocks fixpackages parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-orphans userfetch usersandbox"
GENTOO_MIRRORS="http://gentoo.mirror.web4u.cz/distfiles/"
LANG="en_GB"
LC_ALL="cs_CZ.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,--hash-style=gnu"
LINGUAS="cs en_GB en"
MAKEOPTS="-j1"
PKGDIR="/tmp/binpkgs"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/tmp/tmpwork"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/sunrise /usr/local/portage/layman/dirtyepic /usr/local/portage/layman/gcc-porting /usr/local/portage/layman/enlightenment /usr/local/portage/layman/perl-experimental /usr/local/portage/layman/x11 /usr/local/portage/layman/vmware /usr/local/portage/layman/kde-testing /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow X aalib acl acpi aio alsa amd64 amr apache2 avahi bash-completion berkdb bidi bluetooth branding bzip2 cairo ccache cdparanoia cdr cdrom cgi cli consolekit cracklib crypt cups curl dbus dga doc dri dvb dvd dvdr dvdread emboss encode evo fam fbcon ffmpeg firefox flac flash fmod font-server ftp gd gif gkrellm glib glut gnutls gpgme gpm gps gzip hal iconv icq imagemagick imap imlib innodb ipv6 irc irda isdnlog jabber java java5 java6 javascript joystick jpeg kde kdeenablefinal kdehiddenvisibility kdeprefix kpathsea kqemu krb4 lame libcaca libnotify libwww linuxthreads-tls lirc live lm_sensors logrotate mad maildir matroska midi mikmod mime mmx mozilla mp3 mp4 mpeg mudflap multilib mysql mysqli ncurses network nls nntp nocd nptl nptlonly nsplugin ogg openal opengl openmp opera oss pam pcre pdf perl php pic png pop posix ppds pppd python qt3 qt3support qt4 quicktime readline reflection rss rsync rtc samba sasl screen sdl session silc slang smartcard smime smtp sndfile sockets spell spl sse sse2 ssh ssl startup-notification stream subversion svg svgz symlink sysfs tcpd theora threads tiff truetype unicode usb utempter uudeview v4l v4l2 vdpau vdr videos vim vorbis wxwindows x264 xanim xcb xcomposite xinetd xml xmlreader xmlrpc xorg xosd xpm xscreensaver xsl xulrunner xv xvid zip zlib zvbi" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" APACHE2_MPMS="prefork" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev joystick" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="cs en_GB en" LIRC_DEVICES="devinput" NETBEANS_MODULES="apisupport cnd groovy gsf harness ide identity j2ee java mobility nb php profiler soa visualweb webcommon websvccommon xml dlight enterprise" USERLAND="GNU" VIDEO_CARDS="vesa nvidia nv v4l nouveau"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 3 Martin Jansa 2009-05-18 11:56:27 UTC
Created attachment 191650 [details, diff]
kdelibs-4.2.85-glibc-2.9.patch

patch for glibc-2.9 (bug first appeared here with glibc-2.10.1) and higher from upstream
http://websvn.kde.org/?view=rev&revision=963449

worked for me
Comment 4 Tomáš Chvátal (RETIRED) gentoo-dev 2009-05-18 12:58:17 UTC
Do you know if it was backported to 4.2 branch?
Comment 5 Robert Förster 2009-05-18 13:42:50 UTC
the link from Martin is from branches/4.2, so it was backported, yes, here is the commit for 4.3 trunk http://websvn.kde.org/?view=rev&revision=967299

there is no difference between the two, so it can be safely used for 4.2.3 and 4.2.85
Comment 6 Peter Alfredsen (RETIRED) gentoo-dev 2009-05-19 11:07:16 UTC
*** Bug 270404 has been marked as a duplicate of this bug. ***
Comment 7 Jonathan Adamczewski 2009-05-19 11:28:05 UTC
There does appear to be an extra "const" needed in to complete compilation of kdelibs-4.2.3 with glibc-2.10.1 in kdelibs-4.2.3/khtml/misc/loader.cpp:332.
Comment 8 Robert Förster 2009-05-19 12:23:59 UTC
yea, this is http://websvn.kde.org/?view=rev&revision=963699 for branches/4.2
the 4.3 beta is unaffected
Comment 9 Peter Alfredsen (RETIRED) gentoo-dev 2009-05-23 14:57:52 UTC
*** Bug 270948 has been marked as a duplicate of this bug. ***
Comment 10 Tomáš Chvátal (RETIRED) gentoo-dev 2009-05-27 18:54:56 UTC
applied. Thx for patch.