Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 269769 - net-misc/nxserver-freenx should depend on media-fonts/font-cursor-misc and media-fonts/font-misc-misc
Summary: net-misc/nxserver-freenx should depend on media-fonts/font-cursor-misc and me...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: NX Server Herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-05-14 02:08 UTC by Sarah Gardner
Modified: 2009-05-14 15:15 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sarah Gardner 2009-05-14 02:08:06 UTC
After a recent bout of upgrading, followed by emerge --depclean I found myself running freenx-0.7.3 and needing to reboot to use a new version of the kernel. After the reboot I was unable to start freenx sessions using the Windows client, and the log just showed the session starting and immediately terminating.

After an hour or so of enabling debug logs and searching, I found that the actual error was "could not find the font 'fixed'" and a little later I found out what package that font lived in. The error then changed to "could not find the font 'cursor'"

I have searched this bugzilla and found bug 265890 which states:

>Same issue, the X server no longer needs those fonts itself (the previous
>versions did really need the fonts).

>As for the xorg-x11 meta, it will be stabilized later on. If you have any
>issues with specific applications failing due to the missing font, please open
>bugs against those.

so I am opening a bug against freenx due to it failing without those fonts.

It is also worth noting that emerge --depclean did not remove the two offending packages. I am guessing these fonts were built into the base Xorg installation previously?


Reproducible: Always

Steps to Reproduce:
Comment 1 Bernard Cafarelli gentoo-dev 2009-05-14 15:15:43 UTC
Thanks for the report (and search on the cause)! Somehow these got removed in the updates from nxserver-freenx-0.7.3_p104.

Sorry about that, I've reinstated them, and revbumped the ebuild (to nxserver-freenx-0.7.3_p104-r1)