Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 269312 - [PATCH] app-text/pdftk-1.41-r1 build fails with gcc 4.4.0: gnu.java.locale.Calendar cannot be resolved to a type
Summary: [PATCH] app-text/pdftk-1.41-r1 build fails with gcc 4.4.0: gnu.java.locale.Ca...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Printing Team
URL:
Whiteboard:
Keywords:
: 270358 (view as bug list)
Depends on:
Blocks: gcc-4.4
  Show dependency tree
 
Reported: 2009-05-10 21:16 UTC by Jose daLuz
Modified: 2009-07-23 21:01 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Output of paludis --info pdftk (pdftk_paludis_info.txt,20.06 KB, text/plain)
2009-05-10 21:17 UTC, Jose daLuz
Details
Patch allowing app-text/pdftk-1.41-r1 to build against gcc 4.4 (pdftk-1.41-gcc-4.4.patch,937 bytes, patch)
2009-05-18 22:59 UTC, Víctor Ostorga (RETIRED)
Details | Diff
Patch against current app-text/pdftk-1.41-r1 ebuild (pdftk-1.41-r1-gcc44.ebuild.patch,472 bytes, patch)
2009-05-18 23:00 UTC, Víctor Ostorga (RETIRED)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jose daLuz 2009-05-10 21:16:15 UTC
Rebuilding world after upgrading gcc to 4.4.0 I hit this in pdftk:

>>> Starting src_compile
make -j8 -j1 -f Makefile.Generic
make -C ../java_libs
make[1]: Entering directory `/var/tmp/paludis/app-text-pdftk-1.41-r1/work/pdftk-1.41/java_libs'
make -C "/var/tmp/paludis/app-text-pdftk-1.41-r1/work/pdftk-1.41/java_libs/com/lowagie/text";
make[2]: Entering directory `/var/tmp/paludis/app-text-pdftk-1.41-r1/work/pdftk-1.41/java_libs/com/lowagie/text'
gcj -march=native -O2 -pipe -ggdb -w --encoding=UTF-8 --classpath="/var/tmp/paludis/app-text-pdftk-1.41-r1/work/pdftk-1.41/java_libs" -c Anchor.java -o Anchor.o
/var/tmp/paludis/app-text-pdftk-1.41-r1/work/pdftk-1.41/java_libs/com/lowagie/text/pdf/PdfDate.java:79: error: gnu.java.locale.Calendar cannot be resolved to a type
	private static Class c1= gnu.java.locale.Calendar.class;
	                         ^^^^^^^^^^^^^^^^^^^^^^^^
1 problem (1 error)
make[2]: Leaving directory `/var/tmp/paludis/app-text-pdftk-1.41-r1/work/pdftk-1.41/java_libs/com/lowagie/text'
make[2]: *** [Anchor.o] Error 1
make[1]: Leaving directory `/var/tmp/paludis/app-text-pdftk-1.41-r1/work/pdftk-1.41/java_libs'
make[1]: *** [itext] Error 2
make: *** [java_libs] Error 2
/usr/libexec/paludis/utils/emake: emake returned error 2

!!! ERROR in app-text/pdftk-1.41-r1:

Bug 264510 deals with compilation issues with gcc 4.3.2, but this is a very different error.

Portage 2.2_rc33 (default/linux/amd64/2008.0/desktop, gcc-4.4.0, glibc-2.9_p20081201-r2, 2.6.29.3 x86_64)
=================================================================
System uname: Linux-2.6.29.3-x86_64-Intel-R-_Core-TM-2_Quad_CPU_Q9650_@_3.00GHz-with-gentoo-2.0.0
Timestamp of tree: Sat, 09 May 2009 13:15:02 +0000
ccache version 2.4 [enabled]
app-shells/bash:     4.0_p17-r1
dev-java/java-config: 1.3.7-r1, 2.1.7
dev-lang/python:     2.5.4-r2, 2.6.2
dev-python/pycrypto: 2.0.1-r8
dev-util/ccache:     2.4-r8
dev-util/cmake:      2.6.4
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.4.3-r2
sys-apps/sandbox:    1.9
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.19.1-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.28-r1
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe -ggdb"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=native -O2 -pipe -ggdb"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distlocks fixpackages parallel-fetch preserve-libs protect-owned sandbox sfperms splitdebug strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://gentoo.osuosl.org/ http://distro.ibiblio.org/pub/linux/distributions/gentoo/"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="en"
MAKEOPTS="-j8"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/overlays/zugaina /usr/local/overlays/THE /usr/local/overlays/sunrise /usr/local/overlays/gnome /usr/local/overlays/desktop-effects /usr/local/overlays/vmware /usr/local/overlays/ikelos /usr/local/overlays/java-overlay /usr/local/overlays/berkano /usr/local/overlays/gcc-porting /usr/local/overlays/myoverlay"
SYNC="rsync://rsync.us.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 amr avahi bash-completion berkdb bluetooth branding bzip2 cairo cdda cdr cli cracklib crypt css cups dbus dri dts dvd dvdr dvdread eds emboss encode esd evo expat fam ffmpeg flac fortran gdbm gif gnome gnome-keyring gpm gstreamer gtk hal iconv ipv6 isdnlog java jpeg lcms ldap libnotify mad midi mikmod mmx mono mp3 mpeg mudflap multilib nautilus ncurses networkmanager nls nptl nptlonly nsplugin ogg opengl openmp paludis pam pcre pdf perl pic png policykit ppds pppd pulseaudio python quicktime readline reflection ruby samba sdl session spell spl sqlite sse sse2 ssl startup-notification svg sysfs tcpd theora tiff tracker truetype unicode usb userlocales vcd vorbis x264 xcb xml xorg xulrunner xv xvid zlib" ALSA_CARDS="cmipci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Jose daLuz 2009-05-10 21:17:45 UTC
Created attachment 190873 [details]
Output of paludis --info pdftk
Comment 2 Jose daLuz 2009-05-10 22:44:02 UTC
This Fedora bug: https://bugzilla.redhat.com/show_bug.cgi?id=485641
deals with getting this package built, including a fixed upstream gcc bug that seems to have been included in 4.4.0. I don't know if this would address this issue, perhaps it addresses the issues from bug 264510.
Comment 3 Jose daLuz 2009-05-10 22:46:28 UTC
And there is this Ubuntu commit that refers to fixing building with gcc 4.4: https://launchpad.net/ubuntu/karmic/+source/pdftk/+changelog
Comment 4 Víctor Ostorga (RETIRED) gentoo-dev 2009-05-18 22:59:36 UTC
Created attachment 191725 [details, diff]
Patch allowing app-text/pdftk-1.41-r1 to build against gcc 4.4
Comment 5 Víctor Ostorga (RETIRED) gentoo-dev 2009-05-18 23:00:39 UTC
Created attachment 191726 [details, diff]
Patch against current app-text/pdftk-1.41-r1 ebuild
Comment 6 Jose daLuz 2009-05-18 23:32:26 UTC
I can confirm this patch fixes the build issue. Thanks!
Comment 7 Zac Medico gentoo-dev 2009-05-21 23:57:57 UTC
*** Bug 270358 has been marked as a duplicate of this bug. ***
Comment 8 Samuli Suominen gentoo-dev 2009-07-23 21:01:20 UTC
applied