Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 264510 - app-text/pdftk-1.41-r1 fails to compile after upgrade to gcc 4.3.2-r3
Summary: app-text/pdftk-1.41-r1 fails to compile after upgrade to gcc 4.3.2-r3
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Printing (show other bugs)
Hardware: AMD64 Linux
: High major with 1 vote (vote)
Assignee: Printing Team
URL:
Whiteboard:
Keywords:
Depends on: 370169
Blocks:
  Show dependency tree
 
Reported: 2009-04-01 14:17 UTC by Tanktalus
Modified: 2012-01-28 20:59 UTC (History)
22 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
revised ebuild (pdftk-1.41-r2.ebuild,871 bytes, text/plain)
2009-05-13 00:03 UTC, Craig Counts
Details
patch for revised ebuild (pdftk-1.41-r2.patch,11.44 KB, text/plain)
2009-05-13 00:04 UTC, Craig Counts
Details
Splited build log part 1 (pdftk_build_log.gzaa,1.00 MB, text/plain)
2009-07-21 14:53 UTC, Bjoern Thorwirth
Details
Splited build log part 2 (pdftk_build_log.gzab,535.88 KB, text/plain)
2009-07-21 14:54 UTC, Bjoern Thorwirth
Details
build failure log, gcc 4.5.2 (pdftk-1.41-r1:20110605-160040.log,157.39 KB, text/x-log)
2011-06-05 17:46 UTC, Andreas K. Hüttel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tanktalus 2009-04-01 14:17:54 UTC
I'm getting the following error trying to recompile pdftk with gcc 4.3.2 (found when doing my emerge -e world after upgrading gcc):

g++ pdftk.cc -I../java_libs -O3 -pipe -march=native -DPATH_DELIM=0x2f -DASK_ABOUT_WARNINGS=false -fdollars-in-identifiers -DPDFTK_VER=\"1.41\" -c               
/usr/lib/gcc/x86_64-pc-linux-gnu/4.3.2/include/g++-v4/bits/ostream_insert.h: In function ‘std::basic_ostream<_CharT, _Traits>& std::__ostream_insert(std::basic_ostream<_CharT, _Traits>&, const _CharT*, std::streamsize) [with _CharT = char, _Traits = std::char_traits<char>]’:                                             
/usr/lib/gcc/x86_64-pc-linux-gnu/4.3.2/include/g++-v4/ostream:517:   instantiated from ‘std::basic_ostream<char, _Traits>& std::operator<<(std::basic_ostream<char, _Traits>&, const char*) [with _Traits = std::char_traits<char>]’            
pdftk.cc:114:   instantiated from here                                          
/usr/lib/gcc/x86_64-pc-linux-gnu/4.3.2/include/g++-v4/bits/ostream_insert.h:107: error: mixing C++ and Java catches in a single translation unit                
{standard input}: Assembler messages:                                           
{standard input}:2: Error: junk at end of line, first unrecognized character is `*'                                                                             
{standard input}:3: Error: junk at end of line, first unrecognized character is `*'                                                                             
{standard input}:4: Error: expected comma after "_ZGAN8__JArrayC1Ev"            
make: *** [pdftk.o] Error 1                                                     

emerge --info:

Portage 2.2_rc23 (default/linux/amd64/2008.0, gcc-4.3.2, glibc-2.8_p20080602-r1, 2.6.27-gentoo-r8 x86_64)
=================================================================
System uname: Linux-2.6.27-gentoo-r8-x86_64-AMD_Phenom-tm-_9850_Quad-Core_Processor-with-glibc2.2.5
Timestamp of tree: Wed, 01 Apr 2009 07:45:01 +0000
distcc 3.0 x86_64-pc-linux-gnu [disabled]
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7-r1, 2.1.7
dev-lang/python:     2.5.2-r7
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
dev-util/cmake:      2.6.3-r1
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.4.3-r1
sys-apps/sandbox:    1.3.5
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O3 -pipe -march=native"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/kde/4.2/env /usr/kde/4.2/share/config /usr/kde/4.2/shutdown /usr/share/config /var/bind /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/init.d /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O3 -pipe -march=native"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distlocks fixpackages parallel-fetch preserve-libs protect-owned sandbox sfperms splitdebug strict unmerge-orphans userfetch userpriv usersandbox"
GENTOO_MIRRORS="http://gentoo.cites.uiuc.edu/pub/gentoo/ ftp://gentoo.mirrors.tds.net/gentoo ftp://mirror.datapipe.net/gentoo ftp://gentoo.chem.wisc.edu/gentoo/ http://mirror.datapipe.net/gentoo http://gentoo.mirrors.tds.net/gentoo"
LANG="en_US.utf8"
LC_ALL="en_US.utf8"
LDFLAGS="-Wl,-O1"
LINGUAS="en"
MAKEOPTS="-j -l10"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/home/dmcbride/cvs/portdir-mine /usr/portage/local/layman/jokey /usr/portage/local/layman/kde-testing"
SYNC="rsync://rsync.namerica.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 apache2 arts audiofile avi bash-completion berkdb branding bzip2 cairo cddb cdparanoia cdr cli cracklib crypt css cups dbus dri dvd dvdr dvdread encode exif expat ffmpeg fftw firefox fontconfig fortran gd gdbm gif gimp gmp gnutls gpm gs hal htmlhandbook iconv imagemagick ipv6 isdnlog java jbig jpeg jpeg2k kde kdeprefix lcms lzo mad midi mjpeg mmx mng mp3 mpeg mudflap multilib ncurses nls nptl nptlonly nsplugin ogg opengl openmp pam pcre perl png pppd python qt4 readline reflection sdl session smp spl sse sse2 ssl subversion svg sysfs tcpd threads tiff truetype unicode vcd vorbis wmf x264 xcb xcomposite xinerama xml xorg xulrunner xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" FOO2ZJS_DEVICES="hp2600n" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en" USERLAND="GNU" VIDEO_CARDS="vesa fbdev radeonhd"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-04-01 14:23:42 UTC
*** Bug 264412 has been marked as a duplicate of this bug. ***
Comment 2 marek wojciechowski 2009-04-05 12:18:22 UTC
exactly the same here
Comment 3 Christian Schlotter 2009-04-05 23:57:15 UTC
Currently stable pdftk-1.12 also fails with the new stable gcc.
Comment 4 Sven Müller 2009-04-08 18:03:01 UTC
Add to CC list - same here
Comment 5 Martin Weber 2009-04-09 07:33:09 UTC
I am suffering from Bug 264412 which is slightly different (pdftk-1.12) but has been marked as duplicate.
Comment 6 Craig Counts 2009-04-11 13:19:29 UTC
Also fails to build with gcc-4.3.3-r2

I emailed the developer.
Comment 7 Jose Medellin 2009-04-30 22:07:28 UTC
From bug 225709 (at the last comment), I saw someone managed to get it compiled under gcc-4.3.3-r2.

I run a stable system, so I keyworded gcc-4.3.3-r2 and tried compiling pdftk-1.41-r1

It compiled.

I haven't run it through some heavy usage, but some common tasks do work.

Took forever to compile, though..  Weird... But at least it compiled.

Maybe it's actually a problem with gcc??  I hadn't have success compiling with gcc-4.3.2-r3 (the stable gcc)

Also, Craig in comment #6 in this bug says the very same gcc didn't compile it for him.. If any info needed i'd gladly share it.
Comment 8 Craig Counts 2009-05-01 09:54:42 UTC
> 
> Also, Craig in comment #6 in this bug says the very same gcc didn't compile it
> for him.. If any info needed i'd gladly share it.
> 
 Please do!

My compile still breaks at the same place as the original poster's does.

Comment 9 Jose daLuz 2009-05-09 14:42:58 UTC
It fails with a different error using gcc 4.4.0:

make[2]: Entering directory `/var/tmp/paludis/app-text-pdftk-1.41-r1/work/pdftk-1.41/java_libs/com/lowagie/text'
gcj -march=core2 -O2 -pipe -ggdb -w --encoding=UTF-8 --classpath="/var/tmp/paludis/app-text-pdftk-1.41-r1/work/pdftk-1.41/java_libs" -c Anchor.java -o Anchor.o
/var/tmp/paludis/app-text-pdftk-1.41-r1/work/pdftk-1.41/java_libs/com/lowagie/text/pdf/PdfDate.java:79: error: gnu.java.locale.Calendar cannot be resolved to a type
	private static Class c1= gnu.java.locale.Calendar.class;
	                         ^^^^^^^^^^^^^^^^^^^^^^^^
Comment 10 Craig Counts 2009-05-13 00:03:58 UTC
Created attachment 191083 [details]
revised ebuild
Comment 11 Craig Counts 2009-05-13 00:04:37 UTC
Created attachment 191084 [details]
patch for revised ebuild
Comment 12 Craig Counts 2009-05-13 00:06:29 UTC
I took the (4 patch) patchset from:

http://download.opensuse.org/source/factory/repo/oss/suse/src/pdftk-1.41-103.50.src.rpm

and made one mega patch that I could get to work with an ebuild.

I'm using gcc-4.3.3-r2. It takes forever to compile, ane throws a ton of warnings, but seems to work -- at least it can extract a range of pages.


patch and ebuild attatched

Comment 13 coran.fisher@gmail.com 2009-05-14 22:42:40 UTC
Just wanted to confirm that Craig's attached patch and email worked for me on amd64 with gcc 4.3.3-r2
Comment 14 Martin Weber 2009-05-15 06:46:04 UTC
Craig's patch also works on x86 with gcc 4.3.2-r3.
Comment 15 Milan Holzäpfel 2009-07-19 18:14:02 UTC
Attached patch worked here too with 
Portage 2.1.6.13 (hardened/linux/x86, gcc-4.3.3, glibc-2.8_p20080602-r3, 2.6.28.8 i686)
(GCC 4.3.3 from hardened overlay)
Comment 16 Bjoern Thorwirth 2009-07-21 14:47:06 UTC
works fine hete, too - but with a huge bunch of warnings and problems. see attached build log

emerge --info:
Portage 2.1.6.13 (default/linux/amd64/2008.0/desktop, gcc-4.3.2, glibc-2.9_p20081201-r2, 2.6.28-tuxonice-r10 x86_64)
=================================================================
System uname: Linux-2.6.28-tuxonice-r10-x86_64-Intel-R-_Core-TM-2_Quad_CPU_Q9450_@_2.66GHz-with-gentoo-2.0.1
Timestamp of tree: Sat, 18 Jul 2009 10:45:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p39
dev-java/java-config: 2.1.8-r1
dev-lang/python:     2.5.4-r3, 2.6.2-r1
dev-python/pycrypto: 2.0.1-r8
dev-util/ccache:     2.4-r7
dev-util/cmake:      2.6.4
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.4.3-r3
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.4_p6, 1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=nocona -O3 -pipe -fomit-frame-pointer"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=nocona -O3 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache collision-protect distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict test unmerge-orphans userfetch userprov usersandbox"
GENTOO_MIRRORS="http://mirror.jamit.de/gentoo/"
LANG="de_DE.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--enable-new-dtags -Wl,--sort-common -s"
LINGUAS="de en"
MAKEOPTS="-j5 -s"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/desktop-effects /usr/portage/local/layman/gnome /usr/portage/local/layman/jyujin /usr/portage/local/layman/sunrise /usr/portage/local/layman/enlightenment /usr/portage/local/layman/wolf31o2 /usr/portage/local/layman/mozilla /usr/portage/local/layman/science /usr/portage/local/local-overlay /usr/portage/local/initng-portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="64bit X a52 aac aalib accessibility acl acpi ada alsa amarok amd64 apache2 arts audiofile authdaemond avahi bash-completion berkdb bidi bindist blas bluetooth branding bzip2 cairo cdda cdr chm clearcase cli config_wizard cpudetection cracklib crypt css cups dbus dga djvu dri dts dv dvb dvd dvdr dvdread dvi dxr3 eds emacs emboss encode esd evo extraicons extramodules fam fame fat fbcon fbcondecor fbsplash ffmpeg fftw firefox flac flash foomaticdb fortran fuse gcj gd gdbm gif glitz gnome gnome-keyring gnutls gphoto2 gpm gs gsm gstreamer gtk hal hdaps hfs iconv icq id3 ieee1394 imap inkjar inotify ipv6 irc irda isdnlog jabber jack java jfs jingle joystick jpeg kde kipi kqemu lame laptop latex lcd ldap libcaca libnotify libwww live lm_sensors lzo mad mail maildir matroska midi mikmod mmx mng mono mp3 mpeg mpi mudflap multilib musepack musicbrainz mysql nautilus ncurses network new-login nls nptl nptlonly nsplugin ntfs nvidia ogg ole openal openexr opengl openmp oss pam pascal pcmcia pcre pdf perl php pmu png postgres povray ppds pppd pulseaudio python qt3 qt3support qt4 quicktime quotas rar rdesktop readline reflection reiser4 reiserfs rss ruby samba sasl scanner sdl session shout skins slp sms sndfile speex spell spl sql sse sse2 ssl ssse3 startup-notification stream subversion svg sysfs tcpd test theora threads tiff tk truetype tta unicode usb vcd visualization voice vorbis wavpack weather wifi winbind wma wmf wxwindows x264 xcb xfs xine xinerama xiph xml xorg xosd xpm xprint xscreensaver xsl xulrunner xv xvid xvmc zeroconf zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INITNG_PLUGINS="also bash_launcher chdir chroot conflict cpout critical ctrlaltdel daemon_clean debug_commands envparser find fmon fstat history idleprobe initctl interactive iparser last limit lockfile logfile netdev netprobe ngc4 ngcs nge pause provide reload renice rlparser simple_launcher stcmd stdout suid syncron syslog sysreq unneeded usplash" INPUT_DEVICES="evdev keyboard mouse synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de en" USERLAND="GNU" VIDEO_CARDS="nvidia vesa"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 17 Bjoern Thorwirth 2009-07-21 14:53:43 UTC
Created attachment 198707 [details]
Splited build log part 1
Comment 18 Bjoern Thorwirth 2009-07-21 14:54:14 UTC
Created attachment 198708 [details]
Splited build log part 2
Comment 19 marek wojciechowski 2009-09-23 18:14:12 UTC
hallo!

any actions regarding this bug from developers part? The fact is that stable version (1.12) just does not compile with stable gcc...

Greetings.
Marek
Comment 20 Miles Georgi 2009-09-29 21:46:25 UTC
Not sure if this is useful, since the original bug reporter has an x86_64 system, but...

I have 3 systems and on the 2 amd64 systems that I have, I can compile pdftk (1.12 and 1.41-r1) with stable gcc.  However, it cannot be built on my one x86 system.

I get the same "junk at end of line" error that's mentioned in the first post on the two amd64 systems.  Strange.
Comment 21 Miles Georgi 2009-09-29 21:48:21 UTC
I meant to say "I get the same "junk at end of line" error that's mentioned in the on the x86 system."
Comment 22 Patrick De Pinguin 2009-11-15 15:14:02 UTC
FYI: according to the following mail thread:
http://gcc.gnu.org/ml/java/2008-03/msg00031.html
the message about mixing C++ and Java exceptions is valid, and the bug is a coding problem in pdftk.
Comment 23 mephinet 2010-02-10 20:35:41 UTC
I could reproduce the "mixing C++ and Java catches" issue on two amd64 machines running stable gcc 4.3.4. The ebuild and patch by Craig fix the bug.
Both the number of warnings during compilation and the speed is impressive. Regarding the latter:

# genlop  -t pdftk
 * app-text/pdftk

     Thu Dec 11 23:58:52 2008 >>> app-text/pdftk-1.12
       merge time: 5 minutes and 20 seconds.

     Wed Feb 10 21:17:21 2010 >>> app-text/pdftk-1.41-r2
       merge time: 26 minutes and 7 seconds.

Fir first merge was performed with gcc 4.1.2, the second with gcc 4.3.4

The patch now exists for nine months, is there any chance to get this into the tree? I'd propose reassigning the issue to the java herd instead of the printing team!
Comment 24 Nick White 2010-03-24 07:13:24 UTC
I hit exactly this problem too (with GCC 3.4.3), and the posted ebuild and patch fixed it for me too (though with build warnings as others have mentioned.)

It would be nice to see this committed; as pointed out above, without it the package is unbuildable on stable.
Comment 25 Samuli Suominen (RETIRED) gentoo-dev 2010-05-10 19:34:41 UTC
There is a patch for this? Please point out the URL.
Comment 26 Oliver Putz 2010-05-11 03:33:33 UTC
@Samuli Suominen: See the first two attachments to this bug. A new ebuild (attachment #191083 [details]) and an accompanying patch for it (attachment #191084 [details])
Comment 27 Nick White 2010-06-06 13:37:57 UTC
pdftk-1.41-r1 builds fine again with gcc-4.4.3-r2 (and indeed the patch above causes compilee errors).
Comment 28 Dan Johansson 2010-06-07 16:26:48 UTC
I can confirm this.
pdftk-1.41-r1 builds fine with gcc-4.4.3-r2 WITHOUT the -r2 ebuild/patch and fails WITH the -r2 ebuild/patch.
Comment 29 Nico Baggus 2010-07-07 08:17:44 UTC
I agree with #28. Also on amd64 with gcc-4.4.4 it does compile without errors.
Comment 30 Jean-Philippe Robichaud 2010-08-03 18:51:31 UTC
I can confirm that 1.41-r1 compiles with gcc 4.3.4 (on amd64) but it does take forever:
pdftk-1.41-r1 # genlop -t pdftk
 * app-text/pdftk

     Tue Sep 30 11:22:53 2008 >>> app-text/pdftk-1.12
       merge time: 4 minutes and 40 seconds.

     Fri Feb 13 15:13:13 2009 >>> app-text/pdftk-1.12
       merge time: 3 minutes and 28 seconds.

     Mon Sep 14 09:59:10 2009 >>> app-text/pdftk-1.41-r1
       merge time: 40 minutes and 24 seconds.

     Tue Aug  3 14:45:44 2010 >>> app-text/pdftk-1.41-r1
       merge time: 40 minutes and 32 seconds.


The build.log in /var/tmp/portage/.../temp contains tons of lines like:

gcj -O2 -pipe -march=native -msse -msse2 -msse3 -w --encoding=UTF-8 --classpath="/var/tmp/portage/app-text/pdftk-1.41-r1/work/pdftk-1.41/java_libs" -c FontMapper.java -o FontMapper.o
gcj -O2 -pipe -march=native -msse -msse2 -msse3 -w --encoding=UTF-8 --classpath="/var/tmp/portage/app-text/pdftk-1.41-r1/work/pdftk-1.41/java_libs" -c GlyphList.java -o GlyphList.o
gcj -O2 -pipe -march=native -msse -msse2 -msse3 -w --encoding=UTF-8 --classpath="/var/tmp/portage/app-text/pdftk-1.41-r1/work/pdftk-1.41/java_libs" -c GrayColor.java -o GrayColor.o
gcj -O2 -pipe -march=native -msse -msse2 -msse3 -w --encoding=UTF-8 --classpath="/var/tmp/portage/app-text/pdftk-1.41-r1/work/pdftk-1.41/java_libs" -c HyphenationAuto.java -o HyphenationAuto.o
gcj -O2 -pipe -march=native -msse -msse2 -msse3 -w --encoding=UTF-8 --classpath="/var/tmp/portage/app-text/pdftk-1.41-r1/work/pdftk-1.41/java_libs" -c HyphenationEvent.java -o HyphenationEvent.o
gcj -O2 -pipe -march=native -msse -msse2 -msse3 -w --encoding=UTF-8 --classpath="/var/tmp/portage/app-text/pdftk-1.41-r1/work/pdftk-1.41/java_libs" -c ICC_Profile.java -o ICC_Profile.o

It seems like the gcj command is invoked in a loop for every java source file...  

Is this a gentoo-specific thing or is this problem coming from upstream?
Comment 31 Michael Weber (RETIRED) gentoo-dev 2010-09-30 14:04:46 UTC
Shouldn't it use something like x86_64-pc-linux-gnu-gcj/x86_64-pc-linux-gnu-gcjh defined in toolchain-funcs?
Comment 32 Matt 2010-10-16 13:14:57 UTC
any news on this ?

and could someone please change from Component: Printing to 
Component: Java 

? (one of the devs or the reporter)
Comment 33 Michael Weber (RETIRED) gentoo-dev 2010-11-27 22:31:35 UTC
Hello, can you please try -1.41-r2 or -1.44 from the tree? Thanks 
Comment 34 Nico Baggus 2010-11-29 18:44:28 UTC
pdftk-1.41.-r2 fails with a unpack error:

 * USE:  amd64 elibc_glibc kernel_linux multilib userland_GNU
>>> Unpacking source...
>>> Unpacking pdftk-1.41.tar.gz to /var/tmp/portage/app-text/pdftk-1.41-r2/work
>>> Unpacking pdftk-1.41-makefile.patch to /var/tmp/portage/app-text/pdftk-1.41-r2/work
unpack pdftk-1.41-makefile.patch: file format not recognized. Ignoring.
>>> Source unpacked in /var/tmp/portage/app-text/pdftk-1.41-r2/work
>>> Preparing source in /var/tmp/portage/app-text/pdftk-1.41-r2/work/pdftk-1.41/pdftk ...
 * Applying pdftk-1.41-gcc-4.3.patch ...                                                                                  [ ok ]
 * Applying pdftk-1.41-gcc-4.4.patch ...                                                                                  [ ok ]
 * Applying pdftk-1.41-honor-ldflags.patch ...                                                                            [ ok ]
 * Applying pdftk-1.41-makefile.patch ...

 * Failed Patch: pdftk-1.41-makefile.patch !
 *  ( /var/tmp/portage/app-text/pdftk-1.41-r2/distdir/pdftk-1.41-makefile.patch )
Comment 35 Nico Baggus 2010-11-29 18:53:11 UTC
pdftk-1.44 start out with a whole bunch of warnings about unused variables & parameters...

But it does compile & seems to work.. ;-)
Comment 36 Andreas K. Hüttel archtester gentoo-dev 2011-06-05 17:46:51 UTC
Created attachment 275941 [details]
build failure log, gcc 4.5.2

1.41-r1 also fails with gcc-4.5.2
Comment 37 Andreas K. Hüttel archtester gentoo-dev 2012-01-28 20:59:19 UTC
(In reply to comment #35)
> pdftk-1.44 start out with a whole bunch of warnings about unused variables &
> parameters...
> 
> But it does compile & seems to work.. ;-)

And 1.44 is now stable on all arches.