Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 267267 - app-emulation/virtualbox-{ose,bin}-2.1.4 stabling (previous stable doesn't build with gcc-4.3)
Summary: app-emulation/virtualbox-{ose,bin}-2.1.4 stabling (previous stable doesn't bu...
Status: RESOLVED LATER
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Markus Ullmann (RETIRED)
URL:
Whiteboard:
Keywords: STABLEREQ
: 266756 (view as bug list)
Depends on:
Blocks: 267310
  Show dependency tree
 
Reported: 2009-04-23 20:42 UTC by Patrick Lauer
Modified: 2009-07-02 10:08 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Lauer gentoo-dev 2009-04-23 20:42:02 UTC
virtualbox-2.1.4 has been in the tree for a while and works quite well. 2.2.0 is still a bit explosive ...

The following ebuilds should go stable so we have something supported (unlike current vbox 1.6) stable:

virtualbox-bin
virtualbox-guest-additions
virtualbox-modules
virtualbox-ose
virtualbox-ose-additions
xf86-input-virtualbox
xf86-video-virtualbox

Thanks!
Comment 1 Andrey Vihrov 2009-04-27 16:35:36 UTC
I have been using 2.1.4 on stable amd64 for two months already and have encountered no issues. Contrary to that, the current stable 1.6.6 hangs if I suspend my laptop with a VM running (at least this was true with 2.6.27). So, another vote for a newer stable version here.
Comment 2 Markus Meier gentoo-dev 2009-05-03 13:15:33 UTC
>>> Completed installing xf86-input-virtualbox-2.1.4 into /var/tmp/portage/x11-drivers/xf86-input-virtualbox-2.1.4/image/



 * QA Notice: Pre-stripped files found:
 * /usr/lib/xorg/modules/input/vboxmouse_drv.so
Files matching a file type that is not allowed:
   usr/lib/xorg/modules/input/vboxmouse_drv.so
 *
 * ERROR: x11-drivers/xf86-input-virtualbox-2.1.4 failed.
 * Call stack:
 *       misc-functions.sh, line 729:  Called install_qa_check
 *       misc-functions.sh, line 466:  Called die
 * The specific snippet of code:
 *              [[ ${abort} == yes ]] && die "multilib-strict check failed!"
 *  The die message:
 *   multilib-strict check failed!
Comment 3 Patrick Lauer gentoo-dev 2009-05-22 21:30:20 UTC
(In reply to comment #2)

>  * QA Notice: Pre-stripped files found:
>  * /usr/lib/xorg/modules/input/vboxmouse_drv.so
> Files matching a file type that is not allowed:
>    usr/lib/xorg/modules/input/vboxmouse_drv.so
What does that mean?

>  *  The die message:
>  *   multilib-strict check failed!
Stupid check ;)

I've had a look at the build system, now I want a stiff drink.  

Comment 4 Mounir Lamouri (volkmar) (RETIRED) gentoo-dev 2009-05-29 14:17:42 UTC
bug 266756 is critical because gcc 4.3 is now stable and no stable version of virtualbox-ose can be used with a stable profile.
The bug has been fixed upstream in 2.1.0 [1].

[1] http://www.virtualbox.org/ticket/936
Comment 5 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-05-29 14:29:18 UTC
*** Bug 266756 has been marked as a duplicate of this bug. ***
Comment 6 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-05-29 14:30:24 UTC
Markus (jokey): Any advice on comment #2?
Comment 7 Christian Faulhammer (RETIRED) gentoo-dev 2009-07-02 10:08:07 UTC
Come again, when you fixed this.