Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 266621 - preserved libs is unable to handle icu 3->4 upgrade
Summary: preserved libs is unable to handle icu 3->4 upgrade
Status: RESOLVED FIXED
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Core (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords:
: 265068 267618 (view as bug list)
Depends on:
Blocks: preserve-libs
  Show dependency tree
 
Reported: 2009-04-18 06:45 UTC by Serkan Kaba (RETIRED)
Modified: 2011-05-18 18:57 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info (info,4.51 KB, text/plain)
2009-04-18 06:47 UTC, Serkan Kaba (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Serkan Kaba (RETIRED) gentoo-dev 2009-04-18 06:45:58 UTC
After an upgrade to icu-4 some shared libs were preserved but the list missed libicudata.so.38 which is in NEEDED entries of the package itself. It was probably indirectly referenced by openoffice which broke after the upgrade. Here's the error message.

/usr/lib64/openoffice/program/soffice.bin: error while loading shared libraries: libicudata.so.38: cannot open shared object file: No such file or directory
Comment 1 Serkan Kaba (RETIRED) gentoo-dev 2009-04-18 06:47:06 UTC
Created attachment 188771 [details]
emerge --info
Comment 2 Zac Medico gentoo-dev 2009-04-18 09:11:43 UTC
Having --as-needed in LDFLAGS should solve problems like this, since openoffice apparently doesn't link directly to libicudata.so.38.
Comment 3 Lars Wendler (Polynomial-C) gentoo-dev 2009-04-27 19:18:45 UTC
*** Bug 265068 has been marked as a duplicate of this bug. ***
Comment 4 Lars Wendler (Polynomial-C) gentoo-dev 2009-04-27 19:19:16 UTC
*** Bug 267618 has been marked as a duplicate of this bug. ***
Comment 5 Kevin O'Gorman 2009-04-29 13:09:31 UTC
(In reply to comment #2)
> Having --as-needed in LDFLAGS should solve problems like this, since openoffice
> apparently doesn't link directly to libicudata.so.38.
> 

I don't know what that would do.  I did discover that recompiling OpenOffice
did not help, but that downgrading icu by masking 4.0 made OpenOffice work again.
Consider it a workaround.
Comment 6 Zac Medico gentoo-dev 2011-05-18 18:57:24 UTC
In 2.2.0_alpha34 there are lots of preserve-libs fixes, including bug 286714. Please re-open if you can still reproduce this with 2.2.0_alpha34.