Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 266050 - gnome-extra/hamster-applet-2.24.3 failed with python 2.4 + pysqlite
Summary: gnome-extra/hamster-applet-2.24.3 failed with python 2.4 + pysqlite
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
: 307011 329561 (view as bug list)
Depends on: 306923
Blocks: gnome2.24
  Show dependency tree
 
Reported: 2009-04-13 20:17 UTC by Daniel Gryniewicz (RETIRED)
Modified: 2010-07-23 17:35 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Gryniewicz (RETIRED) gentoo-dev 2009-04-13 20:17:39 UTC
checking for python sqlite module... no
configure: error: Python 2.5+: inbuilt sqlite is required to build hamster


python 2.4 and pysqlite was installed.  I suspect it really needs python-2.5, and the || dep is not appropriate.
Comment 1 VERDOIA Laurent 2009-06-11 01:53:22 UTC
If fact i had the same problem.
I just add the sqlite flag to dev-lang/python, rebuild it and hamster would install.

In the ebuild there is the line :
RDEPEND="
    || ( >=dev-lang/python-2.5[sqlite]
         ( dev-lang/python:2.4
           dev-python/pysqlite:2 ) )
    [...]
"

This line don't work correctly !
When i do python -V the result is: Python 2.6.2
But i still have python 2.4 and 2.5 installed !

So the dependency should be only >=dev-lang/python-2.5[sqlite]
But portage wanted to install dev-python/pysqlite:2 so it's mean that there is a problem in dependency resolving process !
Comment 2 Gilles Dartiguelongue gentoo-dev 2009-07-16 23:10:44 UTC
> python 2.4 and pysqlite was installed.  I suspect it really needs python-2.5,
> and the || dep is not appropriate.

I think that it's just badly written (like () not being handled the way that is implied here), maybe it should be
RDEPEND=">=dev-lang/python-2.4
    || ( >=dev-lang/python-2.5[sqlite]
        dev-python/pysqlite:2 )"

the autofoo looks otherwise good. Letting this open until I can actually check this on a box where I have old pythons installed. I'll commit this change to 2.26.3 though.
Comment 3 James Gilliland 2010-01-21 22:57:15 UTC
This seems to have not been fixed yet(same problem with 2.28.2)
Comment 4 Robert Buchholz (RETIRED) gentoo-dev 2010-02-24 13:11:56 UTC
(In reply to comment #2)
> RDEPEND=">=dev-lang/python-2.4
>     || ( >=dev-lang/python-2.5[sqlite]
>         dev-python/pysqlite:2 )"

Not quite. It needs pysqlite (sqlite2) if system python is 2.4 or sqlite3 (python[sqlite]) if system python is 2.5 or higher. The issue is that for portage, any of the two satisfies the ebuild requirements, whereas the configure script checks the actual system version.
Comment 5 R Deepak 2010-02-26 23:30:24 UTC
I can confirm that it still happens in 2.28.2
Comment 6 C D 2010-02-27 21:07:10 UTC
(In reply to comment #5)
> I can confirm that it still happens in 2.28.2
Second that...
I get "configure: error: Python 2.5+: inbuilt sqlite is required to build hamster" with "gnome-extra/hamster-applet-2.28.2".
And I am using python2.6, I tried "emerge -1 pysqlite" to see if the build was install wrong, but it didn't work.
I am going to try updating to python3.1 to try to fix the problem.
Comment 7 Gilles Dartiguelongue gentoo-dev 2010-03-01 22:22:38 UTC
*** Bug 307011 has been marked as a duplicate of this bug. ***
Comment 8 Gilles Dartiguelongue gentoo-dev 2010-03-01 22:28:11 UTC
As reported here: http://www.mail-archive.com/gentoo-dev@lists.gentoo.org/msg35713.html
we can probably just drop support for python 2.4 and be done with it.
Comment 9 Daniel Gryniewicz (RETIRED) gentoo-dev 2010-03-02 13:11:35 UTC
Okay, I've fixed this for >=2.26 (since those are ~arch) requiring >=python-2.5[sqlite].  This seems to work correctly.  Should we fix the 2.24 at all?
Comment 10 Robert Buchholz (RETIRED) gentoo-dev 2010-03-07 15:52:00 UTC
That depends on the stable plans of 2.28. I am using it in Gnome 2.26.3 and it works fine.
Comment 11 Pacho Ramos gentoo-dev 2010-03-07 17:41:43 UTC
hamster-applet-2.26.3 is already going stable (and already stable on amd64), see bug 306923
Comment 12 Andrew John Hughes 2010-03-16 20:56:13 UTC
Same problem occurs here but with 3.1.  The use requirement is forced on python 3.1 but hamster wants 2.5 or 2.6.
Comment 13 Pacho Ramos gentoo-dev 2010-04-14 16:21:36 UTC
hamster-applet-2.26 stabilized, *original* problem should be solved now then. For any remaining problems, please open a new bug report
Comment 14 renato gallo 2010-07-23 11:05:58 UTC
checking pkg-config is at least version 0.9.0... yes
checking gnome-doc-utils >= 0.17.3... yes
checking for gconftool-2... /usr/bin/gconftool-2
Using config source xml:merged:/etc/gconf/gconf.xml.defaults for schema installation
Using $(sysconfdir)/gconf/schemas as install directory for schema files
checking for a Python interpreter with version >= 2.4... python
checking for python... /usr/bin/python
checking for python version... 2.6
checking for python platform... linux2
checking for python script directory... ${prefix}/lib64/python2.6/site-packages
checking for python extension module directory... ${exec_prefix}/lib64/python2.6/site-packages
checking for headers required to compile python extensions... found
checking for HAMSTER... yes
checking for gnomeapplet module... yes
checking for pygtk-codegen-2.0... /usr/bin/pygtk-codegen-2.0
checking for pygtk defs... /usr/share/pygtk/2.0/defs
checking for python sqlite module... no
configure: error: Python 2.5+: inbuilt sqlite is required to build hamster

Comment 15 Daniel Gryniewicz (RETIRED) gentoo-dev 2010-07-23 14:29:10 UTC
*** Bug 329561 has been marked as a duplicate of this bug. ***
Comment 16 Pacho Ramos gentoo-dev 2010-07-23 17:35:56 UTC
*** Bug 329561 has been marked as a duplicate of this bug. ***