Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 265386 - x11-drivers/xf86-video-intel-2.6.3 - mplayer video output crashes X
Summary: x11-drivers/xf86-video-intel-2.6.3 - mplayer video output crashes X
Status: VERIFIED INVALID
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo X packagers
URL:
Whiteboard:
Keywords:
: 266708 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-04-07 22:11 UTC by Vytautas
Modified: 2009-05-12 07:29 UTC (History)
7 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Xorg.log (Xorg.0.log,19.08 KB, text/plain)
2009-04-08 08:36 UTC, Vytautas
Details
emerge --info (emerge--info,3.01 KB, text/plain)
2009-04-16 14:30 UTC, Vytautas
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vytautas 2009-04-07 22:11:39 UTC
mplayer *.mp3 -> OK
mplayer *.flv -> crash of xorg
mplayer *.avi -> colorful screen of death

Maybe more, but after third case two times I lost my desire to do more experiments.

Reproducible: Always

Steps to Reproduce:
As stated above
Actual Results:  
crash, CSOD

Expected Results:  
video
Comment 1 Rafał Mużyło 2009-04-07 23:32:30 UTC
As a bug report, this is about useless.
At the very least, attach:
- your xorg.conf
- your Xorg log

Perhaps try to rebuild mplayer first.
Comment 2 Vytautas 2009-04-08 08:34:53 UTC
Of course i tried to rebuild before adding bug, here Xorg.conf:


Section "ServerLayout"
	Identifier     "X.org Configured"
	Screen      0  "Screen0" 0 0
	InputDevice    "Mouse0" "CorePointer"
	InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
	ModulePath   "/usr/lib/xorg/modules"
	FontPath     "/usr/share/fonts/misc/"
	FontPath     "/usr/share/fonts/TTF/"
	FontPath     "/usr/share/fonts/OTF"
	FontPath     "/usr/share/fonts/Type1/"
	FontPath     "/usr/share/fonts/100dpi/"
	FontPath     "/usr/share/fonts/75dpi/"
EndSection

Section "Module"
	Load  "extmod"
	Load  "record"
	Load  "dbe"
	Load  "GLcore"
	Load  "xtrap"
	Load  "dri"
	Load  "glx"
	Load  "freetype"
	Load  "type1"
EndSection

Section "InputDevice"
	Identifier  "Keyboard0"
	Option      "XkbLayout" "us,lt"
	Option      "XkbOptions" "grp:alt_shift_toggle"
	Driver      "kbd"
EndSection

Section "InputDevice"
	Identifier  "Mouse0"
	Driver      "mouse"
	Option	    "Protocol" "auto"
	Option	    "Device" "/dev/input/mice"
	Option	    "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
	Identifier   "Monitor0"
	VendorName   "Monitor Vendor"
	ModelName    "Monitor Model"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
        ### [arg]: arg optional
        #Option     "NoAccel"            	# [<bool>]
        #Option     "SWcursor"           	# [<bool>]
        #Option     "ColorKey"           	# <i>
        #Option     "CacheLines"         	# <i>
        #Option     "Dac6Bit"            	# [<bool>]
        #Option     "DRI"                	# [<bool>]
        #Option     "NoDDC"              	# [<bool>]
        #Option     "ShowCache"          	# [<bool>]
        #Option     "XvMCSurfaces"       	# <i>
        #Option     "PageFlip"           	# [<bool>]
	Identifier  "Card0"
	Driver      "intel"
	VendorName  "Intel Corporation"
	BoardName   "82830 CGC [Chipset Graphics Controller]"
	BusID       "PCI:0:2:0"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Card0"
	Monitor    "Monitor0"
	SubSection "Display"
		Viewport   0 0
		Depth     1
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     4
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     8
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     15
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     16
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     24
	EndSubSection
EndSection

I will add log too.
Comment 3 Vytautas 2009-04-08 08:36:33 UTC
Created attachment 187669 [details]
Xorg.log
Comment 4 Vytautas 2009-04-08 08:38:19 UTC
Feel free to ask more info, logs, config files.
Comment 5 Vytautas 2009-04-08 11:30:02 UTC
I changed video driver to vesa and it works. 
Problem in driver I think.
Comment 6 Rafał Mużyło 2009-04-08 14:33:02 UTC
Well, with intel, it may be a bit tricky:
- 2.6.29 (.28 too, I think) do intel dri by GEM,
but on earlier kernels it's done in a different way.
Comment 7 Vytautas 2009-04-11 12:03:27 UTC
I have 2.6.27-r7 now. 
Maybe I will try to update to 2.6.28 this week. 
If I will do this I will post results here.
Comment 8 Jeroen Roovers (RETIRED) gentoo-dev 2009-04-16 04:02:05 UTC
Please reopen this bug report when you are done testing, and then post your `emerge --info' too.
Comment 9 Vytautas 2009-04-16 08:22:34 UTC
I also have 2.6.28-r4 now. (updated).
It is almost fixed now with this kernel.

I can play video normaly and even few videos, but after video playing IF I press ctrl+alt+bcksp or atrl+alt+F1 system crashes leaving just black, empty screen of death. 

Shoud I leave this as FIXED and submit new bug now?
Should I try 2.6.29?

I will post emerge --info next day.
Comment 10 Vytautas 2009-04-16 14:30:15 UTC
Created attachment 188572 [details]
emerge --info
Comment 11 Vytautas 2009-04-17 12:24:10 UTC
I tried mplayer 29040 nothing changed.
I tried kernel 2.6.29-r1 and xorg do not work at all with it (strange colorful lines only).
Comment 12 ta2002 2009-04-20 22:45:12 UTC
*** Bug 266708 has been marked as a duplicate of this bug. ***
Comment 13 ta2002 2009-04-20 22:49:35 UTC
I am having the same problem. Is there some workaround (downgrade of xf86-video-intel or xorg-server) for stable packages?
Comment 14 Matt Michalowski 2009-04-21 01:08:28 UTC
(In reply to comment #13)
> I am having the same problem. Is there some workaround (downgrade of
> xf86-video-intel or xorg-server) for stable packages?
> 

You can try 'mplayer -vo x11' (or put vo=x11 ~/.mplayer/config). It crashes for me when using to xv driver.
Comment 15 ta2002 2009-04-21 06:33:21 UTC
It seems like Ubuntu found a patch for this:

https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/354889
Comment 16 Octavian 2009-04-21 15:11:46 UTC
See also #265803
Comment 17 ta2002 2009-04-21 23:03:43 UTC
(In reply to comment #16)
> See also #265803

Sounds similar. You say you have it working with xf86-video-intel-2.6.1? I am definitely going to downgrade something to try to get this working again - I just haven't figured out exactly what yet. :) The video driver would be a much easier downgrade than xorg-server (if it works).
Comment 18 Octavian 2009-04-22 19:36:26 UTC
Yes downgrading to xf86-video-intel-2.6.1
Comment 19 Vytautas 2009-04-23 11:33:34 UTC
kernel 2.6.28-r4 and xf86-video-intel-2.6.1 do not work at all for me just black screen and mouse.

Can someone do it in most simple way and just copy patch from Ubuntu to Gentoo?
Comment 20 Octavian 2009-04-24 20:12:40 UTC
you need kernel 2.6.27 not 2.6.28
Comment 21 Vytautas 2009-04-25 07:56:11 UTC
kernel 2.6.28-r5 is stable now. So it works too?
Stable means stable or I have to mask it?
(Also look comment  #6).
Comment 22 Octavian 2009-04-25 11:30:12 UTC
yes that's why you need 2.6.27.

After you have a stable situation you can start experimenting.

I will do the same but most likely with 2.6.29 and xorg 1.6 from overlay
Comment 23 Vytautas 2009-04-25 13:57:20 UTC
I think I will follow #14 and wait until stable will become stable again (this bug fixed). I do not see other problems maybe wine also slower, but I do not care about other things much.
Comment 24 Vytautas 2009-04-27 10:38:59 UTC
I had free time for lappy so compilled 2.6.27-r10 and it do not work with xf86-video-intel-2.6.1 too. 
I think unmasking 2.6.1 is just waste of time, that thing is 100% usless.
Comment 25 Octavian 2009-04-27 20:20:10 UTC
(In reply to comment #24)
> I had free time for lappy so compilled 2.6.27-r10 and it do not work with
> xf86-video-intel-2.6.1 too. 
> I think unmasking 2.6.1 is just waste of time, that thing is 100% usless.
> 

Well in my case xf86-video-intel-2.6.3-r1 is broken on two PC's, 
- one intel 865G: when playing in XV, instant crash no matter the kernel.
- another one 9*: 3d very slow.

However xf86-video-intel-2.6.1 works only with 2.6.27* not with 2.6.28 since I get errors about "Couldn't bind memory for BO front buffer"



Comment 26 Vytautas 2009-04-28 06:41:43 UTC
My:
$ lspci | grep "VGA"
00:02.0 VGA compatible controller: Intel Corporation 82830 CGC [Chipset Graphics Controller] (rev 04)
Comment 27 Rémi Cardona gentoo-dev 2009-04-28 06:46:23 UTC
To all,

Please try to keep this bug on topic, the discussion here is getting a bit out of hand.

If you all want to try something, please fetch the "drm-intel-2.6.29" branch from Eric Anholt's kernel tree [1] along with the latest -intel driver.

I'll be putting 2.7.0 in Portage in a few days, so please try that as well when you can.

Thanks
Comment 28 Rémi Cardona gentoo-dev 2009-05-05 11:48:41 UTC
Ok, I'm closing this bug because nothing good will come out of it anymore :)

To all who posted here :
 - please update to the _latest_ ~arch versions of the kernel, libdrm and xf86-video-intel
 - please give a try to xf86-video-intel 2.7 (yes it's in p.mask but it's temporary)
 - once xorg-server 1.6 hits portage, please try it as well

If you still have issues, please don't hesitate to open _new_ bugs.

Thanks to all
Comment 29 Vytautas 2009-05-12 07:29:09 UTC
I simply unmasked 2.7 video driver+new version of lib it needed and everything works fine. Everything else is current 'stable' version.
--
I do not see reasons to hardmask 2.7 it should be stabilized soon.