Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 263641 - >=app-doc/doxygen-1.5.8-r1 doesn't compile on PPC64
Summary: >=app-doc/doxygen-1.5.8-r1 doesn't compile on PPC64
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: PPC64 Linux
: High normal (vote)
Assignee: Kacper Kowalik (Xarthisius) (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on: 266693
Blocks: 271815 323647 338632
  Show dependency tree
 
Reported: 2009-03-24 18:11 UTC by viogus cdf
Modified: 2013-08-10 20:19 UTC (History)
9 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description viogus cdf 2009-03-24 18:11:33 UTC
it has been in portage for nearly 2 months,
and there's no bugs report for it now
(there're 2 bugs mentioning about but not really for it)。
plz stablize it,thx.


Reproducible: Always
Comment 1 Sander Knopper 2009-04-08 09:12:16 UTC
I've been using this version on amd64 for a couple of days now and it works fine. So I'd also appreciate it if it could be stabilized, especially since the current stable version is relatively old.
Comment 2 Ferris McCormick (RETIRED) gentoo-dev 2009-06-01 15:30:18 UTC
Sparc stable for Bug #271815.  You will need to add other archs, however.
Comment 3 Peter Volkov (RETIRED) gentoo-dev 2009-06-17 15:54:03 UTC
Guys, this package is already stable on amd64, ppc, sparc and x86? Are there any reasons we didn't added other archs?
Comment 4 Jeroen Roovers gentoo-dev 2009-07-02 17:04:30 UTC
(In reply to comment #3)
> Guys, this package is already stable on amd64, ppc, sparc and x86? Are there
> any reasons we didn't added other archs?
> 

Guys/girls... :)

And I don't see why we should hold back.
Comment 5 Brent Baude (RETIRED) gentoo-dev 2009-07-03 13:50:27 UTC
fails for ppc64 64UL:

gmake[2]: Leaving directory `/var/tmp/portage/app-doc/doxygen-1.5.8-r1/work/doxygen-1.5.8/src'
/usr/bin/gmake -f Makefile.doxygen    PERL=/usr/bin/perl all
gmake[2]: Entering directory `/var/tmp/portage/app-doc/doxygen-1.5.8-r1/work/doxygen-1.5.8/src'
g++ -c -pipe -Wall -W -fno-exceptions -O2 -pipe -I../qtools -I../libmd5 -I. -o ../objects/main.o main.cpp
g++ -Wl,-O1 -o ../bin/doxygen ../objects/main.o  -L../lib -ldoxygen -ldoxycfg -lqtools -lpng -lmd5 
../lib/libdoxygen.a(language.o):(.text._ZN19TranslatorNorwegian28trCompoundMembersDescriptionEb[TranslatorNorwegian::trCompoundMembersDescription(bool)]+0x82): relocation truncated to fit: R_PPC64_TOC16_DS against `.toc'+10000
../lib/libdoxygen.a(language.o):(.text._ZN19TranslatorNorwegian28trCompoundMembersDescriptionEb[TranslatorNorwegian::trCompoundMembersDescription(bool)]+0xce): relocation truncated to fit: R_PPC64_TOC16_DS against `.toc'+10010
../lib/libdoxygen.a(language.o):(.text._ZN19TranslatorNorwegian28trCompoundMembersDescriptionEb[TranslatorNorwegian::trCompoundMembersDescription(bool)]+0x112): relocation truncated to fit: R_PPC64_TOC16_DS against `.toc'+10008
../lib/libdoxygen.a(language.o):(.text._ZN19TranslatorNorwegian28trCompoundMembersDescriptionEb[TranslatorNorwegian::trCompoundMembersDescription(bool)]+0x15e): relocation truncated to fit: R_PPC64_TOC16_DS against `.toc'+10028
../lib/libdoxygen.a(language.o):(.text._ZN19TranslatorNorwegian28trCompoundMembersDescriptionEb[TranslatorNorwegian::trCompoundMembersDescription(bool)]+0x1a2): relocation truncated to fit: R_PPC64_TOC16_DS against `.toc'+10018
../lib/libdoxygen.a(language.o):(.text._ZN19TranslatorNorwegian28trCompoundMembersDescriptionEb[TranslatorNorwegian::trCompoundMembersDescription(bool)]+0x1f2): relocation truncated to fit: R_PPC64_TOC16_DS against `.toc'+10020
../lib/libdoxygen.a(language.o):(.text._ZN19TranslatorNorwegian25trCompoundListDescriptionEv[TranslatorNorwegian::trCompoundListDescription()]+0x5e): relocation truncated to fit: R_PPC64_TOC16_DS against `.toc'+10038
../lib/libdoxygen.a(language.o):(.text._ZN19TranslatorNorwegian25trCompoundListDescriptionEv[TranslatorNorwegian::trCompoundListDescription()]+0xa2): relocation truncated to fit: R_PPC64_TOC16_DS against `.toc'+10030
../lib/libdoxygen.a(language.o):(.text._ZN19TranslatorNorwegian13trFileMembersEv[TranslatorNorwegian::trFileMembers()]+0x5e): relocation truncated to fit: R_PPC64_TOC16_DS against `.toc'+10040
../lib/libdoxygen.a(language.o):(.text._ZN19TranslatorNorwegian17trCompoundMembersEv[TranslatorNorwegian::trCompoundMembers()]+0x5e): relocation truncated to fit: R_PPC64_TOC16_DS against `.toc'+10048
../lib/libdoxygen.a(language.o):(.text._ZN19TranslatorNorwegian14trCompoundListEv[TranslatorNorwegian::trCompoundList()]+0x5e): additional relocation overflows omitted from the output
collect2: ld returned 1 exit status
gmake[2]: *** [../bin/doxygen] Error 1
gmake[2]: Leaving directory `/var/tmp/portage/app-doc/doxygen-1.5.8-r1/work/doxygen-1.5.8/src'
gmake[1]: *** [all] Error 2
gmake[1]: Leaving directory `/var/tmp/portage/app-doc/doxygen-1.5.8-r1/work/doxygen-1.5.8/src'
make: *** [all] Error 2


emerge info :
quad doxygen # emerge --info
Portage 2.1.6.13 (default/linux/powerpc/ppc64/2008.0/64bit-userland/desktop, gcc-4.3.2, glibc-2.8_p20080602-r1, 2.6.27-gentoo-r8-g5-64 ppc64)
=================================================================
System uname: Linux-2.6.27-gentoo-r8-g5-64-ppc64-PPC970MP,_altivec_supported-with-glibc2.3
Timestamp of tree: Fri, 03 Jul 2009 11:00:01 +0000
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7-r1, 2.1.7
dev-lang/python:     2.4.6, 2.5.4-r2
dev-python/pycrypto: 2.0.1-r6
dev-util/cmake:      2.6.2-r1
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="ppc64"
CBUILD="powerpc64-unknown-linux-gnu"
CFLAGS="-O2 -pipe"
CHOST="powerpc64-unknown-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/bind /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs cvs distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://quad/ http://drake/gentoo/ http://butthead/ http://gentoo.mirrors.tds.net/gentoo"
LDFLAGS="-Wl,-O1"
MAKEOPTS="-j6"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/cell /usr/portage/local/layman/powerpc /usr/local/portage"
SYNC="rsync://sharpie/gentoo-portage"
USE="X acl alsa arts berkdb bluetooth branding bzip2 cairo cdr cli cracklib crypt cups dbus dri dvd dvdr dvdread eds emboss encode esd evo fam firefox fortran gdbm gif gnome gpm gstreamer gtk hal ibm iconv ipv6 isdnlog jpeg kde ldap libnotify mad midi mikmod mp3 mpeg mudflap mysql ncurses nls nptl nptlonly ogg opengl openmp pam pcre pdf perl png ppc64 ppds pppd python qt3 qt3support qt4 quicktime readline reflection sdl session spell spl ssl startup-notification svg sysfs tcpd tiff truetype unicode usb vorbis xml xorg xulrunner xv zlib" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="fbdev mach64 mga nv r128 radeon vesa vga"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS



Comment 6 Jeroen Roovers gentoo-dev 2009-07-09 19:39:27 UTC
Stable for HPPA.
Comment 7 Tobias Klausmann gentoo-dev 2009-07-12 14:13:52 UTC
Stable on alpha.
Comment 8 Raúl Porcel (RETIRED) gentoo-dev 2009-08-27 13:51:34 UTC
arm/ia64/s390/sh stable
Comment 9 Steve Arnold gentoo-dev 2009-10-18 20:50:46 UTC
In another week we can look at stablizing doxygen-1.6.1...

*cough* ppc64 *cough*  Just sayin'...
Comment 10 Maciej Mrozowski gentoo-dev 2009-12-07 02:55:16 UTC
Hmm, how about now? :)
Comment 11 Samuli Suominen gentoo-dev 2010-01-01 16:42:41 UTC
What's going on here? Only ppc64 is going stable for 1.6.1?

Arnold?
Comment 12 Brent Baude (RETIRED) gentoo-dev 2010-01-02 14:52:03 UTC
same error for 1.6.1 on ppc64

../lib/libdoxygen.a(language.o):(.text._ZN19TranslatorHungarian13trGeneratedAtEPKcS1_[TranslatorHungarian::trGeneratedAt(char const*, char const*)]+0xa6): relocation truncated to fit: R_PPC64_TOC16_DS against `.toc'+10000
../lib/libdoxygen.a(language.o):(.text._ZN19TranslatorHungarian13trGeneratedAtEPKcS1_[TranslatorHungarian::trGeneratedAt(char const*, char const*)]+0xee): relocation truncated to fit: R_PPC64_TOC16_DS against `.toc'+10008
../lib/libdoxygen.a(language.o):(.text._ZN19TranslatorHungarian24trGeneratedAutomaticallyEPKc[TranslatorHungarian::trGeneratedAutomatically(char const*)]+0x2e): relocation truncated to fit: R_PPC64_TOC16_DS against `.toc'+10010
../lib/libdoxygen.a(language.o):(.text._ZN19TranslatorHungarian24trGeneratedAutomaticallyEPKc[TranslatorHungarian::trGeneratedAutomatically(char const*)]+0x42): relocation truncated to fit: R_PPC64_TOC16_DS against `.toc'+10018
../lib/libdoxygen.a(language.o):(.text._ZN19TranslatorHungarian24trGeneratedAutomaticallyEPKc[TranslatorHungarian::trGeneratedAutomatically(char const*)]+0xbe): relocation truncated to fit: R_PPC64_TOC16_DS against `.toc'+10020
../lib/libdoxygen.a(language.o):(.text._ZN19TranslatorHungarian24trGeneratedAutomaticallyEPKc[TranslatorHungarian::trGeneratedAutomatically(char const*)]+0x13e): relocation truncated to fit: R_PPC64_TOC16_DS against `.toc'+10028
../lib/libdoxygen.a(language.o):(.text._ZN16TranslatorKorean13trGeneratedAtEPKcS1_[TranslatorKorean::trGeneratedAt(char const*, char const*)]+0x2a): relocation truncated to fit: R_PPC64_TOC16_DS against `.toc'+10030
../lib/libdoxygen.a(language.o):(.text._ZN16TranslatorKorean13trGeneratedAtEPKcS1_[TranslatorKorean::trGeneratedAt(char const*, char const*)]+0x76): relocation truncated to fit: R_PPC64_TOC16_DS against `.toc'+10038
../lib/libdoxygen.a(language.o):(.text._ZN16TranslatorKorean13trGeneratedAtEPKcS1_[TranslatorKorean::trGeneratedAt(char const*, char const*)]+0xd6): relocation truncated to fit: R_PPC64_TOC16_DS against `.toc'+10040
../lib/libdoxygen.a(language.o):(.text._ZN18TranslatorRomanian13trGeneratedAtEPKcS1_[TranslatorRomanian::trGeneratedAt(char const*, char const*)]+0x2a): relocation truncated to fit: R_PPC64_TOC16_DS against `.toc'+10048
../lib/libdoxygen.a(language.o):(.text._ZN18TranslatorRomanian13trGeneratedAtEPKcS1_[TranslatorRomanian::trGeneratedAt(char const*, char const*)]+0x76): additional relocation overflows omitted from the output
Comment 13 Tom Gall (RETIRED) gentoo-dev 2010-01-25 03:16:31 UTC
and adding -mminimal-toc doesn't fix it 

++ -c -pipe -fno-exceptions -fno-rtti -D_LARGEFILE_SOURCE -Wall -W -fno-exceptions -O2 -mtune=970 -mcpu=970 -mminimal-toc -pipe -I../qtools -I../libmd5 -o ../objects/dbusxmlscanner.o dbusxmlscanner.cpp
{standard input}: Assembler messages:
{standard input}:341623: Error: operand out of range (0x0000000000008000 is not between 0xffffffffffff8000 and 0x0000000000007ffc)
{standard input}:341641: Error: operand out of range (0x0000000000008008 is not between 0xffffffffffff8000 and 0x0000000000007ffc)
{standard input}:341708: Error: operand out of range (0x0000000000008010 is not between 0xffffffffffff8000 and 0x0000000000007ffc)
{standard input}:341713: Error: operand out of range (0x0000000000008018 is not between 0xffffffffffff8000 and 0x0000000000007ffc)
{standard input}:341747: Error: operand out of range (0x0000000000008020 is not between 0xffffffffffff8000 and 0x0000000000007ffc)
{standard input}:341779: Error: operand out of range (0x0000000000008028 is not between 0xffffffffffff8000 and 0x0000000000007ffc)
{standard input}:341838: Error: operand out of range (0x0000000000008030 is not between 0xffffffffffff8000 and 0x0000000000007ffc)
.....(there's a great deal more of the same type of message)

I've brought this up with the toolchain types upstream. 
Comment 14 Peter Volkov (RETIRED) gentoo-dev 2010-06-12 09:07:36 UTC
@ppc64, what about doxygen-1.6.3. If it fails could you report this upstream?
Comment 15 Mark Loeser (RETIRED) gentoo-dev 2010-11-01 22:11:02 UTC
Just as an fyi, this is still failing.  I'll look into it further when I get a chance.
Comment 16 Peter Bergner 2010-11-11 15:56:00 UTC
Tom Gall pointed me to this a while back and I can confirm that doxygen does not build with or without -mminimal-toc.  This is not a bug in the GCC TOC code or in -mminimial-toc.  This is a limitation in the original ppc64 code model.

That being said, we (IBM) just added two new ppc64 code models that fix this, but they won't be available in an official FSF GCC release, until GCC 4.6 (we do have a GCC 4.5 backport in our FSF IBM 4.5 branch if anyone is interested).  The code models for ppc64 are now:

  1) -mcmodel=small [-mminimal-toc]    # Ie, the old ppc64 code model.
  2) -mcmodel=medium                   # The new default in GCC 4.6
  3) -mcmodel=large

I'll let Alan's original patch submission describe the different options (there have been multiple changes made since that post):

    http://gcc.gnu.org/ml/gcc-patches/2010-06/msg00747.html

The GCC code model support requires a newish binutils, where Alan has added some linker optimizations when the TOC offsets are small.  Search for "large toc" in the binutils mailing list.

Comment 17 Kacper Kowalik (Xarthisius) (RETIRED) gentoo-dev 2011-01-16 10:20:51 UTC
That failure comes from hundreds of translations strings/if etc. We have following options:
 1) rework the code
 2) wait for new gcc-4.6
 3) add 'use ppc64 && my_conf="${my_conf} --english-only" #263641' to src_configure

I doubt that anyone will do 1) anytime soon, 2) is doing practically nothing ,while 3) works like a charm :)
Comment 18 Steve Arnold gentoo-dev 2011-01-18 06:12:11 UTC
Option 3 added to 1.7.2, should close when gcc fix is confirmed to work.
Comment 19 Mark Loeser (RETIRED) gentoo-dev 2013-08-10 20:19:18 UTC
gcc-4.6 is stable, and we can now build without the workaround, so it is removed.