Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 262994 - Add support for evolution-mapi
Summary: Add support for evolution-mapi
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement with 3 votes (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
: 371629 (view as bug list)
Depends on: 195703 223821 565206
Blocks: gnome2.28
  Show dependency tree
 
Reported: 2009-03-19 07:06 UTC by mikopp
Modified: 2017-08-14 16:16 UTC (History)
24 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Samba 4 with pidl installation (samba-4.0.0_alpha11.ebuild,4.27 KB, text/plain)
2010-03-18 00:55 UTC, Mike Auty (RETIRED)
Details
gnome-extra/evolution-mapi-0.32.2 ebuild (evolution-mapi-0.32.2.ebuild,743 bytes, text/plain)
2011-06-20 09:15 UTC, Sejul Shah
Details
Patch to remove unicode flag from folder list function (evolution-mapi-0.32.2-no_unicode_folders.patch,783 bytes, patch)
2011-06-20 09:16 UTC, Sejul Shah
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description mikopp 2009-03-19 07:06:57 UTC
Gnome 2.26 has been released now and contains a mapi connector for evolution. It would be great to have it available in gentoo.
Comment 1 Robert Piasek (RETIRED) gentoo-dev 2009-03-19 15:02:48 UTC
I've been watching this project closely for a while now. Unfortunately in it's current form it's not as usable as plugin using OWA:

http://www.go-evolution.org/MAPIProvider/vsOWA


R
Comment 2 Alexander Brüning 2009-03-19 15:05:37 UTC
(In reply to comment #1)
> I've been watching this project closely for a while now. Unfortunately in it's
> current form it's not as usable as plugin using OWA:

Yes, but the OWA-Based plugin doesn't work with Exchange 2007 at all.
Comment 3 Gilles Dartiguelongue gentoo-dev 2009-03-19 22:03:05 UTC
thanks for your interest
Comment 4 Gilles Dartiguelongue gentoo-dev 2009-03-19 22:03:44 UTC
however this is already present in gnome overlay where we do the development series work and will land in portage when it is ready. Thanks for reporting.
Comment 5 Mike Auty (RETIRED) gentoo-dev 2009-03-19 22:19:51 UTC
Gilles, I've reopened this bug (correct me if I'm wrong), because the only package I could find in the gnome overlay is evolution-exchange (which is the existing exchange interface for evolution, up to exchange 2003 I believe), but isn't evolution-mapi (which supports up to exchange 2007).  If it's present there and I've just missed it, could you please paste a link from git.overlays.gentoo.org so we could try it out?

If not then its homepage is http://www.go-evolution.org/MAPIProvider, although it already has bugzilla and svn resources on the main gnome infrastructure.  The latest version is 0.26.0.1.
Comment 6 Alexander Brüning 2009-03-27 17:59:10 UTC
Looks like evolution-mapi depends on libmapi which in turn depends on Samba 4. Maybe we could make an ebuild that only installs the required shared libraries instead of the whole Samba package.
Comment 7 Gilles Dartiguelongue gentoo-dev 2009-03-27 22:44:29 UTC
Ok this is indeed not yet in tree. The dependency on samba will depend on how samba guys will split the things up in gentoo. I don't see samba4 ebuilds in tree and I don't plan to take over samba just yet so this might take a while before we actually get it in the tree.
Comment 8 Chris Gianelloni 2009-04-29 23:00:08 UTC
Well, does it require samba4 (RDEPEND), or does it simply require the sources to build (DEPEND)?  There's nothing stopping anyone from pulling the samba4 source tarball and building a package from it.  After all, there's no conflict, since there's no samba4 ebuilds in the tree, and you're not planning on adding any, either.
Comment 9 Daniel Gryniewicz (RETIRED) gentoo-dev 2009-04-30 14:42:40 UTC
Both, as I understand it.  There are libraries from samba4 that libmapi depends on, and evo-mapi depends on libmapi.

It doesn't need "samba4" per se; just libraries from it.
Comment 10 Mike Auty (RETIRED) gentoo-dev 2009-04-30 18:26:33 UTC
Good point, I couldn't tell you, I'd need to investigate libmapi a bit more.  Hopefully it'll have an autoconf directory and we can just unpack it locally and build from there.  I'll look into it, thanks for the idea!  5:)
Comment 11 Mike Auty (RETIRED) gentoo-dev 2009-05-03 19:20:46 UTC
Ugh, so it comes with a "make samba" option, but that will basically download, compile and attempt to install samba into /usr/local/samba.  5:\

The configure check uses pkgconfig to look for dcerpc, ndr and samba-hostconfig.  It also checks for the samba/version.h.  I don't know enough about samba4 to know whether we could cut down the install to just those elements, but it sounds like it would be messy any way we decided to go with this.

Much better would be, well, a) upstream to make a relatively stable release (including sub-packages, the existing packages for libtdb and so forth don't all compile properly, nor interoperate properly), b) for libmapi not to depend on alpha software and c) for us to get a proper idea of how to deal with both samba 3 and samba 4 at once, whether that's via slotting, eselect or some other method.  Comments towards this belong in bug 195703.

So that's where I've gotten to.  I might try building a libmapi/evolution-mapi ebuild pair that work against the most recently submitted samba4 ebuild in bug 195703, but it's unlikely to be soon.  I'd far rather an but working install of samba, than a new not-complete one that may or may not give me access to exchange 2007, which I can already get via other means...
Comment 12 Daniel Gryniewicz (RETIRED) gentoo-dev 2009-05-13 16:46:09 UTC
That's pretty much my take on it too.  I don't think we're going to get evo-mapi in any time soon.
Comment 13 Rolando J. Zappacosta 2009-05-24 16:32:13 UTC
Hi guys,

any estimated release date of an ebuild, even if it's testing/masked one?
Comment 14 Marshall McMullen 2009-05-24 19:19:28 UTC
Yeah, even if it pulled in all of samba-4 as a dependency, it'd be better than nothing at this point.
Comment 15 Daniel Gryniewicz (RETIRED) gentoo-dev 2009-05-24 20:02:12 UTC
~1 day after samba 4 is in the tree?  (okay, maybe as much as a week...)
Comment 16 Andrew Gaffney (RETIRED) gentoo-dev 2009-05-25 03:22:32 UTC
You don't need samba in the tree. Just pull in a samba4 beta tarball and build a few parts of it like the script included with the libmapi source does.
Comment 17 Mike Auty (RETIRED) gentoo-dev 2009-05-25 09:26:17 UTC
Agaffney, see comment 11 for my attempts at just using samba4 for a few bits and pieces.  It turns very ugly very quickly (because basically, libmapi expects you to do an install of its copy of samba4 before you start building it, it can't just be built in a side tree and all installed later).  If you can see a way around this, I'm all up for it but I couldn't see a way around it myself other than the options I laid out in that comment...
Comment 18 Rolando J. Zappacosta 2009-06-09 09:56:16 UTC
(In reply to comment #11)
> give me access to exchange 2007, which I can already get via other means...

do you may through an e-mail app or by opening it on a web browser?
After all, I'm behind evolution just for the former...
Comment 19 Rolando J. Zappacosta 2009-06-19 21:24:13 UTC
Hi guys,

any news regarding this subject?
Comment 20 Robert Piasek (RETIRED) gentoo-dev 2010-02-23 09:59:43 UTC
samba4_alpha11 just landed in portage tree. I should and libmapi soon, so gnome folks should be able to add evolution-mapi.

Comment 21 Robert Piasek (RETIRED) gentoo-dev 2010-02-23 12:35:01 UTC
libmapi is in the tree now.
Comment 22 Rolando J. Zappacosta 2010-02-24 08:40:07 UTC
(In reply to comment #20)
> so gnome folks should be able to add evolution-mapi.

oups, does it mean we should expect no luck under Qt?

Comment 23 Joshua Jackson (RETIRED) gentoo-dev 2010-03-17 23:07:26 UTC
also requires pidl to work..which is part of samba's tarball.This in  not included as part of the install of samba as it stands now in the 4.X ebuild.
Comment 24 Mike Auty (RETIRED) gentoo-dev 2010-03-18 00:55:54 UTC
Created attachment 224065 [details]
Samba 4 with pidl installation

Here's an ebuild that uses the perl eclass to compile and install the required pidl elements.  This ebuild and also an evolution-mapi ebuild (which does work) are in my (ikelos) overlay.  I probably won't maintain them since whilst it works, it only just works.  It had great difficulty maintaining the mail list, and couldn't handle other people's calendars.  Closer but probably not worth getting going...
Comment 25 yegle 2010-10-19 09:04:59 UTC
libmapi depends on >=samba-4.0.0_alpha13, which currently is not in portage.

configure: WARNING: The Samba4 version installed on your system doesn't meet OpenChange requirements (4.0.0alpha13 or 4.0.0alpha13-GIT-).
Comment 26 Pacho Ramos gentoo-dev 2011-06-15 09:06:11 UTC
*** Bug 371629 has been marked as a duplicate of this bug. ***
Comment 27 Sejul Shah 2011-06-20 09:15:47 UTC
Created attachment 277589 [details]
gnome-extra/evolution-mapi-0.32.2 ebuild

Ebuild for evolution-mapi suitable for gnome 2.32
Comment 28 Sejul Shah 2011-06-20 09:16:42 UTC
Created attachment 277591 [details, diff]
Patch to remove unicode flag from folder list function
Comment 29 Martin Wohlert 2015-06-26 13:38:43 UTC
Will this ever become an official ebuild? In "gnome" overlay is an ebuild for 3.16.3. gnome-extra/evolution-ews is not working that good and probably some people might find evolution-mapi to work better for them.
Comment 30 Gilles Dartiguelongue gentoo-dev 2015-06-26 21:57:22 UTC
Well libmapi-2 is not present in gentoo-x86 and I don't think it is wise for us to add this library since none of devs in the team have access to a server that requires this connector.
Comment 31 lperkins 2016-03-31 20:31:10 UTC
Now that Samba 4 is officially available in Gentoo, is there anyone who knows enough about this to take another crack at it?  I've tried building it myself, but keep ending up with strange combinations of missing libraries or header files.  I think I just don't know quite enough about how all the various pieces talk to each other, and I can't find an explanation anywhere of how to pull just the libmapi part out of openchange, so I'm stuck building the entire thing (which, I think, is what's causing a bunch of my trouble.)
Comment 32 Gilles Dartiguelongue gentoo-dev 2017-08-14 16:16:47 UTC
So libmapi was removed from tree in February 2016 and after looking into how it is packaged, I have no intention to push that under the Gnome umbrella. If someone else wants to do it, I'm fine with it but it really does not seem that upstream thought about actual release material for projects to use this.