Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 262567 - [4.3/ICE] building media-video/mplayer-20090226.28734-r1 with gcc-4.3.3-r1 results in ICE
Summary: [4.3/ICE] building media-video/mplayer-20090226.28734-r1 with gcc-4.3.3-r1 re...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: High normal with 1 vote (vote)
Assignee: Gentoo Toolchain Maintainers
URL:
Whiteboard:
Keywords:
: 262584 262618 262619 262627 262634 262643 262646 262657 262738 262767 262782 262790 262807 263076 263092 263220 263577 263605 263616 263677 263816 263821 263825 263850 263855 263957 263995 264076 (view as bug list)
Depends on: PR39013
Blocks:
  Show dependency tree
 
Reported: 2009-03-15 14:36 UTC by drhopfen
Modified: 2009-06-05 13:59 UTC (History)
61 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,390.23 KB, text/plain)
2009-03-15 14:37 UTC, drhopfen
Details
emerge --info (emerge.info,3.98 KB, text/plain)
2009-03-15 14:38 UTC, drhopfen
Details
Preprocessed source (cfft.e.c,245.08 KB, text/plain)
2009-03-15 19:23 UTC, Martin von Gagern
Details

Note You need to log in before you can comment on or make changes to this bug.
Description drhopfen 2009-03-15 14:36:39 UTC
emerge mplayer fails with:

x86_64-pc-linux-gnu-gcc -Wundef -Wdisabled-optimization -Wno-pointer-sign -Wdeclaration-after-statement -std=gnu99  -O2 -pipe -march=core2 -D__STDC_LIMIT_MACROS -D_REENTRANT -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE -I.  -I/usr/X11R6/include -I/usr/include/SDL  -D_REENTRANT   -Ilibdvdread4 -I/usr/include/freetype2   -I/usr/include/schroedinger-1.0 -I/usr/include/liboil-0.3   -Ilibdvdnav -Ilibfaad2 -D_GNU_SOURCE -DHAVE_CONFIG_H    -c -o libfaad2/drc.o libfaad2/drc.c                                                               

libfaad2/cfft.c:1001: internal compiler error: Segmentation fault
Please submit a full bug report,                                 
with preprocessed source if appropriate.                         
See <http://bugs.gentoo.org/> for instructions.
make: *** [libfaad2/cfft.o] Error 1
make: *** Waiting for unfinished jobs....
libfaad2/decoder.c: In function 'NeAACDecInit':
libfaad2/decoder.c:255: warning: passing argument 2 of 'NeAACDecInit2' from incompatible pointer type
 *
 * ERROR: media-video/mplayer-20090226.28734-r1 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 2999:  Called die
 * The specific snippet of code:
 *       emake || die "Failed to build MPlayer!";
 *  The die message:
 *   Failed to build MPlayer!
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/media-video/mplayer-20090226.28734-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-video/mplayer-20090226.28734-r1/temp/environment'.

Reproducible: always
Comment 1 drhopfen 2009-03-15 14:37:37 UTC
Created attachment 185085 [details]
build.log
Comment 2 drhopfen 2009-03-15 14:38:42 UTC
Created attachment 185086 [details]
emerge --info
Comment 3 Sergei Danilov 2009-03-15 14:56:03 UTC
I can confirm the save error on my system (amd64) 
Comment 4 François Chavant 2009-03-15 16:33:10 UTC
I have the exact same error on ~x86
Comment 5 Tomas Psika 2009-03-15 16:50:57 UTC
Just the same error too.
Comment 6 Constantin Baranov 2009-03-15 18:57:15 UTC
This is bug of gcc-4.3.3-r1 certainly.
Both mplayer-20090226.28734 and mplayer-20090226.28734-r1 fails with gcc-4.3.3-r1 but gcc-4.3.3 can compile them.
Comment 7 Martin von Gagern 2009-03-15 19:23:37 UTC
Created attachment 185106 [details]
Preprocessed source

This is the preprocessed form of the source file which causes the problem. The compiler flag "-std=gnu99" seems to be involved as well; without that flag it compiles all right. So to reproduce this, call "i686-pc-linux-gnu-gcc -std=gnu99 -c cfft.e.c".
Comment 8 Bernardo Costa 2009-03-15 21:00:22 UTC
(In reply to comment #7)
> So to reproduce this, call "i686-pc-linux-gnu-gcc
> -std=gnu99 -c cfft.e.c".
Same here, with x86_64-pc-linux-gnu-gcc. BTW, ./libavcodec/eatqi.c is also problematic, and the same workaround applies
Comment 9 Peter Alfredsen (RETIRED) gentoo-dev 2009-03-15 22:33:45 UTC
*** Bug 262584 has been marked as a duplicate of this bug. ***
Comment 10 Boney McCracker 2009-03-16 01:25:23 UTC
Same here, ~x86
Comment 11 Lars Wendler (Polynomial-C) gentoo-dev 2009-03-16 06:16:20 UTC
*** Bug 262619 has been marked as a duplicate of this bug. ***
Comment 12 Lars Wendler (Polynomial-C) gentoo-dev 2009-03-16 06:17:50 UTC
*** Bug 262618 has been marked as a duplicate of this bug. ***
Comment 13 SpanKY gentoo-dev 2009-03-16 07:05:18 UTC
seems to be caused by 69_all_gcc43-pr39013.patch

you should be able to work around by doing:
GENTOO_PATCH_EXCLUDE="69_all_gcc43-pr39013.patch" emerge gcc
Comment 14 Lars Wendler (Polynomial-C) gentoo-dev 2009-03-16 07:12:41 UTC
*** Bug 262627 has been marked as a duplicate of this bug. ***
Comment 15 Anton S. Ustyuzhanin 2009-03-16 08:30:14 UTC
*** Bug 262634 has been marked as a duplicate of this bug. ***
Comment 16 Matt 2009-03-16 09:00:16 UTC
you're trying to build mplayer with an pie compiler ?

this has failed for me like forever ;)
Comment 17 Martin von Gagern 2009-03-16 09:10:22 UTC
(In reply to comment #13)
> seems to be caused by 69_all_gcc43-pr39013.patch

Yes, the patch is broken. Just as I wanted to write details about this, I found that SpanKY came to the same conclusion in bug 254355 comment 25.
Comment 18 Lars Wendler (Polynomial-C) gentoo-dev 2009-03-16 11:24:11 UTC
*** Bug 262646 has been marked as a duplicate of this bug. ***
Comment 19 Lars Wendler (Polynomial-C) gentoo-dev 2009-03-16 11:24:25 UTC
*** Bug 262643 has been marked as a duplicate of this bug. ***
Comment 20 Lars Wendler (Polynomial-C) gentoo-dev 2009-03-16 11:28:27 UTC
(In reply to comment #13)
> seems to be caused by 69_all_gcc43-pr39013.patch
> 
> you should be able to work around by doing:
> GENTOO_PATCH_EXCLUDE="69_all_gcc43-pr39013.patch" emerge gcc

Confirmed. No ICE when compiling ffmpeg and mplayer with gcc-4.3.3-r1 having that patch backed out.
Comment 21 Magnus Granberg gentoo-dev 2009-03-16 11:33:18 UTC
Hane added a new patch for #254355 and i hope it works this time.
Comment 22 Lars Wendler (Polynomial-C) gentoo-dev 2009-03-16 13:34:02 UTC
*** Bug 262657 has been marked as a duplicate of this bug. ***
Comment 23 Lars Wendler (Polynomial-C) gentoo-dev 2009-03-16 23:27:26 UTC
*** Bug 262738 has been marked as a duplicate of this bug. ***
Comment 24 Robert Piasek (RETIRED) gentoo-dev 2009-03-17 00:31:07 UTC
I've tested new patch from #254355

BEFORE PATCH:

twolame:
/bin/sh ../libtool --tag=CC   --mode=compile x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I../build    -I ../build/ -march=native -O2 -pipe -std=c99 -Wunused -Wall  -MT encode.lo -MD -MP -MF .deps/encode.Tpo -c -o encode.lo encode.c                                                                                                    
 x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I../build -I ../build/ -march=native -O2 -pipe -std=c99 -Wunused -Wall -MT crc.lo -MD -MP -MF .deps/crc.Tpo -c crc.c  -fPIC -DPIC -o .libs/crc.o          

encode.c:1305: internal compiler error: Segmentation fault
crc.c:83: internal compiler error: Segmentation fault


mplayer:
x86_64-pc-linux-gnu-gcc -Wundef -Wdisabled-optimization -Wno-pointer-sign -Wdeclaration-after-statement -std=gnu99 -Wall -Wno-switch -Wpointer-arith -Wredundant-decls -O4 -march=x86-64 -mtune=generic -pipe -ffast-math -fomit-frame-pointer -D_REENTRANT -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE -I.  -I/usr/include/directfb -I/usr/X11R6/include -I/usr/include/  -I/usr/include/SDL  -D_REENTRANT -D_REENTRANT   -Ilibdvdread4 -I/usr/include/freetype2   -I/usr/include/dirac   -I/usr/include/schroedinger-1.0 -I/usr/include/liboil-0.3   -Ilibdvdnav -Ilibfaad2 -D_GNU_SOURCE -DHAVE_CONFIG_H    -c -o libfaad2/cfft.o libfaad2/cfft.c

libfaad2/cfft.c:1001: internal compiler error: Segmentation fault

with NEW patch from #254355 everything compiles ok.

Rob
Comment 25 Steven Gill 2009-03-17 00:43:51 UTC
Confirming error on 2 systems.  One is ~x86 and other is ~amd64.  I get the same build issue with ffmpeg 0.5-r1 on the ~x86 system.  Reverting to gcc-4.3.3 resolves the issue
Comment 26 Lars Wendler (Polynomial-C) gentoo-dev 2009-03-17 05:40:03 UTC
*** Bug 262767 has been marked as a duplicate of this bug. ***
Comment 27 Sergey Morozov 2009-03-17 06:22:14 UTC
The same with media-sound/twolame
Comment 28 Vincent Le Ligeour 2009-03-17 08:28:18 UTC
Same here (~ppc64)

powerpc64-unknown-linux-gnu-gcc -Wundef -Wdisabled-optimization -Wno-pointer-sign -Wdeclaration-after-statement -std=gnu99 -Wall -Wno-switch -Wpointer-arith -Wredundant-decls -O4
  -pipe -ffast-math -fomit-frame-pointer -maltivec -mabi=altivec -D_REENTRANT -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE -I.  -I/usr/X11R6/include -I/usr/inc
lude/SDL  -D_REENTRANT   -Ilibdvdread4 -I/usr/include/freetype2   -I/usr/include/dirac   -I/usr/include/schroedinger-1.0 -I/usr/include/liboil-0.3   -I/usr/include/gtk-2.0 -I/usr/
lib64/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/pixman-1 -I/usr/inc
lude/freetype2 -I/usr/include/libpng12   -Ilibdvdnav -Ilibfaad2 -D_GNU_SOURCE -DHAVE_CONFIG_H    -c -o libfaad2/bits.o libfaad2/bits.c
powerpc64-unknown-linux-gnu-gcc -Wundef -Wdisabled-optimization -Wno-pointer-sign -Wdeclaration-after-statement -std=gnu99 -Wall -Wno-switch -Wpointer-arith -Wredundant-decls -O4  -pipe -ffast-math -fomit-frame-pointer -maltivec -mabi=altivec -D_REENTRANT -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE -I.  -I/usr/X11R6/include -I/usr/include/SDL  -D_REENTRANT   -Ilibdvdread4 -I/usr/include/freetype2   -I/usr/include/dirac   -I/usr/include/schroedinger-1.0 -I/usr/include/liboil-0.3   -I/usr/include/gtk-2.0 -I/usr/lib64/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng12   -Ilibdvdnav -Ilibfaad2 -D_GNU_SOURCE -DHAVE_CONFIG_H    -c -o libfaad2/cfft.o libfaad2/cfft.c

libfaad2/cfft.c:1001: internal compiler error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <http://bugs.gentoo.org/> for instructions.
make: *** [libfaad2/cfft.o] Error 1
Comment 29 Martin von Gagern 2009-03-17 09:07:25 UTC
I guess we don't need any more confirmations.

The issue is well understood and bug 254355 comment 29 already has a solution waiting for inclusion. You might vote for either bug instead, if you wish to take some action. Someone with sufficient privileges might make this bug here depend on (the reopened) bug 254355, as that's what we are waiting for.
Comment 30 Peter Alfredsen (RETIRED) gentoo-dev 2009-03-17 09:59:38 UTC
*** Bug 262782 has been marked as a duplicate of this bug. ***
Comment 31 Peter Alfredsen (RETIRED) gentoo-dev 2009-03-17 11:50:22 UTC
*** Bug 262790 has been marked as a duplicate of this bug. ***
Comment 32 Peter Alfredsen (RETIRED) gentoo-dev 2009-03-17 12:15:17 UTC
http://sources.gentoo.org/viewcvs.py/gentoo-x86/sys-devel/gcc/gcc-4.3.3-r1.ebuild?r1=1.1&r2=1.2

IOW, resyncing and re-emerging gcc will clear this bug provisionally.
Comment 33 Sergey Morozov 2009-03-17 12:43:17 UTC
Why this error is corrected without increasing the version number?
Comment 34 R Bar-On 2009-03-17 12:47:32 UTC
agreed.  There should be a revbump for this fix.
Comment 35 Robert Piasek (RETIRED) gentoo-dev 2009-03-17 13:16:49 UTC
(In reply to comment #32)
> http://sources.gentoo.org/viewcvs.py/gentoo-x86/sys-devel/gcc/gcc-4.3.3-r1.ebuild?r1=1.1&r2=1.2
> 
> IOW, resyncing and re-emerging gcc will clear this bug provisionally.
> 

Why do you want to disable this patch rather than use corrected one? I've tested new patch from bug  #254355 and it works fine (comment #24)

R
Comment 36 Peter Alfredsen (RETIRED) gentoo-dev 2009-03-17 13:46:41 UTC
(In reply to comment #35)
> (In reply to comment #32)
> > http://sources.gentoo.org/viewcvs.py/gentoo-x86/sys-devel/gcc/gcc-4.3.3-r1.ebuild?r1=1.1&r2=1.2
> > 
> > IOW, resyncing and re-emerging gcc will clear this bug provisionally.
> > 
> 
> Why do you want to disable this patch rather than use corrected one? I've
> tested new patch from bug  #254355 and it works fine (comment #24)

Just to be clear, that commit was by Vapier. I imagine he'll use the correct patch once he's sure it's safe. As to why not yet, time-management issues probably come into play. For now, this bug has a work-around and will be fixed correctly when time permits.  FYI, running the GCC test-suite can take quite a long time on some architectures.
Comment 37 Peter Alfredsen (RETIRED) gentoo-dev 2009-03-17 15:26:06 UTC
*** Bug 262807 has been marked as a duplicate of this bug. ***
Comment 38 Lars Wendler (Polynomial-C) gentoo-dev 2009-03-19 20:58:04 UTC
*** Bug 263076 has been marked as a duplicate of this bug. ***
Comment 39 Lars Wendler (Polynomial-C) gentoo-dev 2009-03-20 05:37:36 UTC
*** Bug 263092 has been marked as a duplicate of this bug. ***
Comment 40 Lars Wendler (Polynomial-C) gentoo-dev 2009-03-21 09:36:57 UTC
*** Bug 263220 has been marked as a duplicate of this bug. ***
Comment 41 Craig Andrews gentoo-dev 2009-03-24 02:14:45 UTC
(In reply to comment #32)
> http://sources.gentoo.org/viewcvs.py/gentoo-x86/sys-devel/gcc/gcc-4.3.3-r1.ebuild?r1=1.1&r2=1.2
> 
> IOW, resyncing and re-emerging gcc will clear this bug provisionally.
> 

Confirmed - just re-emerging gcc fixed this bug for me.
Comment 42 Nikoli 2009-03-24 17:15:45 UTC
bug 263577 is possibly duplicate
Comment 43 Lars Wendler (Polynomial-C) gentoo-dev 2009-03-24 18:05:33 UTC
*** Bug 263577 has been marked as a duplicate of this bug. ***
Comment 44 Lars Wendler (Polynomial-C) gentoo-dev 2009-03-24 22:26:41 UTC
*** Bug 263605 has been marked as a duplicate of this bug. ***
Comment 45 Lars Wendler (Polynomial-C) gentoo-dev 2009-03-24 22:36:46 UTC
*** Bug 263616 has been marked as a duplicate of this bug. ***
Comment 46 Lars Wendler (Polynomial-C) gentoo-dev 2009-03-24 23:27:40 UTC
*** Bug 263677 has been marked as a duplicate of this bug. ***
Comment 47 Peter Alfredsen (RETIRED) gentoo-dev 2009-03-25 23:43:47 UTC
*** Bug 263816 has been marked as a duplicate of this bug. ***
Comment 48 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-03-26 02:46:13 UTC
*** Bug 263821 has been marked as a duplicate of this bug. ***
Comment 49 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-03-26 04:49:39 UTC
*** Bug 263825 has been marked as a duplicate of this bug. ***
Comment 50 Alex Alexander (RETIRED) gentoo-dev 2009-03-26 11:27:20 UTC
*** Bug 263855 has been marked as a duplicate of this bug. ***
Comment 51 Rauzi Helil 2009-03-26 11:58:54 UTC
I have the exact same error on ~amd64
Comment 52 Jose daLuz 2009-03-26 12:04:41 UTC
Since re-emerging gcc fixes this, given the number of people running into the issue a bump to -r2 to force a rebuild of gcc is appropriate?
Comment 53 Lars Wendler (Polynomial-C) gentoo-dev 2009-03-26 15:13:36 UTC
*** Bug 263850 has been marked as a duplicate of this bug. ***
Comment 54 Ben de Groot (RETIRED) gentoo-dev 2009-03-27 00:43:48 UTC
(In reply to comment #52)
> Since re-emerging gcc fixes this, given the number of people running into the
> issue a bump to -r2 to force a rebuild of gcc is appropriate?
> 
Absolutely. Now let's try to convince the gcc maintainers...
Comment 55 Ryan Hill (RETIRED) gentoo-dev 2009-03-27 02:07:08 UTC
what amazes me is how many people don't know how to do a simple bug search.
Comment 56 Dror Levin (RETIRED) gentoo-dev 2009-03-27 06:04:10 UTC
The summary is to blame, not the users. If anything, they should be thanked for reporting.
Comment 57 Lars Wendler (Polynomial-C) gentoo-dev 2009-03-27 13:13:48 UTC
*** Bug 263957 has been marked as a duplicate of this bug. ***
Comment 58 Lars Wendler (Polynomial-C) gentoo-dev 2009-03-27 20:24:56 UTC
*** Bug 263995 has been marked as a duplicate of this bug. ***
Comment 59 Peter Alfredsen (RETIRED) gentoo-dev 2009-03-27 20:52:53 UTC
+*gcc-4.3.3-r2 (27 Mar 2009)
+
+  27 Mar 2009; Peter Alfredsen <loki_val@gentoo.org> -gcc-4.3.3-r1.ebuild,
+  +gcc-4.3.3-r2.ebuild:
+  Revbump with broken patch disabled to stop duplicates of bug 262567 from
+  flowing in. Bug wranglers know this bug by heart now.
+
Comment 60 Nikos Chantziaras 2009-03-28 11:38:22 UTC
At last, rev-bumped.

Btw, maybe all those duplicates are not the user's inability to search, but their ability to tell you "please *always* rev-bump fixes that are not build-related to the package itself" :P
Comment 61 Alex Alexander (RETIRED) gentoo-dev 2009-03-28 15:01:25 UTC
*** Bug 264076 has been marked as a duplicate of this bug. ***
Comment 62 Julian Heckbert 2009-03-28 15:25:27 UTC
I think the reason why there are so many duplicates of this bug is because many people don't know what ICE is or they are trying to compile a different version from the one in the summary and assume this is an old error.
Comment 63 Robin Bankhead 2009-03-28 16:24:59 UTC
(In reply to comment #62)
> I think the reason why there are so many duplicates of this bug is because many
> people don't know what ICE is or they are trying to compile a different version
> from the one in the summary and assume this is an old error.
> 

I can't agree. This bug is seventh-newest in the search results for "mplayer", and two of the newer six are for different packages. Checking a good handful (if not all) of the newest bugs for the affected package-name and looking for error output that matches your own is just due diligence IMHO.

Mind you, I would dearly love to see better indexing in bugzilla, as searching for a snatch of error output is the easiest way to find "your" bug but sadly isn't really possible (unless the output is in the summary, which in this and most cases it isn't).

More on-topic, doesn't this bug also affect ffmpeg, vlc and possibly others?  If I'm correct on that, perhaps this ought to be mentioned in summary?
Comment 64 Dmitri Seletski 2009-05-15 21:49:50 UTC
same here, recompiling GCC without patch. wil report if it helped or not.
Comment 65 Magnus Granberg gentoo-dev 2009-05-15 22:14:16 UTC
(In reply to comment #64)
> same here, recompiling GCC without patch. wil report if it helped or not.
> 
Update youre GCC and it will be fixed.

Comment 66 Dmitri Seletski 2009-05-16 00:02:01 UTC
compiling without patch and recompiling mplayer worked out fine.
Comment 67 Ryan Hill (RETIRED) gentoo-dev 2009-05-16 00:36:56 UTC
which is why gcc-4.3.3-r2 doesn't contain that patch.
Comment 68 Mark Loeser (RETIRED) gentoo-dev 2009-05-18 00:16:09 UTC
The offending patch to gcc has been fixed.
Comment 69 Alexander Nickolaev 2009-06-05 13:59:25 UTC
(In reply to comment #68)
> The offending patch to gcc has been fixed.
> 

gcc-4.3.2-r3
Same problem with media-video/ffmpeg-0.5-r1.