Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 261674 - dev-util/anjuta-2.24.2 fails to build with media-gfx/graphviz-2.22.0
Summary: dev-util/anjuta-2.24.2 fails to build with media-gfx/graphviz-2.22.0
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
: 266522 (view as bug list)
Depends on: 298200
Blocks: gnome2.24
  Show dependency tree
 
Reported: 2009-03-08 12:37 UTC by nebojsa
Modified: 2010-06-08 07:52 UTC (History)
7 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
https://mailman.research.att.com/pipermail/graphviz-devel/2009/000936.html adapted for dev-util/anjuta-2.24.2 (anjuta-graphviz.patch,3.42 KB, patch)
2009-03-08 12:38 UTC, nebojsa
Details | Diff
fixed tab problem (anjuta-graphviz.patch,2.35 KB, patch)
2009-03-09 13:05 UTC, nebojsa
Details | Diff
anjuta-2.2.0-r2.ebuild (anjuta-2.2.0-r2.ebuild,2.83 KB, text/plain)
2009-09-15 10:20 UTC, Marcello Magaldi
Details
anjuta-2.2.0-graphviz-2.22.0.patch (anjuta-2.2.0-graphviz-2.22.0.patch,1.41 KB, text/plain)
2009-09-15 10:21 UTC, Marcello Magaldi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description nebojsa 2009-03-08 12:37:26 UTC
After upgrading to media-gfx/graphviz-2.22.0, anjuta fails to build.
Ebuild stops with:
class-inherit.c: In function ‘cls_inherit_draw_graph’:
class-inherit.c:760: warning: implicit declaration of function ‘ND_coord_i’
class-inherit.c:760: warning: nested extern declaration of ‘ND_coord_i’
class-inherit.c:760: error: incompatible types in assignment
make[3]: *** [class-inherit.lo] Error 1
make[3]: *** Waiting for unfinished jobs....
mv -f .deps/plugin.Tpo .deps/plugin.Plo
make[3]: Leaving directory `/var/tmp/portage/dev-util/anjuta-2.24.2/work/anjuta-2.24.2/plugins/class-inheritance'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/dev-util/anjuta-2.24.2/work/anjuta-2.24.2/plugins'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/dev-util/anjuta-2.24.2/work/anjuta-2.24.2'
make: *** [all] Error 2


Reproducible: Always

Steps to Reproduce:
1. emerge =media-gfx/graphviz-2.22.0
2. emerge =dev-util/anjuta-2.24.2





It is a known issue. Patch is available at
https://mailman.research.att.com/pipermail/graphviz-devel/2009/000936.html, but it is based on later anjuta.
Comment 1 nebojsa 2009-03-08 12:38:57 UTC
Created attachment 184326 [details, diff]
https://mailman.research.att.com/pipermail/graphviz-devel/2009/000936.html adapted for dev-util/anjuta-2.24.2
Comment 2 Lars Wendler (Polynomial-C) gentoo-dev 2009-03-08 12:39:53 UTC
Reassigning to maintainer.
Comment 3 nebojsa 2009-03-09 13:05:40 UTC
Created attachment 184451 [details, diff]
fixed tab problem
Comment 4 Jonathan-Christofer Demay 2009-04-04 15:20:52 UTC
patch worked for me.
Comment 5 Juergen Rose 2009-04-13 14:21:11 UTC
The patch did not work for me. 'emerge -vD anjut' fails with:
...

F: unlinkat
S: deny
P: /usr/lib64/anjuta/profiler.plugin
A: /usr/lib64/anjuta/profiler.plugin
R: /usr/lib64/anjuta/profiler.plugin
C: rm -fr /usr/lib64/anjuta/libanjuta-build-basic-autotools.so /usr/lib64/anjuta/libanjuta-class-gen.so /usr/lib64/anjuta/libanjuta-class-inheritance.so /usr/lib64/anjuta/libanjuta-cvs-plugin.so /usr/lib64/anjuta/libanjuta-debug-manager.so /usr/lib64/anjuta/libanjuta-devhelp.so /usr/lib64/anjuta/libanjuta-document-manager.so /usr/lib64/anjuta/libanjuta-editor.so /usr/lib64/anjuta/libanjuta-file-wizard.so /usr/lib64/anjuta/libanjuta-gdb.so /usr/lib64/anjuta/libanjuta-git.so /usr/lib64/anjuta/libanjuta-glade.so /usr/lib64/anjuta/libanjuta-gtodo.so /usr/lib64/anjuta/libanjuta-language-cpp-java.so /usr/lib64/anjuta/libanjuta-loader.so /usr/lib64/anjuta/libanjuta-macro.so /usr/lib64/anjuta/libanjuta-message-view.so /usr/lib64/anjuta/libanjuta-patch.so /usr/lib64/anjuta/libanjuta-profiler.so /usr/lib64/anjuta/libanjuta-project-import.so /usr/lib64/anjuta/libanjuta-project-manager.so /usr/lib64/anjuta/libanjuta-project-wizard.so /usr/lib64/anjuta/libanjuta-run-program.so /usr/lib64/anjuta/libanjuta-sample.so /usr/lib64/anjuta/libanjuta-scratchbox.so /usr/lib64/anjuta/libanjuta-search.so /usr/lib64/anjuta/libanjuta-subversion.so /usr/lib64/anjuta/libanjuta-symbol-browser.so /usr/lib64/anjuta/libanjuta-terminal.so /usr/lib64/anjuta/libanjuta-tools.so /usr/lib64/anjuta/libfile-manager.so /usr/lib64/anjuta/liblanguage-manager.so /usr/lib64/anjuta/*.a /usr/lib64/anjuta/anjuta-build-basic-autotools.plugin /usr/lib64/anjuta/anjuta-class-gen.plugin /usr/lib64/anjuta/anjuta-class-inheritance.plugin /usr/lib64/anjuta/anjuta-cvs.plugin /usr/lib64/anjuta/anjuta-debug-manager.plugin /usr/lib64/anjuta/anjuta-devhelp.plugin /usr/lib64/anjuta/anjuta-document-manager.plugin /usr/lib64/anjuta/anjuta-editor.plugin /usr/lib64/anjuta/anjuta-file-wizard.plugin /usr/lib64/anjuta/anjuta-gdb.plugin /usr/lib64/anjuta/anjuta-glade.plugin /usr/lib64/anjuta/anjuta-gtodo.plugin /usr/lib64/anjuta/anjuta-language-cpp-java.plugin /usr/lib64/anjuta/anjuta-loader.plugin /usr/lib64/anjuta/anjuta-macro.plugin /usr/lib64/anjuta/anjuta-message-manager.plugin /usr/lib64/anjuta/anjuta-patch.plugin /usr/lib64/anjuta/anjuta-project-import.plugin /usr/lib64/anjuta/anjuta-project-manager.plugin /usr/lib64/anjuta/anjuta-project-wizard.plugin /usr/lib64/anjuta/anjuta-run-program.plugin /usr/lib64/anjuta/anjuta-sample.plugin /usr/lib64/anjuta/anjuta-scratchbox.plugin /usr/lib64/anjuta/anjuta-search.plugin /usr/lib64/anjuta/anjuta-subversion.plugin /usr/lib64/anjuta/anjuta-symbol-browser.plugin /usr/lib64/anjuta/anjuta-terminal.plugin /usr/lib64/anjuta/anjuta-tools.plugin /usr/lib64/anjuta/file-manager.plugin /usr/lib64/anjuta/git.plugin /usr/lib64/anjuta/language-manager.plugin /usr/lib64/anjuta/profiler.plugin 
--------------------------------------------------------------------------------

>>> Failed to emerge dev-util/anjuta-2.24.2, Log file:

>>>  '/var/tmp/portage/dev-util/anjuta-2.24.2/temp/build.log'

I am using the following USE flags:
root@lynx:/usr/local/portage/dev-util/anjuta(39)# emerge -pvD anjuta

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] dev-util/anjuta-2.24.2  USE="doc glade subversion -debug -devhelp -inherit-graph -sourceview -valgrind" 0 kB [0=>1]

Total: 1 package (1 reinstall), Size of downloads: 0 kB
Portage tree and overlays:
 [0] /usr/portage
 [1] /usr/local/portage
Comment 6 Sven E. 2009-04-14 01:22:21 UTC
I ran into the exact same problem as Juergen.
Comment 7 Markus Bartel 2009-04-17 14:38:37 UTC
*** Bug 266522 has been marked as a duplicate of this bug. ***
Comment 8 Juergen Rose 2009-05-05 08:51:17 UTC
Any news?
Comment 9 Nirbheek Chauhan (RETIRED) gentoo-dev 2009-05-05 11:35:54 UTC
Fixed by upstream in latest 2.26 in overlay, will be added to tree with the rest of 2.26
Comment 10 Alexandre Hannud Abdo 2009-05-08 04:06:07 UTC
Jurgen, Sven:

I had the same error as you, but...

Right after the error I ran the "ebuild merge" command again and it identified anjuta as "already compiled" and proceeded to install it successfully.

I give no guarantees, but... it works. hehe

Good luck,

ale
~~
Comment 11 Mart Raudsepp gentoo-dev 2009-05-26 10:52:47 UTC
I've fixed it with a backport of http://git.gnome.org/cgit/anjuta/patch/?id=badf2dbc86ea694d64d593b31cb4e5d4ccb5bc2d to not break building with earlier graphviz. Thanks for the patience.
Comment 12 Marcello Magaldi 2009-09-15 09:23:01 UTC
(In reply to comment #11)
> I've fixed it with a backport of
> http://git.gnome.org/cgit/anjuta/patch/?id=badf2dbc86ea694d64d593b31cb4e5d4ccb5bc2d
> to not break building with earlier graphviz. Thanks for the patience.
> 

Since graphviz 2.24 hit the stable on x86 and amd64 and on these platform last stable anjuta is 2.2.0-r1 I had the same problem as reported in #285054 , that at this point should be marked as dup of this.
Comment 13 Marcello Magaldi 2009-09-15 10:18:50 UTC
I backported to anjuta 2.2.0 the patch provided by Mart on comment #11 .
I will attach here anjuta-2.2.0-r2.ebuild and the backported patch.
Comment 14 Marcello Magaldi 2009-09-15 10:20:02 UTC
Created attachment 204171 [details]
anjuta-2.2.0-r2.ebuild

ebuild with gv2.22.0 patch application
Comment 15 Marcello Magaldi 2009-09-15 10:21:30 UTC
Created attachment 204173 [details]
anjuta-2.2.0-graphviz-2.22.0.patch

backported Mart's patch for anjuta 2.2.0
Comment 16 Gordon Malm (RETIRED) gentoo-dev 2009-10-28 07:11:03 UTC
Re-opening.  =media-gfx/graphviz-2.24* has been markeds stable.  Now stable =dev-util/anjuta-2.2.0-r1 fails to build with this same error.  The same patch already in ${FILESDIR} for 2.24.2 epatches cleanly and allows the build to complete.
Comment 17 Gilles Dartiguelongue gentoo-dev 2009-10-28 22:37:43 UTC
the patch is applied in 2.24, just wait for arches to complete bug #268359.
Comment 18 Gordon Malm (RETIRED) gentoo-dev 2009-10-28 23:39:42 UTC
(In reply to comment #17)
> the patch is applied in 2.24, just wait for arches to complete bug #268359.
> 

No, REOPENING.  This is idiotic.

Bug #268359 proposes to stabilize a version which doesn't compile due to bug #248796 which you just closed because a latter version (2.26.something) is fixed.

From bug #248796:
------- Comment  #18 From Gordon Malm 2009-10-28 07:08:43 0000  [reply] -------  
Re-opening as =dev-util/anjuta-2.24.2 is listed for stable in bug #268359. 
However, it still has this problem.  Please fix, remove from the tree or
something.

  ------- Comment  #19 From Gilles Dartiguelongue 2009-10-28 22:36:40 0000  [reply] -------  
See comment #13. We consider a problem fixed in a version in tree has the
fixed, no matter if it's not yet stable.