Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 268359 - dev-libs/gdl-2.24.0, dev-python/gdl-python-2.19.1-r1, dev-libs/gnome-build-2.24.1 and dev-util/anjuta-2.24.2 stabilization request
Summary: dev-libs/gdl-2.24.0, dev-python/gdl-python-2.19.1-r1, dev-libs/gnome-build-2....
Status: RESOLVED DUPLICATE of bug 298200
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords: STABLEREQ
: 268635 268638 275226 (view as bug list)
Depends on: 248796
Blocks: gnome2.24
  Show dependency tree
 
Reported: 2009-05-02 21:43 UTC by Gilles Dartiguelongue
Modified: 2010-03-06 20:22 UTC (History)
15 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gilles Dartiguelongue gentoo-dev 2009-05-02 21:43:11 UTC
Hi arches, dev-libs/gdl-2.24.0 has been in tree since 24 Nov 2008.

Please do your magic, target keywords are:  alpha amd64 ia64 ppc ppc64 sparc x86

Thanks in advance
Comment 1 Markus Meier gentoo-dev 2009-05-03 18:53:05 UTC
>>> Emerging (1 of 1) dev-libs/gnome-build-0.3.0
 * gnome-build-0.3.0.tar.bz2 RMD160 SHA1 SHA256 size ;-) ...                                                                                          [ ok ]
 * checking ebuild checksums ;-) ...                                                                                                                  [ ok ]
 * checking auxfile checksums ;-) ...                                                                                                                 [ ok ]
 * checking miscfile checksums ;-) ...                                                                                                                [ ok ]
 *
 * ERROR: dev-libs/gnome-build-0.3.0 failed.
 * Call stack:
 *                  ebuild.sh, line   48:  Called pkg_setup
 *   gnome-build-0.3.0.ebuild, line   35:  Called built_with_use 'dev-libs/gdl' 'gnome'
 *              eutils.eclass, line 1763:  Called die
 * The specific snippet of code:
 *                                      die)   die "$PKG does not actually support the $1 USE flag!";;
 *  The die message:
 *   dev-libs/gdl-2.24.0 does not actually support the gnome USE flag!

should we stabilize dev-libs/gnome-build-2.24.1, seems to emerge w/o any problems?
Comment 2 Gilles Dartiguelongue gentoo-dev 2009-05-03 19:00:08 UTC
indeed, gnome specific code was removed from gdl-2.24 completely so there is no more useflag for it and gnome-build was adapted to those changes. Please stabilize dev-libs/gnome-build-2.24.1 as well.
Comment 3 Markus Meier gentoo-dev 2009-05-03 19:14:32 UTC
amd64/x86 stable
Comment 4 Gordon Malm (RETIRED) gentoo-dev 2009-05-04 02:27:55 UTC
Please also stabilize =dev-python/gdl-python-2.19.1-r1 when stabilizing =dev-libs/gdl-2.24.0.
Comment 5 Dustin Polke 2009-05-04 08:48:35 UTC
Stabilization brakes stable anjuta-2.2.0-r1. revdep-rebuild fails as follows:

checking for GDL... configure: error: Package requirements (gdl-1.0 >= 0.7.3 gdl-gnome-1.0 >= 0.7.3) were not met:

No package 'gdl-gnome-1.0' found


Portage 2.1.6.11 (default/linux/amd64/2008.0, gcc-4.3.2, glibc-2.8_p20080602-r1, 2.6.26-gentoo_dazuko-patch-r4-stable x86_64)
=================================================================
System uname: Linux-2.6.26-gentoo_dazuko-patch-r4-stable-x86_64-Intel-R-_Core-TM-2_Duo_CPU_T8100_@_2.10GHz-with-glibc2.2.5
Timestamp of tree: Mon, 04 May 2009 07:45:02 +0000
app-shells/bash:     3.2_p39
dev-java/java-config: 2.1.7
dev-lang/python:     2.5.4-r2
dev-python/pycrypto: 2.0.1-r8
dev-util/cmake:      2.6.2-r1
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -O2 -pipe -msse4.1 -ggdb"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/bin/mygenkernel /usr/sbin/run-crons /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=core2 -O2 -pipe -msse4.1 -ggdb"
DISTDIR="/usr/portage/distfiles"
FEATURES="collision-protect distlocks fixpackages multilib-strict parallel-fetch protect-owned sandbox sfperms splitdebug strict test unmerge-orphans userfetch userpriv usersandbox"
GENTOO_MIRRORS="ftp://linux.rz.ruhr-uni-bochum.de/gentoo-mirror/                ftp://gd.tuwien.ac.at/opsys/linux/gentoo/               ftp://gentoo.inode.at/source/           ftp://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/"
LANG="C"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en de"
MAKEOPTS="-j5"
PKGDIR="/home/ftp/binpkg/"
PORTAGE_COMPRESS=""
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_EXTRA_OPTS="--timeout=500"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/modified /usr/portage/local/own /usr/portage/local/layman/alon-barlev /usr/portage/local/layman/science /usr/portage/local/layman/desktop-effects /usr/portage/local/layman/sunrise"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X X509 Xaw3d a52 aac aalib accessibility acl acpi alsa amd64 amr amrnb amrr amrwb apm async audacious audiofile bash-completion battery berkdb bindist bl bluetooth branding bzip2 cairo cardbus cdinstall cjk cli cpufreq cracklib crypt css ctype cups dbus dga directfb divx dri dts dv dvd dvdr dvdread eds encode evo exif exiv2 fam fame fbcon fbcondecor fbsplash ffmpeg flac fontforge foomaticdb force-cgi-redirect fortran ftp gd gdbm gif gimp glade glitz gmedia gmp gnutls gphoto2 gs gsm gstreamer gtk gtkhtml guile hal hddtemp hdf5 iconv icq icu idn ieee1394 imagemagick imap imlib iproute2 isdnlog jack java javascript jikes jpeg jpeg2k kerberos keyscrub kino kpathsea lame laptop latex lcms ldap libcaca libnotify libsamplerate libsexy libv4l2 libwww live lm_sensors logrotate loop-aes lzma lzo mad memlimit midi mikmod mime mjpeg mmx mmxext mng mono motif mp2 mp3 mp4 mpeg mplayer mudflap multilib musepack ncurses nls nntp nowin nptl nptlonly nsplugin ntp nuv nvidia ogg opengl openmp opensslcrypto pam pch pcmcia pcre pda pdf perl plotutils png posix ppds pppd print python quicktime readline realmedia reflection rtsp ruby rubytests samba sasl sdl server session simplexml slang sndfile soap sockets sou speex spell spl sse sse2 sse3 sse4.1 ssl ssse3 startup-notification stream svg swat sysfs syslog tcpd tetex tga theora threads tiff truetype unicode usb userlocales v4l v4l2 vcd vim-syntax vim-with-x vorbis wifi winbind wma wmf wmp wxwindows x264 xanim xcomposite xfce xinetd xml xmp xorg xpm xsl xulrunner xv xvid xvmc zlib" ALSA_CARDS="hda-intel mpu401" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="fuji ptp2" ELIBC="glibc" INPUT_DEVICES="keyboard evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en de" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS_FLAGS
Comment 6 Marcello Magaldi 2009-05-04 10:30:15 UTC
(In reply to comment #5)
> Stabilization brakes stable anjuta-2.2.0-r1. revdep-rebuild fails as follows:
> 
> checking for GDL... configure: error: Package requirements (gdl-1.0 >= 0.7.3
> gdl-gnome-1.0 >= 0.7.3) were not met:
> 

same error here, cannot rebuild anjuta
Comment 7 Gilles Dartiguelongue gentoo-dev 2009-05-04 10:42:06 UTC
damn, and anjuta has a couple of open bugs...
@welp, can you inform us about anjuta's status wrt stabilization ?
Comment 8 Gilles Dartiguelongue gentoo-dev 2009-05-04 19:36:08 UTC
*** Bug 268635 has been marked as a duplicate of this bug. ***
Comment 9 Gilles Dartiguelongue gentoo-dev 2009-05-04 19:38:50 UTC
ok I think this time the list should be complete.
Comment 10 Stefan Nilsson 2009-05-04 21:00:03 UTC
(In reply to comment #9)
> ok I think this time the list should be complete.
> 

Please stabilize dev-python/gdl-python-2.19.1-r1 Now there is a blocker

[blocks B     ] <dev-python/gdl-python-2.19.1-r1 ("<dev-python/gdl-python-2.19.1-r1" is blocking dev-libs/gdl-2.24.0)
Comment 11 Tango 2009-05-05 12:26:38 UTC
(In reply to comment #10)
> (In reply to comment #9)
> > ok I think this time the list should be complete.
> > 
> 
> Please stabilize dev-python/gdl-python-2.19.1-r1 Now there is a blocker
> 
> [blocks B     ] <dev-python/gdl-python-2.19.1-r1
> ("<dev-python/gdl-python-2.19.1-r1" is blocking dev-libs/gdl-2.24.0)
> 
I ran into this blocker yesterday and now am having problems solving emerge problems.

equery d gdl-python
[ Searching for packages depending on gdl-python... ]
dev-python/gnome-python-extras-2.19.1-r3 (=dev-python/gdl-python-2.19.1*)

equery d gnome-python-extras
[ Searching for packages depending on gnome-python-extras... ]
media-sound/exaile-0.2.13 (gnome? >=dev-python/gnome-python-extras-2.14)

Exaile depends on gnome-python-extras which depends on gdl-python which will no longer compile.

gdl.override:9:27: error: gdl/gdl-icons.h: No such file or directory
make[2]: *** [gdl.lo] Error 1
make[2]: Leaving directory `/var/tmp/portage/dev-python/gdl-python-2.19.1/work/gnome-python-extras-2.19.1/gdl'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/dev-python/gdl-python-2.19.1/work/gnome-python-extras-2.19.1'
make: *** [all] Error 2
 * 
 * ERROR: dev-python/gdl-python-2.19.1 failed.
 * Call stack:
 *               ebuild.sh, line   48:  Called src_compile
 *             environment, line 3494:  Called gnome2_src_compile
 *             environment, line 2660:  Called die
 * The specific snippet of code:
 *       emake || die "compile failure"
 *  The die message:
 *   compile failure


Not sure what I should do at this point.


Comment 12 michael@smith-li.com 2009-05-05 13:54:25 UTC
*** Bug 268638 has been marked as a duplicate of this bug. ***
Comment 13 Marat Radchenko 2009-05-05 13:59:28 UTC
Also hit blocker with dev-python/gdl-python-2.19.1 + dev-libs/gdl-2.24.0 on stable arch. Please stabilize dev-python/gdl-python-2.19-r1.
Comment 14 Marc-Antoine Perennou 2009-05-07 06:17:33 UTC
(In reply to comment #13)
> Also hit blocker with dev-python/gdl-python-2.19.1 + dev-libs/gdl-2.24.0 on
> stable arch. Please stabilize dev-python/gdl-python-2.19-r1.
> 

Just put =dev-libs/gdl-2.24.0 into your /etc/portage/package.mask while waiting for the bug to be fixed and you will no longer have the blocker :)
Comment 15 Raphael Das Gupta 2009-05-09 14:06:06 UTC
(In reply to comment #14)
> Just put =dev-libs/gdl-2.24.0 into your /etc/portage/package.mask while waiting
> for the bug to be fixed and you will no longer have the blocker :)

Are you sure that'd be the right workaround? 'Cause it gives me the following:

$> sudo emerge -uDavN world

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! All ebuilds that could satisfy ">=dev-libs/gdl-2.23.0" have been masked.
!!! One of the following masked packages is required to complete your request:
- dev-libs/gdl-2.26.0 (masked by: ~x86 keyword)
- dev-libs/gdl-2.24.0 (masked by: package.mask)

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.
(dependency required by "dev-libs/gnome-build-2.24.1" [installed])
(dependency required by "dev-util/anjuta-2.2.0-r1" [installed])
(dependency required by "world" [argument])
Comment 16 Marc-Antoine Perennou 2009-05-10 21:02:25 UTC
(In reply to comment #15)
If you downgrade all packages that need gdl-2.24.0 to the previous version that needed gdl-0.7.x normally it will work, it won't try to upgrade anymore until you'll unmask it.
Comment 17 Markus Meier gentoo-dev 2009-05-13 18:26:06 UTC
I just reverted stabilization on amd64/x86 until anjuta is fixed.
Comment 18 Dustin Polke 2009-05-14 08:47:26 UTC
(In reply to comment #17)
> I just reverted stabilization on amd64/x86 until anjuta is fixed.
> 
 I added "<dev-libs/gdl-2.24.0" and "<dev-libs/gnome-build-2.24.0" to RDEPEND in the anjuta ebuild to restrict upgrade of gdl. Maybe this can be done quite soon to allow users not using anjuta ti upgrade gdl as they are not affected by this issue.

BR,
Dustin
Comment 19 Łukasz Michalik 2009-05-14 09:10:58 UTC
(In reply to comment #17)
> I just reverted stabilization on amd64/x86 until anjuta is fixed.
> 

Shouldn't same happen for gnome-build as well and not for gdl only?  (It's marked stable and deps on >=dev-libs/gdl-2.23.0.)
Comment 20 Gordon Malm (RETIRED) gentoo-dev 2009-05-14 23:14:16 UTC
(In reply to comment #17)
> I just reverted stabilization on amd64/x86 until anjuta is fixed.
> 

I just re-marked =dev-libs/gdl-python-2.19.1 stable on amd64/x86.  It was stabled awhile ago and is unrelated to this bug.

It is =dev-libs/gdl-python-2.19.1-r1 that must be marked stable along with the other packages in this bug.

I left the remainder of the reversion intact.  Thanks.
Comment 21 Raúl Porcel (RETIRED) gentoo-dev 2009-05-28 14:33:10 UTC
Ping?
Comment 22 Raúl Porcel (RETIRED) gentoo-dev 2009-06-13 10:11:22 UTC
All slackers!
Comment 23 Tobias Klausmann gentoo-dev 2009-06-17 18:39:23 UTC
Neither gnome-build nor anjuta are keyworded for alpha, so I skipped those.

Stabilized the other two.
Comment 24 Gilles Dartiguelongue gentoo-dev 2009-06-24 08:26:16 UTC
*** Bug 275226 has been marked as a duplicate of this bug. ***
Comment 25 Brent Baude (RETIRED) gentoo-dev 2009-07-04 18:35:33 UTC
ppc64 done
Comment 26 Brent Baude (RETIRED) gentoo-dev 2009-07-04 18:53:44 UTC
I got 3/4 for PPC64 64UL.  But anjuta is failing like so:

F: unlinkat
S: deny
P: /usr/lib64/anjuta/profiler.plugin
A: /usr/lib64/anjuta/profiler.plugin
R: /usr/lib64/anjuta/profiler.plugin
C: rm -fr /usr/lib64/anjuta/libanjuta-build-basic-autotools.so /usr/lib64/anjuta/libanjuta-class-gen.so /usr/lib64/anjuta/libanjuta-class-inheritance.so /usr/lib64/anjuta/libanjuta-cvs-plugin.so /usr/lib64/anjuta/libanjuta-debug-manager.so /usr/lib64/anjuta/libanjuta-devhelp.so /usr/lib64/anjuta/libanjuta-document-manager.so /usr/lib64/anjuta/libanjuta-editor.so /usr/lib64/anjuta/libanjuta-file-wizard.so /usr/lib64/anjuta/libanjuta-gdb.so /usr/lib64/anjuta/libanjuta-git.so /usr/lib64/anjuta/libanjuta-gtodo.so /usr/lib64/anjuta/libanjuta-language-cpp-java.so /usr/lib64/anjuta/libanjuta-loader.so /usr/lib64/anjuta/libanjuta-macro.so /usr/lib64/anjuta/libanjuta-message-view.so /usr/lib64/anjuta/libanjuta-patch.so /usr/lib64/anjuta/libanjuta-profiler.so /usr/lib64/anjuta/libanjuta-project-import.so /usr/lib64/anjuta/libanjuta-project-manager.so /usr/lib64/anjuta/libanjuta-project-wizard.so /usr/lib64/anjuta/libanjuta-run-program.so /usr/lib64/anjuta/libanjuta-sample.so /usr/lib64/anjuta/libanjuta-scratchbox.so /usr/lib64/anjuta/libanjuta-search.so /usr/lib64/anjuta/libanjuta-symbol-browser.so /usr/lib64/anjuta/libanjuta-terminal.so /usr/lib64/anjuta/libanjuta-tools.so /usr/lib64/anjuta/libfile-manager.so /usr/lib64/anjuta/liblanguage-manager.so /usr/lib64/anjuta/*.a /usr/lib64/anjuta/anjuta-build-basic-autotools.plugin /usr/lib64/anjuta/anjuta-class-gen.plugin /usr/lib64/anjuta/anjuta-class-inheritance.plugin /usr/lib64/anjuta/anjuta-cvs.plugin /usr/lib64/anjuta/anjuta-debug-manager.plugin /usr/lib64/anjuta/anjuta-devhelp.plugin /usr/lib64/anjuta/anjuta-document-manager.plugin /usr/lib64/anjuta/anjuta-editor.plugin /usr/lib64/anjuta/anjuta-file-wizard.plugin /usr/lib64/anjuta/anjuta-gdb.plugin /usr/lib64/anjuta/anjuta-gtodo.plugin /usr/lib64/anjuta/anjuta-language-cpp-java.plugin /usr/lib64/anjuta/anjuta-loader.plugin /usr/lib64/anjuta/anjuta-macro.plugin /usr/lib64/anjuta/anjuta-message-manager.plugin /usr/lib64/anjuta/anjuta-patch.plugin /usr/lib64/anjuta/anjuta-project-import.plugin /usr/lib64/anjuta/anjuta-project-manager.plugin /usr/lib64/anjuta/anjuta-project-wizard.plugin /usr/lib64/anjuta/anjuta-run-program.plugin /usr/lib64/anjuta/anjuta-sample.plugin /usr/lib64/anjuta/anjuta-scratchbox.plugin /usr/lib64/anjuta/anjuta-search.plugin /usr/lib64/anjuta/anjuta-symbol-browser.plugin /usr/lib64/anjuta/anjuta-terminal.plugin /usr/lib64/anjuta/anjuta-tools.plugin /usr/lib64/anjuta/file-manager.plugin /usr/lib64/anjuta/git.plugin /usr/lib64/anjuta/language-manager.plugin /usr/lib64/anjuta/profiler.plugin 
--------------------------------------------------------------------------------

>>> Failed to emerge dev-util/anjuta-2.24.2, Log file:

>>>  '/var/tmp/portage/dev-util/anjuta-2.24.2/temp/build.log'



thoughts?
Comment 27 Thorsten Vollmer 2009-07-09 19:11:24 UTC
(In reply to comment #26)
> I got 3/4 for PPC64 64UL.  But anjuta is failing like so:
> 
> F: unlinkat
> S: deny
> P: /usr/lib64/anjuta/profiler.plugin
> A: /usr/lib64/anjuta/profiler.plugin
> R: /usr/lib64/anjuta/profiler.plugin
> C: rm -fr /usr/lib64/anjuta/libanjuta-build-basic-autotools.so ...
> 
> thoughts?

This is bug 248796, which is still present in dev-util/anjuta-2.24.2.
Comment 28 Jeroen Roovers gentoo-dev 2009-08-19 16:53:33 UTC
Stable for HPPA.
Comment 29 nixnut (RETIRED) gentoo-dev 2009-09-27 13:54:50 UTC
ppc stable
Comment 30 Gordon Malm (RETIRED) gentoo-dev 2009-10-29 07:45:29 UTC
=dev-util/anjuta-2.24.2 has open bug #248796 (known compile failure).
Comment 31 Pacho Ramos gentoo-dev 2010-01-06 14:58:40 UTC
anjuta-2.24 won't probably go stable ever, but work is taking place for trying to get a newer one (probably 2.28) stable 
Comment 32 Christian Faulhammer (RETIRED) gentoo-dev 2010-01-14 15:11:54 UTC
(In reply to comment #31)
> anjuta-2.24 won't probably go stable ever, but work is taking place for trying
> to get a newer one (probably 2.28) stable 

 Can we post-pone the whole stabilisation here and do it with Gnome 2.28?
Comment 33 Pacho Ramos gentoo-dev 2010-01-14 19:27:57 UTC
Seems that it can be stabilized before full gnome-2.28, see bug 298200 (from comment #11) for progress and more info :-)
Comment 34 Christian Faulhammer (RETIRED) gentoo-dev 2010-01-15 20:53:10 UTC
(In reply to comment #33)
> Seems that it can be stabilized before full gnome-2.28, see bug 298200 (from
> comment #11) for progress and more info :-)

 Open a new bug then with all needed deps inside.
Comment 35 Pacho Ramos gentoo-dev 2010-03-06 20:22:49 UTC
We go to 298200 finally

*** This bug has been marked as a duplicate of bug 298200 ***