Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 261446 - update-mime-database reports various unknown media types
Summary: update-mime-database reports various unknown media types
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: All Linux
: High minor (vote)
Assignee: Gentoo KDE team
URL: https://bugs.freedesktop.org/show_bug...
Whiteboard: [kde testing]
Keywords: InOverlay, InVCS
: 289612 310425 (view as bug list)
Depends on:
Blocks: 313999
  Show dependency tree
 
Reported: 2009-03-06 12:48 UTC by Rahul Jain
Modified: 2014-12-27 21:26 UTC (History)
22 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rahul Jain 2009-03-06 12:48:40 UTC
update-mime-database /usr/share/mime
Unknown media type in type 'all/all'

Unknown media type in type 'all/allfiles'

Unknown media type in type 'uri/mms'

Unknown media type in type 'uri/mmst'

Unknown media type in type 'uri/mmsu'

Unknown media type in type 'uri/pnm'

Unknown media type in type 'uri/rtspt'

Unknown media type in type 'uri/rtspu'

Unknown media type in type 'fonts/package'

Unknown media type in type 'interface/x-winamp-skin'

Error remains the same since kdelibs-4.1

I am using several gnome (rather gtk) applications along with KDE apps, it might be the case that the problem arises due to this. However, I do have -gnome in my use flags. 

Other Information:
googly share # grep -r "interface/x-winamp-skin" /usr/share/mime
/usr/share/mime/packages/kde.xml:  <mime-type type="interface/x-winamp-skin">
/usr/share/mime/types:interface/x-winamp-skin
/usr/share/mime/subclasses:interface/x-winamp-skin application/zip
/usr/share/mime/interface/x-winamp-skin.xml:<mime-type xmlns="http://www.freedesktop.org/standards/shared-mime-info" type="interface/x-winamp-skin">
/usr/share/mime/globs:interface/x-winamp-skin:*.wsz
Binary file /usr/share/mime/mime.cache matches
/usr/share/mime/globs2:50:interface/x-winamp-skin:*.wsz

googly share # grep -r "uri/mms" /usr/share/mime
/usr/share/mime/packages/kde.xml:  <mime-type type="uri/mms">
/usr/share/mime/packages/kde.xml:  <mime-type type="uri/mmst">
/usr/share/mime/packages/kde.xml:  <mime-type type="uri/mmsu">
/usr/share/mime/uri/mmst.xml:<mime-type xmlns="http://www.freedesktop.org/standards/shared-mime-info" type="uri/mmst">
/usr/share/mime/uri/mmsu.xml:<mime-type xmlns="http://www.freedesktop.org/standards/shared-mime-info" type="uri/mmsu">
/usr/share/mime/uri/mms.xml:<mime-type xmlns="http://www.freedesktop.org/standards/shared-mime-info" type="uri/mms">
/usr/share/mime/types:uri/mms
/usr/share/mime/types:uri/mmst
/usr/share/mime/types:uri/mmsu

googly share # grep -r "all/all" /usr/share/mime
/usr/share/mime/packages/kde.xml:  <mime-type type="all/all">
/usr/share/mime/packages/kde.xml:  <mime-type type="all/allfiles">
/usr/share/mime/all/all.xml:<mime-type xmlns="http://www.freedesktop.org/standards/shared-mime-info" type="all/all">
/usr/share/mime/all/allfiles.xml:<mime-type xmlns="http://www.freedesktop.org/standards/shared-mime-info" type="all/allfiles">
/usr/share/mime/types:all/all
/usr/share/mime/types:all/allfiles 

Reproducible: Always
Comment 1 Michael Perlov 2009-03-18 08:54:14 UTC
It's not KDE-related bug, the same output on any emerge
Comment 2 Sasha Medvedev 2009-04-08 23:07:36 UTC
I Have the same issue. After removing appropriate records from /usr/share/mime/packages/kde.xml messages disappear. 
Comment 3 Edgardo Rossetto 2009-04-24 18:55:51 UTC
Same issue here

Portage 2.1.6.11 (default/linux/amd64/2008.0, gcc-4.3.3, glibc-2.9_p20081201-r2, 2.6.29-gentoo-r1 x86_64)
=================================================================
System uname: Linux-2.6.29-gentoo-r1-x86_64-Intel-R-_Core-TM-2_Duo_CPU_T7500_@_2.20GHz-with-gentoo-2.0.0
Timestamp of tree: Fri, 24 Apr 2009 15:30:01 +0000
app-shells/bash:     4.0_p17-r1
dev-java/java-config: 2.1.7
dev-lang/python:     2.6.2
dev-python/pycrypto: 2.0.1-r8
dev-util/cmake:      2.6.3-r1
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.4.3-r2
sys-apps/sandbox:    1.9
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.19.1-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.28-r1
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=core2 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages metadata-transfer parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://gentoo.localhost.net.ar/ "
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="en en_US"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/x11 /usr/local/portage/layman/THE /usr/local/portage/layman/vmware /usr/local/portage/layman/gnome /usr/local/portage/erossetto"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 bash-completion berkdb bluetooth bzip2 cairo cdda cddb cdr cleartype cli cracklib crypt cups curl dbus directfb dri dvd dvdr encode exif fbcon ffmpeg flac fontconfig fortran gdbm gif gnome gnome-keyring gnutls gpm gstreamer gtk hal iconv isdnlog jpeg jpeg2k kde lcms libnotify lm_sensors midi mmx mng mono mp3 mudflap multilib mysql ncurses nls nptl nptlonly nvidia ogg opengl openmp pam pcre perl png pppd python qt quicktime raw readline reflection ruby sdl session spl sqlite sse sse2 ssl ssse3 svg sysfs tcl tcpd tiff tk truetype unicode usb vdpau vim-syntax vorbis webkit x264 xcb xml xmp xorg xpm xscreensaver xv xvid xvmc zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_US" USERLAND="GNU" VIDEO_CARDS="nvidia nv vesa"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

Comment 4 Peter Levine 2009-07-25 10:33:30 UTC
Already filed upstream, https://bugs.freedesktop.org/show_bug.cgi?id=16816

A patch should be filed soon.
Comment 5 Xia, Mengxuan 2009-08-08 19:31:07 UTC
It does the same thing, running Gnome, it's not KDE-related. 
Comment 6 El Goretto 2009-10-05 14:02:26 UTC
Guys, have you been using VLC one day or another? Seems to me this message appeared after unmerging it.
Comment 7 Pacho Ramos gentoo-dev 2009-10-10 23:09:06 UTC
(In reply to comment #6)
> Guys, have you been using VLC one day or another? Seems to me this message
> appeared after unmerging it.
> 

Not, in my case they appeared yesterday after updating (amd64), but I didn't have vlc installed :-|
Comment 8 Samuli Suominen gentoo-dev 2009-10-18 18:05:51 UTC
*** Bug 289612 has been marked as a duplicate of this bug. ***
Comment 9 Kaleb Elwert (belak) 2009-10-18 18:23:39 UTC
(In reply to comment #4)
> Already filed upstream, https://bugs.freedesktop.org/show_bug.cgi?id=16816
> 
> A patch should be filed soon.
> 

So, there's a patch, yes?
Does this mean portage should use the -q option?
Comment 10 Markus Giese 2009-10-28 11:24:00 UTC
I Have the same issue. After removing appropriate records from
/usr/share/mime/packages/kde.xml messages disappear. 

that hint helped me , THX !
Comment 11 Kaleb Elwert (belak) 2009-10-28 19:25:40 UTC
(In reply to comment #10)
> I Have the same issue. After removing appropriate records from
> /usr/share/mime/packages/kde.xml messages disappear. 
> 
> that hint helped me , THX !
> 

Yeah, this worked like a charm... I just commented them out with html comments and it stopped giving me errors.
Thanks for the hint.
Comment 12 Samuli Suominen gentoo-dev 2010-03-20 20:29:09 UTC
*** Bug 310425 has been marked as a duplicate of this bug. ***
Comment 13 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2010-04-09 02:13:22 UTC
Unless there are any objections, I'm thinking of patching the kde.xml file. I'm CC'ed on the upstream bug so I'll be notified if there is any change. Waiting for feedback
Comment 14 Samuli Suominen gentoo-dev 2010-04-09 08:32:43 UTC
(In reply to comment #13)
> Unless there are any objections, I'm thinking of patching the kde.xml file. I'm
> CC'ed on the upstream bug so I'll be notified if there is any change. Waiting
> for feedback
> 

that's the correct thing to do, only reason it wasn't done in past is nobody exactly knowing will it break kde in some unknown way, or not
Comment 15 Andreas K. Hüttel gentoo-dev 2010-05-28 22:06:32 UTC
I patched that in the overlay (4.4.3 and newer). Please help testing, we need to find out if it breaks anything. 
Comment 16 Maciej Mrozowski gentoo-dev 2010-05-28 22:58:47 UTC
Moved to tree, let's test there. Please resolve/fix when you feel it's the way to go.
Comment 17 Rahul Jain 2010-05-28 23:49:18 UTC
(In reply to comment #16)
> Moved to tree, let's test there. Please resolve/fix when you feel it's the way
> to go.
> 

A revbump would have not have been bad ... :)
Comment 18 Andreas K. Hüttel gentoo-dev 2010-06-06 16:26:01 UTC
Everybody running ~arch should get this now. 

No big screams yet, so I'll close the bug.