Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 261367 - Utf8 issues with KDE 4.2 and Qt 4.5
Summary: Utf8 issues with KDE 4.2 and Qt 4.5
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo KDE team
URL: https://bugs.kde.org/show_bug.cgi?id=...
Whiteboard:
Keywords:
: 262254 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-03-05 21:47 UTC by Marian Kyral
Modified: 2009-03-23 12:57 UTC (History)
7 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Opening file from dolphin (dolphin_kwrite.png,76.18 KB, image/png)
2009-03-06 07:00 UTC, Marian Kyral
Details
krusader_kwite.png (krusader_kwite.png,51.20 KB, image/png)
2009-03-06 19:55 UTC, Marian Kyral
Details
Patched ebuild gwenview-4.2.1-r1 from kde-testing (gwenview-4.2.1-r1.ebuild.patch,470 bytes, patch)
2009-03-10 21:34 UTC, Marian Kyral
Details | Diff
gwenview-qt45_utf8.patch (gwenview-qt45_utf8.patch,432 bytes, patch)
2009-03-10 21:35 UTC, Marian Kyral
Details | Diff
full out for failedd kdelibs-4.2.1-r2 (kdelibs-4.2.1-kcatalog.patch-29825.out,3.19 KB, text/plain)
2009-03-11 15:48 UTC, BerS
Details
system settings (screen.jpeg,68.61 KB, image/jpeg)
2009-03-12 07:34 UTC, BerS
Details
kdelibs-4.2.1-qt4.5_kdialog.patch (kdelibs-4.2.1-qt4.5_kdialog.patch,350 bytes, patch)
2009-03-12 19:32 UTC, Marian Kyral
Details | Diff
Updated ebuild (kdelibs-4.2.1-r2.ebuild,6.71 KB, text/plain)
2009-03-16 12:42 UTC, Marian Kyral
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marian Kyral 2009-03-05 21:47:57 UTC
http://forums.gentoo.org/viewtopic.php?p=5535236#5535236

After upgrade Qt libraries to 4.5.0 I'm not able to open any file containing Czech characters from dolphin or krusader.

Okular error: Unable to open file:///home/marian/dokumenty/T0002798_dvÄ.pdf
(File name is: T0002798_dvě.pdf)

Reproducible: Always

Steps to Reproduce:
1. Create file containing non english characters.
2. With Qt libraries 4.5.0_rc1 installed, oppening of the file from dolphin/krusader works. 
3. Upgrade Qt libraries to version 4.5.0
4. Try to open the file from dolphin/krusader

Actual Results:  
Okular shows and error: Unable to open file:///home/marian/dokumenty/T0002798_dvÄ.pdf

Kate, kwrite opens a new blank file with name: "test_dvÄ.txt"

Expected Results:  
Files with non English characters are opened correctly.
Comment 1 Tomáš Chvátal (RETIRED) gentoo-dev 2009-03-05 21:54:47 UTC
cant reproduce.
i created příšerněžluťoučkýkůňúpělďábelskéódy.txt
and it is readable, editable deletable whatsoever, did you recompiled kdelibs and mostly all kde libs after update.
Comment 2 Marian Kyral 2009-03-05 22:14:49 UTC
(In reply to comment #1)
> cant reproduce.
> i created příšerněžluťoučkýkůňúpělďábelskéódy.txt
> and it is readable, editable deletable whatsoever, did you recompiled kdelibs
> and mostly all kde libs after update.
> 

Did you tried to open the file from dolphin? (open with kwrite/kate?)

I'm just compiling KDE 4.2.1 on my last (and most slower) box. Will see morning.
Comment 3 Azamat H. Hackimov 2009-03-05 22:42:36 UTC
confirm that for Russian UTF-8. Also when I try call any KDE-program with key --help I get ????? instead actual help info.
Comment 4 Marian Kyral 2009-03-06 06:58:47 UTC
(In reply to comment #2)
> (In reply to comment #1)
> > cant reproduce.
> > i created příšerněžluťoučkýkůňúpělďábelskéódy.txt
> > and it is readable, editable deletable whatsoever, did you recompiled kdelibs
> > and mostly all kde libs after update.
> > 
> 
> Did you tried to open the file from dolphin? (open with kwrite/kate?)
> 
> I'm just compiling KDE 4.2.1 on my last (and most slower) box. Will see
> morning.
> 

So KDE updated to 4.2.1 and no change. See attachment.
Comment 5 Marian Kyral 2009-03-06 07:00:48 UTC
Created attachment 184093 [details]
Opening file from dolphin

After double click on "unison_dv?.txt".
Comment 6 Marian Kyral 2009-03-06 07:05:26 UTC
sorry, I forget :-(

nest marian # emerge --info      
 * Overlay eclasses override eclasses from PORTDIR:
 *                                                 
 *   '/usr/local/portage/layman/kde-testing/eclass/cmake-utils.eclass'
 *   '/usr/local/portage/layman/kde-testing/eclass/kde4-base.eclass'
 *   '/usr/local/portage/layman/kde-testing/eclass/kde4-functions.eclass'
 *   '/usr/local/portage/layman/kde-testing/eclass/kde4-meta.eclass'
 *
 * It is best to avoid overriding eclasses from PORTDIR because it will
 * trigger invalidation of cached ebuild metadata that is distributed with
 * the portage tree. If you must override eclasses from PORTDIR then you
 * are advised to add FEATURES="metadata-transfer" to /etc/make.conf and to
 * run `emerge --regen` after each time that you run `emerge --sync`. Set
 * PORTAGE_ECLASS_WARNING_ENABLE="0" in /etc/make.conf if you would like to
 * disable this warning.
Portage 2.2_rc23 (!/usr/portage/profiles/default/linux/x86/2008.0/desktop/, gcc-4.3.3, glibc-2.9_p20081201-r2, 2.6.28-gentoo-r2 i686)
=================================================================
System uname: Linux-2.6.28-gentoo-r2-i686-AMD_Athlon-tm-_2600+-with-glibc2.0
Timestamp of tree: Thu, 05 Mar 2009 15:45:01 +0000
app-shells/bash:     3.2_p48-r1
dev-java/java-config: 1.3.7-r1, 2.1.7
dev-lang/python:     2.4.4-r15, 2.5.4-r2
dev-python/pycrypto: 2.0.1-r6
dev-util/cmake:      2.6.3
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.4.3-r1
sys-apps/sandbox:    1.3.9
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.4_p6, 1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.19.1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.28-r1
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=athlon-xp -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -march=athlon-xp -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--keep-going"
FEATURES="distlocks fixpackages parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://ftp.snt.utwente.nl/pub/os/linux/gentoo http://mirror.switch.ch/ftp/mirror/gentoo/ http://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/"
LANG="cs_CZ.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="en cs"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/var/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/kde-testing /usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="3dnow X a52 aac acl acpi aim alsa ao audiofile berkdb bzip2 cairo cddb cdparanoia cdr cli cracklib crypt css cups curl dbus dri dts dv dvd dvdr dvdread emboss encode enscript evo exif expat fam ffmpeg fftw firefox flac fontconfig foomaticdb fortran ftp gdbm gif gimp git gnutls gpm graphviz gstreamer hal hddtemp iconv icq ieee1394 imagemagick imlib ipv6 isdnlog jabber jack jpeg jpeg2k kde kdehiddenvisibility kerberos lame lcms libnotify lzma mad matroska midi mikmod mime mmx mng mp3 mpeg mplayer msn mudflap mysql ncurses nls nptl nptlonly nsplugin ogg openal openexr opengl openmp oscar pam pcre pdf perl png posix ppds pppd python qt3 qt3support qt4 quicktime raw readline reflection sdl session slang sox spell spl sqlite sqlite3 sse ssl startup-notification subversion svg sysfs taglib tcpd threads tiff truetype unicode usb vcd vim-syntax vorbis win32codecs wmf wxwindows x86 xcomposite xine xml xorg xosd xpm xscreensaver xulrunner xv xvid zlib" ALSA_CARDS="via82xx" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en cs" USERLAND="GNU" VIDEO_CARDS="nvidia vesa nv"
Unset:  CPPFLAGS, CTARGET, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

Comment 7 BerS 2009-03-06 07:41:19 UTC
The problem is when opening file from Dolphin or Krusader or Kmail in Kwrite, Kate, Okular, Gwenview.
I have problem with Russian names of files (UTF-8)

emerge --info
Portage 2.2_rc23 (default/linux/amd64/2008.0, gcc-4.3.3, glibc-2.9_p20081201-r2, 2.6.28.7-utf8 x86_64)                                                                                                    
=================================================================                                    
System uname: Linux-2.6.28.7-utf8-x86_64-Intel-R-_Core-TM-2_Duo_CPU_E4500_@_2.20GHz-with-glibc2.2.5  
Timestamp of tree: Fri, 06 Mar 2009 07:05:01 +0000                                                   
ccache version 2.4 [enabled]                                                                         
app-shells/bash:     3.2_p48-r1                                                                      
dev-java/java-config: 2.1.7                                                                          
dev-lang/python:     2.5.4-r2                                                                        
dev-util/ccache:     2.4-r8                                                                          
dev-util/cmake:      2.6.3                                                                           
sys-apps/baselayout: 2.0.0                                                                           
sys-apps/openrc:     0.4.3-r1                                                                        
sys-apps/sandbox:    1.3.9                                                                           
sys-devel/autoconf:  2.13, 2.63                                                                      
sys-devel/automake:  1.4_p6, 1.5, 1.7.9-r1, 1.9.6-r2, 1.10.2                                         
sys-devel/binutils:  2.19.1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.28-r1
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=nocona -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/kde/4.2/env /usr/kde/4.2/share/config /usr/kde/4.2/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -march=nocona -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distlocks fixpackages parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="ru_RU.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="ru"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file--delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/mozilla"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X accessibility acl alsa amd64 audacious bash-completion bzip2 cairo cdr cli cracklib crypt cups dbus dlloader dri dts dvd esd gdbm gif glitz gpm gtk hal htmlhandbook iconv isdnlog javascript jpegjpeg2k kde kdeprefix lm_sensors mad midi mmx mmxext mng mp3 mudflap multilib ncurses nls nptl nptlonly opengl openmp oss pam pcre pdf perl png pppd python qt3 qt3support qt4 rdesktop readline reflection rtc samba session spl sqlite sse sse2 ssl ssse3 svg sysfs tcpd tiff truetype unicode vim-syntax vorbis wmp xcomposite xorg xv xvid zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboardmouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="ru" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 8 Marian Kyral 2009-03-06 19:28:35 UTC
I've created a bug on kde.org.
https://bugs.kde.org/show_bug.cgi?id=186386
Comment 9 Marian Kyral 2009-03-06 19:55:05 UTC
Created attachment 184168 [details]
krusader_kwite.png

Double click on file "p?íšern?žlu?ou?kýk??úp?l?ábelskéódy.txt" in krusader.
Comment 11 Marian Kyral 2009-03-06 21:57:06 UTC
So patch was applied, it fixed kwrite and okular problem, but I still have issue with gwenview. Maybe gwenview problem.
Comment 12 Dror Levin (RETIRED) gentoo-dev 2009-03-09 13:06:41 UTC
I'm having this problem with Hebrew.
The bug is marked as fixed bug in KDE bugzilla so I assume it will be in 4.2.2, but other distributions are applying the patch to kdelibs-4.2.1. Can that be done in Gentoo as well please?
Comment 13 BerS 2009-03-09 16:14:17 UTC
Fixed by recompile Qt with USE "-iconv" :)
Comment 14 Marian Kyral 2009-03-09 17:28:14 UTC
(In reply to comment #13)
> Fixed by recompile Qt with USE "-iconv" :)
> 

Gwenview as well?
Comment 15 BerS 2009-03-10 07:24:10 UTC
> 
> Gwenview as well?
> 
Yes. ;)
Comment 16 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2009-03-10 13:38:18 UTC
I've just added kdelibs-4.2.1-r1 to the tree.
Let it replicate to mirrors and please test it. Please confirm if this solves the issues as promised in upstream bug.
Comment 17 Nikos Chantziaras 2009-03-10 16:13:14 UTC
The patch fixed the problem here for text files, but Gwenview is still bugged.
Comment 18 Marian Kyral 2009-03-10 16:17:53 UTC
(In reply to comment #17)
> The patch fixed the problem here for text files, but Gwenview is still bugged.
> 

I think this is problem in Gwenview.
Comment 19 Marian Kyral 2009-03-10 21:33:40 UTC
This patch fixed gwenview.

https://bugs.kde.org/show_bug.cgi?id=186038#c23
Comment 20 Marian Kyral 2009-03-10 21:34:51 UTC
Created attachment 184622 [details, diff]
Patched ebuild gwenview-4.2.1-r1 from kde-testing
Comment 21 Marian Kyral 2009-03-10 21:35:24 UTC
Created attachment 184623 [details, diff]
gwenview-qt45_utf8.patch
Comment 22 Dror Levin (RETIRED) gentoo-dev 2009-03-10 22:25:56 UTC
I can confirm that kdelibs-4.2.1-r1 fixes the issues with okular/kate and krusader/dolphin. I have not checked gwenview.
Comment 23 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2009-03-11 02:42:56 UTC
(In reply to comment #21)
> Created an attachment (id=184623) [edit]
> gwenview-qt45_utf8.patch

David Faure provided a new patch in the bug as the issue seems to be about kdelibs and not gwenview. Anyone having this issue please try the patch in https://bugs.kde.org/show_bug.cgi?id=186038#c27
Comment 24 BerS 2009-03-11 08:38:14 UTC
Ok, for me with Russian charset utf8:
1. Recompile Qt with USE="-iconv" (kdelibs-4.2.1 without patch) and no problems.
2. Upgrade to kdelibs-4.2.1-r1 (Qt with USE="-iconv") - no problems.
3. Recompile Qt with USE="+iconv" (kdelibs-4.2.1-r1) - Gwenview fail. :(
I returned to Qt with USE="-iconv".
Comment 25 Marian Kyral 2009-03-11 13:55:33 UTC
(In reply to comment #23)
> (In reply to comment #21)
> > Created an attachment (id=184623) [edit]
> > gwenview-qt45_utf8.patch
> 
> David Faure provided a new patch in the bug as the issue seems to be about
> kdelibs and not gwenview. Anyone having this issue please try the patch in
> https://bugs.kde.org/show_bug.cgi?id=186038#c27
> 

Tested successfully. Kwrite, okular, gwenview works now.
Comment 26 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2009-03-11 14:50:04 UTC
(In reply to comment #25)
> (In reply to comment #23)
> > (In reply to comment #21)
> > > Created an attachment (id=184623) [edit]
> > > gwenview-qt45_utf8.patch
> > 
> > David Faure provided a new patch in the bug as the issue seems to be about
> > kdelibs and not gwenview. Anyone having this issue please try the patch in
> > https://bugs.kde.org/show_bug.cgi?id=186038#c27
> > 
> 
> Tested successfully. Kwrite, okular, gwenview works now.

Good to hear. Fix applied in the tree. Please reopen the bug if something is still not working appropriately.
Comment 27 BerS 2009-03-11 15:45:01 UTC
* Failed Patch: kdelibs-4.2.1-kcatalog.patch !
 *  ( /usr/portage/kde-base/kdelibs/files/kdelibs-4.2.1-kcatalog.patch )
Comment 28 BerS 2009-03-11 15:48:08 UTC
Created attachment 184710 [details]
full out for failedd kdelibs-4.2.1-r2
Comment 29 Marian Kyral 2009-03-11 15:54:34 UTC
(In reply to comment #28)
> Created an attachment (id=184710) [edit]
> full out for failedd kdelibs-4.2.1-r2
> 

There is missing patch before kcatalog.cpp. 

Index: kcatalog.cpp
===================================================================
--- kdecore/localization/kcatalog.cpp   (revision 938013)
+++ kdecore/localization/kcatalog.cpp   (working copy)
Comment 30 Marian Kyral 2009-03-11 15:55:12 UTC
(In reply to comment #29)
> (In reply to comment #28)
> > Created an attachment (id=184710) [edit]
> > full out for failedd kdelibs-4.2.1-r2
> > 
> 
> There is missing patch before kcatalog.cpp. 
> 
> Index: kcatalog.cpp
> ===================================================================
> --- kdecore/localization/kcatalog.cpp   (revision 938013)
> +++ kdecore/localization/kcatalog.cpp   (working copy)
> 

There is missing PATH before kcatalog.cpp. ;-)
Comment 31 BerS 2009-03-12 07:34:13 UTC
Created attachment 184777 [details]
system settings
Comment 32 BerS 2009-03-12 07:35:41 UTC
All ok. Only one problem with System Settings. See attachment.
Comment 33 Marian Kyral 2009-03-12 08:55:30 UTC
(In reply to comment #32)
> All ok. Only one problem with System Settings. See attachment.
> 

Can confirm. This status is only after start of systemsettings. If you go to some module or click on advanced tab, it is replaced by correct string.
Comment 34 BerS 2009-03-12 09:16:00 UTC
I know, but it's must be corrected ;)
Comment 35 Marian Kyral 2009-03-12 10:22:26 UTC
(In reply to comment #34)
> I know, but it's must be corrected ;)
> 

I know that you know. It was for developers ;-)
Comment 36 Tomáš Chvátal (RETIRED) gentoo-dev 2009-03-12 11:16:04 UTC
Comment on attachment 184777 [details]
system settings

crap i cant type :D
Comment 37 Tomáš Chvátal (RETIRED) gentoo-dev 2009-03-12 11:17:03 UTC
Reopening again. This utf issue is starting to be fun :]
Comment 38 Tomáš Chvátal (RETIRED) gentoo-dev 2009-03-12 11:56:27 UTC
*** Bug 262254 has been marked as a duplicate of this bug. ***
Comment 39 Marian Kyral 2009-03-12 12:01:01 UTC
Maybe this bug should be renamed to "KDE 4.2 and Qt 4.5 utf8 issues"

There is another utf8 issue with kdialog:
https://bugs.kde.org/show_bug.cgi?id=186038#c38
Comment 40 Tomáš Chvátal (RETIRED) gentoo-dev 2009-03-12 12:05:16 UTC
(In reply to comment #39)
> Maybe this bug should be renamed to "KDE 4.2 and Qt 4.5 utf8 issues"
> 
> There is another utf8 issue with kdialog:
> https://bugs.kde.org/show_bug.cgi?id=186038#c38
> 

You are owner of the bug so change it yourself.
And i find this utf issues bit annoying. :P
Comment 41 Dror Levin (RETIRED) gentoo-dev 2009-03-12 12:53:26 UTC
What is the problem with kdelibs-4.2.1-r2? It seems to have fixed the problems I was having...
Comment 42 Marian Kyral 2009-03-12 19:32:45 UTC
Created attachment 184825 [details, diff]
kdelibs-4.2.1-qt4.5_kdialog.patch

A fix for the kdialog and looks like for the systemsetting issue as well. At least I'm not able reproduce it now.

https://bugs.kde.org/show_bug.cgi?id=186038#c40
Comment 43 Ben de Groot (RETIRED) gentoo-dev 2009-03-13 18:20:15 UTC
(In reply to comment #40)
> And i find this utf issues bit annoying. :P

So go beat up upstream. UTF-8 issues should really be something of the past. How can they release stuff that breaks it? 

Comment 44 Marian Kyral 2009-03-13 18:40:43 UTC
(In reply to comment #43)
> (In reply to comment #40)
> > And i find this utf issues bit annoying. :P
> 
> So go beat up upstream. UTF-8 issues should really be something of the past.
> How can they release stuff that breaks it? 
> 

Because it worked correctly with Qt libraries less than 4.5 final. The final release of Qt 4.5 libraries contains change (bugfix) that corrected utf8 handling and breaks KDE. It was fixed in the 4.3 branch. The 4.2 branch was developed on Qt 4.4 and not fully tested with Qt 4.5 that was released later than KDE 4.2.
  
Comment 45 Marian Kyral 2009-03-16 12:40:01 UTC
(In reply to comment #42)
> Created an attachment (id=184825) [edit]
> kdelibs-4.2.1-qt4.5_kdialog.patch
> 
> A fix for the kdialog and looks like for the systemsetting issue as well. At
> least I'm not able reproduce it now.
> 
> https://bugs.kde.org/show_bug.cgi?id=186038#c40
> 

So what we will do? The patch above fixed all issues with utf8 I have and I didn't find any new utf8 issue. Could be this patch included in the kdelibs ebuild? Or we have to wait for KDE 4.2.2?
Comment 46 Marian Kyral 2009-03-16 12:42:22 UTC
Created attachment 185181 [details]
Updated ebuild
Comment 47 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2009-03-16 12:43:00 UTC
(In reply to comment #46)
> Created an attachment (id=185181) [edit]
> Updated ebuild

I'll take care of this bug later today.
Comment 48 Marian Kyral 2009-03-16 15:35:00 UTC
(In reply to comment #47)
> 
> I'll take care of this bug later today.
> 

Thanks
Comment 49 BerS 2009-03-23 08:35:16 UTC
Ok, for me, update to kdelibs-4.2.1-r3 fixed systemsetting's problem. Thanks for all.
Comment 50 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2009-03-23 12:57:13 UTC
(In reply to comment #49)
> Ok, for me, update to kdelibs-4.2.1-r3 fixed systemsetting's problem. Thanks
> for all.

I was too tired yesterday to add a note here. All of the fixes in that bug have been applied in kdelibs-4.2.1-r3.
I'm closing this bug as it should be fixed now. If you still have any problem relating to this, please reopen it.