Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 257178 - sys-apps/v86d-0.1.9(uvesafb) seg fault/kernel not syncing block in kernel 2.6.27-2.6.28
Summary: sys-apps/v86d-0.1.9(uvesafb) seg fault/kernel not syncing block in kernel 2.6...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: High major with 1 vote (vote)
Assignee: Michal Januszewski (RETIRED)
Depends on:
Reported: 2009-02-01 02:52 UTC by Liviu Balan
Modified: 2012-10-06 15:41 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---

Dmesg when modprobe of uvesafb display blank screen (dmesg.modprobe,48.94 KB, text/plain)
2009-02-01 21:49 UTC, Liviu Balan
Vesafb driver working (dmesg.vesafbworking,35.40 KB, text/plain)
2009-02-01 22:46 UTC, Liviu Balan
Xorg log file with vesa driver working (Xorg.0.log,81.26 KB, text/plain)
2009-02-22 16:58 UTC, Liviu Balan
Kernel config (.config,51.36 KB, text/plain)
2009-04-17 21:28 UTC, Liviu Balan

Note You need to log in before you can comment on or make changes to this bug.
Description Liviu Balan 2009-02-01 02:52:46 UTC
Copiling the kernel with uvesafb generates a Kernel not syncing error with stack trace at start.

When compiling as a module and trying to modprobe it the error looks like this:

mail ~ # modprobe uvesafb mode_option=1024x768-32@60
mail ~ # dmesg | grep vesa
Command line: /root=dev/sda4 video=uvesafb:1024x768-32@60,ywrap mtrr=3 quiet splash=silent,fadein,theme:livecd-2007.0 CONSOLE=/dev/tty1                                                                       
Kernel command line: /root=dev/sda4 video=uvesafb:1024x768-32@60,ywrap mtrr=3 quiet splash=silent,fadein,theme:livecd-2007.0 CONSOLE=/dev/tty1                                                                
uvesafb: <1>BUG: unable to handle kernel paging request at ffff88011fd7f36d
Modules linked in: uvesafb(+) cfbcopyarea cfbimgblt cfbfillrect coretemp hwmon snd_seq snd_seq_device snd_mixer_oss fuse ata_generic ahci sky2 snd_hda_intel snd_pcm snd_timer i2c_i801 i2c_core pata_marvell snd snd_page_alloc fglrx(P)                                                                            
 [<ffffffffa03337e3>] ? uvesafb_exec+0x255/0x262 [uvesafb]
 [<ffffffffa033456c>] ? uvesafb_probe+0xf5/0xd95 [uvesafb]
 [<ffffffffa033520c>] ? uvesafb_init+0x0/0xb1 [uvesafb]
 [<ffffffffa033520c>] ? uvesafb_init+0x0/0xb1 [uvesafb]
 [<ffffffffa0335266>] ? uvesafb_init+0x5a/0xb1 [uvesafb]

Searching for bugs and solutions I have found bug and tried to compile uvesafb as a module but still same result.

Emerged v86d with the debug option and testvbe gives this error:

VBE Version:     3.00
Segmentation fault

Tried to compile from source with the patch with different parameters but still testvbe gives the same error.

I use dev-libs/klibc-1.5.12-r1.

Emerge info:
Portage 2.2_rc23 (default/linux/amd64/2008.0, gcc-4.1.2, glibc-2.6.1-r0, 2.6.28-gentoo-r1 x86_64)
System uname: Linux-2.6.28-gentoo-r1-x86_64-Intel-R-_Core-TM-2_Quad_CPU_Q6600_@_2.40GHz-with-glibc2.2.5
Timestamp of tree: Sat, 31 Jan 2009 23:00:01 +0000                                                     
app-shells/bash:     3.2_p48                                                                           
dev-java/java-config: 1.3.7-r1, 2.1.7                                                                  
dev-lang/python:     2.4.4-r13, 2.5.4-r2                                                               
dev-python/pycrypto: 2.0.1-r6
dev-util/cmake:      2.6.2-r1
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.3.0-r1
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.28-r1
CFLAGS="-march=nocona -O2 -mfpmath=sse -pipe"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=nocona -O2 -mfpmath=sse -pipe"
FEATURES="distlocks fixpackages parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-orphans userfetch"
LINGUAS="en ro ko"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/usr/portage/local/layman/kde-testing /usr/local/portage"
USE="X aac acl acpi alsa amd64 apache2 arts asf berkdb bitmap-fonts browserplugin bzip2 cairo cdda cddb cdio cdr cegui cli cracklib crypt cups curl dbus dridvd dvdread encode ffmpeg firefox fortran ftp fuse gdbm gif gpm gstreamer hal iconv imagemagick imap imlib immqt-bc ipv6 isdnlog java jpeg kde logitech-mouse mhash midi mikmod mmx mp3 mpeg mudflap multilib mysql ncurses nls nptl nptlonly nsplugin ogg opengl openmp pam pcre perl php png ppds pppd python qt qt3 qt4 quicktime readline reflection samba sasl sdl session shaper slang softquota speex spell spl sqlite sse sse3 ssl svg symlink sysfs tcpd tiff truetype truetype-fonts type1-fonts unicode usb vcd vda vorbis xcomposite xine xml xml2 xorg xpm xulrunner xv xvid yahoo zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en ro ko" USERLAND="GNU" VIDEO_CARDS="fglrx radeon"

Reproducible: Always
Comment 1 Michal Januszewski (RETIRED) gentoo-dev 2009-02-01 09:13:03 UTC
This looks similar to  Could you please have a look at the upstream bug and confirm?  Also, is this a new problem in 2.6.27/28, or have you never tried to use uvesafb on this system with an older kernel?
Comment 2 Liviu Balan 2009-02-01 20:27:43 UTC
Yes. seems very similar to that one. I will put some more info along the way of trying some of the steps described there for debugging.

Yes, running testvbe results with the following under dmesg:

EBDA at 9dc00-9ffff                                                                              
VBIOS at c0000-cdbff
task flags: 0x01
EAX=0x00004f00 EBX=0x00000000 ECX=0x00000000 EDX=0x00000000
ESP=0x00000000 EBP=0x00000000 ESI=0x00000000 EDI=0x00000000
The mode list is in the buffer at 00012122.
testvbe[15256] general protection ip:410ac4 sp:7fff4df84b58 error:0 in testvbe[400000+14000]

And with gdb:

gdb testvbe
GNU gdb 6.8
Copyright (C) 2008 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-pc-linux-gnu"...
(gdb) bt
No stack.
(gdb) run
Starting program: /sbin/testvbe
VBE Version:     3.00

Program received signal SIGSEGV, Segmentation fault.
0x0000000000410ac4 in vsnprintf ()
(gdb) bt
#0  0x0000000000410ac4 in vsnprintf ()
#1  0x0000000000000002 in ?? ()
#2  0x00007fffd6ab39e0 in ?? ()
#3  0x0000000000000000 in ?? ()

This is similar to . 

Way before around kernel 2.6.24-25 I was using the old vesafb, which broke around 2.6.26(not 100% about version numbers but should be about right) maybe because of the initrd image that was created with an very old kernel. Anyway I did not bother to fix this until i switched to 2.6.27 and to v86d 0.1.3 or w/e the latest version was at that time. I had the same problem since then and I never was able to get uvesafb working.

To note is that i'm using an ATI card too like in that bug you linked me.

I will post more along the way of debuging conform to that post.

Thank you.
Comment 3 Liviu Balan 2009-02-01 20:32:41 UTC
More info run hwinfo under x (with fglrx module in):

hwinfo --framebuffer
02: None 00.0: 11001 VESA Framebuffer                           
  [Created at bios.450]                                         
  Unique ID: rdCR.QstqgPARaQB                                   
  Hardware Class: framebuffer                                   
  Model: ""                                                     
  Vendor: ""                                                    
  Device: ""                                                    
  SubVendor: "ATI ATOMBIOS"                                     
  Revision: ""                                                  
  Memory Size: 16 MB                                            
  Memory Range: 0xd0000000-0xd0ffffff (rw)                      
  Mode 0x0300: 640x400 (+640), 8 bits                           
  Mode 0x0301: 640x480 (+640), 8 bits                           
  Mode 0x0303: 800x600 (+800), 8 bits                           
  Mode 0x0305: 1024x768 (+1024), 8 bits                         
  Mode 0x0307: 1280x1024 (+1280), 8 bits                        
  Mode 0x0310: 640x480 (+1280), 15 bits                         
  Mode 0x0311: 640x480 (+1280), 16 bits                         
  Mode 0x0312: 640x480 (+2560), 24 bits                         
  Mode 0x0313: 800x600 (+1600), 15 bits                         
  Mode 0x0314: 800x600 (+1600), 16 bits                         
  Mode 0x0315: 800x600 (+3200), 24 bits                         
  Mode 0x0316: 1024x768 (+2048), 15 bits                        
  Mode 0x0317: 1024x768 (+2048), 16 bits                        
  Mode 0x0318: 1024x768 (+4096), 24 bits                        
  Mode 0x0319: 1280x1024 (+2560), 15 bits                       
  Mode 0x031a: 1280x1024 (+2560), 16 bits                       
  Mode 0x031b: 1280x1024 (+5120), 24 bits                       
  Mode 0x030d: 320x200 (+640), 15 bits                          
  Mode 0x030e: 320x200 (+640), 16 bits                          
  Mode 0x030f: 320x200 (+1280), 24 bits                         
  Mode 0x0320: 320x200 (+1280), 24 bits                         
  Mode 0x0393: 320x240 (+320), 8 bits                           
  Mode 0x0394: 320x240 (+640), 15 bits                          
  Mode 0x0395: 320x240 (+640), 16 bits                          
  Mode 0x0396: 320x240 (+1280), 24 bits                         
  Mode 0x03b3: 512x384 (+512), 8 bits                           
  Mode 0x03b4: 512x384 (+1024), 15 bits                         
  Mode 0x03b5: 512x384 (+1024), 16 bits                         
  Mode 0x03b6: 512x384 (+2048), 24 bits                         
  Mode 0x03c3: 640x350 (+640), 8 bits                           
  Mode 0x03c4: 640x350 (+1280), 15 bits                         
  Mode 0x03c5: 640x350 (+1280), 16 bits                         
  Mode 0x03c6: 640x350 (+2560), 24 bits                         
  Mode 0x0383: 640x400 (+640), 8 bits                           
  Mode 0x0384: 640x400 (+1280), 15 bits                         
  Mode 0x0385: 640x400 (+1280), 16 bits                         
  Mode 0x0386: 640x400 (+2560), 24 bits                         
  Mode 0x0333: 720x400 (+720), 8 bits                           
  Mode 0x0334: 720x400 (+1440), 15 bits                         
  Mode 0x0335: 720x400 (+1440), 16 bits                         
  Mode 0x0336: 720x400 (+2880), 24 bits                         
  Mode 0x0353: 1152x864 (+1152), 8 bits                         
  Mode 0x0354: 1152x864 (+2304), 15 bits                        
  Mode 0x0355: 1152x864 (+2304), 16 bits                        
  Mode 0x0356: 1152x864 (+4608), 24 bits                        
  Mode 0x0363: 1280x1024 (+1280), 8 bits                        
  Mode 0x0364: 1280x1024 (+2560), 15 bits
  Mode 0x0365: 1280x1024 (+2560), 16 bits
  Mode 0x0366: 1280x1024 (+5120), 24 bits
  Mode 0x0321: 640x480 (+2560), 24 bits
  Mode 0x0322: 800x600 (+3200), 24 bits
  Mode 0x0323: 1024x768 (+4096), 24 bits
  Mode 0x0324: 1280x1024 (+5120), 24 bits
  Mode 0x0343: 1400x1050 (+1400), 8 bits
  Mode 0x0344: 1400x1050 (+2800), 15 bits
  Mode 0x0345: 1400x1050 (+2800), 16 bits
  Mode 0x0346: 1400x1050 (+5600), 24 bits
  Mode 0x0373: 1600x1200 (+1600), 8 bits
  Mode 0x0374: 1600x1200 (+3200), 15 bits
  Mode 0x0375: 1600x1200 (+3200), 16 bits
  Mode 0x0376: 1600x1200 (+6400), 24 bits
  Mode 0x0383: 640x400 (+640), 8 bits
  Mode 0x0384: 640x400 (+1280), 15 bits
  Mode 0x0385: 640x400 (+1280), 16 bits
  Mode 0x0386: 640x400 (+2560), 24 bits
  Mode 0x03d3: 1856x1392 (+1856), 8 bits
  Mode 0x03d4: 1856x1392 (+3712), 15 bits
  Mode 0x03d5: 1856x1392 (+3712), 16 bits
  Mode 0x03d6: 1856x1392 (+7424), 24 bits
  Mode 0x03e3: 1920x1440 (+1920), 8 bits
  Mode 0x03e4: 1920x1440 (+3840), 15 bits
  Mode 0x03e5: 1920x1440 (+3840), 16 bits
  Mode 0x03e6: 1920x1440 (+7680), 24 bits
  Config Status: cfg=new, avail=yes, need=no, active=unknown

Comment 4 Liviu Balan 2009-02-01 20:54:54 UTC
Yes. Patches at and helped me get testvbe working and displaying:

VBE Version:     3.00                                                                                  
OEM String:      ATI ATOMBIOS                                                                          
OEM Vendor Name: 5cd53985                                                                              
OEM Prod. Name:  5cd538c4                                                                              
OEM Prod. Rev:   5cd589d2                                                                              

ID     attr   mode
0100   00bf   640x400-8    
0101   00bf   640x480-8    
0103   00bf   800x600-8    
0105   00bf   1024x768-8   
0107   00bf   1280x1024-8  
0109   000f   132x25-4     
010a   000f   132x43-4     
0130   000f   132x44-4     
0110   00bf   640x480-16   
0111   00bf   640x480-16   
0112   00bf   640x480-32   
0113   00bf   800x600-16   
0114   00bf   800x600-16   
0115   00bf   800x600-32   
0116   00bf   1024x768-16  
0117   00bf   1024x768-16  
0118   00bf   1024x768-32  
0119   00bf   1280x1024-16 
011a   00bf   1280x1024-16 
011b   00bf   1280x1024-32 
010d   00bf   320x200-16   
010e   00bf   320x200-16   
010f   00bf   320x200-32   
0120   00bf   320x200-32   
0193   00bf   320x240-8    
0194   00bf   320x240-16   
0195   00bf   320x240-16   
0196   00bf   320x240-32   
01b3   00bf   512x384-8    
01b4   00bf   512x384-16   
01b5   00bf   512x384-16   
01b6   00bf   512x384-32   
01c3   00bf   640x350-8    
01c4   00bf   640x350-16   
01c5   00bf   640x350-16   
01c6   00bf   640x350-32   
0183   00bf   640x400-8    
0184   00bf   640x400-16   
0185   00bf   640x400-16   
0186   00bf   640x400-32   
0133   00bf   720x400-8    
0134   00bf   720x400-16   
0135   00bf   720x400-16   
0136   00bf   720x400-32   
0153   00bf   1152x864-8   
0154   00bf   1152x864-16  
0155   00bf   1152x864-16  
0156   00bf   1152x864-32  
0163   00bf   1280x1024-8
0164   00bf   1280x1024-16
0165   00bf   1280x1024-16
0166   00bf   1280x1024-32
0121   00bf   640x480-32
0122   00bf   800x600-32
0123   00bf   1024x768-32
0124   00bf   1280x1024-32
0143   00bf   1400x1050-8
0144   00bf   1400x1050-16
0145   00bf   1400x1050-16
0146   00bf   1400x1050-32
0173   00bf   1600x1200-8
0174   00bf   1600x1200-16
0175   00bf   1600x1200-16
0176   00bf   1600x1200-32
0183   00bf   640x400-8
0184   00bf   640x400-16
0185   00bf   640x400-16
0186   00bf   640x400-32
01d3   00bf   1856x1392-8
01d4   00bf   1856x1392-16
01d5   00bf   1856x1392-16
01d6   00bf   1856x1392-32
01e3   00bf   1920x1440-8
01e4   00bf   1920x1440-16
01e5   00bf   1920x1440-16
01e6   00bf   1920x1440-32

One step ahead. Will follow further that bug report.
Comment 5 Liviu Balan 2009-02-01 21:49:03 UTC
Created attachment 180612 [details]
Dmesg when modprobe of uvesafb display blank screen
Comment 6 Liviu Balan 2009-02-01 21:51:39 UTC
Seems after applying the divide by zero patch under I am able to modprobe uvesafb successfuly. However the screen goes blank and I can not even get to the kde login(start x). I was able to ssh into the machine to get this dmesg log though. Is it an initrd problem or fbcondecor or I am still stuck at the uvesafb problem. 

See attached dmesg.modprobe ( for more info.

Thank you.
Comment 7 Michal Januszewski (RETIRED) gentoo-dev 2009-02-01 22:08:56 UTC
(In reply to comment #6)

> I am able to modprobe
> uvesafb successfuly. However the screen goes blank and I can not even get to
> the kde login(start x). I was able to ssh into the machine to get this dmesg
> log though. Is it an initrd problem or fbcondecor or I am still stuck at the
> uvesafb problem. 

It looks like a problem with uvesafb or the Video BIOS.  Could you please
see whether you can get vesafb to work on that system?  You should be able
to use the mode IDs listed by testvbe as vga= parameter values (just add 
0x200 to them, e.g. 0123 becomes 0x323, etc).
Comment 8 Liviu Balan 2009-02-01 22:46:46 UTC
Created attachment 180616 [details]
Vesafb driver working
Comment 9 Liviu Balan 2009-02-01 22:47:35 UTC
Hmm.. vesafb works like a charm. Attached is the entire dmesg output. It is compiled in kernel and splash/fbcondecor work as expected.
Comment 10 Jeroen Roovers (RETIRED) gentoo-dev 2009-02-02 17:37:38 UTC
Don't CC maintainers when you cannot assign bugs.
Comment 11 Michal Januszewski (RETIRED) gentoo-dev 2009-02-15 22:39:21 UTC
(In reply to comment #9)
> Hmm.. vesafb works like a charm. Attached is the entire dmesg output. It is
> compiled in kernel and splash/fbcondecor work as expected.

OK.  Could you please try to emerge the xf86-video-vesa X driver and then change your /etc/X11/xorg.conf file so that the 'vesa' driver is used (that's: Driver "vesa" in Section "Device").  Afterwards, start the X server.  Does it work?  Regardless of it working or not, please attach your /var/log/Xorg.0.log after starting the X server with the 'vesa' driver.

Comment 12 Liviu Balan 2009-02-22 16:58:46 UTC
Created attachment 182791 [details]
Xorg log file with vesa driver working
Comment 13 Liviu Balan 2009-02-22 16:59:16 UTC
Just added the xorg log file when using the vesa driver. Seems to work fine without any issues.
Comment 14 Michal Januszewski (RETIRED) gentoo-dev 2009-03-26 07:58:32 UTC
Could you please also attach your full kernel config?
Comment 15 Liviu Balan 2009-04-17 21:28:57 UTC
Created attachment 188730 [details]
Kernel config

Added the full kernel config file as requested.
Comment 16 Pacho Ramos gentoo-dev 2012-06-16 09:45:59 UTC
Still valid with more recent kernels?
Comment 17 Liviu Balan 2012-06-28 11:52:30 UTC
While cleaning the back-log is good, a response after 2-3 years would most probably find a different environment. Following no response initially and no other help, I just decided to switch to nvidia based video cards. 

I really apologize, but at this moment it would be close to impossible to go back and re-test this issue since hardware conditions have changed.

Thank you again for following up. Feel free to close this bug.
Comment 18 Pacho Ramos gentoo-dev 2012-10-06 15:41:09 UTC
Closing as my father was using uvesafb without problems some months ago