Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 257093 - games-fps/quake1-data: needs to install files in all lowercase
Summary: games-fps/quake1-data: needs to install files in all lowercase
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Games (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Games
URL: http://tldp.org/HOWTO/html_single/Qua...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-01-31 13:49 UTC by vitor
Modified: 2009-01-31 23:35 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description vitor 2009-01-31 13:49:45 UTC
Quake 1 linux can't load data files if they are uppercase.

Reproducible: Always

Steps to Reproduce:
1. # echo 'games-fps/ezquake cdinstall' >> /etc/portage/package.use
2. # emerge ezquake-bin
3. $ ezquake-gl.glx
Error: W_LoadWadFile: couldn't load gfx.wad
Actual Results:  
The game won't load until you rename the files.


Just rename every file in game's dir to lowercase.
for name in `find /usr/share/games/quake1/id1/*`; do
    mv $name `echo $name | tr '[A-Z]' '[a-z]'`
done
Comment 1 Piotr Szymaniak 2009-01-31 14:15:29 UTC
Can you check the quake1-data ebuild from bug #166704?