Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 166704 - games-fps/quake1-data use of demo data for pak0.pak, plus vispatch
Summary: games-fps/quake1-data use of demo data for pak0.pak, plus vispatch
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Games (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Gentoo Games
URL: http://linux.omnipotent.net/article.p...
Whiteboard:
Keywords: EBUILD
Depends on: 213556
Blocks:
  Show dependency tree
 
Reported: 2007-02-13 19:13 UTC by Paul Bredbury
Modified: 2012-09-15 04:05 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
quake1-data-2.40.ebuild (quake1-data-2.40.ebuild,2.01 KB, text/plain)
2007-02-13 19:14 UTC, Paul Bredbury
Details
quake1-data-2.40.ebuild (quake1-data-2.40.ebuild,1.85 KB, text/plain)
2007-07-28 10:08 UTC, Paul Bredbury
Details
quake1-data-2.40.ebuild (quake1-data-2.40.ebuild,2.04 KB, text/plain)
2007-08-06 16:59 UTC, Paul Bredbury
Details
games-fps/quake1-data-2.40-r1.ebuild (quake1-data-2.40-r1.ebuild,2.58 KB, text/plain)
2008-03-16 09:53 UTC, Piotr Szymaniak
Details
games-fps/quake1-data-2.40-r1.ebuild (quake1-data-2.40-r1.ebuild,2.28 KB, text/plain)
2008-03-16 17:24 UTC, Piotr Szymaniak
Details
quake1-data-2.40-r1.ebuild (quake1-data-2.40-r1.ebuild,2.29 KB, text/plain)
2009-08-11 23:27 UTC, James Le Cuirot
Details
quake1-data-2.40-r1.ebuild (quake1-data-2.40-r1.ebuild,2.31 KB, text/plain)
2009-08-12 10:09 UTC, James Le Cuirot
Details
quake1-data-2.40-r2.ebuild (quake1-data-2.40-r2.ebuild,2.00 KB, text/plain)
2009-11-11 19:56 UTC, Piotr Szymaniak
Details
ebuild w/ vispatch fixes (quake1-data-2.40-r2.ebuild,2.03 KB, text/plain)
2010-07-15 19:47 UTC, Jared B.
Details
games-fps/quake1-data-2.40-r3.ebuild (quake1-data-2.40-r3.ebuild,2.11 KB, text/plain)
2012-09-15 04:05 UTC, Jared B.
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Paul Bredbury 2007-02-13 19:13:14 UTC
Hi, here is an ebuild which performs the task mentioned in the comment at the top of quake1-data-2.40.ebuild:

# TODO: if installing off of the 1.01 cd, need to fetch the
#       quake shareware and use that pak0

It's untested, but looks good to me :)
Comment 1 Paul Bredbury 2007-02-13 19:14:22 UTC
Created attachment 110091 [details]
quake1-data-2.40.ebuild
Comment 2 Paul Bredbury 2007-07-28 10:08:56 UTC
Created attachment 126208 [details]
quake1-data-2.40.ebuild

Includes lha fix from bug #159100.
Comment 3 Luke Ashdown 2007-08-06 04:11:34 UTC
Doesn't work here. I think the problem is with unpacking quake106.zip, when I checked it out the contents were also in the form of a resource.1 file; this would also have to be run through lha to extract the files, then the pak0.pak can be copied over.
Comment 4 Paul Bredbury 2007-08-06 05:10:35 UTC
Show the error message. Look at the ebuild:

cp "${CDROM_ROOT}"/resource.1 resource.x || die "cp"
lha xqf resource.x || die "lha resource.x"
Comment 5 Luke Ashdown 2007-08-06 05:39:52 UTC
id1/pak1.pak    - Melted
>>> Unpacking quake106.zip to /var/tmp/portage/games-fps/quake1-data-2.40/work
cp: cannot stat `pak0.pak': No such file or directory

!!! ERROR: games-fps/quake1-data-2.40 failed.
Call stack:
  ebuild.sh, line 1632:   Called dyn_unpack
  ebuild.sh, line 763:   Called qa_call 'src_unpack'
  ebuild.sh, line 44:   Called src_unpack
  quake1-data-2.40.ebuild, line 48:   Called die

!!! cp demo pak0.pak failed


Thanks
Comment 6 Paul Bredbury 2007-08-06 16:59:49 UTC
Created attachment 127086 [details]
quake1-data-2.40.ebuild

Should be fixed now.
Comment 7 Luke Ashdown 2007-08-08 04:55:04 UTC
Thanks Paul, the updated ebuild worked just fine. If there are any other changes or additions you'd like me to test for you please let me know :)
Comment 8 Piotr Szymaniak 2008-03-16 09:53:08 UTC
Created attachment 146275 [details]
games-fps/quake1-data-2.40-r1.ebuild

New ebuild including optional support for transparent water patches.

Depends on bug #213556
Comment 9 Piotr Szymaniak 2008-03-16 17:24:44 UTC
Created attachment 146322 [details]
games-fps/quake1-data-2.40-r1.ebuild

Updated, now without fetch restriction.
Comment 10 James Le Cuirot gentoo-dev 2009-08-11 23:27:11 UTC
Created attachment 200971 [details]
quake1-data-2.40-r1.ebuild

The vispatch stuff wasn't working for me. The paths should be quoted but vispatch didn't seem to like being given a full path anyway. Maybe it's a bug in the program. We don't need to give the full path though so here's a simplified version that works.
Comment 11 James Le Cuirot gentoo-dev 2009-08-11 23:34:44 UTC
Sorry, scratch that, it's still not right because it only patches pak0.pak, not pak1.pak, which contains episodes 2-4. This means pak1.pak should probably be copied to ${S}/id1 first instead of being copied directly into the install tree. It's late, I'll fix it tomorrow.
Comment 12 James Le Cuirot gentoo-dev 2009-08-12 10:09:56 UTC
Created attachment 201010 [details]
quake1-data-2.40-r1.ebuild

Sorted. :)
Comment 13 Mr. Bones. (RETIRED) gentoo-dev 2009-11-10 22:36:38 UTC
care to update to EAPI=2 for ditching the built_with_use check?
Comment 14 James Le Cuirot gentoo-dev 2009-11-10 23:12:44 UTC
Well I'm trying but I can't seem to make the blocker work, even without any USE flags added. I've written countless ebuilds before so I'm really perplexed. What am I doing wrong?

RDEPEND="!games-fps/quake1-demodata"
Comment 15 Piotr Szymaniak 2009-11-11 19:56:45 UTC
Created attachment 209936 [details]
quake1-data-2.40-r2.ebuild

This should work I think. (:
Comment 16 Piotr Szymaniak 2009-11-11 19:58:33 UTC
@James
Please check out the changes I've made for vispatch. Thanks.
Comment 17 James Le Cuirot gentoo-dev 2009-11-11 21:13:12 UTC
Cool, that's a bit simpler thought you might want to add a "die" to the mv. The blocker still isn't working for me but maybe I'm not understanding how they work. Shouldn't "USE=symlink emerge quake1-demodata" fail after emerging this?
Comment 18 Piotr Szymaniak 2009-11-11 21:24:29 UTC
(In reply to comment #17)
> Shouldn't "USE=symlink emerge quake1-demodata" fail after emerging this?

No, the other way around. "USE=symlink emerge quake1-demodata" and then "emerge quake1-data" will be blocked by the symlink use flag in -demodata.

But it should fail (anyway) if you have quake1-data installed and you try to emerge -demodata with symlink flag.
Comment 19 Jared B. 2010-07-15 19:47:54 UTC
Created attachment 238925 [details]
ebuild w/ vispatch fixes

Fixed two problems with the vispatch code:

1. Main problem: vispatch wouldn't apply; always died with "vispatch failed"

2. Cosmetic problem: complained about missing ID1.VIS

The following changes, included in the attached ebuild, fixes this:

[ -f "ID1.VIS" ] && mv ID1.VIS id1.vis
vispatch -dir id1 -data id1.vis || die "vispatch failed"
Comment 20 Jared B. 2010-07-15 19:49:57 UTC
Is there anything preventing this from being added to portage at this point?  The version already included is broken, failing on the lha command, which led me to this ebuild (thanks for the update, btw).  Would be helpful for users to include a working version in portage.
Comment 21 Joshua Barney 2010-10-08 02:28:50 UTC
Still no workie:

* CPV:  games-fps/quake1-data-2.40-r2
 * REPO: local
 * USE:  amd64 elibc_glibc kernel_linux multilib userland_GNU vispatch
>>> Unpacking source...
 * This ebuild will need the cdrom for quake1-data

 * If you do not have the CD, but have the data files
 * mounted somewhere on your filesystem, just export
 * the variable CD_ROOT so that it points to the
 * directory containing the files.

 * For example:
 * export CD_ROOT=/mnt/cdrom

 * Found CD #1 root at /mnt/cdrom
>>> Unpacking quake106.zip to /var/tmp/portage/games-fps/quake1-data-2.40-r2/work
>>> Unpacking id1_vis.tgz to /var/tmp/portage/games-fps/quake1-data-2.40-r2/work

gzip: stdin: not in gzip format
tar: Child returned status 1
tar: Error is not recoverable: exiting now

Seems like maybe id1_vis.tgz is a corrupt file?
Comment 22 James Le Cuirot gentoo-dev 2010-10-08 20:00:15 UTC
Try downloading it again. The file looks fine to me.
Comment 23 Jared B. 2012-09-15 04:05:29 UTC
Created attachment 323836 [details]
games-fps/quake1-data-2.40-r3.ebuild

Couple updates:

1. cdrom eclass now explicitly included, as required

2. USE flags for doe (bug 144372) and soa (bug 144371) have been added to automatically pull in data for expansion packs