Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 253727 - app-office/openoffice-bin-3.0.0 bundles Python 2.3.4
Summary: app-office/openoffice-bin-3.0.0 bundles Python 2.3.4
Status: RESOLVED DUPLICATE of bug 361695
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High enhancement (vote)
Assignee: Gentoo Office Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 328799
  Show dependency tree
 
Reported: 2009-01-04 15:13 UTC by René Rhéaume (a.k.a. repzilon, rener)
Modified: 2011-07-26 21:16 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info (emerge-info.txt,3.46 KB, text/plain)
2009-01-04 15:16 UTC, René Rhéaume (a.k.a. repzilon, rener)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description René Rhéaume (a.k.a. repzilon, rener) 2009-01-04 15:13:38 UTC
The openoffice-bin package seems to bundle a whole python 2.3.4 in /usr/lib/openoffice/basis3.0/program/python-core-2.3.4/ (for OOo 3.0, it was somewhere else for 2.x), after a quick compare with my system python.

Two of those binaries have text relocations, /usr/lib/openoffice/basis3.0/program/python-core-2.3.4/lib/lib-dynload/{_curses,_curses_panel}.so . It does not bode well for hardened Gentoo.

Reproducible: Always

Steps to Reproduce:
1. emerge openoffice-bin
2. As root (to search everywhere), scanelf -aq -lpR | grep TEXTREL
3. Watch the command results

Actual Results:  
 0444 LE  TEXTREL    /usr/lib/openoffice/basis3.0/program/python-core-2.3.4/lib/lib-dynload/_curses.so
 0444 LE  TEXTREL    /usr/lib/openoffice/basis3.0/program/python-core-2.3.4/lib/lib-dynload/_curses_panel.so

Expected Results:  
No output from scanelf because OpenOffice uses a properly built system Python.

I wonder if it is possible to add an hardened USE flag which would pull only the required source code to bridge the Python and OpenOffice.org without downloading and compiling the whole OpenOffice, which is the point of providing a binary ebuild.
Comment 1 René Rhéaume (a.k.a. repzilon, rener) 2009-01-04 15:16:19 UTC
Created attachment 177351 [details]
emerge --info
Comment 2 Tomáš Chvátal (RETIRED) gentoo-dev 2010-07-31 08:41:08 UTC
I tried last 2 releases with simple symlink

/usr/lib64/python2.6 -> /usr/lib/openoffice/basis3.2/program/python-core-${VERSION_THEY_BUNDLED}/lib

And i observed no failitures when using ooo...

(just saying)
Comment 3 Tomáš Chvátal (RETIRED) gentoo-dev 2011-07-26 21:16:44 UTC
Messing with the binary package is quite pain and it will need complete overhaul, duping this bug against the bit more recent complain about its bundles.

*** This bug has been marked as a duplicate of bug 361695 ***