Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 328799 - app-office/openoffice-bin-3.2.1 should depend on dev-libs/openssl:0.9.8
Summary: app-office/openoffice-bin-3.2.1 should depend on dev-libs/openssl:0.9.8
Status: RESOLVED DUPLICATE of bug 361695
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Office Team
URL:
Whiteboard:
Keywords:
Depends on: 253727
Blocks:
  Show dependency tree
 
Reported: 2010-07-18 09:53 UTC by Dennis Schridde
Modified: 2011-07-26 23:01 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dennis Schridde 2010-07-18 09:53:25 UTC
Apparently some python module of app-office/openoffice-bin-3.2.1 requires libssl.so.0.9.8, hence the package should depend on dev-libs/openssl:0.9.8.

>>> package: dev-libs/openssl-1.0.0a
 *  - /usr/lib64/libssl.so.0.9.8
 *      used by /usr/lib64/openoffice/basis3.2/program/python-core-2.6.1/lib/lib-dynload/_hashlib.so (app-office/openoffice-bin-3.2.1)
 *      used by /usr/lib64/openoffice/basis3.2/program/python-core-2.6.1/lib/lib-dynload/_ssl.so (app-office/openoffice-bin-3.2.1)
 *  - /usr/lib64/libcrypto.so.0.9.8
 *      used by /usr/NX/bin/nxssh (net-misc/nxclient-3.4.0.7)
 *      used by /usr/lib64/openoffice/basis3.2/program/python-core-2.6.1/lib/lib-dynload/_hashlib.so (app-office/openoffice-bin-3.2.1)
 *      used by /usr/lib64/openoffice/basis3.2/program/python-core-2.6.1/lib/lib-dynload/_ssl.so (app-office/openoffice-bin-3.2.1)
Use emerge @preserved-rebuild to rebuild packages using these libraries
~ # scanelf -n /usr/lib64/openoffice/basis3.2/program/python-core-2.6.1/lib/lib-dynload/_hashlib.so
 TYPE   NEEDED FILE 
ET_DYN libssl.so.0.9.8,libcrypto.so.0.9.8,libpython2.6.so.1.0,libpthread.so.0,libc.so.6 /usr/lib64/openoffice/basis3.2/program/python-core-2.6.1/lib/lib-dynload/_hashlib.so 
~ # q file /usr/lib64/openoffice/basis3.2/program/python-core-2.6.1/lib/lib-dynload/_hashlib.so
app-office/openoffice-bin (/usr/lib64/openoffice/basis3.2/program/python-core-2.6.1/lib/lib-dynload/_hashlib.so)


Reproducible: Always
Comment 1 Tomáš Chvátal (RETIRED) gentoo-dev 2010-07-31 08:42:30 UTC
This might be resolved based on bug 253727...
Comment 2 Tomáš Chvátal (RETIRED) gentoo-dev 2011-07-26 23:01:26 UTC
we will punt ooo-bin really soon in favor of loo-bin and then we will need to overhaul that one. Duping against the loo-bin megabug.

*** This bug has been marked as a duplicate of bug 361695 ***