Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 252488 - [2.6.28 regression] compilation broken on alpha
Summary: [2.6.28 regression] compilation broken on alpha
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: Alpha Linux
: High normal (vote)
Assignee: Gentoo Kernel Bug Wranglers and Kernel Maintainers
URL: http://bugzilla.kernel.org/show_bug.c...
Whiteboard: linux-2.6.28-regression
Keywords: InVCS
Depends on:
Blocks:
 
Reported: 2008-12-25 16:22 UTC by Tobias Klausmann
Modified: 2009-01-19 12:55 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
2.6.28+patches panic on boot (2.6.28_panic_on_boot.log,7.35 KB, text/plain)
2009-01-11 11:56 UTC, Tobias Klausmann
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tobias Klausmann gentoo-dev 2008-12-25 16:22:14 UTC
$ make all
scripts/kconfig/conf -s arch/alpha/Kconfig
  CHK     include/linux/version.h
  UPD     include/linux/version.h
  CHK     include/linux/utsrelease.h
  UPD     include/linux/utsrelease.h
  SYMLINK include/asm -> include/asm-alpha
  CC      kernel/bounds.s
  GEN     include/linux/bounds.h
  CC      arch/alpha/kernel/asm-offsets.s
In file included from
/home/klausman/src/linux-2.6.28-rc1/arch/alpha/include/asm/core_tsunami.h:5,
                 from
/home/klausman/src/linux-2.6.28-rc1/arch/alpha/include/asm/io.h:232,
                 from arch/alpha/kernel/asm-offsets.c:12:
include/linux/pci.h: In function 'pci_ioremap_bar':
include/linux/pci.h:1148: error: implicit declaration of function
'ioremap_nocache'
include/linux/pci.h:1149: warning: return makes pointer from integer without a
cast
In file included from arch/alpha/kernel/asm-offsets.c:12:
/home/klausman/src/linux-2.6.28-rc1/arch/alpha/include/asm/io.h: At top level:
/home/klausman/src/linux-2.6.28-rc1/arch/alpha/include/asm/io.h:300: error:
conflicting types for 'ioremap_nocache'
include/linux/pci.h:1148: error: previous implicit declaration of
'ioremap_nocache' was here
make[1]: *** [arch/alpha/kernel/asm-offsets.s] Error 1
make: *** [prepare0] Error 2

A solution has been discussed here:
http://www.nabble.com/-ALPHA--2.6.28-rc-fails-to-compile-td20223847.html
Comment 1 LiorD 2008-12-25 16:26:41 UTC
Have you tried with the final 2.6.28 kernel?
Comment 2 Tobias Klausmann gentoo-dev 2008-12-25 16:28:29 UTC
Yes, of course. Same error.
Comment 3 Daniel Drake (RETIRED) gentoo-dev 2009-01-01 12:59:25 UTC
Thanks, will watch upstream bug
Comment 4 Daniel Drake (RETIRED) gentoo-dev 2009-01-11 11:00:51 UTC
Please try applying this patch to 2.6.28

http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff_plain;h=1684f5ddd4c0c754f52c78eaa2c5c69ad09fb18c
Comment 5 Tobias Klausmann gentoo-dev 2009-01-11 11:56:35 UTC
Created attachment 178030 [details]
2.6.28+patches panic on boot

The kernel now compiles (after adding the irq_srm.c fix, too). Unfortunately, it panics on boot (see attached file).
Comment 6 Daniel Drake (RETIRED) gentoo-dev 2009-01-11 12:42:24 UTC
That is unlikely to be related to this patch, you are just hitting it because this is the first time you have been able to boot 2.6.28. Please file a different bug for that if we don't manage to fix it on IRC.
Comment 7 Daniel Drake (RETIRED) gentoo-dev 2009-01-11 12:42:40 UTC
.
Comment 8 Daniel Drake (RETIRED) gentoo-dev 2009-01-19 12:55:38 UTC
fixed in gentoo-sources-2.6.28-r1