Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 251969 - media-video/mpeg-tools: pre-stripped files found
Summary: media-video/mpeg-tools: pre-stripped files found
Status: RESOLVED DUPLICATE of bug 282733
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High QA (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
: 274324 (view as bug list)
Depends on:
Blocks: prestripped
  Show dependency tree
 
Reported: 2008-12-21 21:07 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2009-08-25 19:40 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2008-12-21 21:07:55 UTC
media-video/mpeg-tools-1.5b-r2:20081217-012658.log:  * QA Notice: Pre-stripped files found:
media-video/mpeg-tools-1.5b-r2:20081217-012658.log:  * /var/tmp/portage/media-video/mpeg-tools-1.5b-r2/image/usr/bin/mpeg_encode

Portage warns about pre-stripped files being installed into the image directory; this is a bad thing since it makes Portage's splitdebug feature useless, and it stops the users and the developers from looking into backtraces with full debug information available.

For the developers going to look into it, what you have to look out for, to
find what is stripping the files, is one of these conditions:

- explicit "strip" command run on the produced files;
- "install -s" command to install the binary files;
- "-Wl,-s" flag passed during linking

Remove the "strip" commands, remove the "-s" option at install, and remove
"-Wl,-s" and the problem should be gone.

Thanks,
Diego
Comment 1 Justin Lecher gentoo-dev 2009-08-25 19:33:50 UTC
*** Bug 274324 has been marked as a duplicate of this bug. ***
Comment 2 Justin Lecher gentoo-dev 2009-08-25 19:40:10 UTC

*** This bug has been marked as a duplicate of bug 282733 ***