Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 248898 - media-gfx/iscan-2.21.0 version bump request
Summary: media-gfx/iscan-2.21.0 version bump request
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: AMD64 Linux
: High normal with 2 votes (vote)
Assignee: Stefan Briesenick (RETIRED)
: 262385 (view as bug list)
Depends on:
Blocks: 274625 277117
  Show dependency tree
Reported: 2008-11-26 14:14 UTC by Tomáš Linhart
Modified: 2009-10-22 20:18 UTC (History)
9 users (show)

See Also:
Package list:
Runtime testing required: ---

Ebuild for iscan-2.15.0 (iscan-2.15.0.ebuild,9.38 KB, text/plain)
2009-01-05 15:38 UTC, Stefan Wimmer
modified ebuild (iscan-2.15.0.ebuild,9.37 KB, text/plain)
2009-01-11 22:30 UTC, Ștefan Talpalaru
Ebuild for iscan-2.16.1 (iscan-2.16.1.ebuild,9.95 KB, text/plain)
2009-02-24 15:49 UTC, Raimonds Cicans
iscan-2.19.0.ebuild (iscan-2.19.0.ebuild,9.95 KB, text/plain)
2009-05-12 14:20 UTC, jebas
iscan-2.19.2.ebuild (updated 2.19.0) (iscan-2.19.2.ebuild,9.95 KB, text/plain)
2009-06-06 16:21 UTC, Tomas Thiemel
iscan-2.20.0.ebuild (iscan-2.20.0.ebuild,9.41 KB, text/plain)
2009-07-02 19:06 UTC, INODE64 Sistemas
Patch for AMD64 and Glibc 2.10 (iscan-2.20.0.patch,1.29 KB, patch)
2009-07-07 20:59 UTC, Michael Baer
Details | Diff
iscan-2.20.0.ebuild (iscan-2.20.0.ebuild,6.85 KB, text/plain)
2009-07-09 00:26 UTC, Will Lepofsky
Patch for glibc >= 2.10 (iscan-2.20.0-glibc2.10.patch,696 bytes, patch)
2009-07-11 15:23 UTC, Michael Baer
Details | Diff
Patch for nonfree-lib/Makefile bug (iscan-2.20.0-makefile.patch,628 bytes, patch)
2009-07-11 15:24 UTC, Michael Baer
Details | Diff
ebuild for makefile and glibc bug (iscan-2.20.0-r1.ebuild,7.12 KB, text/plain)
2009-07-11 15:26 UTC, Michael Baer
Ebuild with glibc-patch only (iscan-2.20.0-r1.ebuild,7.00 KB, text/plain)
2009-07-11 17:35 UTC, Michael Baer
Patches for gcc 4.4.1 (?) (iscan-2.20.1-gcc4.4.1.patch,771 bytes, patch)
2009-08-11 23:46 UTC, Raimund
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Tomáš Linhart 2008-11-26 14:14:46 UTC
A new version of iscan adding support for more devices was released some time ago (

I tried to use the iscan-2.11.0.ebuild with no luck :-(

Reproducible: Always
Comment 1 Stefan Wimmer 2009-01-05 15:38:10 UTC
Created attachment 177472 [details]
Ebuild for iscan-2.15.0

I succeeded to make an ebuild for iscan-2.15.0 (well - I just copied the 2.11.0 ebuild and commented out one patch ;-) ), make sure to also copy the gcc43-patch to files/iscan-2.15.0-gcc43.patch! 

Everything is working as far as I can test it now ...
Comment 2 Stefan Briesenick (RETIRED) gentoo-dev 2009-01-06 23:00:21 UTC
looks like, that there are also some 64-Bit libs now. ;-)
But that's for later. I first bump it for x86.
Comment 3 Stefan Briesenick (RETIRED) gentoo-dev 2009-01-06 23:48:47 UTC
ok folks, it's a little bit more complicated. There're more changes... stay tuned, I'm working on it.
Comment 4 Ștefan Talpalaru 2009-01-11 22:30:21 UTC
Created attachment 178132 [details]
modified ebuild

The source URL was fixed. eautoreconf was messing up libltdl so it was removed. The ebuild has been tested and it's being used with a Epson SX200 on ~x86.
Comment 5 Alexander Vedernikov 2009-01-24 23:25:50 UTC
 * Cannot find $EPATCH_SOURCE!  Value for $EPATCH_SOURCE is:
 *   /usr/local/portage/overlay/media-gfx/iscan/files/iscan-2.15.0-gcc43.patch
 *   ( iscan-2.15.0-gcc43.patch )
 * ERROR: media-gfx/iscan-2.15.0 failed.
 * Call stack:
 *     , line   49:  Called src_unpack
 *             environment, line 3101:  Called epatch '/usr/local/portage/overlay/media-gfx/iscan/files/iscan-2.15.0-gcc43.patch'
 *             environment, line 1606:  Called die
 * The specific snippet of code:
 *                   die "Cannot find $EPATCH_SOURCE!";
 *  The die message:
 *   Cannot find $EPATCH_SOURCE!

I got it on my x64 system :(
Comment 6 A. Person 2009-02-19 03:26:10 UTC
Renaming to 2.16.1 worked on amd64 for an Epson Artisan 700.
Comment 7 Raimonds Cicans 2009-02-24 15:14:42 UTC
(In reply to comment #5)
>  * Cannot find $EPATCH_SOURCE!  Value for $EPATCH_SOURCE is:
>  * 
>  *   /usr/local/portage/overlay/media-gfx/iscan/files/iscan-2.15.0-gcc43.patch
>  *   ( iscan-2.15.0-gcc43.patch )

Please carefully read comment #1

cp /usr/portage/media-gfx/iscan/files/iscan-2.11.0-gcc43.patch /usr/local/portage/overlay/media-gfx/iscan/files/iscan-2.15.0-gcc43.patch
Comment 8 Raimonds Cicans 2009-02-24 15:49:34 UTC
Created attachment 183025 [details]
Ebuild for iscan-2.16.1

- fixed SRC_REV
- "epkowa.desc" is now used instead of "iscan.usermap" as source for "99-iscan.rules" generation (because format of iscan.usermap changed in 2.15.0, and this file disappeared in 2.16.1) 
- added existence check for "epkowa.desc" file (to prevent semi empty "99-iscan.rules" file generation if they remove or rename "epkowa.desc" in future versions)
Comment 9 Raimonds Cicans 2009-02-24 15:53:01 UTC
(In reply to comment #8)
I tested iscan-2.16.1 with Epson SX400 on amd64
Comment 10 Tomáš Linhart 2009-02-24 18:22:01 UTC
(In reply to comment #8)

I have tried the ebuild on my ~amd64 system but I have got the following error just after configure...

config.status: creating po/Makefile                                                                                                                                                      
make -j2 CXX=x86_64-pc-linux-gnu-g++                                                                                                                                                     
cd . && /bin/sh /var/tmp/paludis/media-gfx-iscan-2.16.1/work/iscan-2.16.1/missing --run aclocal-1.9 -I m4                                                                        error: unknown libltdl build type: _LTDL_TYPE                                                                                                                          
/usr/share/aclocal/ltdl.m4:226: LTDL_INIT is expanded from...                                                                                                                            
/usr/share/aclocal/ltdl.m4:352: AC_LIB_LTDL is expanded from...                                                                                                                  the top level                                                                                                                                                          
autom4te-2.63: /usr/bin/m4 failed with exit status: 1                                                                                                                                    
aclocal-1.9: autom4te failed with exit status: 1                                                                                                                                         
make: *** [aclocal.m4] Error 1                                                                                                                                                           
/usr/libexec/paludis/utils/emake: emake returned error 2

Do you have any idea what is going wrong?

Comment 11 Kris Kersey 2009-03-03 15:55:02 UTC
iscan 2.17.0 is now available.
Comment 12 Boris Ruppert 2009-04-19 16:50:09 UTC
iscan 2.19 is available
Comment 13 jebas 2009-05-12 14:20:33 UTC
Created attachment 191020 [details]

Using the 2.16 ebuild, I changed the SRC_REV to 4, and commented out the gcc43 patch.  It install perfectly onto a x86 system.
Comment 14 Will Lepofsky 2009-06-05 20:08:14 UTC
Suggest the the summary is changed to reflect latest version available.  Bug #262385 is requesting a version bump to 2.18.0-2.  Although nothing is going on in that bug, no sense in having duplicate bugs.
Comment 15 Tomas Thiemel 2009-06-06 15:33:37 UTC
*** Bug 262385 has been marked as a duplicate of this bug. ***
Comment 16 Tomas Thiemel 2009-06-06 16:21:01 UTC
Created attachment 193737 [details]
iscan-2.19.2.ebuild (updated 2.19.0)

it seems that original iscan_2.19.0-4.tar.gz has been replaced by iscan_2.19.2-1.tar.gz on its homepage. (
It works for me on AMD64...
Comment 17 renato gallo 2009-06-17 07:29:55 UTC
64 bit support is out with scanner button support for linux
RPM 64bit package  	
iscan-2.20.0-6.x86_64.rpm 	383.956 bytes
iscan-plugin-gt-f670-2.1.0-3.c2.x86_64.rpm 	190.518 bytes

DEB 64bit package 	
iscan_2.20.0-6_amd64.deb 	369.526 bytes
iscan-plugin-gt-f670_2.1.0-3_amd64.deb 	179.526 bytes

DEB 64bit core package [libltdl7] (for Ubuntu 8.10 or later) 	
iscan_2.20.0-6.ltdl7_amd64.deb 	372.900 bytes

Comment 18 renato gallo 2009-06-17 07:39:00 UTC
make -j5 CXX=x86_64-pc-linux-gnu-g++                                                                                                                                             
cd . && /bin/sh /var/tmp/portage/media-gfx/iscan-2.19.2/work/iscan-2.19.2/missing --run aclocal-1.10 -I m4                                                                       
ac-wrapper: warning: invalid WANT_AUTOCONF 'latest'; ignoring.                                                                                                           error: unknown libltdl build type: _LTDL_TYPE                                                                                                                  
/usr/share/aclocal/ltdl.m4:226: LTDL_INIT is expanded from...                                                                                                                    
/usr/share/aclocal/ltdl.m4:352: AC_LIB_LTDL is expanded from...                                                                                                          the top level                                                                                                                                                  
autom4te-2.63: /usr/bin/m4 failed with exit status: 1                                                                                                                            
aclocal-1.10: autom4te failed with exit status: 1
make: *** [aclocal.m4] Error 1
 * ERROR: media-gfx/iscan-2.19.2 failed.
 * Call stack:
 *     , line   49:  Called src_compile
 *             environment, line 3225:  Called die
 * The specific snippet of code:
 *       emake CXX="$(tc-getCXX)" || die "emake failed"
 *  The die message:
 *   emake failed
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/media-gfx/iscan-2.19.2/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-gfx/iscan-2.19.2/temp/environment'.

>>> Failed to emerge media-gfx/iscan-2.19.2, Log file:

(In reply to comment #16)
> Created an attachment (id=193737) [edit]
> iscan-2.19.2.ebuild (updated 2.19.0)
> Hi, 
> it seems that original iscan_2.19.0-4.tar.gz has been replaced by
> iscan_2.19.2-1.tar.gz on its homepage.
> (
> It works for me on AMD64...

Comment 19 W. Trevor King 2009-06-18 16:48:45 UTC
(In reply to comment #16)
> Created an attachment (id=193737) [edit]
> iscan-2.19.2.ebuild (updated 2.19.0)
> It works for me on AMD64...

Works for me on x86.
Comment 20 INODE64 Sistemas 2009-07-02 19:06:12 UTC
Created attachment 196417 [details]

Support for AMD64 and new firmwares, gimp plugin not depend of disable frontend

More test en AMD64
Update links of firmware scanners

Change X by frontend
Comment 21 Bob Paddock 2009-07-06 00:57:43 UTC
(In reply to comment #20)
> Created an attachment (id=196417) [edit]
> iscan-2.20.0.ebuild

I'm not getting this to compile.

The makefile is creating a simlink to non-free/ however
the file is actually called

-rwxr-xr-x 1 root root 562256 Jun  7 22:39
lrwxrwxrwx 1 root root     20 Jul  5 20:48 -> ./

Making all in non-free
make[2]: Entering directory `/var/tmp/portage/media-gfx/iscan-2.20.0/work/iscan-2.20.0/non-free'
rm -f
case x86_64 in \
          i?86)         arch=i386;; \
          x86_64)       arch=x86_64;; \
          *)    echo "unsupported architecture" 1>&2; \
                exit 1;; \
        esac; \
        ln -s ./libesmod-${arch}.so
make[2]: Leaving directory `/var/tmp/portage/media-gfx/iscan-2.20.0/work/iscan-2.20.0/non-free'
Making all in frontend
make[2]: Entering directory `/var/tmp/portage/media-gfx/iscan-2.20.0/work/iscan-2.20.0/frontend'
make[2]: *** No rule to make target `../non-free/', needed by `iscan'.  Stop.
make[2]: Leaving directory `/var/tmp/portage/media-gfx/iscan-2.20.0/work/iscan-2.20.0/frontend'
Comment 22 Michael Baer 2009-07-07 20:47:58 UTC
Bob, the problem is, that iscan-2.20.0/non-free/ is crap.

You have to change this line:

@ENABLE_FRONTEND_TRUE@   x86_64)       arch=x86_64;;

@ENABLE_FRONTEND_TRUE@   x86_64)       arch=x86_64.c2;;

It should compile with this change, because the Makefile will now use the correct shared lib ("the existing one", because for 64bit the .so doesn't exist, only!).

Great ebuild.

Some hints:
- iscan won't compile with libtool 2.2. You should add a dependency for libtool not greater than 1.5
- you should add RESTRICT="nomirror" as long as there is no mirror for the files (just a "nice to have" ;-) )
- if it is possible to check the glibc-version, you should add a section for glibc greater than 2.10. There's an api-change that prevents iscan from compiling (thanks to flameeyes, bug #276932). There's just two lines to change and it will work. Take a look at the attachment.
- There should be at least a comment for v30/300 user, that the driver have to be initialized with the command:
iscan-registry --add interpreter usb 0x04b8 0x0131
    ${MY_LIB}/esci/libesci-interpreter-gt-f720 /usr/share/esci/esfw8b.bin"
(thanks to Trevor , bug #274625)
Comment 23 Michael Baer 2009-07-07 20:59:25 UTC
Created attachment 197121 [details, diff]
Patch for AMD64 and Glibc 2.10
Comment 24 Will Lepofsky 2009-07-09 00:26:22 UTC
Created attachment 197282 [details]

Removed the plugins.  I believe they should be seperate packages.

Added use flags for png, jpeg, and tiff.

Disable static seem to work.

I'm on amd64 and it works for me.
Comment 25 Will Lepofsky 2009-07-09 16:23:06 UTC
Bob and Michael (comment #21 and comment #22):

I use amd64 and I'm not experiencing this issue with my ebuild.  Is it due to glibc-2.10?

My listing of from /usr/lib64

/usr/lib64 $ ls -la libesmod*
lrwxrwxrwx 1 root root     17 2009-07-08 19:03 ->
lrwxrwxrwx 1 root root     17 2009-07-08 19:03 ->
-rwxr-xr-x 1 root root 562256 2009-07-08 19:03
Comment 26 Michael Baer 2009-07-09 17:54:25 UTC

One issue is about glibc 2.10. Maybe you're using STABLE amd64?

I've no idea, why the makefile will not work for me. As far as I can see, the shared libs in nonfree will not be compiled but used "as is". I've checked 2.20 and 2.19 and the 64-bit .so (without c2) was missing in both packages.

Maybe the static-flag could solve the problem with makefile.
Comment 27 Will Lepofsky 2009-07-10 13:17:10 UTC
@ Michael

Yes, I'm using stable amd64.  And, I'm trying to figure out how to add your patch.  When I do, I'll update my ebuild.
Comment 28 Will Lepofsky 2009-07-10 13:28:31 UTC
I've been writing some ebuilds for the plugins in bug #277117 (they're based off of bug #274625 from W. Trevor King).  They only work on x86/amd64 platforms.  I know the the iscan-plugin-gt-f700-2.1.0.ebuild works with my iscan ebuild (I have an Epson Perfection V350 Photo).  Hopefully the others will work as well.

More will come when time permits.
Comment 29 Michael Baer 2009-07-11 15:23:43 UTC
Created attachment 197560 [details, diff]
Patch for glibc >= 2.10
Comment 30 Michael Baer 2009-07-11 15:24:22 UTC
Created attachment 197561 [details, diff]
Patch for nonfree-lib/Makefile bug
Comment 31 Michael Baer 2009-07-11 15:26:12 UTC
Created attachment 197563 [details]
ebuild for makefile and glibc bug

I renamed ebuild to -r1 as there are many changes since the first ebuild (e.g. firmware no more part of iscan ebuild)
Comment 32 Michael Baer 2009-07-11 15:31:27 UTC
I've splitted the single patch into two pieces. The patches were applied as
expected (tested on stable/unstable amd64 and stable x86 with ebuild -B iscan).

But something's really strange. The makefile patch is no more needed for
ebuild. But if I'm compiling manually from tarball (with the generated
configure options) the patch is needed on either stable or unstable (amd64-)
I'm not quiet sure, if we should include the makefile patch into ebuild. In my
opinion we should, because it seems to be a bug in makefile nevertheless.
Comment 33 Will Lepofsky 2009-07-11 17:09:22 UTC
(In reply to comment #32)


Could it have something to do with this line:

# hint: dirty hack, look into '' for 'PACKAGE_CXX_ABI'
CXX="g++" econf

in the make file?

I know when I tried to get rid of that hack in the ebuild, it would fail for me (remember that I use stable amd64).

And thanks for showing how to do the patch, most informative.
Comment 34 Michael Baer 2009-07-11 17:35:47 UTC
Created attachment 197573 [details]
Ebuild with glibc-patch only


Great work!

CXX="c++" is the trick.

CXX="c++" ./configure ... && make

works for clean tarball.

makefile-patch removed from ebuild.
Comment 35 Martin Mokrejš 2009-08-04 13:05:27 UTC
The current patch works fine for me on ~x86. Thanks.
Comment 36 Raimund 2009-08-11 23:46:02 UTC
Created attachment 200972 [details, diff]
Patches for gcc 4.4.1 (?)
Comment 37 Raimund 2009-08-11 23:49:38 UTC
I had to add the above patch to make it compile, don't know if it's really related to the new gcc.
But it works for me now, on amd64.
Please note the new version 2.20.1-1.
Comment 38 Jean-Noël Rivasseau (RETIRED) gentoo-dev 2009-09-21 15:11:43 UTC
I added this to the Portage tree today as I have a scanner that needs it. I used the latest 2.21 version which apparently supports gcc-4.4+ and glibc-2.10+ out of the box.

I also cleaned the ebuild a lot, although I am sure there is still much to do (I am not the official maintainer for this).

Thanks a lot guys for the ebuild. I may try to package the plugins next :)
Reopen if there are problems with ~amd64 with the ebuild (I don't have any amd64 box to test).