Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 246451 - sys-apps/portage-2.2_rc14: emerge @security crashes: list index out of range
Summary: sys-apps/portage-2.2_rc14: emerge @security crashes: list index out of range
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Core (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Portage team
Keywords: InVCS
Depends on:
Blocks: 144480 210077
  Show dependency tree
Reported: 2008-11-12 01:49 UTC by Matteo Modesti
Modified: 2008-11-22 05:54 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---

use match-all for consistency with portage.glsa.getMinUpgrade() (match_all.patch,526 bytes, patch)
2008-11-12 02:28 UTC, Zac Medico
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Matteo Modesti 2008-11-12 01:49:20 UTC
Every time I run "emerge @security" portage crashes. I tried both 2.2_rc14 and 2.2_rc13; didn't try any other version.
Here's the output on the shell:

dargor mattemod # emerge @security -pv
Traceback (most recent call last):
  File "/usr/bin/emerge", line 18, in <module>
    retval = _emerge.emerge_main()
  File "//usr/lib64/portage/pym/_emerge/", line 13935, in emerge_main
    myfiles, retval = expand_set_arguments(myfiles, myaction, root_config)
  File "//usr/lib64/portage/pym/_emerge/", line 13770, in expand_set_arguments
    set_atoms = setconfig.getSetAtoms(s)
  File "//usr/lib64/portage/pym/portage/sets/", line 146, in getSetAtoms
    myatoms = myset.getAtoms()
  File "//usr/lib64/portage/pym/portage/sets/", line 57, in getAtoms
  File "//usr/lib64/portage/pym/portage/sets/", line 52, in _load
  File "//usr/lib64/portage/pym/portage/sets/", line 44, in load
  File "//usr/lib64/portage/pym/portage/sets/", line 49, in _reduce
    cpv = self._portdbapi.match(atom)[0]
IndexError: list index out of range

Reproducible: Always

Steps to Reproduce:
1. emerge sys-apps/portage-2.2_rc14 (or rc13)
2. run emerge @security -pv

dargor mattemod # emerge --info                                                          
Portage 2.2_rc14 (default/linux/amd64/2008.0, gcc-4.2.4, glibc-2.6.1-r0, 2.6.26-gentoo-r2 x86_64)
System uname: Linux-2.6.26-gentoo-r2-x86_64-AMD_Phenom-tm-_9850_Quad-Core_Processor-with-glibc2.2.5
Timestamp of tree: Wed, 12 Nov 2008 00:45:01 +0000                                                 
ccache version 2.4 [enabled]                                                                       
app-shells/bash:     3.2_p33                                                                       
dev-java/java-config: 1.3.7, 2.1.6                                                                 
dev-lang/python:     2.5.2-r7                                                                      
dev-util/ccache:     2.4-r7                                                                        
dev-util/cmake:      2.4.8                                                                         
sys-devel/autoconf:  2.13, 2.61-r2
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
CFLAGS="-march=native -O2 -pipe"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=native -O2 -pipe"
FEATURES="ccache distlocks fixpackages parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-orphans userfetch"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="3dnow 3dnowext 3ds 64bit 7zip X Xaw3d a52 aac ace acl acpi additions aio akode alsa amd64 ao apache2 audacious audiofile autoreplace bash-completion berkdb branding bzip2 cairo cal3d caps ccache cdda cddb cdio cdparanoia cdr chardet chroot cli cpudetection cracklib crypt css cups curl dbus dga dirac directfb divx dmi double-precision dri dts dv dvb dvd dvdr dvdread ecc emovix enca encode exif expat fam fame fbcon fbdev ffmpeg fftw firefox flac flash fontconfig fortran fpx ftp gd gdbm ggi gif gimp glib glitz glut gmedia gmp gnutls gpm graphviz gs gtk gtkhtml guile gzip hal hdri history iconv id3 id3tag idea imagemagick imlib isdnlog jabber java5 java6 javascript jbig jingle jpeg jpeg2k justify kde kdrive ladspa lame lcms libcaca libnotify libsamplerate lm_sensors loop-aes lzo mad matroska md5sum messenger midi mikmod mime mjpeg mmap mmx mmxext mng modplug mono motif mozdom mp2 mp3 mp4 mpeg mpeg2 mplayer msn mudflap multilib musepack musicbrainz mysql ncurses networking nls nokia6600 nptl nptlonly nsplugin ntlm nuv oav objc objc++ objc-gc offensive ogg openal openexr opengl openmp openssl pam paste64 pch pcre pdf perl physfs png ppds pppd pth python qt3 qt3support qt4 quicktime radio rar readline realmedia reflection replytolist rtc rtsp samba schroedinger sdl sdl-image sdl-sound sdlaudio sensord session shout slang slp smp sms sndfile sockets speex spell spl sql srp srt sse sse2 sse3 ssl statistics stream svg sysfs syslog szip t1lib tcpd tetex tga theora threads tidy tiff toolbar truetype tta type1 unicode unzip usb utempter v4l v4l2 vcd vdr vorbis wav wavpack wifi winbind wma wmf wmp x264 xanim xcomposite xforms xine xml xorg xpm xprint xsl xulrunner xv xvid xvmc zip zlib" ALSA_CARDS="ca0106" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" DVB_CARDS="bcm3510 dibusb-usb1 dibusb-usb2 nxt2002 nxt200x or51132 or51211 tda10045 tda10046 ttpci ttusb-dec usb-a800 usb-bluebird usb-dib0700 usb-dtt200u usb-umt usb-vp702x usb-vp7045 usb-wt220u" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="it" USERLAND="GNU" VIDEO_CARDS="fglrx radeon vesa vga fbdev"
Comment 1 Zac Medico gentoo-dev 2008-11-12 02:28:12 UTC
Created attachment 171498 [details, diff]
use match-all for consistency with portage.glsa.getMinUpgrade()

If this patch is saved as /tmp/match_all.patch then it can be applied as follows:

  patch /usr/lib/portage/pym/portage/sets/ /tmp/match_all.patch

This patch will probably solve the problem but I'm not 100% sure. Please test and report back.
Comment 2 Matteo Modesti 2008-11-12 04:43:26 UTC
The patch works, thanks!
Comment 3 Zac Medico gentoo-dev 2008-11-22 05:54:41 UTC
Thanks for testing. This is fixed in 2.2_rc15.