Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 246193 - app-emulation/wine doesnt compile with bison-2.4
Summary: app-emulation/wine doesnt compile with bison-2.4
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Wine Maintainers
URL:
Whiteboard:
Keywords:
: 246427 246570 wine-1.1.8 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-11-09 18:31 UTC by Christian Schwinn
Modified: 2008-11-14 08:00 UTC (History)
17 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log of the failing compilation of wine-1.1.8 (wine-1.1.8-build.log,749.78 KB, text/plain)
2008-11-09 18:34 UTC, Christian Schwinn
Details
Wine 1.1.8 patch (wine.patch,468 bytes, text/plain)
2008-11-09 19:18 UTC, Marcin Deranek
Details
fixed ebuild for wine-1.1.8 which applies Marcin's patch (wine-1.1.8.ebuild,3.76 KB, text/plain)
2008-11-09 20:33 UTC, Christian Schwinn
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Schwinn 2008-11-09 18:31:59 UTC
Wine-1.1.8 fails to build on an x86 system when compiling kernel32.dll.
Changing to MAKEOPTS="-j1" didn't help.
Wine-1.1.8 DID build on my amd64 system.

Here my emerge info:
################################################################################
Portage 2.2_rc13 (default/linux/x86/2008.0, gcc-4.3.2, glibc-2.8_p20080602-r0, 2.6.27-gentoo-r2 i686)
=================================================================
System uname: Linux-2.6.27-gentoo-r2-i686-Intel-R-_Core-TM-_Duo_CPU_T2450_@_2.00GHz-with-glibc2.0
Timestamp of tree: Sun, 09 Nov 2008 17:15:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7, 2.1.6-r1
dev-lang/python:     2.5.2-r8
dev-util/ccache:     2.4-r8
dev-util/cmake:      2.6.2
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.3.0-r1
sys-apps/sandbox:    1.2.18.1-r3
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.5, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.19
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distlocks parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://gentoo.inode.at"
LANG="de_DE.UTF-8"
LC_ALL="de_DE.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="de"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/overlays/myoverlay"
SYNC="rsync://rsync.de.gentoo.org/gentoo-portage"
USE="X a52 aac aalib acl acpi alsa audiofile avi bash-completion berkdb bluetooth bzip2 cairo cdr cli cracklib crypt cups dbus dga directfb divx dri dvd dvdr dvdread encode exif fam firefox flac flash font-config fortran freetype gdbm gif gmedia gnome gnome-keyring gpm gstreamer gtk gtk2 hal i18n iconv imap intel ipv6 isdnlog java jpeg jpeg2k lame laptop libnotify mad midi mikmod mmx mng mp2 mp3 mpeg mudflap musepack nautilus ncurses networkmanager nls nptl nptlonly nsplugin ogg opengl openmp pam pcre pdf perl png pppd python quicktime readline realmedia reflection samba sdl seahorse session slang smp sndfile speex spell spl sse sse2 sse3 ssh ssl ssse3 svg synaptics sysfs tcpd tga theora thunderbird tiff truetype unicode usb userlocales videos vidix vorbis wifi win32codecs wmp x264 x86 xanin xml xorg xulrunner xv xvid xvmc zlib zoran" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse synaptics evded" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de" USERLAND="GNU" VIDEO_CARDS="intel"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
################################################################################

Build.log will be attached...


Best regards,
Chris


Reproducible: Always

Steps to Reproduce:
1a. emerge wine
or
1b. emerge -uDN @world
Comment 1 Christian Schwinn 2008-11-09 18:34:10 UTC
Created attachment 171213 [details]
build.log of the failing compilation of wine-1.1.8

This is the build.log of the failing compilation of wine-1.1.8.
Comment 2 Marcin Deranek 2008-11-09 18:48:23 UTC
Same error here on ~amd64:

parser.y: In function 'parser_parse':
parser.y:320: error: expected ';' before '}' token
make[2]: *** [parser.tab.o] Error 1

My system: paludis-0.30.3 (default/linux/amd64/2008.0/desktop, gcc-4.3.2, glibc-2.8_p20080602-r0, 2.6.27-gentoo-r2 x86_64)
My use flags for wine: X alsa cups (-dbus) -esd gecko (-gnutls) (-hal) -jack jpeg lcms ldap (-nas) ncurses opengl oss -samba (-scanner) xml
What are your use flags on amd64 ?
Comment 3 Marcin Deranek 2008-11-09 19:17:24 UTC
Seems like either typo or new gcc is more picky than previous version..
See attached patch which fixes the problem.. at least for myself.
Comment 4 Marcin Deranek 2008-11-09 19:18:10 UTC
Created attachment 171215 [details]
Wine 1.1.8 patch
Comment 5 Christian Schwinn 2008-11-09 20:22:37 UTC
Your patch worked. Thanks!

I still wonder why the error didn't occur on my amd64 installation - with the same gcc version...
Comment 6 Christian Schwinn 2008-11-09 20:33:37 UTC
Created attachment 171229 [details]
fixed ebuild for wine-1.1.8 which applies Marcin's patch

Installation instructions (replace <path_to_your_overlay> with your setup):

1. download the ebuild and put it in <path_to_your_overlay>/app-emulation/wine/
2. create the directory <path_to_your_overlay>/app-emulation/wine/files/
3. copy over "wine-gentoo-no-ssp.patch" from /usr/portage/app-emulation/wine/files/
4. download Marcin's patch to <path_to_your_overlay>/app-emulation/wine/files/ and name it "parser-y.patch"
5. run "ebuild <path_to_your_overlay>/app-emulation/wine/wine-1.1.8.ebuild digest"
6. emerge wine-1.1.8

Best regards
Chris
Comment 7 Marcin Deranek 2008-11-09 20:47:31 UTC
Looks like masking bison-2.4 (and using version 2.3) helps as well.
Comment 8 Wormo (RETIRED) gentoo-dev 2008-11-10 00:01:47 UTC
Thanks for your fix, Christian and Marcin. Assigning to wine team.
Comment 9 Rafał Mużyło 2008-11-10 01:15:30 UTC
The problem here is that, while this bug is
indeed caused by bison 2.4, it because of a behavior change,
that bison upstream wants to make the default in 2.5.

According to bug-bison mailing list, a lot more packages is hit
by this bison problem, among other is gcc.
Comment 10 Martin von Gagern 2008-11-11 16:52:22 UTC
Upstream found and fixed this issue as well:
http://source.winehq.org/git/wine.git/?a=commitdiff;h=2827a74cb137001aff4c
Comment 11 Lars Wendler (Polynomial-C) gentoo-dev 2008-11-11 21:41:50 UTC
*** Bug 246427 has been marked as a duplicate of this bug. ***
Comment 12 Doug Goldstein gentoo-dev 2008-11-12 18:49:23 UTC
This is fixed with the bison commit we just applied in bison-2.4-r1. I'll have to test this fix to see if it's compatible with that and we may apply that as well since it's the way forward.
Comment 13 Ben de Groot (RETIRED) gentoo-dev 2008-11-13 10:09:34 UTC
*** Bug 246584 has been marked as a duplicate of this bug. ***
Comment 14 Ben de Groot (RETIRED) gentoo-dev 2008-11-13 10:13:15 UTC
*** Bug 246570 has been marked as a duplicate of this bug. ***
Comment 15 SpanKY gentoo-dev 2008-11-14 08:00:34 UTC
if upstream bison (and our bison-2.4-r1) is changed to not require the ; and upstream wine is adding it, then there isnt much point in patching our ebuilds