Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 246427 - app-emulation/wine-1.1.8 doesn't compile
Summary: app-emulation/wine-1.1.8 doesn't compile
Status: RESOLVED DUPLICATE of bug 246193
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-11-11 20:49 UTC by Andrés Becerra Sandoval
Modified: 2008-11-11 21:41 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrés Becerra Sandoval 2008-11-11 20:49:11 UTC
With
USE="X alsa cups dbus esd gecko hal jpeg ldap ncurses opengl xml -gnutls -jack -lcms -nas -oss -samba -scanner"

The compilation of app-emulation/wine-1.1.8 hangs at this point:


i686-pc-linux-gnu-gcc -c -I. -I. -I../../include -I../../include  -D__WINESRC__ 
-D_KERNEL32_ -D_REENTRANT -fPIC -Wall -pipe -fno-strict-aliasing -Wdeclaration-a
fter-statement -Wwrite-strings -Wtype-limits -Wpointer-arith  -O2 -mtune=pentium
4 -pipe  -o toolhelp.o toolhelp.c
i686-pc-linux-gnu-gcc -c -I. -I. -I../../include -I../../include  -D__WINESRC__ 
-D_KERNEL32_ -D_REENTRANT -fPIC -Wall -pipe -fno-strict-aliasing -Wdeclaration-a
fter-statement -Wwrite-strings -Wtype-limits -Wpointer-arith  -O2 -mtune=pentium
4 -pipe  -o utthunk.o utthunk.c
i686-pc-linux-gnu-gcc -c -I. -I. -I../../include -I../../include  -D__WINESRC__ 
-D_KERNEL32_ -D_REENTRANT -fPIC -Wall -pipe -fno-strict-aliasing -Wdeclaration-a
fter-statement -Wwrite-strings -Wtype-limits -Wpointer-arith  -O2 -mtune=pentium
4 -pipe  -o version.o version.c
i686-pc-linux-gnu-gcc -c -I. -I. -I../../include -I../../include  -D__WINESRC__ 
-D_KERNEL32_ -D_REENTRANT -fPIC -Wall -pipe -fno-strict-aliasing -Wdeclaration-a
../../tools/wmc/wmc -i -U -H /dev/null -o nls/winerr_deu.mc.rc nls/winerr_deu.mc
../../tools/wmc/wmc -i -U -H /dev/null -o nls/winerr_enu.mc.rc nls/winerr_enu.mc
../../tools/wmc/wmc -i -U -H /dev/null -o nls/winerr_fra.mc.rc nls/winerr_fra.mc
../../tools/wmc/wmc -i -U -H /dev/null -o nls/winerr_kor.mc.rc nls/winerr_kor.mc
../../tools/wmc/wmc -i -U -H /dev/null -o nls/winerr_nor.mc.rc nls/winerr_nor.mc
../../tools/winebuild/winebuild -D_REENTRANT -fPIC --as-cmd "i686-pc-linux-gnu-as" --dll -o krnl386.exe.spec.o --dll-name kernel --main-module kernel32.dll --res version16.res --export ./krnl386.exe.spec
../../tools/wrc/wrc --nostdinc -I. -I. -I../../include -I../../include  -D__WINESRC__ -D_KERNEL32_  -fokernel.res kernel.rc
../../tools/winegcc/winegcc -B../../tools/winebuild -shared ./kernel32.spec comm.drv.spec.o krnl386.exe.spec.o stress.spec.o system.drv.spec.o toolhelp.spec.o win87em.spec.o windebug.spec.o atom16.o error16.o kernel16.o registry16.o toolhelp16.o win87em.o winhelp.exe.o winoldap.mod.o actctx.o atom.o change.o comm.o computername.o console.o cpu.o debugger.o dosmem.o editline.o environ.o except.o fiber.o file.o file16.o format_msg.o global16.o heap.o instr.o kernel_main.o lcformat.o local16.o locale.o lzexpand.o module.o ne_module.o ne_segment.o oldconfig.o path.o powermgnt.o process.o profile.o relay16.o resource.o resource16.o selector.o snoop16.o stress.o string.o sync.o syslevel.o system.o tape.o task.o thread.o thunk.o time.o toolhelp.o utthunk.o version.o virtual.o volume.o vxd.o windebug.o wowthunk.o    relay16asm.o kernel.res -Wb,-F,KERNEL32.dll -Wl,--image-base,0x7b800000 -o kernel32.dll.so  -lntdll   ../../libs/port/libwine_port.a -Wl,-O1
make[2]: se sale del directorio `/var/tmp/portage/app-emulation/wine-1.1.8/work/wine-1.1.8/dlls/kernel32'
make[1]: se sale del directorio `/var/tmp/portage/app-emulation/wine-1.1.8/work/wine-1.1.8/dlls'
make: *** [dlls] Error 2

If I cd into /var/tmp/portage/app-emulation/wine-1.1.8/work/wine-1.1.8/
and execute make again, I get this new problem:

make[2]: se sale del directorio `/var/tmp/portage/app-emulation/wine-1.1.8/work/wine-1.1.8/dlls/itss'
make[2]: se ingresa al directorio `/var/tmp/portage/app-emulation/wine-1.1.8/work/wine-1.1.8/dlls/jscript'
i686-pc-linux-gnu-gcc -c -I. -I. -I../../include -I../../include  -D__WINESRC__  -D_REENTRANT -fPIC -Wall -pipe -fno-strict-aliasing -Wdeclaration-after-statement -Wwrite-strings -Wtype-limits -Wpointer-arith  -O2 -mtune=pentium4 -pipe  -o parser.tab.o parser.tab.c
parser.y: En la función ‘parser_parse’:
parser.y:320: error: expected ‘;’ before ‘}’ token
make[2]: *** [parser.tab.o] Error 1
make[2]: se sale del directorio `/var/tmp/portage/app-emulation/wine-1.1.8/work/wine-1.1.8/dlls/jscript'
make[1]: *** [jscript] Error 2
make[1]: se sale del directorio `/var/tmp/portage/app-emulation/wine-1.1.8/work/wine-1.1.8/dlls'
make: *** [dlls] Error 2
Comment 1 Lars Wendler (Polynomial-C) gentoo-dev 2008-11-11 21:09:48 UTC
Hi,

could you please provide output in english language?
Something like

> LANG="C" emerge -1v =wine-1.1.8

should be sufficient. The output of 

> emerge --info 

would be helpful as well.

Cheers
Comment 2 Rafał Mużyło 2008-11-11 21:32:51 UTC
Well, this is a duplicate of bug 246193.
Comment 3 Lars Wendler (Polynomial-C) gentoo-dev 2008-11-11 21:41:50 UTC
I think you're right. Marking this bug as duplicate.
Andrés if you need wine-1.1.8 right now, downgrade sys-devel/bison to version 2.3

*** This bug has been marked as a duplicate of bug 246193 ***