Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 246131 - net-misc/kiax fails to compile w/ glibc-2.8 (h_addr issue)
Summary: net-misc/kiax fails to compile w/ glibc-2.8 (h_addr issue)
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: voip herd (OBSOLETE)
URL:
Whiteboard:
Keywords:
: 248107 (view as bug list)
Depends on:
Blocks: glibc-2.8 258813
  Show dependency tree
 
Reported: 2008-11-09 07:28 UTC by A Frederick Christensen
Modified: 2009-02-16 19:13 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Patch to fix the h_addr issue (h_addr_list.patch,1.09 KB, patch)
2008-11-09 07:30 UTC, A Frederick Christensen
Details | Diff
Ebuild to go with the above patch (kiax-0.8.51.ebuild,1.08 KB, text/plain)
2008-11-09 07:31 UTC, A Frederick Christensen
Details
Patch fixing compilation issue with glibc-2.8 (kiax-0.8.51-h_addr_list.patch,1.09 KB, patch)
2009-02-14 00:39 UTC, Mounir Lamouri (volkmar) (RETIRED)
Details | Diff
Patch from 0.8.51 to 0.8.51-r1 (kiax-0.8.51-r1.ebuild.patch,1.85 KB, patch)
2009-02-14 00:50 UTC, Mounir Lamouri (volkmar) (RETIRED)
Details | Diff
Ebuild for kiax-0.8.51-r1 (kiax-0.8.51-r1.ebuild,1.45 KB, text/plain)
2009-02-14 21:46 UTC, Mounir Lamouri (volkmar) (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description A Frederick Christensen 2008-11-09 07:28:38 UTC
kiax fails to compile, dying with the following output:

libiax2/src/iax.c: In function ‘iax_register’:
libiax2/src/iax.c:1556: error: ‘struct hostent’ has no member named ‘h_addr’
libiax2/src/iax.c: In function ‘iax_call’:
libiax2/src/iax.c:1949: error: ‘struct hostent’ has no member named ‘h_addr’
make[1]: *** [libiax2/src/iax.o] Error 1
Comment 1 A Frederick Christensen 2008-11-09 07:30:04 UTC
Created attachment 171150 [details, diff]
Patch to fix the h_addr issue

This patch fixed the compile for me. (Worked on x86 ... haven't tested any other circumstances.)
Comment 2 A Frederick Christensen 2008-11-09 07:31:01 UTC
Created attachment 171151 [details]
Ebuild to go with the above patch

Ebuild that includes the patch above.
Comment 3 Wormo (RETIRED) gentoo-dev 2008-11-10 01:36:51 UTC
Thanks for submitting this compile fix. Could you post your version of glibc as additional info, since the problem must come from newer versions of glibc dropping h_addr definition from netdb.h?
Comment 4 A Frederick Christensen 2008-11-10 13:02:54 UTC
(In reply to comment #3)
> Thanks for submitting this compile fix. Could you post your version of glibc as
> additional info, since the problem must come from newer versions of glibc
> dropping h_addr definition from netdb.h?
> 

Thanks for pointing that out, Wormo. I'm running sys-libs/glibc-2.8_p20080602.
Comment 5 Pacho Ramos gentoo-dev 2009-02-13 13:52:16 UTC
*** Bug 248107 has been marked as a duplicate of this bug. ***
Comment 6 Mounir Lamouri (volkmar) (RETIRED) gentoo-dev 2009-02-14 00:39:46 UTC
Created attachment 181919 [details, diff]
Patch fixing compilation issue with glibc-2.8

Actually, I just renamed A. Frederick Christensen patch.
Comment 7 Mounir Lamouri (volkmar) (RETIRED) gentoo-dev 2009-02-14 00:50:39 UTC
Created attachment 181921 [details, diff]
Patch from 0.8.51 to 0.8.51-r1

This patch use the patch to fix glibc-2.8 issue. It is also cleaning the ebuild and fixing bug #233062.

Note: I had a sandbox violation so I add :
    # throw a sandbox error otherwise
    sed -ie "s:../../../../../../../../share:usr/share:g" \
        src/Makefile || die "patching src/Makefile failed"
I made many tests and I don't think it's linked with my system.
Can anyone confirm this ?

As I have not glibc-2.8, I must trust Frederick about his patch fixing everything. Only I can say is it is not breaking anything without glibc-2.8 ;)
Another time, can anyone test this ?
Comment 8 Mounir Lamouri (volkmar) (RETIRED) gentoo-dev 2009-02-14 21:46:51 UTC
Created attachment 182070 [details]
Ebuild for kiax-0.8.51-r1

I search a deeper reason about sandbox violation and I'm now using eqmake3 instead of upstream script.
This is changing many things in the ebuild so I prefer to provide a plain text ebuild instead of a patch.

So, I just need someone to confirm this is working with glibc-2.8.

By the way, if this ebuild is added to the tree and old ones removed, configure.patch can be removed too.
Comment 9 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-02-16 19:13:58 UTC
thx, added -r1, removed -r0.