Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 245188 - media-sound/pulseaudio-0.9.13 should be patched (various problems)
Summary: media-sound/pulseaudio-0.9.13 should be patched (various problems)
Status: RESOLVED UPSTREAM
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Sound Team
URL: http://www.pulseaudio.org/ticket/403
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-11-01 19:47 UTC by Maciej Piechotka
Modified: 2009-01-01 14:40 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Ebuild with 24 patches from fedora. (pulseaudio-0.9.13-r1.ebuild,8.16 KB, text/plain)
2009-01-01 14:29 UTC, Mieszko Ślusarczyk
Details
Ebuild with 24 patches from fedora. (pulseaudio-0.9.13-r1.ebuild,8.16 KB, text/plain)
2009-01-01 14:31 UTC, Mieszko Ślusarczyk
Details
Tarball containing ebuild with those 24 patches (pulseaudio.tar.bz2,24.43 KB, text/plain)
2009-01-01 14:31 UTC, Mieszko Ślusarczyk
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Maciej Piechotka 2008-11-01 19:47:53 UTC
media-sound/pulseaudio-0.9.13 should be patched by 22 patches from Fedora (otherwise it might hung for example).

Reproducible: Always




Portage 2.2_rc12 (default/linux/x86/2008.0/developer, gcc-4.3.2, glibc-2.8_p20080602-r0, 2.6.27-zen3 i686)
=================================================================
System uname: Linux-2.6.27-zen3-i686-Intel-R-_Celeron-R-_M_processor_1.50GHz-with-gentoo-2.0.0
Timestamp of tree: Sat, 01 Nov 2008 03:00:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7, 2.1.6-r1
dev-lang/python:     2.5.2-r8, 2.6-r4
dev-util/ccache:     2.4-r8
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.3.0-r1
sys-apps/sandbox:    1.2.18.1-r3
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.4_p6, 1.5, 1.7.9-r1, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r4
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-Os -march=pentium-m -mfpmath=sse -pipe -momit-leaf-frame-pointer -ggdb -w -ftree-vectorize -ftree-loop-optimize -freorder-blocks-and-partition -fgcse-sm -fgcse-las -fgcse-after-reload -ftracer -maccumulate-outgoing-args"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-Os -march=pentium-m -mfpmath=sse -pipe -momit-leaf-frame-pointer -ggdb -w -ftree-vectorize -ftree-loop-optimize -freorder-blocks-and-partition -fgcse-sm -fgcse-las -fgcse-after-reload -ftracer -maccumulate-outgoing-args -fvisibility-inlines-hidden"
DISTDIR="/var/tmp/distfiles"
FEATURES="ccache collision-protect cvs digest distlocks multilib-strict parallel-fetch prelink preserve-libs protect-owned sandbox sfperms sign splitdebug stricter unmerge-orphans userfetch userpriv usersandbox"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="en_US.UTF-8"
LC_ALL="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--add-needed -Wl,--as-needed -Wl,--hash-style=both -Wl,--sort-common"
LINGUAS="en_GB en_US pl"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage-crossdev /usr/local/portage /usr/portage/local/layman/zen-overlay /usr/portage/local/layman/java-overlay /usr/portage/local/layman/x11 /usr/portage/local/layman/my-gnome"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X aac acl acpi alsa applet attr avahi avalon bash-completion berkdb bittorrent boo browseplugin bzip2 c++ cairo calendar caps cddb cdparanoia cdr cli clisp context cracklib crypt cups curl curlwrappers cxx d daap dbus deskbar detex devhelp disk-partition djvu docbook dri dvd dvdnav dvdr dvdread eclipse eds emacs emboss encode eog epiphany esd evo evolution exif expat extra fam ffmpeg flac flash fortran fuse galago gconf gd gdbm gdl gedit gif gimp git glib glut gmail gmp gnome gnome-keyring gnutls gpm gsf gstreamer gtk guile hal iconv idle imap inherit-graph inotify ipod iproute2 ipv6 isdnlog jabber java java5 java6 jingle jpeg jpeg2k jython kerberos keyring kqemu laptop latex libburn libffi libgda libnotify libsexy logrotate lucene mad maildir mailwrapper mhash midi mikmod mmap mmx mono moonlight mozilla mp3 mpeg mudflap mule musicbrainz nautilus ncurses network networkmanager nls nntp no-old-linux nptl nptlonly nsplugin ntpl ogg oggvorbis openal opengl openmp pam pango pbm pccts pch pcre pda pdf perl png policykit pop postgres ppds pppd pulseaudio python qt3support quicktime raw readline reflection regex reiserfs resolvconf rhino ruby samba scanner science sdl session snmp soap soup sourceview spell spl sqlite sqlite3 sse sse2 ssh ssl startup-notification subversion svg symlink sysfs syslog tcpd tetex theora threads threadsafe tiff timidity totem tracker trayicon truetype unicode usb valgrind vim vorbis vte wifi win32codecs wxwindows x86 xattr xcb xforms xhtml xml xml2 xorg xsl xslt xulrunner xv zeroconf zlib" ALSA_CARDS="atiixp" ALSA_PCM_PLUGINS="null empty dmix dshare ioplug" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="panasonic" ELIBC="glibc" INPUT_DEVICES="evdev mouse keyboard" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en_GB en_US pl" USERLAND="GNU" VIDEO_CARDS="radeon"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, MAKEOPTS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Rafał Mużyło 2008-11-01 20:58:12 UTC
While this sucks as a bug report,
I can confirm that 0.9.13 does indeed work
without those patches far worse than 0.9.12 did.
With those patches, it works just fine.
All of those patches seem to be git patches anyway.
Comment 2 Gilles Dartiguelongue gentoo-dev 2008-11-02 13:22:29 UTC
care to provide a descriptive of the patches and where are they available from fedora ? (maybe descriptive is optional if lennart says we should apply them).
Comment 3 Rafał Mużyło 2008-11-02 21:08:06 UTC
They're in rawhide recent rpm (pulseaudio-0.9.13-4.fc10 to be exact).
They are clean git patches, so each has a full description.
They're already prepared to be used by (recursive) epatch -
each has a numeric prefix, so it's only a matter of
packing them in a single tarball.
Comment 4 Aidan Thornton 2008-11-05 21:30:26 UTC
0022-make-sure-to-use-64bit-rounding-even-on-32bit-machin.patch is definitely needed; the bug it fixes causes all sorts of issues on some 32-bit machines (see for example https://bugzilla.redhat.com/show_bug.cgi?id=462200#c41). In my case, without the patch all media playback applications (mplayer, mythtv, flash, etc) display severe stuttering and a/v syncronisation issues, even total stalls of playback in mplayer. Pulseaudio also uses far too much CPU (35% or more), which would be a serious issue if I was using realtime support. Both of these issues are fixed by the patch.

(This issue may be specific to users of HD97 audio codecs, but they're very common these days.)

The rest of the patches also look like good candidates for being applied to the package, but since I'm not affected by any of the issues in them I can't comment. They can be extracted from the Fedora SRPM with rpm2tgz; the appropriate SRPM can be downloaded from http://download.fedora.redhat.com/pub/fedora/linux/development/source/SRPMS/pulseaudio-0.9.13-6.fc10.src.rpm. 
Comment 5 Maciej Piechotka 2008-11-05 21:52:27 UTC
(In reply to comment #4)
> (This issue may be specific to users of HD97 audio codecs, but they're very
> common these days.)
> 

They are not I am owner of AC97.
Comment 6 Rafał Mużyło 2008-11-07 14:43:13 UTC
(In reply to comment #5)
> (In reply to comment #4)
> > (This issue may be specific to users of HD97 audio codecs, but they're very
> > common these days.)
> > 
> 
> They are not I am owner of AC97.
> 
So am I.
Comment 7 Diego Elio Pettenò (RETIRED) gentoo-dev 2008-11-24 13:40:11 UTC
I'm trying to get a hold of Lennart to see if he can release a 0.9.14, since that's going to be much easier than going to apply 22 patches...
Comment 8 Mieszko Ślusarczyk 2009-01-01 14:29:57 UTC
Created attachment 177003 [details]
Ebuild with 24 patches from fedora.

Since it's been more than a month and nothing happened, I submit ebuild wit 24 (!) patches from fedora.
Let me know if I should drop one or two oO.
Comment 9 Mieszko Ślusarczyk 2009-01-01 14:31:04 UTC
Created attachment 177004 [details]
Ebuild with 24 patches from fedora.

Since it's been more than a month and nothing happened, I submit ebuild wit 24 (!) patches from fedora.
Let me know if I should drop one or two oO.
Comment 10 Mieszko Ślusarczyk 2009-01-01 14:31:33 UTC
Created attachment 177006 [details]
Tarball containing ebuild with those 24 patches
Comment 11 Mieszko Ślusarczyk 2009-01-01 14:34:36 UTC
ooops. Sorry for submitting same comment twice.

BTW ebuild+patches is in my overlay now:
http://github.com/spitfire/spitfire-overlay/tree

To add type:

layman -f -o http://github.com/spitfire/spitfire-overlay/raw/master/spitfire-overlay.list -a spitfire-overlay