Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 244975 - /usr/bin/emerge is gone after i did 'emerge --unmerge portage'. How can i get it back?
Summary: /usr/bin/emerge is gone after i did 'emerge --unmerge portage'. How can i get...
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Core - Interface (emerge) (show other bugs)
Hardware: PPC Linux
: High major (vote)
Assignee: Portage team
Keywords: InVCS
Depends on:
Blocks: 651232 210077 216231
  Show dependency tree
Reported: 2008-10-30 16:32 UTC by dominik bartkowski
Modified: 2018-03-24 02:42 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description dominik bartkowski 2008-10-30 16:32:34 UTC
Because of portage problems, i encoutered few weeks ago, I decided to unmerge the portage and install it again.
i run this command;
emerge --unmerge portage
The system was saying that important files will be deleted, i decided to continue anyway. Afterwards I realized that I cannot run the emerge command anymore. If I try to run it, i can read this:
zsh: command not found: emerge

if I try this
man emerge
i get:
No manual entry for emerge

could somebody tell me how to reinstall portage in a proper and efficient way and get emerge back. I tried to google it, unfortunatelly results were not really satysfying.

thanks in advance 


Reproducible: Didn't try

Steps to Reproduce:
1.emerge --unmerge portage
2.emerge portage (doesn't work)

Actual Results:  
/usr/bin/emerge is gone.
man emerge doesn't work neither.
if i run emerge in the terminal, i have this:
zsh: command not found: emerge

Expected Results:  
i didn't know that we cannot unmerge the portage.

i work with a iBook G4 - ppc, i have a dual boot.
Comment 1 Łukasz Damentko (RETIRED) gentoo-dev 2008-10-30 17:12:49 UTC
Try that:
Comment 2 Zac Medico gentoo-dev 2008-10-30 17:41:05 UTC
You should be fine after you reinstall portage by hand as described in the link above.

Perhaps we should add a safety net that disallows portage from uninstalling itself since it doesn't seem like it could ever possibly be the right thing to do.
Comment 3 Zac Medico gentoo-dev 2008-10-30 22:20:58 UTC
It's fixed in svn r11756 to behave like this:

# emerge -C portage
 * Not unmerging package sys-apps/portage-2.2 since there is no valid
 * reason for portage to unmerge itself.

>>> No packages selected for removal by unmerge
Comment 4 Zac Medico gentoo-dev 2008-11-02 01:06:59 UTC
This has been released in 2.2_rc13.
Comment 5 dominik bartkowski 2008-11-03 16:43:27 UTC

the method described bellow works fine, the only thing is that i cannot make it work with portage-2.2_rc13 but with portage-

i will have to try it again.
thanks a lot for your help guys.