Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 243040 - media-video/totem-2.24.2 sandbox violation when source compiled
Summary: media-video/totem-2.24.2 sandbox violation when source compiled
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
: 243828 249331 (view as bug list)
Depends on:
Blocks: 243288
  Show dependency tree
 
Reported: 2008-10-21 12:35 UTC by Celso Fernandes (icezimm)
Modified: 2008-12-02 18:30 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
comments all addpredict lines (totem-2.24.2-addpredict.patch,291 bytes, text/plain)
2008-10-31 02:31 UTC, Helmut Eberharter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Celso Fernandes (icezimm) 2008-10-21 12:35:42 UTC
when emerging media-video/totem-2.24.2, after source is compiled receives the message:

--------------------------- ACCESS VIOLATION SUMMARY ---------------------------
LOG FILE = "/var/log/sandbox/sandbox-6454.log"

open_wr:   /root/.gconf/.testing.writeability
unlink:    /root/.gconf/.testing.writeability
open_wr:   /root/.gconfd/saved_state
open_wr:   /root/.gconfd/saved_state
open_wr:   /root/.gconfd/saved_state
open_wr:   /root/.gconfd/saved_state
open_wr:   /root/.gconfd/saved_state
open_wr:   /root/.gconfd/saved_state
open_wr:   /root/.gconfd/saved_state
open_wr:   /root/.gconfd/saved_state
open_wr:   /root/.gconfd/saved_state
open_wr:   /root/.gconfd/saved_state.tmp
--------------------------------------------------------------------------------

Reproducible: Always

Steps to Reproduce:
emerge =media-video/totem-2.24.2
Comment 1 Gilles Dartiguelongue gentoo-dev 2008-10-21 12:51:53 UTC
don't forgot to add emerge --info

which version of gconf do you have, does it come from the overlay or portage ?
Comment 2 Celso Fernandes (icezimm) 2008-10-21 12:55:16 UTC
(In reply to comment #1)
> don't forgot to add emerge --info
> 
> which version of gconf do you have, does it come from the overlay or portage ?
> 

sorry, my fault

Portage 2.2_rc12 (default/linux/x86/2008.0/desktop, gcc-4.3.2, glibc-2.8_p20080602-r0, 2.6.26-gentoo-r1 i686)
=================================================================
System uname: Linux-2.6.26-gentoo-r1-i686-Genuine_Intel-R-_CPU_T2250_@_1.73GHz-with-glibc2.0
Timestamp of tree: Tue, 21 Oct 2008 10:30:01 +0000
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7, 2.1.6-r1
dev-lang/python:     2.5.2-r8
dev-util/ccache:     2.4-r8
dev-util/cmake:      2.6.2
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.3.0-r1
sys-apps/sandbox:    1.2.18.1-r3
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.26
ACCEPT_KEYWORDS="x86 ~* ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="buildpkg ccache distlocks parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://gentoo.localhost.net.ar/"
LANG="pt_BR.utf8"
LDFLAGS="-Wl,-O1"
LINGUAS="en en_US pt_BR"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/enlightenment /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X aac aalib acl acpi alsa apache2 avahi bash-completion bcmath berkdb bluetooth branding bzip2 cairo cddb cdparanoia cdr cgi cli cracklib crypt css ctype cups curl dbus directfb dri dvd dvdr dvdread eds emboss encode esd evo fam fbcon ffmpeg firefox flac fortran gd gdbm gif gnome gnome-keyring gnutls gpm gstreamer gtk gtkhtml hal hddtemp iconv ipv6 isdnlog java java6 javascript jpeg kde kerberos kpathsea lame latex ldap libnotify libwww lm_sensors lzo mad mailwrapper mdnsresponder-compat midi mikmod mime mp3 mpeg mudflap musicbrainz mysql ncurses nls nptl nptlonly nsplugin offensive ofx ogg opengl openmp pam pcmcia pcre pdf perl php png posix postgres ppds pppd python qt3 qt3support qt4 quicktime rdesktop readline reflection rss samba sasl sdl session snmp sockets spell spl ssl startup-notification subversion svg svga sysfs syslog tcpd tetex tiff truetype unicode usb vhosts vim-syntax vnc vorbis wifi win32codecs x86 xinerama xinetd xml xorg xosd xulrunner xv xvideo zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" APACHE2_MPMS="prefork" ELIBC="glibc" INPUT_DEVICES="evdev keyboard mouse synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_US pt_BR" USERLAND="GNU" VIDEO_CARDS="i810 nv radeon"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

About GConf:

gnome-base/gconf-2.24.0 from portage

Thanks
Comment 3 Gilles Dartiguelongue gentoo-dev 2008-10-21 13:10:03 UTC
Ok so I think I've found the origin of what I commented in the ebuild,

Totem calls gconftool2 --set in data/schemas.sh which is used to generate a defaults schema for gconf. This is problematic since the tarball doesn't seem to include a pregenerated file resulting in spawning a gconfd process at build time.

I've missed this because of some user* FEATURES. I'll take care of adding a comment in the ebuild when fixing that.
Comment 4 Gilles Dartiguelongue gentoo-dev 2008-10-25 10:25:50 UTC
*** Bug 243828 has been marked as a duplicate of this bug. ***
Comment 5 Helmut Eberharter 2008-10-31 02:31:59 UTC
Created attachment 170373 [details]
comments all addpredict lines

there's a broken version in the tree for some time now, it compiles here if the patch is applied.
Comment 6 Mart Raudsepp gentoo-dev 2008-11-02 02:17:06 UTC
Actually all addpredict does is make sandbox not fail if the given path is tried to touch, so I have no idea why it would get fixed for you if you comment it out.
The portage version already had two of the three addpredict's commented out, and that makes it fail build for me (I still have gconf-2.22 btw). I have uncommented the addpredicts for my build to succeed, but leaving the bug open because the addpredict's shouldn't be necessary and instead the build system needs fixed (upstream) to not write to those paths via gconftool-2 during a tarball build.
Comment 7 Mart Raudsepp gentoo-dev 2008-11-02 03:23:48 UTC
Saying I leave the bug open but leaving FIXED checked from before. Go me. Reopening
Comment 8 Gilles Dartiguelongue gentoo-dev 2008-11-30 11:22:55 UTC
*** Bug 249331 has been marked as a duplicate of this bug. ***
Comment 9 Gilles Dartiguelongue gentoo-dev 2008-11-30 11:23:36 UTC
fixed 2.24.2 and 2.24.3. I bite the bullet and readded the addpredict.
Comment 10 Martin von Gagern 2008-12-02 15:07:46 UTC
(In reply to comment #9)
> fixed 2.24.2 and 2.24.3. I bite the bullet and readded the addpredict.

I see the fix for 2.24.2 in CVS revision 1.3 of the ebuild, but for 2.24.3 there is only one revision, 1.1, and this does not contain the fix. Please commit.

http://sources.gentoo.org/viewcvs.py/gentoo-x86/media-video/totem/totem-2.24.2.ebuild?r1=1.2&r2=1.3
http://sources.gentoo.org/viewcvs.py/gentoo-x86/media-video/totem/totem-2.24.3.ebuild?rev=1.1
Comment 11 Gilles Dartiguelongue gentoo-dev 2008-12-02 16:00:47 UTC
erf sorry it looks like I did the change but forgot to commit. This is now fixed. Thanks for poking.
Comment 12 Martin von Gagern 2008-12-02 18:30:32 UTC
Thanks. Referring to the FIXME comment in the ebuild, I can confirm that these lines are a viable alternative to the addpredict:

export HOME="${T}/fakehome"
mkdir -p "${HOME}"