Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 242304 - www-client/mozilla-firefox-bin-3.1_beta1: Filesize does not match recorded size
Summary: www-client/mozilla-firefox-bin-3.1_beta1: Filesize does not match recorded size
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Portage team
Keywords: InVCS
Depends on:
Blocks: 210077 216231
  Show dependency tree
Reported: 2008-10-16 05:26 UTC by Mikko Husari
Modified: 2008-12-05 02:49 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Mikko Husari 2008-10-16 05:26:55 UTC
I tried to emerge firefox but it kept giving me digest verification failures, i tried to sync couple of times but it did not help. the ebuild fetches tar.bz2 file from

Reproducible: Always

Steps to Reproduce:
1. comment the masking from package.mask
2. add required keywords
3. emerge www-client/mozilla-firefox-bin-3.1_beta1
4. observe failure
Actual Results:  
!!! Digest verification failed:
!!! /usr/portage/distfiles/firefox-3.1b1.tar.bz2
!!! Reason: Filesize does not match recorded size
!!! Got: 9556516
!!! Expected: 0

Expected Results:  
new and shiny firefox-bin installation.
Comment 1 Zac Medico gentoo-dev 2008-10-16 06:59:38 UTC
I've fixed the manifest in CVS. Seems like a repoman bug since 0 byte distfiles are never valid and therefore it should try to download the file. Commit was with portage-2.2_rc12.
Comment 2 Fabian Groffen gentoo-dev 2008-10-16 07:14:28 UTC
maybe related:

- do "repoman manifest"
- Ctrl-C during the wget attempts to find a mirror
- do "repoman manifest" again, it will succeed thinking the zero-byte created file is valid

slightly off-topic:
generating a valid Manifest after such mistake is quite difficult, as repoman resists in telling you the downloaded file is wrong, and moving it to the right file manifesting it again seems not to help (I got a nice commit salvo for that on vim).  The only solution I found so far is to manually remove the entry from the Manifest file.
Comment 3 Zac Medico gentoo-dev 2008-10-16 22:58:11 UTC
In svn r11695 it's fixed to force download in cases when the Manifest contains a digest for a zero-byte distfile.
Comment 4 Zac Medico gentoo-dev 2008-11-02 01:04:00 UTC
This is fixed in 2.2_rc13.