Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 241756 - www-servers/nginx installs perllocal.pod
Summary: www-servers/nginx installs perllocal.pod
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Konstantin Arkhipov (RETIRED)
URL:
Whiteboard:
Keywords:
: 302178 302239 (view as bug list)
Depends on: 107076
Blocks: perllocal
  Show dependency tree
 
Reported: 2008-10-13 12:16 UTC by Joost Ruis
Modified: 2010-01-26 08:05 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
nginx-0.8.17-r1.ebuild (nginx-0.8.17-r1.ebuild,3.54 KB, text/plain)
2009-10-04 18:49 UTC, mephinet
Details
PerlQt-3.009_beta2-r1.ebuild (PerlQt-3.009_beta2-r1.ebuild,1.77 KB, text/plain)
2009-10-04 19:00 UTC, mephinet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Joost Ruis 2008-10-13 12:16:37 UTC
* package dev-perl/PerlQt-3.009_beta2 NOT merged
 *
 * Detected file collision(s):
 *
 *  /usr/lib/perl5/5.8.8/i686-linux/perllocal.pod
 *
 * Searching all installed packages for file collisions...
 *
 * Press Ctrl-C to Stop
 *
 * www-servers/nginx-0.7.17
 *  /usr/lib/perl5/5.8.8/i686-linux/perllocal.pod
 *
 * Package 'dev-perl/PerlQt-3.009_beta2' NOT merged due to file
 * collisions. If necessary, refer to your elog messages for the whole
 * content of the above message.



Reproducible: Always
Comment 1 Joost Ruis 2008-10-23 09:07:43 UTC
in addition:

 * package dev-libs/libpreludedb-0.9.13 NOT merged
 *
 * Detected file collision(s):
 *
 *  /usr/lib/perl5/5.8.8/i686-linux/perllocal.pod
 *
 * Searching all installed packages for file collisions...
 *
 * Press Ctrl-C to Stop
 *
 * dev-perl/PerlQt-3.009_beta2
 *  /usr/lib/perl5/5.8.8/i686-linux/perllocal.pod
 *
 * Package 'dev-libs/libpreludedb-0.9.13' NOT merged due to file
 * collisions. If necessary, refer to your elog messages for the whole
 * content of the above message.

Comment 2 Joost Ruis 2008-11-03 09:03:23 UTC
sys-fs/owfs-2.7_p4 also causes a collision.

please fix it.
Comment 3 Elias Probst 2009-03-03 11:28:44 UTC
net-analyzer/collectd-4.5.2 is affected too:

Collision on amd64:
/usr/lib64/perl5/5.8.8/x86_64-linux-thread-multi/perllocal.pod
Comment 4 Torsten Veller (RETIRED) gentoo-dev 2009-03-03 12:25:57 UTC
(In reply to comment #3)
> net-analyzer/collectd-4.5.2 is affected too:

That must be from an overlay. Which one is it?

If it is appropriate to file a bugreport in gentoo's bugzilla, it is best to file a new bug and block bug 241834.

Thanks.
Comment 5 Elias Probst 2009-03-03 22:29:01 UTC
> (In reply to comment #3)
> > net-analyzer/collectd-4.5.2 is affected too:
> 
> That must be from an overlay. Which one is it?
> 
> If it is appropriate to file a bugreport in gentoo's bugzilla, it is best to
> file a new bug and block bug 241834.
> 
> Thanks.

You're right - my mistake - I didn't pay attention to this. This ebuild is from bug#107076.

I'll add this bug to the collectd ebuild bug as blocker.
Comment 6 mephinet 2009-10-04 18:49:45 UTC
Created attachment 206023 [details]
nginx-0.8.17-r1.ebuild

The attached ebuild for the latest in-tree version of nginx fixes the perllocal.pod installation issue on that end.
Comment 7 mephinet 2009-10-04 19:00:49 UTC
Created attachment 206026 [details]
PerlQt-3.009_beta2-r1.ebuild

... and this ebuild fixes the perllocal.pod creation for PerlQt.
Comment 8 Torsten Veller (RETIRED) gentoo-dev 2009-11-20 20:27:30 UTC
dev-perl/PerlQt was removed.
Comment 9 Dirkjan Ochtman gentoo-dev 2010-01-03 19:06:50 UTC
Fixed in nginx-0.7.64-r1 (will port to the 0.8.x branch soon).
Comment 10 Torsten Veller (RETIRED) gentoo-dev 2010-01-25 15:09:02 UTC
*** Bug 302178 has been marked as a duplicate of this bug. ***
Comment 11 Torsten Veller (RETIRED) gentoo-dev 2010-01-26 08:05:17 UTC
*** Bug 302239 has been marked as a duplicate of this bug. ***