Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 240506 - sys-fs/cloop-2.624 - ../advfs.cc:886: error: `INT_MAX' was not declared in this scope, fails to build with gcc 4.3
Summary: sys-fs/cloop-2.624 - ../advfs.cc:886: error: `INT_MAX' was not declared in th...
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: AMD64 Linux
: High major (vote)
Assignee: Stefan Schweizer (RETIRED)
URL:
Whiteboard:
Keywords:
: 251686 (view as bug list)
Depends on: 251795
Blocks: gcc-4.3
  Show dependency tree
 
Reported: 2008-10-08 13:12 UTC by Sylvain Raybaud
Modified: 2009-05-30 00:21 UTC (History)
7 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge log for cloop (sys-fs:cloop-2.624:20081008-121629.log,7.61 KB, text/plain)
2008-10-08 13:13 UTC, Sylvain Raybaud
Details
adds include limits.h (cloop-2.625-limits.patch,351 bytes, patch)
2008-10-09 09:06 UTC, ThS
Details | Diff
Ebuild prototype (cloop-2.625.ebuild,961 bytes, text/plain)
2008-10-09 09:08 UTC, ThS
Details
build log (build.log,10.47 KB, text/plain)
2008-10-14 20:45 UTC, brent
Details
patch for the "semaphore" include problem with gentoo-sources 2.6.27 (cloop-2.625-semaphore.patch,470 bytes, patch)
2008-10-15 19:08 UTC, ThS
Details | Diff
ebuild, including semaphore patch (cloop-2.625.ebuild,1.00 KB, text/plain)
2008-10-15 19:09 UTC, ThS
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sylvain Raybaud 2008-10-08 13:12:36 UTC
emerge fails with :

make[1]: Entering directory `/dev/shm/portage/portage/sys-fs/cloop-2.624/work/cloop-2.624/advancecomp-1.15'
g++ -DHAVE_CONFIG_H -I. -I. -I.     -march=athlon64 -O2 -pipe -DUSE_ERROR_SILENT -DUSE_COMPRESS -pthread -c -o advfs.o ../advfs.cc
g++ -DHAVE_CONFIG_H -I. -I. -I.     -march=athlon64 -O2 -pipe -DUSE_ERROR_SILENT -DUSE_COMPRESS -pthread -c -o zip.o zip.cc
g++ -DHAVE_CONFIG_H -I. -I. -I.     -march=athlon64 -O2 -pipe -DUSE_ERROR_SILENT -DUSE_COMPRESS -pthread -c -o file.o file.cc
g++ -DHAVE_CONFIG_H -I. -I. -I.     -march=athlon64 -O2 -pipe -DUSE_ERROR_SILENT -DUSE_COMPRESS -pthread -c -o data.o data.cc
g++ -DHAVE_CONFIG_H -I. -I. -I.     -march=athlon64 -O2 -pipe -DUSE_ERROR_SILENT -DUSE_COMPRESS -pthread -c -o siglock.o siglock.cc
g++ -DHAVE_CONFIG_H -I. -I. -I.     -march=athlon64 -O2 -pipe -DUSE_ERROR_SILENT -DUSE_COMPRESS -pthread -c -o compress.o compress.cc
g++ -DHAVE_CONFIG_H -I. -I. -I.     -march=athlon64 -O2 -pipe -DUSE_ERROR_SILENT -DUSE_COMPRESS -pthread -c -o zipsh.o zipsh.cc
../advfs.cc: In function âint main(int, char**)â:
../advfs.cc:827: warning: deprecated conversion from string constant to âchar*â
../advfs.cc:886: error: âINT_MAXâ was not declared in this scope
make[1]: *** [advfs.o] Error 1
make[1]: *** Waiting for unfinished jobs....
make[1]: Leaving directory `/dev/shm/portage/portage/sys-fs/cloop-2.624/work/cloop-2.624/advancecomp-1.15'
make: *** [advancecomp-1.15/advfs] Error 2

right after configure

Reproducible: Always

Steps to Reproduce:
emerge cloop



I'm attaching the build log.
I'm pasting emerge --info here as recquiered :

Portage 2.2_rc11 (default-linux/amd64/2006.1/desktop, gcc-4.3.1, glibc-2.8_p20080602-r0, 2.6.24-gentoo-r2 x86_64)
=================================================================
System uname: Linux-2.6.24-gentoo-r2-x86_64-AMD_Athlon-tm-_64_X2_Dual_Core_Processor_4200+-with-glibc2.2.5
Timestamp of tree: Wed, 08 Oct 2008 11:45:04 +0000
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7, 2.1.6-r1
dev-lang/python:     2.4.4-r6, 2.5.2-r8
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.2.5
sys-apps/sandbox:    1.2.18.1-r3
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.26
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=athlon64 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=athlon64 -O2 -pipe"
DISTDIR="/var/portage/distfiles"
FEATURES="ccache distlocks fixpackages metadat-transfer parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-orphans userfetch userpriv usersandbox"
FFLAGS="-march=athlon64 -O2 -pipe"
GENTOO_MIRRORS="ftp://gentoo.imj.fr/pub/gentoo http://cudlug.cudenver.edu/gentoo http://ftp.club-internet.fr/pub/mirrors/gentoo http://distfiles.gentoo.org http://www.ibiblio.org/pub/Linux/distributions/gentoo http://gentoo.modulix.net/gentoo"
LC_ALL="en_GB.UTF-8"
LDFLAGS=""
LINGUAS="en_GB fr en"
MAKEOPTS="-j4"
PKGDIR="/var/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/dev/shm/portage"
PORTDIR="/var/portage"
PORTDIR_OVERLAY="/var/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X a52 aac aalib alsa amd64 arts bash-completion berkdb bzip2 cairo cddb cdr cli cracklib crypt dbus dri dvd dvdr dvdread eds emboss encode esd exif fam ffmpeg firefox flac fortran fuse gdbm gif gpm gstreamer gtk gtk2 hal iconv ieee1394 isdnlog jpeg jpeg2k kde kdeenablefinal latex libcaca lm_sensors mad midi mikmod mp3 mpeg mudflap ncurses nls nptl nptlonly nvidia ogg opengl openmp oss pam pcre pdf perl png ppds pppd python qt3 qt4 quicktime readline reflection samba sdl session socks5 sox spell spl ssl svg tcpd tetex theora threads truetype unicode usb vorbis x264 xinerama xml xorg xscreensaver xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x       ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3       trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en_GB fr en" USERLAND="GNU" VIDEO_CARDS="nvidia nv vesa vga"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Sylvain Raybaud 2008-10-08 13:13:17 UTC
Created attachment 167600 [details]
emerge log for cloop
Comment 2 ThS 2008-10-09 09:06:09 UTC
Created attachment 167708 [details, diff]
adds include limits.h

Solves the INT_MAX problem
Comment 3 ThS 2008-10-09 09:08:03 UTC
Created attachment 167710 [details]
Ebuild prototype

This ebuild seems to work for me but needs rework by an expert
Comment 4 ThS 2008-10-09 09:12:22 UTC
My first attchment is a fix for the INT_MAX problem which is used in the second attchment, an ebuild for cloop-2.625.
Comment 5 brent 2008-10-14 12:27:19 UTC
just wanted to quick mention another (possibly related (!)) bug with this ebuild (present in the updated ebuild T.Scholz was kind enough to provice) is that it does NOT mark app-arch/advancecomp(-1.15) as a dependency. emerging it does not help, however, as it still fails at this:

g++ -pthread  -O2 -march=i686 -pipe -DUSE_ERROR_SILENT -DUSE_COMPRESS   -o advfs  advfs.o zip.o file.o data.o siglock.o compress.o zipsh.o getopt.o snprintf.o 7zdeflate.o 7zlzma.o AriBitCoder.o CRC.o DeflateDecoder.o DeflateEncoder.o HuffmanEncoder.o IInOutStreams.o InByte.o LSBFDecoder.o LSBFEncoder.o LZMA.o LZMADecoder.o LZMAEncoder.o LenCoder.o LiteralCoder.o OutByte.o WindowIn.o WindowOut.o  -lz  -lpthread
make[1]: Leaving directory `/var/tmp/portage/sys-fs/cloop-2.625/work/cloop-2.625/advancecomp-1.15'







more info:

* ERROR: sys-fs/cloop-2.625 failed.
 * Call stack:
 * ebuild.sh, line   49:  Called src_compile
 * environment, line 3147:  Called linux-mod_src_compile
 * environment, line 2422:  Called die
 * The specific snippet of code:
 * eval "emake HOSTCC="$(tc-getBUILD_CC)" 						CC="$(get-KERNEL_CC)" 						LDFLAGS="$(get_abi_LDFLAGS)" 						${BUILD_FIXES} 						${BUILD_PARAMS} 						${BUILD_TARGETS} " || die "Unable to emake HOSTCC="$(tc-getBUILD_CC)" CC="$(get-KERNEL_CC)" LDFLAGS="$(get_abi_LDFLAGS)" ${BUILD_FIXES} ${BUILD_PARAMS} ${BUILD_TARGETS}";
 * The die message:
 * Unable to emake HOSTCC=i686-pc-linux-gnu-gcc CC=i686-pc-linux-gnu-gcc LDFLAGS=  KVERSION=2.6.27-gentoo KERNEL_DIR=/usr/src/linux all
 * 
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/sys-fs/cloop-2.625/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-fs/cloop-2.625/temp/environment'.
 * This ebuild is from an overlay: '/usr/local/portage/'
Comment 6 ThS 2008-10-14 14:59:20 UTC
(In reply to comment #5)
> just wanted to quick mention another (possibly related (!)) bug with this
> ebuild (present in the updated ebuild T.Scholz was kind enough to provice) is
> that it does NOT mark app-arch/advancecomp(-1.15) as a dependency. emerging it
> does not help, however, as it still fails at this:
> 
> g++ -pthread  -O2 -march=i686 -pipe -DUSE_ERROR_SILENT -DUSE_COMPRESS   -o
> advfs  advfs.o zip.o file.o data.o siglock.o compress.o zipsh.o getopt.o
> snprintf.o 7zdeflate.o 7zlzma.o AriBitCoder.o CRC.o DeflateDecoder.o
> DeflateEncoder.o HuffmanEncoder.o IInOutStreams.o InByte.o LSBFDecoder.o
> LSBFEncoder.o LZMA.o LZMADecoder.o LZMAEncoder.o LenCoder.o LiteralCoder.o
> OutByte.o WindowIn.o WindowOut.o  -lz  -lpthread
> make[1]: Leaving directory
> `/var/tmp/portage/sys-fs/cloop-2.625/work/cloop-2.625/advancecomp-1.15'
> 

I dont see an error, here.

> 
> more info:
> 
> * ERROR: sys-fs/cloop-2.625 failed.
>  
> LDFLAGS="$(get_abi_LDFLAGS)" ${BUILD_FIXES} ${BUILD_PARAMS} ${BUILD_TARGETS}";
>  * The die message:
>  * Unable to emake HOSTCC=i686-pc-linux-gnu-gcc CC=i686-pc-linux-gnu-gcc
> LDFLAGS=  KVERSION=2.6.27-gentoo KERNEL_DIR=/usr/src/linux all
>  * 
>  * If you need support, post the topmost build error, and the call stack if
> relevant.
>  * A complete build log is located at
> '/var/tmp/portage/sys-fs/cloop-2.625/temp/build.log'.
>  * The ebuild environment file is located at
> '/var/tmp/portage/sys-fs/cloop-2.625/temp/environment'.
>  * This ebuild is from an overlay: '/usr/local/portage/'

Please post /var/tmp/portage/sys-fs/cloop-2.625/temp/build.log, at least 10 or 20 lines preceding the error message.
Comment 7 brent 2008-10-14 20:43:46 UTC
(In reply to comment #6)
> I dont see an error, here.

whoops, 

neither do i. sorry, just skimmed the error message!
> Please post /var/tmp/portage/sys-fs/cloop-2.625/temp/build.log, at least 10 or
> 20 lines preceding the error message.

i'll post the whole thing as an attachment. 

Comment 8 brent 2008-10-14 20:45:38 UTC
Created attachment 168478 [details]
build log

build log from patched ebuild.
2008-10-14 08:25 EST5EDT
Comment 9 ThS 2008-10-15 19:08:35 UTC
Created attachment 168604 [details, diff]
patch for the "semaphore" include problem with gentoo-sources 2.6.27

Here is a patch for the "semaphore" include problem with gentoo-sources 2.6.27 and the new ebuild
Comment 10 ThS 2008-10-15 19:09:37 UTC
Created attachment 168606 [details]
ebuild, including semaphore patch

ebuild, including semaphore patch
Comment 11 Peter Alfredsen (RETIRED) gentoo-dev 2008-12-17 22:40:19 UTC
@treecleaner: Maintainer unresponsive, current patches fail with newer kernels. No upstream.
Comment 12 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2008-12-20 20:57:33 UTC
Handling removal notice on bug 251795. 
Comment 13 Peter Alfredsen (RETIRED) gentoo-dev 2009-02-15 20:55:51 UTC
Updating status
# Jeremy Olexa <darkside@gentoo.org> (20 Dec 2008)
# Removed in 60 days, multiple bugs - does not compile with recent kernels.
# bug 251795
Comment 14 Peter Alfredsen (RETIRED) gentoo-dev 2009-02-15 20:57:28 UTC
*** Bug 251686 has been marked as a duplicate of this bug. ***
Comment 15 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-05-30 00:21:50 UTC
removed from tree, wontfix