Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 239293 - >=gnome-base/gnome-settings-daemon-2.24.0 - randomly fails to start
Summary: >=gnome-base/gnome-settings-daemon-2.24.0 - randomly fails to start
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: x86 Linux
: High normal with 1 vote (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
: 246158 (view as bug list)
Depends on:
Blocks: gnome2.24
  Show dependency tree
 
Reported: 2008-10-01 21:00 UTC by Ray Ishido
Modified: 2009-02-13 14:19 UTC (History)
17 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
.xsession-errors (xsession-errors,1.51 KB, text/plain)
2008-11-12 16:10 UTC, Cedric Girard
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ray Ishido 2008-10-01 21:00:16 UTC
Gnome-setting-deamon 2.24 don't start when the laptop is plugged, but start when on battery.

Reproducible: Always




emerge --info
Portage 2.2_rc11 (default/linux/x86/2008.0, gcc-4.3.1, glibc-2.8_p20080602-r0, 2.6.26-gentoo i686)
=================================================================
System uname: Linux-2.6.26-gentoo-i686-Genuine_Intel-R-_CPU_T2050_@_1.60GHz-with-glibc2.0
Timestamp of tree: Tue, 30 Sep 2008 19:45:01 +0000
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7, 2.1.6-r1
dev-lang/python:     2.4.4-r13, 2.5.2-r8
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.2.5
sys-apps/sandbox:    1.2.18.1-r3
sys-devel/autoconf:  2.13, 2.62-r1
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2.4
virtual/os-headers:  2.6.25-r4
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=native -Os -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=native -Os -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS=" #ftp://mirror.ovh.net/gentoo-distfiles ftp://gentoo.imj.fr/pub/gentoo/ #ftp://ftp.free.fr/mirrors/ftp.gentoo.org/ #ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gentoo/ #		http://ftp.club-internet.fr/pub/mirrors/gentoo"
LANG="fr_FR.UTF-8"
LC_ALL="fr_FR.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="fr"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/desktop-effects /usr/local/portage/layman/roslin /usr/local/portage/layman/gnome"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X aac acl acpi aiglx alsa asf battery berkdb bzip2 cairo cdr cli cracklib crypt cups dbus dri dvd dvdr encode esd exif ffmpeg fortran gdbm gif glitz gnome gphoto2 gpm gtk gtk2 hal iconv isdnlog java javascript jpeg kdeenablefinal lirc mad midi mono mp3 mpeg mudflap nautilus ncurses nls nptl nptlonly nvidia opengl openmp pam pcre pda perl pic pmu png pppd qt readline reflection reiserfs session smp spl sqlite sqlite3 sse sse2 ssl svg sysfs tcpd tiff truetype unicode usb wifi win32codecs x264 x86 xcomposite xml xorg xulrunner zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="ptp2 canon" ELIBC="glibc" INPUT_DEVICES="keyboard mouse wacom evdev joystick" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="fr" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Gilles Dartiguelongue gentoo-dev 2008-10-11 23:21:36 UTC
do you have any interesting information in ~/.xsession-errors.

Did you try to run it by hand and see if it crashed ?
Are you using gnome-session 2.22 or 2.24 ?
Comment 2 Gilles Dartiguelongue gentoo-dev 2008-10-27 00:04:38 UTC
looks like there is a problem in gnome-session 2.24 starting gnome-settings-daemon asynchrously which results from time to time in g-s-d being started to late or even not at all (or is it segfaulting).

Although if you don't provide us more information this bug is not going anywhere.
Comment 3 Auke Booij (tulcod) 2008-11-01 10:00:02 UTC
it *may* be possible that i had a related issue, which was that when starting gdm, it would error with some message saying that "gconf-sanity-check-2 exited with status code 256". then i downgraded to gdm 2.22 though, which seems to have solved the issue (but left me with a system where sessions didn't get restored, although that got fixed by downgrading gnome-session to 2.22 too :P (dunno if it's related)). and now i'm simply using kdm. anyway, gconf-sanity-check-2 failed in gdm 2.24.
Comment 4 Gilles Dartiguelongue gentoo-dev 2008-11-09 18:38:13 UTC
*** Bug 246158 has been marked as a duplicate of this bug. ***
Comment 5 Pacho Ramos gentoo-dev 2008-11-09 18:59:36 UTC
A similar problem was also reported in mandriva's bugzilla:
https://qa.mandriva.com/show_bug.cgi?id=43783

Maybe this could be an upstream problem :-/
Comment 6 Marcin Kurek 2008-11-11 13:47:33 UTC
I guess my problem was the same, but it fails always. Anyway patch mentioned in #246170 (http://patch-tracking.debian.net/patch/series/dl/gnome-session/2.22.3-2/02_gsd-spawn.patch) solves problem here. 
Comment 7 ammar wk 2008-11-12 08:42:07 UTC
i have this problem too, re-emerging the gnome-settings-daemon doesnt solve this problems. and i hate to ruse previous version.

Comment 8 Cedric Girard 2008-11-12 16:10:02 UTC
Created attachment 171545 [details]
.xsession-errors

I haven't tried any patch yet.
Running "killall gnome-settings-daemon && /usr/libexec/gnome-settings-daemon" after being logged in successively start gnome settings-daemon.

I've attached my .xsession-errors. Not sure there is anything relevant in it.
Comment 9 Ray Ishido 2008-11-12 20:56:56 UTC
ok, with time the bug is not always reproductible. sometimes gnome-settings-deamon don't start, somtimes it does.
a solution is to launch one or twice the appearance application.
xsession-errors do not report anythings, and trying to run gnome-settings-deamon manually do not work.
I will try the patch
Comment 10 Ian Abbott 2008-11-13 15:30:54 UTC
On my system (dual-core amd64) it doesn't seem random - gnome-settings-daemon fails every time!
Comment 11 Tony Vroon gentoo-dev 2008-11-13 17:25:37 UTC
+*gnome-session-2.22.3-r1 (13 Nov 2008)
+
+  13 Nov 2008; <chainsaw@gentoo.org>
+  +files/gnome-session-2.22.3-gsd-spawn.patch,
+  +gnome-session-2.22.3-r1.ebuild:
+  Debian patch identified by Marcin Kurek <morgoth6@gmail.com> resolves
+  intermittent gnome-session-manager failures on login (only SMP systems
+  appear to be affected). First step towards closing bug #239293.
Comment 12 Tony Vroon gentoo-dev 2008-11-13 17:36:15 UTC
+  13 Nov 2008; <chainsaw@gentoo.org> gnome-settings-daemon-2.24.0.ebuild:
+  Add an explicit dependency on the fixed gnome-session that spawns instead
+  of using D-Bus. This resolves the intermittent start failures on SMP
+  systems, reported by Ray Ishido <ray.ishido@gmail.com> in bug #239293.

And this *very* annoying bug is now fixed. A big thank you to all reporters on this bug :)
Comment 13 Cedric Girard 2008-11-13 20:19:55 UTC
Seems to work. Thanks.
Comment 14 Nick Andrade 2008-12-01 12:19:01 UTC
This bug is marked as resolved, but I'm still seeing this issue with gnome-settings-daemon-2.24.1.  It's possible it's not the same issue, but the error is identical, and the system it's occurring on is SMP.
Comment 15 Stephen Chisholm 2009-01-16 14:40:58 UTC
(In reply to comment #14)
> This bug is marked as resolved, but I'm still seeing this issue with
> gnome-settings-daemon-2.24.1.  It's possible it's not the same issue, but the
> error is identical, and the system it's occurring on is SMP.
> 

I'm also still experiencing this issue with gnome-settings-daemon-2.24.1 on two pc's with SMP.
Comment 16 Tony Vroon gentoo-dev 2009-01-16 14:47:00 UTC
Open a new bug guys, this will just confuse the issue.
Comment 17 walt 2009-02-13 14:05:58 UTC
(In reply to comment #16)
> Open a new bug guys, this will just confuse the issue.

Has a new bug been opened for this?  I'm still seeing it a month later.


Comment 18 Ian Abbott 2009-02-13 14:19:49 UTC
(In reply to comment #17)
> (In reply to comment #16)
> > Open a new bug guys, this will just confuse the issue.
> 
> Has a new bug been opened for this?  I'm still seeing it a month later.

There is bug #256016.  Maybe it applies to you.