Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 246158 - gnome-base/gnome-settings-daemon-2.24.0 is not started when logging into gnome
Summary: gnome-base/gnome-settings-daemon-2.24.0 is not started when logging into gnome
Status: RESOLVED DUPLICATE of bug 239293
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-11-09 13:02 UTC by Jürgen Geuter
Modified: 2008-11-09 18:38 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jürgen Geuter 2008-11-09 13:02:38 UTC
After having merged gnome-settings-daemon-2.24.0 I get, when logging in, an (unthemed) Popup telling me that the gnome-setting-daemon cannot be started. When I run The appearances-configuration thingy I get the themes and stuff back, but when I login the next time the settings-daemon is not started again.
I verified it with a new profile: Same problem.

I downgraded to gnome-settings-daemon-2.22.2.1 (which meant downgrading to gnome-desktop-2.22.3) and things work normal again.

Reproducible: Always

Steps to Reproduce:
1.update to gnome-settings-daemon-2.24.0
2. log into a gnome session
3.

Actual Results:  
No theming and an error popping up about not being able to start gnome-settings-daemon

Expected Results:  
Proper theming and no error message

tante@sanzen ~ $ emerge --info
WARNING: repository at /usr/local/portage/layman/cwiid is missing a repo_name entry
Portage 2.2_rc13 (default/linux/amd64/2008.0/desktop, gcc-4.2.4, glibc-2.8_p20080602-r0, 2.6.27-gentoo-r2 x86_64)
=================================================================
System uname: Linux-2.6.27-gentoo-r2-x86_64-Intel-R-_Core-TM-2_Duo_CPU_T7300_@_2.00GHz-with-glibc2.2.5
Timestamp of tree: Sun, 09 Nov 2008 11:30:01 +0000
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7, 2.1.6-r1
dev-lang/python:     2.4.4-r15, 2.5.2-r8
dev-python/pycrypto: 2.0.1-r6
dev-util/cmake:      2.6.2
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.3.0-r1
sys-apps/sandbox:    1.2.18.1-r3
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.4_p6, 1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.19
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=nocona -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=nocona -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distlocks fixpackages parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://ftp.tu-clausthal.de/pub/linux/gentoo/ ftp://ftp.gentoo.mesh-solutions.com/gentoo/ http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror/"
LANG="en_US"
LC_ALL="en_US.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="en de"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/sunrise /usr/local/portage/layman/cwiid /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X X509 a52 aac aalib acl acpi administrator aim alsa amarok amazon amd64 ao apache2 applet async audiofile autoipd automount avahi bash-completion berkdb bluetooth bogofilter bonjour branding bzip2 cairo caps cdb cddb cdio cdparanoia cdr chroot cli colordiff cracklib crypt cscope css cups curl cvs daap dbus device-mapper disk-partition dri dts dvd dvdr dvdread eds emboss encode esd evo exif expat fam fat ffmpeg firefox flac fontconfig fortran fuse gconf gd gdbm gdm gedit geoip gif gimp glade glib gmail gnome gnome-keyring gnutls gpg gphoto2 gpm grub gstreamer gtk gtkhtml gzip hal hdaps hddtemp ibam icons iconv icq id3 id3tag imagemagick imap imlib imlib2 ipod ipv6 isdnlog jabber javascript john jpeg jpeg2k json kpathsea lame laptop latex libgda libnotify libsamplerate libwww lm_sensors loop-aes lvm mad maildir matroska mdnsresponder-compat midi mikmod mime mjpeg mmap mmx mng mono mozdevelop mp3 mp4 mpeg mpeg2 mplayer msn mudflap multilib music musicbrainz mysql mysqli nautilus ncurses network networkmanager nfs nls nptl nptlonly nsplugin ntfs ntp obex offensive ogg ogg123 openal opengl openid openmp oscar pam pango parted pcmcia pcre pdf pdo perl php pidgin pixmaps plugins png pop posix postgres postscript ppds pppd pulseaudio python pyzord qemu qt3 qt3support qt4 query-browser quicktime rar rdesktop readline reflection reiserfs rss samba sdl session sharedmem silc simplexml smp sndfile sockets spell spl sql sqlite sqlite3 sse sse2 ssl startup-notification stream subversion svg sysfs syslog t1lib taglib tagwriting talkfilters tcpd tetex theora threads tidy tiff totem tracker transcode truetype twolame type1 unicode unzip upnp usb v4l2 vcd vcdx vhosts vim-syntax vnc vorbis wav webdav webdav-neon wifi wmf wxwindows x264 xattr xcb xcf xcomposite xft xine xinerama xml xmlrpc xorg xosd xpm xrandr xscreensaver xulrunner xv xvid yahoo zeroconf zip zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en de" USERLAND="GNU" VIDEO_CARDS="intel vesa"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Jürgen Geuter 2008-11-09 13:04:29 UTC
Another addition I forgot mentioning:

When I'm in the session with gnome-settings-daemon-2.24.0 the menu items system->"log out" and system->shutdown don't do anything, in order to log out I have to do CTRL+ALT+BACKSPACE.
Comment 2 Harris Landgarten 2008-11-09 13:07:02 UTC
run revdep-rebuild ( or reconcilio on paludis ) and then reinstall gnome-settings-daemon. That fixed it for me.
Comment 3 Jürgen Geuter 2008-11-09 15:02:49 UTC
Running "revdep-rebuild" and "emerge @preserved-rebuild" and installing gnome-settings-daemon afterwards gets rid of the error in starting the settings daemon. It still does not allow me to log out or shutdown from the menu but I'll file another bug for that.
Comment 4 Tim Ryan 2008-11-09 17:00:57 UTC
I have the same problem, also on amd64. I get this error when I try to run it from the command line as user:
** (gnome-settings-daemon:16704): WARNING **: Failed to acquire org.gnome.SettingsDaemon

I found out accidentally that if I run it as root it works, then I can kill it and it runs as the user without error. Still no log out or shutdown.
Comment 5 Gilles Dartiguelongue gentoo-dev 2008-11-09 18:38:13 UTC

*** This bug has been marked as a duplicate of bug 239293 ***