Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 238125 - x11-base/xorg-server-1.5.0 breaks keyboard due to "Video Bus" (type: KEYBOARD)
Summary: x11-base/xorg-server-1.5.0 breaks keyboard due to "Video Bus" (type: KEYBOARD)
Status: RESOLVED WORKSFORME
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: udev maintainers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-09-19 16:22 UTC by Martin Mokrejš
Modified: 2009-03-20 07:17 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
udev.conf (udev.conf,277 bytes, text/plain)
2008-09-19 16:23 UTC, Martin Mokrejš
Details
/etc/udev/rules.d/90-hal.rules (90-hal.rules,82 bytes, text/plain)
2008-09-19 16:23 UTC, Martin Mokrejš
Details
/etc/udev/._cfg0000_udev.conf (._cfg0000_udev.conf,277 bytes, text/plain)
2008-09-19 16:24 UTC, Martin Mokrejš
Details
/etc/X11/xorg.conf (xorg.conf,14.75 KB, text/plain)
2008-09-19 16:24 UTC, Martin Mokrejš
Details
/etc/hal/fdi/policy/use-multiple-layouts.fdi (use-multiple-layouts.fdi,805 bytes, text/plain)
2008-09-19 16:31 UTC, Martin Mokrejš
Details
/var/log/Xorg.0.log (working udev-125-r2) (Xorg.0.log,41.62 KB, text/plain)
2008-09-20 09:08 UTC, Martin Mokrejš
Details
lshal output (sys-apps/hal-0.5.11-r3, udev-125-r2, vanilla 2.6.24.7) (lshal.txt,79.36 KB, text/plain)
2008-09-20 09:11 UTC, Martin Mokrejš
Details
/var/log/Xorg.0.log (working under udev-128) (Xorg.0.log,42.72 KB, text/plain)
2008-09-20 11:37 UTC, Martin Mokrejš
Details
lshal output (lshal.txt,79.23 KB, text/plain)
2008-09-25 15:07 UTC, Martin Mokrejš
Details
/var/log/Xorg.0.log (1.5.0) (Xorg.0.log,40.05 KB, text/plain)
2008-09-25 15:07 UTC, Martin Mokrejš
Details
/etc/X11/xorg.conf (xorg.conf,14.69 KB, text/plain)
2008-09-25 15:08 UTC, Martin Mokrejš
Details
Xorg.0.log (1.5.2) (Xorg.0.log,30.58 KB, text/plain)
2008-10-23 07:17 UTC, Martin Mokrejš
Details
/var/log/Xorg.0.log with attempt to remove VideoBus (Xorg.0.log,42.35 KB, text/plain)
2008-10-23 17:11 UTC, Martin Mokrejš
Details
lshal output after the attempt to remove VideoBus (lshal.txt,80.67 KB, text/plain)
2008-10-24 10:40 UTC, Martin Mokrejš
Details
bbug.txt (kbbugs.txt,91.12 KB, text/plain)
2008-12-18 11:37 UTC, Martin Mokrejš
Details
use-multiple-layouts.fdi (use-multiple-layouts.fdi,4.70 KB, text/plain)
2009-03-01 20:48 UTC, Martin Mokrejš
Details
Xorg.0.log (udev-1.35-r4) (Xorg.0.log,41.22 KB, text/plain)
2009-03-01 21:08 UTC, Martin Mokrejš
Details
lshal output (sys-apps/hal-0.5.11-r8, hal-info-20090202) (lshal.txt,88.94 KB, text/plain)
2009-03-01 21:11 UTC, Martin Mokrejš
Details
fdi override (10-x11-input.fdi,649 bytes, text/plain)
2009-03-12 12:58 UTC, Richard Westwell
Details
Xorg.0.log (Xorg.0.log,31.80 KB, text/plain)
2009-03-20 00:11 UTC, Martin Mokrejš
Details
use-multiple-layouts.fdi (use-multiple-layouts.fdi,4.72 KB, text/plain)
2009-03-20 00:12 UTC, Martin Mokrejš
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Mokrejš 2008-09-19 16:22:32 UTC
Hi,
  I have upgraded from sys-fs/udev-125-r2 to sys-fs/udev-128 and my xdm session stopped working. I couldn't move the mouse cursor at all using either USB mouse nor synaptics touchpad on my laptop. I had xorg-server-1.4.2 installed and that hasn't been upgraded yet. To fix that I though I should try to finish the upgrade. So the system got upgraded to xorg-server-1.5.0, I have recompile dthe drivers in x11-drivers/ but still, I could only switch by ctrl+alt+F1 to console mode but could not use ctrl+alt+backspace to kill xdm. Staring /usr/bin/X gave me same behavior but I could use ctrl+c to kill it. Using startx I got 3 xterms opened, one was active but typing whatever on the keyboard did not result in letters being shown on the screen. NumLock LED light could be switched on and off. At the same time gpm could be started manually and the mouse used to cut&paste paste quite well while in the console mode.

 After analysing my logfiles I found udev was the culprit. Reverting back to sys-fs/udev-125-r2 fixed the problem.
Comment 1 Martin Mokrejš 2008-09-19 16:23:21 UTC
Created attachment 165851 [details]
udev.conf
Comment 2 Martin Mokrejš 2008-09-19 16:23:54 UTC
Created attachment 165853 [details]
/etc/udev/rules.d/90-hal.rules
Comment 3 Martin Mokrejš 2008-09-19 16:24:22 UTC
Created attachment 165854 [details]
/etc/udev/._cfg0000_udev.conf
Comment 4 Martin Mokrejš 2008-09-19 16:24:50 UTC
Created attachment 165855 [details]
/etc/X11/xorg.conf
Comment 5 Martin Mokrejš 2008-09-19 16:26:57 UTC
Portage 2.2_rc8 (default-linux/x86/2007.0/desktop, gcc-4.3.1, glibc-2.8_p20080602-r0, 2.6.24.7 i686)
=================================================================
System uname: Linux-2.6.24.7-i686-Mobile_Intel-R-_Pentium-R-_4_-_M_CPU_1.80GHz-with-glibc2.0
Timestamp of tree: Wed, 17 Sep 2008 11:15:01 +0000
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7, 2.1.6-r1
dev-lang/python:     2.5.2-r7
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.2.5
sys-apps/sandbox:    1.2.18.1-r3
sys-devel/autoconf:  2.13, 2.62-r1
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2.4
virtual/os-headers:  2.6.26
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=pentium4 -mmmx -msse -msse2 -fomit-frame-pointer -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /var/bind /var/qmail/alias /var/qmail/control /var/spool/torque /var/vpopmail/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -march=pentium4 -mmmx -msse -msse2 -fomit-frame-pointer -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks parallel-fetch preserve-libs sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://gentoo.mirror.web4u.cz"
LDFLAGS=""
LINGUAS="en cs cz"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="7zip R X Xaw3d a52 aac aalib ace acl acpi alsa amr amrnb amrwb apache2 audacious audiofile bash-completion bcmath berkdb blas boost bzip2 cairo cblas cddb cdparanoia cdr clamav cli colordiff compress cpio cracklib crypt cscope css ctype cups curl curlwrappers cxx dbus dga dia directfb djbfft dri dts dv dvb dvd dvdr dvdread eds emacs emboss emf enblend encode enscript exif expat fam fame fat fbcon ffmpeg fftw firefox flac flash foomaticdb fortran fpx ftp gcj gd gdbm ggi gif gimp gimpprint glibc-compat20 glibc-omitfp glitz glut gmp gnuplot gnutls gpgme gphoto2 gpm graphviz gs gsl gstreamer gtk gtkhtml hal hdf hdf5 i8x0 icc iconv icu id3 ieee1394 ifc imagemagick imlib inifile innodb isdnlog ithreads jack java javascript jbig jikes jpeg jpeg2k kdtree kerberos lame lapack laptop lcms leim libcaca libedit libwww live lzo lzw mad maildir matroska mhash midi mikmod mime ming mjpeg mmap mmx mng mod_python modperl modplug motif mozilla moznoirc mp2 mp3 mp4 mpeg mpi mpi_njtree mpich2 mplayer mudflap mule musepack mxdatetime mysql mysqli ncurses netcdf netpbm network nls nntp nptl nptlonly nsplugin ntfs numeric ogg opengl openmp pam pango pcmcia pcntl pcre pdf perl plotutils plugin png pnm postproc postscript ppds pppd procmail pymol python qt3 qt3support qt4 quicktime rar raw readline real recode reflection reiserfs rpm rtc samba sasl scanner scp seamonkey server session sftp sift slp smime sndfile soap sockets spell spl sqlite srt sse sse2 ssl subtitles subversion svg svgz sysfs sysvipc t1lib tcl tcpd tetex theora threads tidy tiff tk transcode truetype unicode urandom usb userlocales uuencode v4l v4l2 vcd vim-syntax vim-with-x vorbis wifi win32codecs wmf wxwindows x264 x86 xanim xcf xfs xft xinerama xinetd xml xorg xpm xprint xsl xslt xv xvid xvmc yv12 zip zlib" ALSA_CARDS="intel-8x0m" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config mem_cache mime mime_magic rewrite setenvif speling status unique_id userdir usertrack vhost_alias negotiation" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en cs cz" USERLAND="GNU" VIDEO_CARDS="radeon"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, MAKEOPTS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

I have after the downgrade sys-apps/hal-0.5.11-r3.
Comment 6 Martin Mokrejš 2008-09-19 16:31:06 UTC
Created attachment 165856 [details]
/etc/hal/fdi/policy/use-multiple-layouts.fdi

# ls -la /etc/hal/fdi/policy/
total 12
drwxr-xr-x 2 root root 4096 May 20 20:04 .
drwxr-xr-x 5 root root 4096 Feb  1  2008 ..
-rw-r--r-- 1 root root    0 Sep 18 19:49 .keep_sys-apps_hal-0
-rw-r--r-- 1 root root    0 Sep 18 19:49 10-x11-input.fdi
-rw-r--r-- 1 root root  805 Feb  6  2008 use-multiple-layouts.fdi
#
Comment 7 Wormo (RETIRED) gentoo-dev 2008-09-20 05:07:22 UTC
Good job of filing an informative bug report :)

Assigning to maintainers.
Comment 8 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2008-09-20 05:20:02 UTC
My system here is running udev-128 and hal-0.5.11-r3 for the last two reboots, and it's been fine (all ~arch). My 10-x11-input.fdi is simpler than your use-multiple-layouts however, just evdev/latin with compose+meta options.

I do see that your xorg.conf doesn't declare any mouse or synaptics section (they are both commented out). Did the problem happen when they were uncommented?

Your .cfg0000_dev.conf isn't any use, it's identical to the udev.conf.
Comment 9 Martin Mokrejš 2008-09-20 07:24:27 UTC
First of all, let me re-cap that I haven't touched any configs, just plain upgrade broke things. Second, the xorg.conf was suggested by Jakub Moc to me half a years ago when the transition xorg-1.4 broke almost everywhere due to hal. It was crucial to leave the configuration unset in xorg.conf otherwise the keyboard mapping somehow did not work. It could be xorg-conf now doesn't work when the xorg.conf is almost empty, but it is weird that no [a-zA-Z0-9] buttons work. Why it actually interferes with udev-128 I don't know.
Comment 10 Rémi Cardona gentoo-dev 2008-09-20 08:47:36 UTC
(In reply to comment #9)
> First of all, let me re-cap that I haven't touched any configs, just plain
> upgrade broke things.

HAL and udev are still moving targets. Configs are known to break from time to time. When you add Xorg/evdev to the mix, things can get pretty messy.

> Second, the xorg.conf was suggested by Jakub Moc to me
> half a years ago when the transition xorg-1.4 broke almost everywhere due to
> hal. It was crucial to leave the configuration unset in xorg.conf otherwise the
> keyboard mapping somehow did not work.

One easy workaround is to tell Xorg never to listen to HAL. Or you can properly configure HAL... your pick.

> It could be xorg-conf now doesn't work
> when the xorg.conf is almost empty, but it is weird that no [a-zA-Z0-9] buttons
> work. Why it actually interferes with udev-128 I don't know.

Could you post /var/log/Xorg.0.log with both udev versions (or at least with 128)? Maybe the output of lshal too.

Thanks
Comment 11 Rémi Cardona gentoo-dev 2008-09-20 08:55:53 UTC
Oh and it seems your HAL configuration files use a deprecated syntax.

Please read this on how to upgrade them: http://cgit.freedesktop.org/xorg/xserver/tree/config/x11-input.fdi

Maybe that'll help?

Thanks
Comment 12 Martin Mokrejš 2008-09-20 09:08:21 UTC
Created attachment 165883 [details]
/var/log/Xorg.0.log (working udev-125-r2)
Comment 13 Martin Mokrejš 2008-09-20 09:11:49 UTC
Created attachment 165885 [details]
lshal output (sys-apps/hal-0.5.11-r3, udev-125-r2, vanilla 2.6.24.7)
Comment 14 Martin Mokrejš 2008-09-20 11:36:48 UTC
Upgrading only udev to udev-128 leads to a working system. Cannot reproduce myself. :(
Comment 15 Martin Mokrejš 2008-09-20 11:37:57 UTC
Created attachment 165891 [details]
/var/log/Xorg.0.log (working under udev-128)
Comment 16 Martin Mokrejš 2008-09-25 15:06:50 UTC
So after all I can conclude that I can get udev-128 running with xorg-server-1.5.0 and keyboard and mouse working. The only problem is that my
multiple language keyboard layouts are possibly overridden by somehow mis-assigned "Video Bus" defined as KEYBOARD (obviously with us layout).
Am puzzled why that happens.

One note regarding the /etc/hal/fdi/policy/ files. Am not sure whether it was of any help to change "stringlist" to "string" in my case. It seemed to me "input.keys" can be found in the list of capabilities very often and so matching "input.keyboard" seemed better approach. Clues?
Comment 17 Martin Mokrejš 2008-09-25 15:07:23 UTC
Created attachment 166385 [details]
lshal output
Comment 18 Martin Mokrejš 2008-09-25 15:07:49 UTC
Created attachment 166387 [details]
/var/log/Xorg.0.log  (1.5.0)
Comment 19 Martin Mokrejš 2008-09-25 15:08:29 UTC
Created attachment 166389 [details]
/etc/X11/xorg.conf
Comment 20 Rémi Cardona gentoo-dev 2008-09-25 15:47:50 UTC
There's a way to tell in the FDI file that Xorg should not use this device in any case... I can't find how though...

I'll search a little more when I get back.
Comment 21 Martin Mokrejš 2008-10-23 07:17:15 UTC
I have upgraded to xorg-server-1.5.2 and still face the same problem, probably still a configuration issue.


(II) config/hal: Adding input device AT Translated Set 2 keyboard
(II) LoadModule: "evdev"

(II) Loading /usr/lib/xorg/modules/input//evdev_drv.so
(II) Module evdev: vendor="X.Org Foundation"
        compiled for 1.5.1, module version = 2.0.6
        Module class: X.Org XInput Driver
        ABI class: X.Org XInput driver, version 2.1
(**) AT Translated Set 2 keyboard: always reports core events
(**) AT Translated Set 2 keyboard: Device: "/dev/input/event3"
(II) AT Translated Set 2 keyboard: Found keys
(II) AT Translated Set 2 keyboard: Configuring as keyboard
(II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD)
(**) Option "xkb_rules" "xorg"
(**) AT Translated Set 2 keyboard: xkb_rules: "xorg"
(**) Option "xkb_model" "evdev"
(**) AT Translated Set 2 keyboard: xkb_model: "evdev"
(**) Option "xkb_layout" "us,cz"
(**) AT Translated Set 2 keyboard: xkb_layout: "us,cz"
(**) Option "xkb_variant" ",qwerty"
(**) AT Translated Set 2 keyboard: xkb_variant: ",qwerty"
(**) Option "xkb_options" "grp:alt_shift_togglegrp_led:scrollcaps:shift_nocancel"
(**) AT Translated Set 2 keyboard: xkb_options: "grp:alt_shift_togglegrp_led:scrollcaps:shift_nocancel"
(II) config/hal: Adding input device Logitech USB-PS/2 Optical Mouse
(**) Logitech USB-PS/2 Optical Mouse: always reports core events
(**) Logitech USB-PS/2 Optical Mouse: Device: "/dev/input/event7"
(II) Logitech USB-PS/2 Optical Mouse: Found x and y relative axes
(II) Logitech USB-PS/2 Optical Mouse: Found mouse buttons
(II) Logitech USB-PS/2 Optical Mouse: Configuring as mouse
(II) XINPUT: Adding extended input device "Logitech USB-PS/2 Optical Mouse" (type: MOUSE)
(II) config/hal: Adding input device Video Bus
(**) Video Bus: always reports core events
(**) Video Bus: Device: "/dev/input/event6"
(II) Video Bus: Found keys
(II) Video Bus: Configuring as keyboard
(II) XINPUT: Adding extended input device "Video Bus" (type: KEYBOARD)
(**) Option "xkb_rules" "base"
(**) Video Bus: xkb_rules: "base"
(**) Option "xkb_model" "evdev"
(**) Video Bus: xkb_model: "evdev"
(**) Option "xkb_layout" "us"
(**) Video Bus: xkb_layout: "us"
Comment 22 Martin Mokrejš 2008-10-23 07:17:55 UTC
Created attachment 169538 [details]
Xorg.0.log (1.5.2)
Comment 23 Rémi Cardona gentoo-dev 2008-10-23 16:12:39 UTC
Could you try adding this bit to your fdi file?

<?xml version="1.0" encoding="ISO-8859-1"?>
<deviceinfo version="0.2">
  <device>
    <match key="info.product" contains="Video Bus">
      <remove key="input.x11_driver"/>
    </match>
  </device>
</deviceinfo>

Thanks
Comment 24 Martin Mokrejš 2008-10-23 17:11:50 UTC
Created attachment 169594 [details]
/var/log/Xorg.0.log with attempt to remove VideoBus

> Comment #23

No, it did not help, see the log.

<?xml version="1.0" encoding="utf-8"?>
<deviceinfo version="0.2">
  <device>
   <match key="info.capabilities" contains="input.mouse">
      <merge key="input.x11_driver" type="string">mouse</merge>
      <match key="/org/freedesktop/Hal/devices/computer:system.kernel.name" string="Linux">
        <merge key="input.x11_driver" type="string">evdev</merge>
      </match>
   </match>

   <match key="info.capabilities" contains="input.keyboard">
      <merge key="input.x11_driver" type="string">evdev</merge>
      <merge key="input.xkb.rules" type="string">xorg</merge>
      <merge key="input.xkb.model" type="string">evdev</merge>
      <merge key="input.xkb.layout" type="string">us,cz</merge>
      <merge key="input.xkb.variant" type="string">,qwerty</merge>
      <!-- replace 'strlist' with 'string' on 'input.xkb.options' lines,
           see http://bugs.gentoo.org/show_bug.cgi?id=237742#c5 -->
      <merge key="input.xkb.options" type="string">grp:alt_shift_toggle</merge>
      <append key="input.xkb.options" type="string">grp_led:scroll</append>
      <append key="input.xkb.options" type="string">caps:shift_nocancel</append>
   </match>

   <match key="info.product" contains="Video Bus">
      <remove key="input.x11_driver"/>
   </match>

   <!-- http://bugs.gentoo.org/show_bug.cgi?ctype=html&id=200060 to avoid need to run setxkbmap manually
   <match key="info.capabilities" contains="input.keys">
      <append key="info.callouts.add" type="strlist">hal-setup-keymap</append>
   </match> -->
  </device>
</deviceinfo>
Comment 25 Rémi Cardona gentoo-dev 2008-10-23 22:31:19 UTC
(In reply to comment #24)
> Created an attachment (id=169594) [edit]
> /var/log/Xorg.0.log with attempt to remove VideoBus

Could you show the output of lshal with the updated fdi file? If the key still appears there, then looking at Xorg.0.log will be of no help.

Thanks
Comment 26 Martin Mokrejš 2008-10-24 10:40:09 UTC
Created attachment 169696 [details]
lshal output after the attempt to remove VideoBus

I did even reboot since inserting the "remove" rule, so it is not an issue
with me not restarting hald. ;-)
Comment 27 Martin Mokrejš 2008-12-18 11:37:14 UTC
Created attachment 175709 [details]
bbug.txt

The keyboard still does not work with app-misc/hal-info-20080508 sys-apps/hal-0.5.11-r4 x11-base/xorg-server-1.5.3 x11-drivers/xf86-input-evdev-2.1.0 although lshal does not show the "Video Bus" anymore. Maybe because I played with my kernel's .config ? :(
Comment 28 Martin Mokrejš 2009-01-30 12:17:30 UTC
The Video BUS does not appear in Xorg.0.log anymore and in lshal I see some difference:

--- videobus.old        2009-01-30 13:13:51.000000000 +0100
+++ videobus.new        2009-01-30 13:13:38.000000000 +0100
@@ -1,19 +1,19 @@
-udi = '/org/freedesktop/Hal/devices/computer_logicaldev_input'
+udi = '/org/freedesktop/Hal/devices/computer_logicaldev_input_2'
   info.addons.singleton = {'hald-addon-input'} (string list)
   info.capabilities = {'input', 'input.keys', 'button'} (string list)
   info.category = 'input'  (string)
   info.parent = '/org/freedesktop/Hal/devices/computer'  (string)
   info.product = 'Video Bus'  (string)
   info.subsystem = 'input'  (string)
-  info.udi = '/org/freedesktop/Hal/devices/computer_logicaldev_input'  (string)
-  input.device = '/dev/input/event6'  (string)
+  info.udi = '/org/freedesktop/Hal/devices/computer_logicaldev_input_2'  (string)
+  input.device = '/dev/input/event7'  (string)
   input.product = 'Video Bus'  (string)
   input.xkb.layout = 'us'  (string)
   input.xkb.model = 'evdev'  (string)
   input.xkb.rules = 'base'  (string)
   input.xkb.variant = ''  (string)
-  linux.device_file = '/dev/input/event6'  (string)
+  linux.device_file = '/dev/input/event7'  (string)
   linux.hotplug_type = 2  (0x2)  (int)
   linux.subsystem = 'input'  (string)
-  linux.sysfs_path = '/sys/devices/LNXSYSTM:00/device:00/PNP0A03:00/device:01/LNXVIDEO:00/input/input6/event6'  (string)
+  linux.sysfs_path = '/sys/class/input/input7/event7'  (string)


<deviceinfo version="0.2">
  <device>
   <match key="info.capabilities" contains="input.mouse">
      <merge key="input.x11_driver" type="string">mouse</merge>
      <match key="/org/freedesktop/Hal/devices/computer:system.kernel.name" string="Linux">
        <merge key="input.x11_driver" type="string">evdev</merge>
      </match>
   </match>

   <match key="info.capabilities" contains="input.keyboard">
      <merge key="input.x11_driver" type="string">evdev</merge>
      <merge key="input.xkb.rules" type="string">xorg</merge>
      <merge key="input.xkb.model" type="string">evdev</merge>
      <merge key="input.xkb.layout" type="string">us,cz</merge>
      <merge key="input.xkb.variant" type="string">,qwerty</merge>
      <!-- replace 'strlist' with 'string' on 'input.xkb.options' lines,
      <merge key="input.xkb.options" type="string">grp:alt_shift_toggle</merge>
      <append key="input.xkb.options" type="string">grp_led:scroll</append>
      <append key="input.xkb.options" type="string">caps:shift_nocancel</append>
   </match>

   <match key="info.product" contains="Video Bus">
      <remove key="input.x11_driver"/>
   </match>

   <!-- http://bugs.gentoo.org/show_bug.cgi?ctype=xml&id=200060 to avoid need to run setxkbmap manually
   <match key="info.capabilities" contains="input.keys">
      <append key="info.callouts.add" type="strlist">hal-setup-keymap</append>
   </match> -->
  </device>
</deviceinfo>

(II) config/hal: Adding input device Logitech USB-PS/2 Optical Mouse
(II) LoadModule: "evdev"

LoaderOpen(/usr/lib/xorg/modules/input//evdev_drv.so)
(II) Loading /usr/lib/xorg/modules/input//evdev_drv.so
(II) Module evdev: vendor="X.Org Foundation"
        compiled for 1.5.3, module version = 2.1.1
        Module class: X.Org XInput Driver
        ABI class: X.Org XInput driver, version 2.1
(**) Logitech USB-PS/2 Optical Mouse: always reports core events
(**) Logitech USB-PS/2 Optical Mouse: Device: "/dev/input/event5"
(II) Logitech USB-PS/2 Optical Mouse: Found 3 mouse buttons
(II) Logitech USB-PS/2 Optical Mouse: Found x and y relative axes
(II) Logitech USB-PS/2 Optical Mouse: Configuring as mouse
(**) Logitech USB-PS/2 Optical Mouse: YAxisMapping: buttons 4 and 5
(**) Logitech USB-PS/2 Optical Mouse: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
(II) XINPUT: Adding extended input device "Logitech USB-PS/2 Optical Mouse" (type: MOUSE)
FlushingSerial
(II) config/hal: Adding input device AT Translated Set 2 keyboard
(**) AT Translated Set 2 keyboard: always reports core events
(**) AT Translated Set 2 keyboard: Device: "/dev/input/event4"
(II) AT Translated Set 2 keyboard: Found keys
(II) AT Translated Set 2 keyboard: Configuring as keyboard
(II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) AT Translated Set 2 keyboard: xkb_rules: "evdev"
(**) Option "xkb_model" "evdev"
(**) AT Translated Set 2 keyboard: xkb_model: "evdev"
(**) Option "xkb_layout" "us,cz"
(**) AT Translated Set 2 keyboard: xkb_layout: "us,cz"
(**) Option "xkb_variant" ",qwerty"
(**) AT Translated Set 2 keyboard: xkb_variant: ",qwerty"
(**) Option "xkb_options" "grp:alt_shift_togglegrp_led:scrollcaps:shift_nocancel"
(**) AT Translated Set 2 keyboard: xkb_options: "grp:alt_shift_togglegrp_led:scrollcaps:shift_nocancel"
Popen: `"/usr/bin/xkbcomp" -w 1 "-R/usr/share/X11/xkb" -xkm "-" -em1 "The XKEYBOARD keymap compiler (xkbcomp) reports:" -emp "> " -eml "Errors from xk
bcomp are not fatal to the X server" "/var/lib/xkb/server-0.xkm"', fp = 0x8458888
Pclose: fp = 0x8458888
Group width mismatch between key and type
Group width mismatch between key and type
Group width mismatch between key and type
Group width mismatch between key and type
Group width mismatch between key and type
Group width mismatch between key and type
Group width mismatch between key and type
Group width mismatch between key and type
Group width mismatch between key and type
Group width mismatch between key and type
Group width mismatch between key and type
Group width mismatch between key and type
Group width mismatch between key and type
Group width mismatch between key and type
Group width mismatch between key and type
Group width mismatch between key and type
Group width mismatch between key and type
Group width mismatch between key and type
Group width mismatch between key and type
Group width mismatch between key and type
Group width mismatch between key and type
Group width mismatch between key and type
Group width mismatch between key and type
Group width mismatch between key and type
Group width mismatch between key and type
Group width mismatch between key and type
Group width mismatch between key and type
Loaded XKB keymap /var/lib/xkb/server-0.xkm, defined=0x7f
Comment 29 Martin Mokrejš 2009-03-01 20:46:19 UTC
Removing the depend on bug #256579 because it turned to be unrelated to this issue.

My post to the xorg@ mailing list got answered but I do suspect this is a bug in hal. Will attach working HAL policy file for czech keyboard. An excellent explanation of what was wrong is in http://lists.freedesktop.org/mailman/listinfo/xorg archive on Feb 23 2009 under thread name "[Bug 19947] xkbcomp-1.0.5: Group width mismatch between key and type". Basically, I messed up <merge> and <append>.
Comment 30 Martin Mokrejš 2009-03-01 20:48:17 UTC
Created attachment 183606 [details]
use-multiple-layouts.fdi

Working us/czech-qwerty layouts, switch between them using left alt + shift button. I only suspect that [shift]+twice pressing [=] on the US keyboard layout
followed by pressing [u] should probably generate ? instead of ?u. But, the character is anyway mapped over the [;] character of US layout.
Comment 31 Martin Mokrejš 2009-03-01 21:08:53 UTC
Created attachment 183608 [details]
Xorg.0.log (udev-1.35-r4)

Obsoletting all previous versions.
Comment 32 Martin Mokrejš 2009-03-01 21:11:16 UTC
Created attachment 183609 [details]
lshal output (sys-apps/hal-0.5.11-r8, hal-info-20090202)

HAL disables as intended the former mis-recognition of Video BUS by Xorg server.
Comment 33 Richard Westwell 2009-03-12 12:58:11 UTC
Created attachment 184803 [details]
fdi override

I was having a similar problem to the above recently after upgrading to KDE 4.2 with the newer xorg
I tried updating to hal-info to 20090309 but this didn't seem to work

I've attached a file which you can place at /etc/hal/fdi/policy/10-x11-input.fdi

you just need to edit the layout section to set it to whatever keyboard type is needed (at the moment the attached file is for gb / the UK)
hald should find this file first before processing the ones under /usr/share/hal/fdi, setting the "Video Bus" Device or any other device found to a different layout by default
Comment 34 Martin Mokrejš 2009-03-19 23:57:54 UTC
I have to conclude that the "Video Bus" device did not break my keyboard layout.
My keyboard layout is now working fine and I do not believe it was ever caused by "Video Bus" being detected by hal. Am on ~x86 so have xorg-server-1.5.3-r4, hal-info-20090309, hal-0.5.12_rc1, xf86-input-evdev-2.2.0-r1 installed. Sorry for the noise.


Quoting a message from xorg mailing list:

From: James Cloos
Date: 03/14/2009 19:05
Subject: Confused

>>>>> "Simon" == Simon Thum <simon.thum@gmx.de> writes:

Simon> I fully agree for diverse buttons, but why should evdev handle a
Simon> 'Video Bus'? OTOH, as long as it doesn't cause problems, all is fine.

The Video Bus input device is a keyboard.  Mine is:

,----[ excerpt from: /proc/bus/input/devices ]
| I: Bus=0019 Vendor=0000 Product=0006 Version=0000
| N: Name="Video Bus"
| P: Phys=/video/input0
| S: Sysfs=/devices/LNXSYSTM:00/device:00/PNP0A03:00/device:08/device:09/input/input3
| U: Uniq=
| H: Handlers=kbd event3 
| B: EV=3
| B: KEY=3f000b 0 0 0 0 0 0 0
`----

The Handlers line shows that it is a keyboard (and only a keyboard).

The KEY= line shows that "Video Bus" can send any of these keys:

,----[ excerpt from: /usr/include/linux/input.h ]
| #define KEY_BRIGHTNESSDOWN      224
| #define KEY_BRIGHTNESSUP        225
| #define KEY_SWITCHVIDEOMODE     227     /* Cycle between available video
|                                            outputs (Monitor/LCD/TV-out/etc) */
| #define KEY_UNKNOWN             240
| #define KEY_VIDEO_NEXT          241     /* drive next video source */
| #define KEY_VIDEO_PREV          242     /* drive previous video source */
| #define KEY_BRIGHTNESS_CYCLE    243     /* brightness up, after max is min */
| #define KEY_BRIGHTNESS_ZERO     244     /* brightness off, use ambient */
| #define KEY_DISPLAY_OFF         245     /* display device to off state */
`----

So, if one wants to handle those keys via X, evdev needs to read that
input device.

-JimC
-- James Cloos <cloos@jhcloos.com> OpenPGP: 1024D/ED7DAEA6 _______________________________________________ xorg mailing list xorg@lists.freedesktop.org http://lists.freedesktop.org/mailman/listinfo/xorg 
Comment 35 Martin Mokrejš 2009-03-20 00:11:37 UTC
Created attachment 185587 [details]
Xorg.0.log

Currently have both us-cz keyboard layout, "Video BUS" enabled by hal and used by xorg-server.
Comment 36 Martin Mokrejš 2009-03-20 00:12:25 UTC
Created attachment 185588 [details]
use-multiple-layouts.fdi
Comment 37 Rémi Cardona gentoo-dev 2009-03-20 07:17:11 UTC
Thanks for the follow up, I'll keep this bit in mind.

Cheers